#koha: Development IRC meeting 9 November 2016

Meeting started by kidclamp at 19:03:43 UTC (full logs).

Meeting summary

    1. Nick Clemens, ByWater Solutions (kidclamp, 19:04:02)
    2. Chris Cormack, Catalyst IT (rangi, 19:04:12)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 19:04:14)
    4. Michael Kuhn, Admin Kuhn GmbH (MKuhn, 19:04:33)
    5. Josef Moravec, Municipal Library Usti nad Orlici, Czech Republic (josef_moravec, 19:04:46)
    6. Nick Clemens, ByWater Solutions (kidclamp, 19:05:18)
    7. rangi is working on updating the manual (kidclamp, 19:07:43)
    8. http://translate.koha-community.org/manual/sphinx-branch/en/html/index.html (tcohen, 19:07:45)
    9. http://jenkins.theke.io (tcohen, 19:11:47)
    10. tcohen set a temporary jenkins server until community jenkins is back up (kidclamp, 19:12:06)
    11. http://jenkins.theke.io (kidclamp, 19:12:15)
    12. If anyone has strong opinions on CI tools, please write to tcohen about it (tcohen, 19:15:48)
    13. substituting jenkins for something else is a really possible option (tcohen, 19:16:13)
    14. ACTION: tcohen will investigate options for jenkins and coordinate with laurent @ BibLibre (kidclamp, 19:17:04)

  1. Review of coding guidelines (kidclamp, 19:17:38)
    1. Proposal - REST: Ban id fields in POST/PUT/PATCH bodies (kidclamp, 19:17:53)
    2. Thomas Dukleth, Agogme, New York City (thd, 19:19:07)
    3. bag Brendan Gallagher (bag, 19:20:42)
    4. Jiri Kozlovsky, Brno, Czech Republic (jirislav, 19:21:55)
    5. VOTE: Voted on "Should we add a coding guideline to ban id fields in post/put/patch bodies for the rest api?" Results are (kidclamp, 19:26:46)
    6. vote passed unanimously with 7 yes (kidclamp, 19:27:55)

  2. Progress on next release (16.11) (kidclamp, 19:28:09)
    1. http://jenkins.theke.io/job/Koha_Master_D8/ (tcohen, 19:28:47)
    2. Joubu working on failing tests (kidclamp, 19:30:43)
    3. bag says things are going well - kyle shared draft 1 of release notes (kidclamp, 19:31:07)
    4. odd dependency situation causing error: Undefined subroutine &C4::Circulation::GetItem (kidclamp, 19:33:34)
    5. tcohen, joubu and other investigating (kidclamp, 19:33:43)
    6. Developer documentation (POD) needs to be a QA issue. (kidclamp, 19:35:59)
    7. http://search.cpan.org/~neilb/Test-Pod-Coverage-1.10/lib/Test/Pod/Coverage.pm (rangi, 19:38:04)
    8. ACTION: POD coverage should be in qa script and a coding guideline added (kidclamp, 19:39:55)
    9. ACTION: Joubu (has been) volunteered to update qa script for pod (kidclamp, 19:41:23)
    10. Highlight easy to test bugs for beginners (follow-up) (kidclamp, 19:41:49)
    11. https://wiki.koha-community.org/wiki/I_want_to_help (rangi, 19:44:36)
    12. ACTION: please tag simple bugs with 'Academy' tag now and year round to help move them along and get people involved (kidclamp, 19:44:40)
    13. https://wiki.koha-community.org/wiki/I_want_to_help (kidclamp, 19:44:49)
    14. ACTION: kidclamp will update the wiki page with academy tag info and link (kidclamp, 19:46:43)
    15. Bootstrap 3 upgrade (Bug 16239) and relating UI changes (kidclamp, 19:47:40)
    16. caboose ByWaterSolutions (caboose_, 19:48:43)
    17. please test bug 16239 to get it ready for early next release cycle to encourage more testing/debugging (kidclamp, 19:51:24)
    18. REST API - how to solve "conflicts" in endpoints? For example bugs 17007 and 17371 (kidclamp, 19:54:48)
    19. Katrin Fischer, BSZ, Germany (cait, 19:55:19)
    20. https://wiki.koha-community.org/wiki/Rest_Api_HowTo (cait, 20:03:20)
    21. REST api conflicts should be brough up in bugzilla/posted to koha-devel/discussed at dev meeting (kidclamp, 20:05:57)
    22. ACTION: Someone involved in REST api should update 'how to' wiki and note guidelines on conflicts and cities endpoint as base example (kidclamp, 20:06:43)
    23. 17007 seems to be a subset of 17371 and should be merged (kidclamp, 20:07:57)

  3. Updates from the QA team (kidclamp, 20:08:37)
    1. please focus on bug fixes for the next release (kidclamp, 20:10:54)
    2. https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&list_id=181688&namedcmd=FIXME%20NOW&remaction=run&sharer_id=1 List of critical and blocker bugs (cait, 20:12:00)
    3. https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=FIXME%20NOW&sharer_id=1 (kidclamp, 20:12:00)
    4. review critical bugs 17522 and 16340 especially :-) (kidclamp, 20:14:39)

  4. Koha and Qvarn - http://qvarn.org/ (kidclamp, 20:15:10)
    1. Liz Rea, Catalyst NZ (wizzyrea, 20:23:01)
    2. ACTION: rangi or liw will post some qvarn info to listservs (kidclamp, 20:26:18)

  5. Set time of next meeting (kidclamp, 20:28:38)
    1. Next meeting December 14th, 13 UTC (kidclamp, 20:36:03)


Meeting ended at 20:36:47 UTC (full logs).

Action items

  1. tcohen will investigate options for jenkins and coordinate with laurent @ BibLibre
  2. POD coverage should be in qa script and a coding guideline added
  3. Joubu (has been) volunteered to update qa script for pod
  4. please tag simple bugs with 'Academy' tag now and year round to help move them along and get people involved
  5. kidclamp will update the wiki page with academy tag info and link
  6. Someone involved in REST api should update 'how to' wiki and note guidelines on conflicts and cities endpoint as base example
  7. rangi or liw will post some qvarn info to listservs


Action items, by person

  1. kidclamp
    1. kidclamp will update the wiki page with academy tag info and link
  2. rangi
    1. rangi or liw will post some qvarn info to listservs
  3. tcohen
    1. tcohen will investigate options for jenkins and coordinate with laurent @ BibLibre
  4. UNASSIGNED
    1. POD coverage should be in qa script and a coding guideline added
    2. Joubu (has been) volunteered to update qa script for pod
    3. please tag simple bugs with 'Academy' tag now and year round to help move them along and get people involved
    4. Someone involved in REST api should update 'how to' wiki and note guidelines on conflicts and cities endpoint as base example


People present (lines said)

  1. kidclamp (122)
  2. tcohen (77)
  3. rangi (64)
  4. josef_moravec (36)
  5. cait (32)
  6. huginn (17)
  7. jirislav (16)
  8. bag (14)
  9. thd (10)
  10. caboose_ (7)
  11. wahanui (5)
  12. wizzyrea (2)
  13. jransom (1)
  14. MKuhn (1)


Generated by MeetBot 0.1.4.