10:01:05 <cait> #startmeeting General IRC meeting 3 August 2016
10:01:05 <huginn> Meeting started Wed Aug  3 10:01:05 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:01:05 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
10:01:05 <huginn> The meeting name has been set to 'general_irc_meeting_3_august_2016'
10:01:13 <cait> #topic Introductions
10:01:13 <wahanui> #info wahanui, a bot that has become sentient
10:01:23 <cait> please introduce yourself following wahanui's example
10:01:29 <cait> #info Katrin Fischer, BSZ, Germany
10:01:34 <cait> #chair drojf
10:01:34 <huginn> Current chairs: cait drojf
10:01:36 <schnydszch> #info Eugene Espinoza Philippines
10:01:39 <oleonard> #info Owen Leonard, Athens County Public Libraries
10:01:50 <cc> #info Colin Campbell, PTFS-Europe Ltd
10:01:54 <MichaelKuhn> @drojf Yes, I'm lucky today :-)
10:01:54 <huginn> MichaelKuhn: I'll give you the answer as soon as RDA is ready
10:02:03 <drojf> heh
10:02:12 <Joubu> #info Jonathan Druart
10:02:23 <cait> today's agenda:
10:02:25 <cait> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_3_August_2016
10:02:39 <drojf> #info Mirko Tietgen, Berlin, Germany
10:02:50 <fredericd> #info Frédéric Demians
10:02:55 <d_antonakis> #info Dimitris Antonakis, Athens, Greece
10:03:10 <magnuse> #info Magnus Enger, Libriotech, Norway
10:04:10 <MichaelKuhn> #info Michael Kuhn, Allschwil (next to Basel), Switzerland
10:04:53 <ola> #info Ola Andersson, LTU, Sweden
10:04:59 <cait> nice, big crowd
10:05:05 <drojf> scary
10:05:11 <cait> please get your #info in, i am switching topic in a quick moment
10:05:11 <drojf> in a good way
10:05:20 <magnuse> we'll be kind
10:05:43 <cait> davidnind: #info? :)
10:06:18 <cait> ok, moving on
10:06:21 <cait> #topic Announcements
10:06:22 <davidnind> #info David Nind, Wellington, New Zealand
10:06:27 <cait> heh
10:06:34 <cait> ok, any announcements?
10:06:35 <thd> #info Thomas Dukleth, Agogme, New York City
10:06:42 <cait> please hold KohaCon until we move into that topic
10:06:43 <Oak> #info Arslan Farooq, Islamabad, Pakistan
10:07:00 <cait> My understanding is that some people are travelling to the Koha US conference this week
10:07:16 <cait> including bag afaik
10:07:22 <cait> any Rmaints around?
10:07:58 <rangi> yep
10:08:04 <cait> announcements? :)
10:08:15 <rangi> nope
10:08:26 <drojf> no inztroduction, you don't exist :P
10:08:32 <drojf> or i missed it
10:08:35 <rangi> just that i hope we can all get back to the releasing on the 22nd schedule
10:09:05 <drojf> some schedule would be nice. from a "packaging your stuff" point of view
10:09:17 * fredericd will do my best for 22nd releasing
10:09:44 <cait> #info Please try and keep maintenance releases on schedule - around 22nd each month
10:09:47 <drojf> i would like to have packages soon after release. so it would be cool to know when it happens :)
10:09:57 <rangi> bgkriegel regens the po files ont the 15th, so that gives a week for that translators
10:10:13 <cait> #info RMaints - please keep drojf in the loop about your planned release day to have timely packages
10:10:24 <cait> rangi: is that automatic?
10:10:29 <rangi> yup
10:10:53 <rangi> well he might do it manually, but it's always on the 15th (at least it has been)
10:11:00 <cait> #info RMaints and translators - po files are updates for releases on the 15th!
10:11:11 <cait> anything else?
10:11:11 <wahanui> hmmm... anything else is just being crap
10:11:37 <rangi> 3.20.x is mainly going to be just security fixes from now on
10:11:49 <fredericd> There is no project for 16.05 branch on Jenkins server. Could it be added?
10:11:56 <cait> #info 3.20.x to mainly include security fixes from now on
10:12:06 <rangi> ah yep
10:12:23 <rangi> @later tell tcohen can you set up a 16.05 job on jenkins please
10:12:23 <huginn> rangi: The operation succeeded.
10:12:43 <fredericd> My goal for this stable release was to include as much of master patches as possible in order to minimize master/stable code divergence, especially for templates.
10:13:04 <fredericd> And so, in order to ease bug fixes backporting in the stable release cycle.
10:13:23 <fredericd> In this perspective, I've included what I've considered as minor enhancements.
10:13:39 <fredericd> I may have been a little bit too far...
10:13:48 <Joubu> fredericd: yes it should. We will see with tcohen when he will be around
10:14:02 <Joubu> (oops sorry, not at the bottom)
10:14:15 <fredericd> From now onwards, I will take a more conservative approach.
10:14:30 <cait> thx fredericd
10:14:47 <cait> #action tcohen - please set up a 16.05 job on jenkins
10:15:04 <cait> moving on?
10:15:30 <drojf> i released a package reverting a patch before it was done by the RMaint. to avoid a lot of kohas exploding. any objections to doing that?
10:15:40 <drojf> i don't plan to add features on my own ;)
10:15:45 <cait> quick check, do we have something for the next topic, please just say yes
10:15:50 <cait> otherwise i am goig to jump to kohacon
10:16:21 <cait> no objections from me in that case - seemed straightforward
10:16:31 <fredericd> drojf: rather encouragement than objection
10:16:59 <drojf> ok cool
10:17:04 <cait> moving onto KohaCon as next topic
10:17:19 <cait> #KohaCon
10:17:22 <cait> hm sorry
10:17:26 <cait> #topic KohaCon17
10:18:10 <cait> there has been quite a confusion since yesterday and I hope we will be able to resolve it
10:18:27 <cait> #link https://wiki.koha-community.org/wiki/KohaCon17_Proposals
10:18:48 <cait> For this year there was one proposal added early to the list for the Philippines by mtompset
10:19:01 <cait> after drojf asked for updates on the mailing list
10:19:15 <cait> the bid was first changed to remove one of the contacts, then later removed with an email to the mailing list
10:19:30 <cait> the mailing list emails are linked to the wiki
10:19:54 <magnuse> *linked to from the wiki
10:19:55 <cait> before that happend, it hink also yesterdy eugene jose espinoza had sent an email about the Philippines still be interested
10:20:04 <cait> of course, thx magnuse
10:20:27 <cait> the reason mtompset gave for withdrawing the bit was ongoing renovations at the national library
10:20:39 <cait> some time before this meeting today, the bid was restored
10:20:49 <cait> is someone here for the bidders?
10:20:54 <schnydszch> okay here
10:21:31 <drojf> can you explain what is going on?
10:21:37 <schnydszch> I have edited the bid to instead be held at the Ayala Museum, where they offered there place, hence, restoring the bid
10:22:28 <drojf> i see the national library in the bid
10:22:37 <schnydszch> we have talked among ourselves those currently in the Philippines to restore the bid because we've got the Ayala Museusm and also the Association of Special Libraries of the Philippines to help us
10:22:38 <drojf> and tulong aklatan who were deleted before
10:22:45 <drojf> (deperately from the other deletion)
10:22:51 <cait> separately :)
10:22:54 <drojf> äh
10:22:55 <drojf> lol
10:22:55 <drojf> yes
10:22:57 <drojf> sorry
10:22:57 <drojf> :D
10:23:05 <schnydszch> I have edited just hours ago. NP drojf
10:23:29 <schnydszch> http://www.ayalamuseum.org/
10:23:53 <schnydszch> it was actually the Filipinas Heritage Library of the Ayala Museum
10:23:54 <schnydszch> http://www.filipinaslibrary.org.ph/
10:24:05 <drojf> so the person that was said to be out of the bid is now in again?
10:24:37 <drojf> and what is the involvement of the national library?
10:24:40 <cait> #info new location for the Philippines bid: Ayala Museum http://www.ayalamuseum.org/
10:24:46 <schnydszch> Yes, we have talked among ourselves upon learning that Filipinas Heritage Library is offering there place
10:25:11 <cait> ok, so can we confirm that OnStrike is part of the organizing team now?
10:25:14 <drojf> by ourselves you mean all in the list now? (sorry it's not obvious to me and all very confusing)
10:25:15 <cait> trying to do this bit by bit :)
10:25:17 <thd> schnydszch: Would people from the National Library still be participating as hosts without the location of the National Library itself being the location for the venue?
10:25:19 <schnydszch> as a matter of courtesy, they are still involved, they can lend us transportation for example
10:25:39 <cait> trying to sort this a bit
10:25:47 <cait> schnydszch: the last one was referring to national library?
10:25:50 <schnydszch> I have edited the conference location to Ayala Museum
10:26:02 <cait> yep, i have logged that
10:26:03 <cait> it looks nice
10:26:10 <cait> we are just still a bit confused about the list of organizers
10:26:27 <schnydszch> here: https://wiki.koha-community.org/wiki/KohaCon17_Proposals
10:27:00 <schnydszch> list of organizers: OSLS, TA, NLP, FHL, ASLP
10:27:02 <schnydszch> in that order
10:27:13 <drojf> and there is still no date
10:27:29 <schnydszch> Onstrike Library Solutions, Tulong Aklatan, National Library of the Philippines, Filipinas Heritage Library, Association of Special Libraries of the Philippines
10:27:40 <rangi> cool
10:27:41 <schnydszch> June
10:27:59 <cait> please keep talking, iw ill info some of that for the meeting minutes and then we can ask about what is not clear yet
10:28:24 <schnydszch> previously proposed date was june, sept or oct
10:28:33 <cait> #info Organizers are OSLS, TA, NLP, FHL, ASLP - Onstrike Library Solutions, Tulong Aklatan, National Library of the Philippines, Filipinas Heritage Library, Association of Special Libraries of the Philippines
10:28:47 <schnydszch> but opted for June
10:28:57 <cait> #info The conference date would be in June
10:29:51 <schnydszch> the local hotels, restaurants will be edited since it will be in Makati, the Philippines central business district
10:30:10 <thd> Have we not voted on KohaCon proposals without the date being precisely specified in the past even if what had been specified in such cases had been a much more constrained period?
10:30:12 <rangi> nice temperatures in june too
10:30:30 <schnydszch> yep, not so hot already
10:30:45 <rangi> thd: indicative is good enough
10:30:50 <cait> thd: i think a missing exact date is not a blocker - just good to have a general idea
10:30:51 <schnydszch> May is Summer in the Philippines
10:30:51 <drojf> thd: yes, the date does not need to be fixed. but people want to know when it may be, kind of
10:31:05 <drojf> so three months was a bit much
10:31:36 <thd> Agreed, three months is not enough specificity.
10:31:40 <cait> just checking - city is the same, just another part of it, right?
10:31:47 <schnydszch> yep
10:31:54 <schnydszch> part of Metropolitan Manila
10:32:30 <drojf> ok then all the rest still applies i guess, hotels and stuff?
10:32:45 <schnydszch> basically, but we will update it to suit Makati area
10:32:51 <cait> #info local hotels, restaurants will be edited since it will be in Makati, the Philippines central business district of Manila
10:33:06 <cait> i have to run :( but drojf will take over chairing
10:33:14 <cait> thx for the information schnydszch!
10:33:15 <drojf> ok
10:33:16 <rangi> that sounds good to me
10:33:38 <drojf> schnydszch: anything else you would like to add?
10:33:51 <thd> schnydszch: Will the National Library still be open for its own library business during the renovation?
10:33:52 <schnydszch> ..thinking
10:34:23 <rangi> as long as there is adobo there, i will be happy :)
10:34:37 <schnydszch> they are still open, in fact they are under renovation and still open. The sight is not good since you can see cobbles, etc.
10:34:49 <schnydszch> Yes @rangi a lot of adobo
10:34:57 <schnydszch> we will take note of that
10:35:01 <drojf> what is adobo?
10:35:31 <schnydszch> marinated pork/chicken in soy, vinegar
10:35:32 <drojf> oh i'm chair, stop silly questions
10:35:46 <drojf> thanks a lot for the update schnydszch
10:36:03 <thd> schnydszch: The important sight is the books, etc. not whether they have free conference rooms available.
10:36:22 <drojf> we will have one more week until bidding closes
10:36:23 <schnydszch> Yes books and artifacts
10:36:56 <drojf> at the moment there is only another bid from europe which does not apply because we were in europe this year
10:37:09 <schnydszch> in the museum. ancient jars, those traded during the galleon trade with Mexico and Spain :) as far as Ayala Museum is concern
10:37:35 <drojf> i think we can move on to discussing processes
10:37:49 <drojf> the rotation for kohacon came up on the mailing list
10:38:04 <drojf> rangi: you said it was written down in 2010. where?
10:38:08 <schnydszch> we will research on what happened during the last Koha Conferences and will try to make it enjoyable :)
10:38:18 <drojf> in the wiki it does not seem very precise
10:38:33 <rangi> a couple of places on the wiki, katrin is working on better wording
10:39:03 <rangi> i think the main thing is that if its not twice in a row, there is still the danger it ends up, europe,usa,europe,usa etc
10:39:20 <drojf> marcelr proposed to drop the rule if there are no other offers (if i understand correctly)
10:39:28 <rangi> i think that is fine
10:39:30 <thd> Knowing what counts as a continent could be an issue.
10:40:01 <rangi> hasnt been yet thd
10:40:01 <drojf> if we allow that, we should not scare away bidders from the last continent
10:40:15 <MichaelKuhn> I guess Antarctica will never win the bid :-(
10:40:27 <thd> I would not think there is currently a problem considering North America and South America as separate continents.
10:40:41 <drojf> i told people from europe they would not get it for 2017. if in the end europe would be allowed, that would be a bad thing to do
10:41:10 <MichaelKuhn> Africa, Asia, Europe, North America, South America, Australia
10:41:13 <rangi> well, i dont think we have to worry now :)
10:41:39 <drojf> rangi: no, but the same thing can rise again. so it would be better to word it differently
10:41:57 <drojf> like, the rules, the exception. write a proposal but be aware there is only little chance. or something
10:42:38 <rangi> yeah, only if there is no valid one from
10:42:49 <rangi> one of the other 3
10:43:09 <rangi> something like that
10:43:10 <drojf> yep. bu that is different to "no chance". which i told people so far
10:44:12 <drojf> i would propose to have the deadline for bidding. and if there is no offer according to the rules, extend it. for 2 weeks, or 4 maybe. and if there is still none, accept the exceptions
10:44:15 <drojf> does that make sense?
10:44:18 <rangi> the only other informal rule was the idea that every 10 years it should be in nz, for the 10th, 20th, 30th anniversary etc
10:44:39 <rangi> drojf: that makes sense to me
10:45:10 <drojf> maybe 4 weeks, as 2 is very little for a new proposal? we should end bidding earlier in general if we do that
10:45:28 <rangi> yeah
10:45:59 <drojf> #info cait is working on rewording the rules regarding kohacon and continents
10:46:39 <drojf> #info if we do not get bids according to the rules, an exception is possible
10:47:01 <thd> "KohaCon shall not be held in the same continent twice in succession unless no proposal has been introduced from a different continent.  Continents for the sake of the rule shall be distinguished as Africa, Asia, Europe, North America, South America, and Australia.  Rule may be revised at a Koha IRC meeting if a problem develops."
10:47:14 <rangi> its not twice
10:47:20 <rangi> in succession
10:47:33 <drojf> #info after the regular deadline for bids, if there is none that meets the rules, there will be a 4 weeks extension to the deadline
10:47:34 <rangi> that still allows NA,Europe,NA,Europe etc
10:47:45 <rangi> its not within 3 years
10:47:57 <magnuse> yeah, 3 years make sense
10:48:00 <MichaelKuhn> It didn't happen until now
10:48:02 <drojf> #info if there is no bid that matches the rules after the extention period, exceptions from the rules are possible
10:48:17 <thd> "KohaCon shall not be held in the same continent within three years unless no proposal has been introduced from a different continent.  Continents for the sake of the rule shall be distinguished as Africa, Asia, Europe, North America, South America, and Australia.  Rule may be revised at a Koha IRC meeting if a problem develops."
10:48:17 <rangi> MichaelKuhn: because we have always had the not within 3 years rule
10:48:30 <rangi> that works thd
10:48:30 <magnuse> Australia - does that include nz and the pacific?
10:48:42 <rangi> id call it oceania
10:48:45 <drojf> this
10:48:47 <rangi> instead of australia
10:48:53 <MichaelKuhn> OK, some protectionism may not be too bad
10:48:54 <magnuse> nice
10:49:24 <rangi> then its more clear it includes the pacific an nz
10:49:33 <rangi> kohacon in fiji would be nice ;)
10:49:39 <thd> "KohaCon shall not be held in the same continent within three years unless no proposal has been introduced from a different continent.  Continents for the sake of the rule shall be distinguished as Africa, Asia, Europe, North America, South America, and Oceania [Australia, New Zealand, etc.].  Rule may be revised at a Koha IRC meeting if a problem develops."
10:50:05 <drojf> antarctica should be in there
10:50:07 <drojf> i want to go
10:50:09 <drojf> :P
10:50:29 <oleonard> first we have to get them using Koha
10:50:43 <rangi> yeah, there are 2 libraries there
10:50:56 <rangi> we do have libraries in fiji using koha though :)
10:50:58 <thd> drojf: When it becomes warm enough, it may be the only place left :)
10:51:03 <drojf> #info continents are Africa, Antarctica, Asia, Europe, North America, South America, Oceania
10:51:12 <drojf> :P
10:51:50 <rangi> heh
10:52:18 <drojf> ok anything else regarding kohacon locations?
10:52:28 <rangi> not from me
10:52:33 <MichaelKuhn> There is a beautiful animation about the naming of continents on https://en.wikipedia.org/wiki/Continent
10:52:43 <drojf> ok moving on then
10:53:00 <drojf> #topic  Actions from General IRC meeting 6 July 2016 (none, meeting postponed)
10:53:06 <drojf> we had no meeting
10:53:08 <drojf> so…
10:53:22 <MichaelKuhn> I didn't miss that one then
10:53:26 <drojf> heh nope
10:53:32 <drojf> #topic Community involvement - Use 'Academy' keyword year round
10:53:41 <drojf> anyone knows what that is about?
10:53:52 <drojf> or who added it?
10:54:02 <rangi> no idea
10:54:05 <MichaelKuhn> nope
10:54:06 <rangi> lemme look
10:54:11 <thd> MichaelKuhn: Not enough people were present last month to conduct a meeting.
10:54:13 <oleonard> About bug reports for the Catalyst Academy?
10:54:23 * oleonard guesses
10:54:40 <drojf> oleonard: but when it's on the agenda i guess somebody wanted to discuss it?
10:54:44 <rangi> was added nick clemens from bywater
10:54:57 <drojf> hm. ok
10:55:03 <rangi> so maybe they want to overload our catalyst academy keyword to use for their one?
10:55:24 <drojf> maybe they should get another then instead
10:55:29 <rangi> which is fine as long as there are about 20 bugs left there in january :)
10:55:38 <drojf> not really a topic for the meeting i guess
10:56:10 <rangi> what might be good is tagging easy bugs
10:56:20 <rangi> all throughout the year
10:56:22 <drojf> yes that is always useful
10:56:35 <rangi> for people who want to get started
10:56:48 <rangi> maybe that was what was meant
10:57:06 <drojf> #info nobody around to explain the topic
10:57:06 <drojf> #info tagging easy bugs makes sense to help people get started
10:57:16 <thd> Some apparently 'easy' bugs are rabbit holes for descending.
10:57:22 <MichaelKuhn> I would be grateful
10:57:34 <drojf> i'd end it with that
10:57:45 <drojf> thats all on the agenda, we need a date for next time
10:57:54 <drojf> unless there is anything else?
10:58:34 <drojf> 7 august 2016, 20 UTC?
10:58:47 <drojf> err, september
10:58:56 <drojf> 7 september 2016, 20 UTC?
10:59:11 <thd> I prefer 14 Sep. at 20 UTC.
10:59:33 <drojf> won't work for me. which does not mean much
10:59:37 <MichaelKuhn> That's a midnight session on Sunday
10:59:48 <drojf> huh?
10:59:51 <MichaelKuhn> sorry, no
11:00:49 <drojf> preferences, anyone?
11:00:50 <davidnind1> generally the first Wednesday, has been for a while now, happy with 7 Sept.
11:00:51 * thd has a general preference against the first Wed. of the month for 20 UTC.
11:01:06 <drojf> thd: that was kind of the general date
11:01:37 * thd has no strong reservation for Sep.
11:02:10 <thd> 7 Sep. should work for me actually.  When the time changes it can become tricky.
11:02:24 <thd> s/time/local time/
11:02:48 <drojf> ok, then it's 7 september 2016, 20 UTC
11:02:56 <davidnind1> +
11:03:02 <drojf> #info next meeting 7 september 2016, 20 UTC
11:03:12 <drojf> #endmeeting