20:00:50 <cait> #startmeeting Koha General IRC Meeting 13 January 2016
20:00:50 <huginn`> Meeting started Wed Jan 13 20:00:50 2016 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:50 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:50 <huginn`> The meeting name has been set to 'koha_general_irc_meeting_13_january_2016'
20:00:51 <JesseM> :) coffee
20:00:58 <cait> Welcome all!
20:01:07 <cait> today's agenda is at http://wiki.koha-community.org/wiki/General_IRC_meeting_13_January_2016
20:01:16 <cait> #link http://wiki.koha-community.org/wiki/General_IRC_meeting_13_January_2016
20:01:21 <cait> #topic Introductions
20:01:22 <wahanui> #info wahanui, a bot that has become sentient
20:01:35 <cait> please introduce yourself like wahanui just did, using #info
20:01:56 <JesseM> #info Jesse Maseto - ByWater, USA
20:01:56 <blou> #blou, a bot not quite so sentient
20:01:57 <BobB> #info Bob Birchall, Calyx, Australia
20:02:03 <bag> #info Brendan Gallagher - ByWater Solutions
20:02:04 <Colinc> #info Colin Campbell, ptfs-europe
20:02:04 <drojf> #info Mirko Tietgen, Berlin, Germany
20:02:13 <blou> #info Philippe Blouin, inLibro
20:02:13 <cait> #info Katrin Fischer, BSZ, Germany
20:02:13 <khall> #info Kyle Hall, ByWater Solutions
20:02:14 <Joubu> #info Jonathan Druart, UK
20:02:15 <hbraum> #info Heather Braum, NEKLS/NExpress, Lawrence, KS, USA
20:02:20 <andreashm> #info Andreas Hedström Mace, Stockholm University Library
20:02:20 <jmsasse> #info Joel Sasse Plum Creek, USA
20:02:34 <cait> :)
20:02:37 <cait> nice!
20:02:48 <rangi> #info Chris Cormack, Catalyst IT, NZ
20:03:19 <barton_kohameeting> #info Barton Chittenden, BWS, Louisville KY USA
20:03:33 <cait> ok, let's move on  to our first topic for tonight :)
20:03:40 <cait> #topic Announcements
20:04:00 <cait> anyony any announcements?
20:04:10 <tubaclarinet> #info Christopher Davis, Uintah County Library, Utah, USA
20:04:12 <cait> anyone...
20:04:13 <wahanui> anyone is free to organize one at any time :-)
20:04:14 <rangi> next week is the group work for the academy
20:04:43 <rangi> please add the keyword Academy in the keyword field to any bugs that you think might be ok for them to look at
20:05:07 <cait> #info next week is group work week for the academy at Catalyst IT - please add the academy keyword to any bugs you think would be ok for them to look at
20:05:20 <cait> ok = not too hard to fix?
20:05:35 <rangi> yeah, preferably don't touch the db ;)
20:05:42 <cait> :)
20:05:53 <cait> anything else?
20:05:54 <wahanui> anything else is just being crap
20:05:59 <drojf> i got feedback for the pre-kohacon meeting in berlin. there is only one short day now (thursday)
20:06:00 <rangi> but id rather have more, even if we go, oh thats too hard, than have only a few to pick from
20:06:02 <bag> are there currently any that are marked?
20:06:03 <rangi> if that makes sense
20:06:05 <rangi> yep
20:06:16 <Joubu> rangi: to signoff, submit a patch or both?
20:06:19 <rangi> if you do a search in bugs for that keyword, you will find them ;)
20:06:23 <rangi> Joubu: both please
20:06:24 <wahanui> rumour has it both is best :)
20:06:33 <Joubu> rangi: ok great :)
20:07:00 <cait> #info Pre-KohaCon meeting in Berlin has room secured - only one short day now (Thursday)
20:07:27 <cait> moving on?
20:07:53 <drojf> there may be a catmandu workshop
20:07:58 <cait> :)
20:08:00 <drojf> or in greece, depends
20:08:07 <bag> :)
20:08:48 <cait> moving on!
20:08:50 <cait> #topic Update on releases
20:08:57 <andreashm> oh catmandu
20:08:58 <wahanui> it has been said that catmandu is pretty super awesome
20:09:07 <cait> jajm, wizzyrea, fredericd? bag?
20:09:35 <bag> I have some - should I go first?
20:09:38 <rangi> i think wizzyrea is still on the bus
20:09:50 <cait> yep please start bag
20:09:55 <bag> Jenkins (once tcohen is back in the office I will spend sometime with him so we can get master stable again)
20:10:16 <bag> I am really interested in XSS patches from Joubu ( needs QA http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13618 )
20:10:17 <huginn`> 04Bug 13618: enhancement, P5 - low, ---, jonathan.druart, Signed Off , Prevent XSS in the Staff Client and the OPAC
20:10:36 <bag> qa team that would be awesome if we nudge that along
20:10:49 <cait> I am on it, I think it's pretty close now
20:10:56 <khall> excellent!
20:10:57 <bag> sweet
20:11:13 <bag> Change in the wording on the bug (when changing the status to pushed to master).  I want to put (Pushed to Master - Should be in the May 2016 release)  - any objections?
20:11:13 <wahanui> bag: that doesn't look right
20:11:19 <Joubu> bag: it's a very hard one, cait found bugs when I was sure there were not...
20:11:19 <irma> #info Irma, CALYX Sydney : sorry I am late
20:11:39 <Joubu> bag: we will certainly found some others when pushed
20:12:04 <bag> yeah Joubu I think there are going to be some - I will be cautious when pushing - but would like that early early in the release cycle :)
20:12:05 <Joubu> but at least if it's pushed not to close to the release, we will have time to get them!
20:12:06 <rangi> nope
20:12:17 <Joubu> :)
20:12:36 <rangi> that was nope to bag, no objections to changing the text
20:12:49 <rangi> not nope to that bag ;-)
20:13:22 <Joubu> bag: yep good idea
20:13:23 <bag> cool it was brought to my attention that it was sort of hard to go back a few years and see a message “that was pushed to master”  but when?  heh
20:13:46 <bag> currently my goal is to keep the PQA queue low
20:13:48 <rangi> dont forget you have the release notes text area now too
20:13:59 <Joubu> when you have it, but you don't know where :)
20:13:59 <bag> Patches - it's all fair game now.  Anything that is passed QA is a candidate to be pushed
20:14:29 <bag> we also Created Elastic Search branch for easy testing.  ( http://git.koha-community.org/gitweb/?p=koha.git;a=shortlog;h=refs/heads/new_12478_elasticsearch )
20:14:40 <bag> bug 12478
20:14:41 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12478 enhancement, P5 - low, ---, robin, NEW , Elasticsearch support for Koha
20:14:59 <Joubu> master is quite unstable at the moment, but we have patches in the queue
20:15:16 <Joubu> (I don't have the numbers, sorry)
20:15:19 <bag> it’s pretty close to master and I will work on trying to make sure that branch is close to current
20:16:00 <bag> yes it’s unstable - I want to work on that in the next couple of weeks.  I was waiting for tcohen to come back so I can learn more about Jenkins - then I’m sure we’ll have some spots to attack
20:16:11 <bag> would be great to get it stable
20:16:28 <Joubu> Why is the branch called new?
20:16:47 <cait1> test
20:16:47 <Joubu> it is the same as the one on the catalyst repo, right?
20:16:52 <cait1> sorry, i lost connection to IRC
20:16:55 <cait1> reading back now quickly
20:17:10 <Joubu> (rebased I meant)
20:17:11 <bag> hmmm something to do with how gmcharlt_ set up the permissions
20:17:35 <bag> yes it is the same as the catalyst repo currently
20:17:38 <rangi> i think you need to get your nick back before you can continue the meeting cait1
20:17:59 <cait1> hm already exists
20:18:02 <cait1> we need to kill the othe rcait
20:18:07 <rangi> we cant
20:18:14 <cait1> ugh
20:18:17 <rangi> it needs to timeout/fall off
20:18:22 <rangi> we can only kick it from the channel
20:18:27 <rangi> which doesn't actually help
20:18:30 <bag> yeah whoops
20:18:31 <rangi> the nick still exists
20:18:32 <rangi> :)
20:18:43 <drojf> you can kill it if you have a password
20:18:52 <cait1> hm let me try to remember
20:19:11 <cait1> and +1 for adding the expected version to the RM push notes on bugs
20:19:22 <cait> ok back :)
20:19:48 <bag> ok that’s really it from me.  any questions?
20:19:55 <cait> #info XSS patches on bug 13618 should be pushed soon - will have all to look out for bugs
20:19:56 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=13618 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Prevent XSS in the Staff Client and the OPAC
20:20:13 <cait> i got 2 things i already told while disconnected (noone saw) :)
20:20:14 <cait> sec
20:20:29 <cait> bug 15358
20:20:30 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15358 blocker, P1 - high, ---, julian.maurice, Needs Signoff , merge.pl does not populate values to merge
20:20:45 <bag> yes saw that - it’s a blocker
20:20:46 <Joubu> that's a bad on
20:20:50 <cait> bug 6657
20:20:51 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6657 critical, P5 - low, ---, jonathan.druart, Needs Signoff , Making 999 visible in framework duplicates 999 entry and affects index
20:20:58 <bag> I’ll ask nick to test that
20:20:59 <cait> Are in need for good testing and speedy sign-off please
20:21:08 <bag> khall: can you ask nick to take a look at that one?
20:21:18 <khall> will do!
20:21:19 <cait> so we can get that fixed for the next maintenance releases
20:21:34 <bag> hmm maybe both of those khall
20:21:42 <cait> authority merge and authority add broken
20:21:44 <khall> can do
20:22:01 <Joubu> There is bug 15568 too
20:22:02 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15568 major, P5 - low, ---, jonathan.druart, Needs Signoff , Circ rules are not displayed anymore
20:22:19 <Joubu> (which is not really major)
20:22:24 <khall> on the list
20:22:31 <bag> cool
20:23:01 <cait> #info please help with good testing and speedy sign off for evil bugs: 15358, 6657 (authorities) and 15568 (admin)
20:23:14 <cait> anything else?
20:23:14 <wahanui> hmmm... anything else is just being crap
20:23:29 <bag> also I am completely open to anyone that has ideas on promotion of more sign-offers :)
20:23:52 <bag> I am working on getting more bywater peeps to do sign-offs (getting the right tools inplace first)
20:24:28 <cait> i think one problem is that we have a lot of hard to test things - architecture and internals
20:24:32 <Joubu> bug 15570 affects stable releases
20:24:33 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15570 major, P5 - low, ---, jonathan.druart, Needs Signoff , circ/renew.pl is broken
20:24:41 <bag> and will be putting an appeal to the librarians that work with bywater
20:25:45 <cait> :)
20:26:26 <cait> bag: maybe organizing a test day like lyon did could help
20:26:35 <cait> helping people to set up sandboxes for bugs they have picked before
20:26:38 <bag> cool :) noted
20:27:06 <cait> ok, one last thing :)
20:27:15 <andreashm> setting up sandboxes sounds like a good wau to make sign-offs easier
20:27:24 <bag> once I am not traveling so much - I’ll be trying some virtual “help” too
20:27:28 <tubaclarinet> I know there's <http://bywatersolutions.com/2013/11/29/koha-sandboxes/> but a video of it would be stellar!
20:27:45 <cait> hm a tutorial video is a good idea!
20:28:08 <cait> #idea create a tutorial video about setting up a sandbox, testing and signing off with it
20:28:10 <barton> nengard has been looking at 'guide on the side' for training/documentation purposes, but I think that we could use it for testing as well
20:28:21 <bag> cool I’ll ask nicole to create a video
20:28:31 <cait> #idea organize a test day where libraries can pick bugs to test before and help them testing them (setting up sandboxes, fixing conflicts)
20:28:39 <barton> +1 for video
20:28:46 <cait> a webinar might work too
20:29:01 <tubaclarinet> Please include in the video troubleshooting like symptoms of the wrong database, etc.
20:29:17 <tubaclarinet> FWIW
20:29:24 <cait> maybe we could add an faq section to the wiki page
20:29:28 <barton> good idea tubaclarinet.
20:29:29 <cait> about problems
20:29:39 <cait> if you see... ... that did not work, because...
20:29:54 <tubaclarinet> faq section = :-)
20:30:11 <cait> some other thing I'd like to get done - ashimema has volunteered to join the QA team again (yay!) - so i'd like to do a quick vote to see if we can make this happen :)
20:30:36 <bag> +1
20:30:37 <cait> #startvote Are you ok with ashimema joining the QA team for 3.24? (yes,no)
20:30:37 <huginn`> Begin voting on: Are you ok with ashimema joining the QA team for 3.24? Valid vote options are , yes, no, .
20:30:37 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
20:30:52 <cait> #vote yes
20:30:57 <Joubu> #vote yes
20:31:00 <davidnind> #vote yes
20:31:02 <khall> #vote yes
20:31:05 <barton> #vote yes
20:31:05 <drojf> #vote yes
20:31:11 <jmsasse> #vote yes
20:31:12 <bag> #vote yes
20:31:19 <hbraum> #vote yes
20:31:32 <BobB> #vote Yes
20:31:53 <cait> ending vote...
20:32:02 <cait> #endvote
20:32:02 <huginn`> Voted on "Are you ok with ashimema joining the QA team for 3.24?" Results are
20:32:02 <huginn`> yes (10): Joubu, davidnind, cait, jmsasse, barton, BobB, khall, bag, hbraum, drojf
20:32:03 <Colinc> #vote yes
20:32:15 <andreashm> #vore yes
20:32:22 <andreashm> ah, damn, to late
20:32:35 <andreashm> and misspelled. =)
20:32:53 <cait> #agreed Martin Renvoize joins the QA team for 3.24 - 12 yes votes
20:33:01 <cait> moving on to the next?
20:33:02 <bag> nice
20:33:15 <cait> #topic Comments on Circ Rules Revamp
20:33:35 <bag> khall ^^^
20:33:44 <cait> #link http://wiki.koha-community.org/wiki/Circulation_Rules_Interface_and_Backend_Revamp_RFC
20:34:10 <khall> We'd really like to nail down any issues with the circ rules revamp if there are any
20:34:24 <khall> anyone who is interested please read the rfc
20:34:36 <khall> if you've already read it and have any questions now, I'm here to field them
20:34:53 <tubaclarinet> rfc = request for comment?
20:35:00 <bag> yes
20:35:09 <khall> I think this is very important in the long term as our movement to increasing amounts of circ rules has maid the current interface untenable
20:35:15 <cait> I think i am slightly in favour of a more table like thing ot be honest
20:35:22 <cait> but that's me
20:35:43 <indradg> #info Indranil Das Gupta, India.
20:35:49 <khall> cait: we already have a table like thing ; ) The primary goal is to move to a more flexible approach that allows for simpler rule sets
20:35:56 <cait> I'd like something where I can easily compare rules for different itemtypes or different categories
20:35:59 <khall> this approach doesn't jive all that well with a table based approach
20:36:03 <Joubu> I think we need oleonard :)
20:36:09 <khall> cait: that's already on my list!
20:36:20 <cait> i am not sure how that would work with the mock up
20:36:23 <ikourmou> #info Giannis Kourmoulis, Thessaloniki Greece
20:36:49 <khall> I think a second screen that gives a matrix of types categories and libraries with what the rule will be ( and where that rule is coming from ) would be a good companion
20:36:59 <andreashm> I have read the RFC... I'm a bit concerned that having a lot of issuing rules will make this new appoach hard to overview
20:37:02 <BobB> indradg it must be early for you!
20:37:18 <BobB> like middle of the night?
20:37:20 <andreashm> khall: that seems like a good approach
20:37:22 <khall> andreashm: that is what the second screen I propose will take care of
20:37:43 <khall> thanks!
20:37:44 <indradg> BobB: 2:10 am
20:37:58 <BobB> :)  well done!
20:38:09 <barton> cait -- how would you feel about some sort of explicit 'compare circ rules' functionality?
20:38:11 <cait> khall: could youmaybe mock up the second screen too?
20:38:26 <cait> to get a better idea?
20:38:29 <hbraum> my consortia is sponsoring this development, although i’m very much letting pianohacker and khall take the reins on this. we’ve currently got 1200 issuingrule lines, so they have a good test case for lots of rules already.
20:38:31 * andreashm would like that too
20:38:32 <khall> cait: yes, I can do that
20:38:53 <andreashm> hbraum: ouch
20:38:54 <hbraum> and looking at the current mockup, a second screen overview would be helpful, I agree.
20:38:55 <cait> #action khall asked nicely to add another mock-up for an overview kind of page
20:38:56 <bag> yeah 1200 lines is crazy
20:39:19 <khall> The first step is to change the internals without changing the externals. If anyone has an issue with the proposed schema please let us know asap
20:39:53 <cait> it will be a bit harder to get a nice excel sheet out :)
20:40:04 <cait> that's what we do now - because you can make it sortable
20:40:11 <cait> if there is no longer a need for it... that might be not too bad
20:40:16 <khall> this would be a table too, so very sortable
20:40:23 <rangi> first thing id do is create a script where you can pass a itemtype, categorycode and branch, and get back what the rule applied would be
20:40:27 <rangi> then you can change the internals
20:40:30 <rangi> run that again
20:40:37 <rangi> and prove it hasn't suddenly changed
20:40:42 <khall> rangi: agreed, unit tests ++
20:41:21 <barton> khall: I've got most of that written.
20:41:26 <rangi> that script could then have a web frontend put on it later, so librarians could choose from a drop down, and see what rule would be applied .. rather than having to read everything
20:41:46 <rangi> why was this book issued for 4 weeks .. oh it used this rule
20:41:50 <khall> rangi: you're reading my mind ; ) We've discussed that idea
20:41:55 <cait> #idea have a script that gives you the circ conditions for branch, itemtype and patron category entered
20:42:00 <rangi> 70% of support queuries gone :)
20:42:04 <khall> I think that should definitely be built in
20:42:17 <bag> more time to signoff!!!
20:42:41 <Joubu> bag: heh, we have found what you wanted
20:42:44 <hbraum> rangi ha! no kidding.
20:43:07 <barton> In design discussions, we talked about making the lookup available on the circ page too, just for reference.
20:43:12 <cait> hbraum: nekls++ btw for sponsoring - much needed
20:43:26 <cait> for libraries with only 150 and less rules too :)
20:43:56 <cait> ok, any more ideas or can we move on?
20:44:05 <cait> full agenda tonight, but i don't want to rush youtoo much :)
20:44:12 <khall> going once
20:44:17 <hbraum> yw! the overall development scope of the project will also help branch specific circ-related rules get applied through this, right khall?
20:44:36 <khall> hbraum: yes!
20:44:57 <cait> i'd lke to move up a topic - Kohacon16
20:44:58 <khall> it will hopefully be a grand unification theory for Koha circ rules
20:45:10 <khall> agreed, let's move on
20:45:21 <cait> #topic KohaCon16 - Greece
20:45:23 <bag> thanks khall
20:45:30 <cait> ikourmou?
20:45:39 <ikourmou> i'm here!
20:45:48 <cait> I think we are all curious for an update :)
20:46:11 <wizzyrea> #info Liz Rea, Catalyst
20:46:16 <ikourmou> we are working on the ocnference, we started with forming a committee
20:46:23 <ikourmou> the dates are set
20:46:31 <ikourmou> from 30th of may
20:46:36 <davidnind> #info David Nind, Wellington, NZ
20:46:38 <ikourmou> to 4th of june
20:46:57 <cait> #info dates are set - may 30 - june 4
20:47:12 <ikourmou> 3 first days of presentations, then a day off for a roadtrip for sightseeing
20:47:25 <ikourmou> and then teo days for the hackfest
20:47:37 <ikourmou> the venue is already booked
20:47:57 <ikourmou> and the webpage for the Kohacon16 will be live next week
20:48:24 <ikourmou> I would like to ask you people for a couple of things...
20:48:43 <JesseM> ikourmou++
20:48:47 <ikourmou> there will be a call for presentations i suppose
20:49:14 <ikourmou> what is the best way to deal with it?
20:49:29 <cait> hm you could look at how it was done the last years maybe
20:49:40 <cait> i think probably put it on the website, but alos send to the mailing lists
20:49:50 <ikourmou> do we have to specify subjects in advance?
20:49:55 <rangi> nope
20:50:04 <rangi> apart from, should be Koha related :)
20:50:26 <cait> i think you can probably keep it simple :)
20:50:36 <rangi> it's nice to get as many local presentations as you can too
20:50:51 <ikourmou> ok, there are some thoughts on presentation subjects from the organising team here
20:51:37 <ikourmou> aso, when would we start accepting registrations?
20:51:59 <cait> I think getting out the cfp would be highest prio now
20:52:08 <cait> some people onl yget funding for travel if they get to speak
20:52:10 <cait> or it's easier for them
20:52:45 <cait> and also with an idea about the program, more people might register - not sure
20:52:48 <ikourmou> ok, it could be done by next week
20:53:19 <rangi> often it makes it easier for people to get funding
20:53:24 <ikourmou> you mean a more specific program than i mentioned above, i suppose
20:53:27 <rangi> to attend
20:53:48 <rangi> if they can say "theres a presentation about linked data and Koha .. we want to do that" to their boss ;)
20:53:59 <rangi> if that makes sense
20:54:18 <ikourmou> ok, i understand
20:54:23 <cait> ikourmou: i think if you have some specific topics oyu'd like to get presntations about you could put that in the cfp, but laeave it open for other ideas as well?
20:54:50 <ikourmou> yes, that's what we were thinking
20:55:01 <rangi> cool
20:55:08 <cait> cool :)
20:55:28 <BobB> re the conference dates, an early announcement to the mailing list is always good - announce early and announce often
20:55:40 <drojf1> ikourmou: i think it is not uncommon to get a few people from the community to help decide on the presentations once the call for papers is over. if you need help with that feel free to ask
20:56:05 <ikourmou> BobB: already sent to koha mailing list and to koha news
20:56:24 <BobB> keep doing it, just sayin'
20:56:51 <ikourmou> BobB: will do again with the webpage address, thx
20:57:02 <BobB> yes, very good
20:57:18 <wizzyrea> ikourmou: please let me know when  you have stuff for the community kohacon16 page
20:57:29 <ikourmou> thanks, drojf1, that was my next question
20:57:44 <wizzyrea> stuff = a url, specific copy you'd like there
20:57:50 <wizzyrea> otherwise you're leaving it up to me :)
20:58:35 <ikourmou> and another question:
20:59:09 <ikourmou> if we get to many proposals for presentations, what is the best way to choose?
20:59:22 <ikourmou> or should we try to fit them all to the schedule?
20:59:41 <rangi> that's up to you
20:59:56 <rangi> but one question to ask is, are you definitely coming
21:00:03 <rangi> when i ran kohacon10
21:00:14 <rangi> we got a lot of proposals, then a lot couldn't come
21:00:26 <rangi> so it's easy to drop those ones out
21:00:51 <ikourmou> ok, i will note this - hadn't thought of it :-)
21:00:52 <drojf1> you may get a lot of papers from a single institution, who you could ask to share slots. if you got the same topic covered by a library and a support provider, choose the library
21:00:54 <bag> magnuse: knuckles
21:00:57 <rangi> after that, we had enough :)
21:01:31 <drojf1> or make them collaborate ;)
21:01:52 <BobB> if you have the capacity, you can run parallel sessions too
21:02:10 <rangi> which is kinda horrible imho
21:02:11 <rangi> :)
21:02:33 <rangi> i think single track conferences are so so so much better than multi track
21:02:34 <irma> that would not be my choice ... parallel sessions
21:02:38 <cait> yeah... having to pick... aah
21:02:39 <fredericd> #info Frédéric Demians, Tamil
21:02:39 <cait> :)
21:02:40 <magnuse> bag: HI
21:02:41 <wahanui> que tal, magnuse
21:03:08 <rangi> however, sometimes you can ask if someone would rather present as part of the hackfest
21:03:09 <cait> having some kind of discussion/roundtable thing or question and answers is also good to fill slots
21:03:20 <rangi> having said all this .. it's never been a problem in the past
21:03:27 <irma> single track conferences ++
21:03:32 <cait> maybe worry, once the papers come in :)
21:03:36 <rangi> and having too many presentations will be a new and exciting problem to solve :)
21:03:45 <cait> oh, and set a deadline - i think i tmakes people actually write abstracts
21:03:58 <cait> can still extend if necessary
21:04:00 <ikourmou> we were thinking of placing "introductory" presentations in the morning sessions, leaving the more specialised ones for the afternoon
21:04:19 <rangi> that makes sense to me
21:04:48 <ikourmou> another question:
21:04:49 <drojf1> sleeping in ++
21:04:56 <ikourmou> Is there something we should take care of, regarding travel arrangements?
21:05:06 <magnuse> #info Magnus Enger, Libriotech, Norway
21:05:09 <ikourmou> especially for people oustide the EU?
21:05:22 <rangi> I have always found a page, that lists airports close
21:05:23 <BobB> the conference should be accessible for librarians and newbies; very technical presentations can be left to the hackfest
21:05:36 <rangi> really helpful
21:05:43 <rangi> and maybe a link to VISA requirements etc
21:05:55 <rangi> also, for some people they make ask you for an invitation letter
21:05:56 <wizzyrea> does greece ... yeah that
21:06:07 <BobB> ikourmou I would like a scholarship to attend the conference please, $5k should do it :)
21:06:22 <rangi> so having a letter you can sign and scan is handy too
21:06:34 <rangi> (it helps with some people getting a VISA)
21:06:43 <ikourmou> BobB: I 'll see what we can do :)
21:07:16 <BobB> thanks ikourmou, I will wait patiently
21:07:43 <ikourmou> ok, noted (VISA info and invitation letter). thanks
21:08:06 <cait> i forgot to add #info... but curious people wil read full minutes i hope
21:08:21 <cait> #info forgot to add more infos... lots of KohaCon infos in full meeting logs
21:08:35 <BobB> cait +1
21:09:00 <cait> ikourmou: any more questions? or questions for ikourmou?
21:09:05 <rangi> http://kohacon15.projektlinkkonsult.com/getting-to-ibadan/  <-- a page like that is handy
21:09:31 <ikourmou> rangi: yes, i've seen that
21:09:51 <Joubu> Are there good beers in Greece?
21:10:04 <rangi> heh
21:10:19 <rangi> http://wiki.koha-community.org/wiki/Kohacon13/Social  <--- i brought my own
21:10:20 <wizzyrea> that's probably the most important question
21:10:29 <ikourmou> is there anything that you would like sto stress out in general? especially you people that already organised a conference before...
21:10:31 <rangi> but pages like that on the wiki are good to create too, also
21:10:40 <rangi> http://wiki.koha-community.org/wiki/Kohacon13/Arrivals
21:11:03 <ikourmou> Jobu: a lot of microbreweries, i hope you will find interesting
21:11:12 <Joubu> rangi: I will try to bring them!
21:11:51 <Joubu> ikourmou: great :)
21:12:04 <cait> #info there are lots of microbreweries in Greece
21:12:18 <bag> I’m sold can we have kohacon next week?
21:12:21 <cait> best advertising for kohacon...
21:12:26 <cait> heh
21:12:28 <cait> i am all fo rit
21:12:33 <cait> but i think we need to move on
21:12:58 <ikourmou> ok, thank you people for the advice :)
21:13:05 <cait> #topic Update from the International Fund Committee
21:13:12 <bag> not much besides - we tried to put together a meeting - but with holidays we weren’t able to find one
21:13:13 <bag> still working on the next meeting
21:13:18 <ikourmou> hope to see you in Greece!
21:13:22 <cait> ikourmou: please get in contact if we can help in any wa
21:13:23 <cait> y
21:13:24 <bag> thanks ikourmou
21:13:53 <cait> #info looking for dates for the next meeting
21:13:58 <BobB> there are two things to do re fundraising
21:14:06 <BobB> organise a meeting
21:14:27 <BobB> and write rules for the HLT Grants committee - Galen and I are to do that
21:15:01 <BobB> bag do you have any info on how much has been raised at HLT?  I suspect not a lot yet?
21:15:20 <cait> #info Galen and BobBto write rules for the HLT Grants committee
21:15:24 <bag> I don’t have that - but I can ask Jo and will report for the next meeting
21:15:47 <cait> #action bag to ask how much has been raised so far
21:15:54 <cait> and report...
21:15:55 <wahanui> i guess report is for Overdues that we want to mail out from the library, not use peoples' emails. It needs to show the patrons' information and just the items that are overdue all on a single page. Each page needs to have one patron only. Can anyone help me with this?
21:15:55 <BobB> cool, I'll have another go at scheduling a meeting
21:16:23 <BobB> wahanui, read the manual
21:16:24 <wahanui> BobB: i'm not following you...
21:16:35 <pianohacker> wahanui: forget report
21:16:35 <wahanui> pianohacker: I forgot report
21:16:46 <cait> #action BobB to schedule the meeting
21:16:54 <cait> any questions?
21:16:57 <pianohacker> also hi y'all
21:17:38 <cait> moving on :)
21:17:44 <cait> #topic Let's Encrypt
21:17:57 <drojf1> we are running a little late already, i'm trying to make this short. i think it would be good to support letsencrypt as soon as possible
21:18:06 <drojf1> gmcharlt introduced me to eric hellman who is going to look into letsencrypt adoption by library projects for the library freedom project, they are pretty interested in this too
21:18:17 <cait> just a warning - if no protests i'd like to move the kohacon voting discussion nd the INSTALL.debian topics to the next meeting
21:18:23 <drojf1> i basically have two questions: 1) it's only debian script changes, can we have it in stable before 3.24 (when it's tested ok)? 2) should it become default eventually, or would that be considered antifeatureish?
21:18:54 <cait> drojf1: does it have any new dependencies?
21:19:05 <cait> i think that hs been the major blocker for backporting - or one of them currently
21:19:11 <drojf1> not in debian yet, beuase there is no package
21:19:36 * magnuse would vote for getting it into 3.22.x
21:19:47 <drojf1> atm you need to checkout from git. i dont know how long this will take until its in the repo
21:20:04 <drojf1> the bug is 15303, i added a new patch today and it can be tested (please)
21:20:12 <wizzyrea> +1 to make it very easy to SSL
21:20:17 <drojf1> i will open another for koha-letsencrypt to do it with existing installations
21:20:48 <drojf1> but in the long run i think it would be good to have this as a default (which can be overidden of course)
21:21:30 <magnuse> +1 to make it default
21:21:47 <cait> maybe: backport but make it optional
21:21:58 <cait> and think about default for next release?
21:22:13 <davidnind> I think it needs to be optional, for those behind firewalls
21:22:16 <drojf1> i would propose: backport, as optional. and label it experimental maybe, because you need to checkot the client yourself and stuff
21:22:23 <rangi> yeah
21:22:28 <cait> davidnind: i think it would always be - just thinking about the default setting
21:22:31 <magnuse> make it easy to enable for existing sites and default for new sites
21:22:37 <cait> i think i didn't phrase it right
21:22:40 <drojf1> oh. it should always be optional!
21:22:51 <drojf1> a default an be overridden of course
21:22:58 <cait> i meant non-default - not optional :)
21:23:01 <drojf1> it wont work for everyone, that is for sure
21:23:17 <drojf1> and some people will use their own certs, etc
21:24:18 <drojf1> but if we backport it now we also have more testers and can fix stuff before it may be a default
21:24:42 <drojf1> it's not interfering with koha codebase apart from the debian scripts
21:24:43 <cait> jajm is not here tonight, so we can't reall ymake a decision i think
21:24:56 <drojf1> true
21:25:05 <cait> but we can get an idea about what poeple tend to maybe
21:25:11 <cait> is someone against backporting?
21:25:34 <cait> or has questions? doubts?
21:25:47 <rangi> id wait until its packaged, it's kinda moot at this point ;)
21:26:04 <rangi> (ie making a dependency, it needs to be debian packaged before we could that anyway)
21:26:15 <Joubu> I'll read the patch first :)
21:26:21 <rangi> but certainly showing how to install it with Koha, is a great idea
21:26:26 <wizzyrea> ^
21:26:59 <cait> #link http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15303
21:27:00 <huginn`> 04Bug 15303: enhancement, P5 - low, ---, mirko, Needs Signoff , Letsencrypt option for Debian package installations
21:27:35 <drojf1> i'll try to find out about the package situation
21:28:02 <rangi> https://obs.library.workbuffer.org/  <-- uses letsencrypt fwiw
21:28:05 <cait> btw drojf++
21:28:09 <rangi> thats my kids school
21:28:16 <rangi> yep
21:28:18 <magnuse> yeah drojf++
21:28:19 <rangi> drojf++
21:28:28 <indradg> +1 for backporting
21:29:18 <cait> #info please help testing the patches for Letsencrypt on bug 15303
21:29:19 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15303 enhancement, P5 - low, ---, mirko, Needs Signoff , Letsencrypt option for Debian package installations
21:29:29 <cait> any more questions?
21:29:32 <drojf1> ok that sabout it for now
21:29:41 <drojf1> that's about
21:30:02 <cait> are people ok with wrapping it up for today?
21:30:13 <rangi> yep
21:30:14 <davidnind> yep
21:30:25 <drojf1> +1
21:30:27 <BobB> yes
21:30:32 <Colinc> yep
21:30:40 <cait> we didn't cover INSTALL.debian and KohaCon17, KohaCon voting - so pushing those to next time
21:30:54 <cait> #topic Next meeting
21:31:02 <drojf1> we will push the voring stuff until the next vote :P
21:31:11 <drojf1> *voting
21:31:20 <cait> #info INSTALL.debian, KohaCon17, and KohaCon voting mechanism are postponed to the next meeting
21:31:34 <cait> drojf1: or first on agenda next time :)
21:31:45 <cait> what about february 3rd?
21:32:09 <drojf1> sounds good to me (3rd)
21:32:13 <davidnind> +1
21:32:16 <magnuse> +1
21:32:19 <cait> what time?
21:32:19 <wahanui> i think time is like a big ball of wibbly wobbly... time-y wimey... stuff. or generously donated to giving support in #koha but if you need more help faster than we can give it try http://koha-community.org/support/paid/
21:32:29 <Colinc> +1
21:32:36 <rangi> +1
21:32:53 <cait> 10 UTC?
21:32:54 <wahanui> rumour has it 10 UTC is a good time, but is very early on east coast USA
21:33:03 <magnuse> +1
21:33:14 <drojf1> +1
21:33:40 <cait> #agreed Next IRC meeting will be on February 3, 10 UTC
21:33:49 <cait> #endmeeting