#koha: Development IRC meeting 11 January 2017

Meeting started by kidclamp at 20:01:33 UTC (full logs).

Meeting summary

    1. Nick Clemens, ByWater Solutions (kidclamp, 20:01:45)
    2. Kyle M Hall, ByWater Solutions (khall, 20:01:56)
    3. Chris Cormack, Catalyst IT (rangi, 20:01:59)
    4. Thomas Dukleth, Agogme, New York City (thd, 20:02:29)
    5. Katrin Fischer, BSZ, Germany (cait, 20:02:32)
    6. Claire Gravely, BSZ, Germany (LibraryClaire, 20:02:53)
    7. David Nind, Wellington, New Zealand (davidnind, 20:02:53)
    8. Mirko Tietgen, Berlin, Germany (drojf, 20:02:56)
    9. Reed Wade, prev Catalyst IT (reed_, 20:03:05)
    10. Josef Moravec, Municipal LIbrary Usti nad Orlici, Czech Republic (josef_moravec, 20:03:12)
    11. Jonathan Druart, France (Joubu, 20:03:32)
    12. (nuentoter, 20:04:43)

  1. Announcements (kidclamp, 20:05:12)
    1. Justin Martin, Abel J. Morneault memorial library, United States (nuentoter, 20:05:15)
    2. PR koha-dashboard to display an "overall health status" (kidclamp, 20:05:56)
    3. https://jenkins.koha-community.org/ is jenkins.theke.io (rangi, 20:09:28)
    4. https://jenkins.koha-community.org/job/Koha_Master_D8//badge/icon (rangi, 20:09:59)
    5. Badges are broken on Jenkins and there are some failing tests (kidclamp, 20:11:39)
    6. http://dashboard.koha-community.org/ are the better stats to optimise (wahanui, 20:12:56)

  2. Review of coding guidelines (kidclamp, 20:13:15)
  3. Progress on next release (17.05) (kidclamp, 20:14:56)
    1. Barton Chittenden, BWS (Louisville, KY, USA, Earth, SOL) (barton, 20:15:50)
    2. Michael Cabus, BWS (Princeton, NJ, USA) (caboose__, 20:16:50)
    3. Kyle will push bug 16239 on Friday - this will cause some other bugs to need rebasing - be aware (kidclamp, 20:17:38)

  4. Progress on current release (16.11) (kidclamp, 20:18:20)
    1. string freeze coming, cait will email the lists (kidclamp, 20:18:36)
    2. HELP: please look at bug 17817 before 16.11.2 (kidclamp, 20:19:34)

  5. General development discussion (kidclamp, 20:20:29)
    1. Roadmap for The TT syntax for notices? (kidclamp, 20:20:43)
    2. many willing to help on this, we need to convert all the default notices (kidclamp, 20:27:54)
    3. more info on the list next week (kidclamp, 20:28:03)

  6. Benchmark? (kidclamp, 20:28:11)
    1. we need more people to replay the benchmarks and report results (kidclamp, 20:30:03)

  7. Updates from the QA team (kidclamp, 20:32:35)
    1. where are the QAers? (kidclamp, 20:32:45)
    2. HELP: QA team should be checking critical bugs frequently and keep them moving (kidclamp, 20:36:29)
    3. Help for refactoring (kidclamp, 20:38:04)
    4. ACTION: kidclamp will email the list for help in preparing reports affected by bug 17196 (kidclamp, 20:54:10)
    5. ACTION: nvm, davidnind will send out the note about reports (kidclamp, 20:55:22)

  8. Next Meeting (kidclamp, 20:56:26)
    1. Next meeting is 25 January 2017, 13 UTC (kidclamp, 20:58:51)


Meeting ended at 20:59:00 UTC (full logs).

Action items

  1. kidclamp will email the list for help in preparing reports affected by bug 17196
  2. nvm, davidnind will send out the note about reports


Action items, by person

  1. davidnind
    1. nvm, davidnind will send out the note about reports
  2. kidclamp
    1. kidclamp will email the list for help in preparing reports affected by bug 17196


People present (lines said)

  1. Joubu (85)
  2. kidclamp (66)
  3. cait (48)
  4. rangi (33)
  5. barton (15)
  6. drojf (9)
  7. khall (8)
  8. huginn` (8)
  9. LibraryClaire (6)
  10. josef_moravec (5)
  11. davidnind (4)
  12. wahanui (3)
  13. thd (3)
  14. nuentoter (3)
  15. khall_ (2)
  16. reed_ (1)
  17. caboose__ (1)


Generated by MeetBot 0.1.4.