14:00:56 <kidclamp> #startmeeting Development IRC meeting 11 October 2017
14:00:56 <huginn`> Meeting started Wed Oct 11 14:00:56 2017 UTC. The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:56 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:56 <huginn`> The meeting name has been set to 'development_irc_meeting_11_october_2017'
14:01:04 <kidclamp> #topic Introductions
14:01:14 <greenjimll> #info Jon Knight, Loughborough University
14:01:24 <kidclamp> #info Nick Clemens, ByWater Solutions
14:01:29 <marcelr> #info Marcel de Rooy, Rijksmuseum
14:01:40 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:02:22 <thd> #info Thomas Dukleth, Agogme, New York, NY
14:02:26 <Joubu> #info Jonathan Druart
14:02:31 <slef> #info MJ Ray, software.coop, England
14:02:47 <Joubu> Rmaints? mtj, fridolin, cait ?
14:03:12 <tcohen> #info Tomas Cohen Arazi
14:03:34 <cait> #info Katrin Fischer, BSZ, Germany
14:03:39 <fridolin> #info Fridolin Somers, Biblibre, France
14:04:11 <cait> String freeze is planned for 15th - we will have lots of bug fixes in 16.11.13
14:04:42 <kidclamp> #topic Announcements
14:05:08 <kidclamp> Today is GBSD! Squash things!
14:05:11 <JesseM> #info Jesse Maseto, BWS
14:05:14 <kidclamp> anyone else :-)
14:05:28 <JesseM> YAY!!
14:05:31 <Joubu> I am waiting for you to let me push all the things
14:05:32 <fridolin> Jenkins for 17.05.x is stable at laaaaaast
14:05:46 <tcohen> fridolin++
14:05:47 <Joubu> yes, 16.11 is going to very soon
14:06:04 <Joubu> and 16.05, after bug 19441
14:06:04 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19441 major, P5 - low, ---, jonathan.druart, Needs Signoff , Several tests are failing on 16.05.x
14:06:18 <Joubu> so all the 3 maintaned releases will be stable
14:06:30 <marcelr> or seem stable :)
14:06:38 <Joubu> (we should not be happy about that, it should be a normal situation)
14:06:53 <kidclamp> #info soon all stable releases are expected to be stable (according to jenkins)
14:07:02 <Joubu> marcelr: I only trust jenkins :p
14:07:05 <tcohen> mtj has provided a third node for dockerized jenkins runs
14:07:21 <kidclamp> #info mtj has provided a third node for dockerized jenkins runs
14:07:46 <kidclamp> anything more?
14:08:04 <Joubu> yes
14:08:11 <Joubu> it's GBSD today
14:08:20 <Joubu> (yes I know, but always good to repeat)
14:08:32 <kidclamp> :-)
14:09:40 <kidclamp> #topic Update from the Release manager (17.11)
14:10:02 <kidclamp> that's you Joubu
14:10:08 <Joubu> nothing from me, I am waiting for bugs to push. Release dates have been published
14:10:25 <Joubu> 1w after the usual dates, for personal reasons
14:10:43 <Joubu> nothing else
14:10:54 <Joubu> (personal reasons = holidays)
14:11:12 <kidclamp> #info release dates were published, give him more things to push!
14:11:25 <kidclamp> #topic Updates from the Release Maintainers
14:11:29 <Joubu> ha, and please SO and QA the 7 majors!
14:11:39 <kidclamp> fridolin, cait, mtj
14:12:49 <kidclamp> #info 16.11 - String freeze is planned for 15th - we will have lots of bug fixes in 16.11.13
14:13:02 * fridolin tries to reduce gap between stable and master
14:13:18 <greenjimll> Is that 15th October or 15th November?
14:13:24 <cait> sorry, only half here
14:13:28 <cait> missed my spot
14:13:45 <fridolin> 15th October, for 17.05.05 too
14:14:05 <fridolin> there have beeen some work on translatability so please translate
14:14:41 <cait> greenjimll: 15 each month for the stable releases, different for 17.11
14:15:06 <kidclamp> #info October 15th is string freeze for both stable
14:15:34 <kidclamp> #info please work on translations (and manual and bugs, please)
14:15:47 <kidclamp> anything more?
14:16:14 <fridolin> and dont hesitate to mail me to point some bugs you want to see in stable
14:16:33 <fridolin> some enhancements may be backported
14:16:34 <Joubu> I cc you on bugs when needed
14:16:45 <fridolin> Joubu: yes thanks a lot
14:16:56 <kidclamp> #info poke Frido if you want something backported
14:16:57 <fridolin> there have been a few realy dirty ones
14:17:46 <kidclamp> moving on
14:17:53 <kidclamp> #topic Updates from the QA team
14:18:38 <marcelr> nothing much to say..
14:19:05 <kidclamp> do we want another sprint? been trying to step up before release
14:19:27 <marcelr> the queue is large enough ;)
14:20:05 <marcelr> and there are lots of enh in it
14:20:06 <Joubu> NQA queue must be around 50 (and used to be like that)
14:20:15 <Joubu> now it's ~150 for the last 6 months
14:20:30 <Joubu> and there are not much SO...
14:21:12 <Joubu> (just complaining, you can move on)
14:22:03 <marcelr> you could be dutch, Joubu
14:22:14 <kidclamp> #info please QA and SO - queues are big, possible sprint soon
14:22:19 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:22:30 <Joubu> I am (almost) half french, I guess that's why
14:23:06 <kidclamp> not sure who proposed, but I like
14:23:13 <kidclamp> Should we move the advanced cataloguing editor out of the Labs tab?
14:23:25 <Joubu> it's cait
14:24:33 <kidclamp> I am happy to comment, we have many partners using it, it has been improving, there are some small usability bugs, but have not seen data lost or anything for concern
14:24:34 <cait> we could also tihnk about moving elastic under labs maybe
14:24:58 <cait> yeah i think it's safe to use
14:25:09 <cait> still adding new things, but we had some libraries using it too without any problems
14:25:17 <cait> and we add new things to other parts of Koha too
14:26:12 <kidclamp> unless anyone has strong objections I think it can be filed as a bug
14:26:25 <cait> what about moving searchenging to labs?
14:27:23 <Joubu> I did not remember that tabs, should we use it more or remove it?
14:27:30 * kidclamp is okay with that - maybe easier to just add (experimental) to the dropdown choice for elastic
14:27:33 <Joubu> should we put new feature in it?
14:27:56 <kidclamp> yeah, not much goes in there, only rancor right now
14:28:18 <cait> yep
14:28:21 <cait> it was added for rancor
14:28:46 <cait> it might get more attention in its own tab, but not sure
14:28:55 <cait> was supposed to be "we are working on this, you can start testing it"
14:29:20 <Joubu> ok, action?
14:29:24 * thd hates the false implication of the terminology search engine
14:29:41 <kidclamp> ?
14:30:14 <kidclamp> #action kidclamp will file a bug to move rancor out of the 'labs' section
14:31:10 <kidclamp> beyond that I don't know if there is consensus, maybe just an fio / email to consider that tab usage?
14:31:21 <kidclamp> s/fio/info/
14:31:47 <Joubu> yes, fill a bug and we will discuss there
14:32:03 <kidclamp> okay
14:32:12 <kidclamp> #topic Review of coding guidelines
14:32:13 <thd> "Search Engine" has become the popular term for any indexing and retrieval system implying more with engine than actually happens in any indexing and retrieval system and masking proper understanding of such systems.
14:32:16 <Joubu> my opinion is that it needs maintenance and we lack people
14:32:27 <kidclamp> Stop adding [SIGNED_OFF] labels when signing off patches (marcelr)
14:32:35 <Joubu> yes, +1
14:32:36 <marcelr> yes sir
14:32:39 <Joubu> I think we should vote
14:32:40 <khall> +1
14:32:43 <marcelr> +1
14:32:45 <tcohen> +1
14:32:48 <oleonard> frowny-face
14:33:09 <Joubu> IIRC I have also made the necessary changes to kohadevbox and the wiki
14:33:20 <marcelr> oleonard: these labels prevent automatic selection for obsoletion
14:33:26 <kidclamp> wiki link Joubu?
14:33:41 <thd> Was there not some subtlety in the mailing list discussion for some appropriate instances?
14:33:47 <jenkins> Project Koha_Master_D8 build #295: FAILURE in 3 min 13 sec: https://jenkins.koha-community.org/job/Koha_Master_D8/295/
14:33:54 <kidclamp> boo ^
14:33:56 <tcohen> https://github.com/digibib/kohadevbox/commit/6ab941382df8cad7f66c1daf4fbe97b732af1d5b
14:34:06 <oleonard> marcelr: I understand the reason. I think it's unfortunate that it will be m ore difficult to tell which patches are signed off when looking at attachments in Bugzilla.
14:34:09 <cait> +1
14:34:24 <marcelr> oleonard: this probably is what thd means
14:34:28 <Joubu> https://wiki.koha-community.org/w/index.php?title=Tips_and_tricks&action=historysubmit&diff=19340&oldid=10188
14:34:35 <marcelr> yes, a partial signoff is the exception
14:34:36 <kidclamp> is the sign off line not clear?
14:34:46 <greenjimll> If we're running kohadevbox via vagrant, is there anything we need to do to for this signoff change?
14:35:19 <oleonard> kidclamp: I refer specifically to the list of attachments, not the comments section.
14:35:36 <oleonard> I'm not arguing against the change, I'm just complaining.
14:35:44 <marcelr> we could still do that, but it should be exceptional
14:35:46 <cait> I think if your devbox is current it already has the change - maybe chekc on your next signoff
14:35:49 <thd> What is the mechanism for working around oleonard's reservation?
14:36:04 <marcelr> manual add it in bugzilla ?
14:36:10 <Joubu> 95% of the time, we want to SO on all the patchset
14:36:19 <marcelr> or more
14:36:19 <Joubu> maybe 94%
14:36:23 <marcelr> no
14:36:26 <Joubu> or 96%
14:36:27 <marcelr> 96
14:36:29 <Joubu> ;)
14:36:46 <oleonard> thd: It requires a change in habits, that's all.
14:37:35 <thd> Has the instruction been changed to indicate the exception of partial signoff?
14:38:00 <marcelr> we should put it somewhere probably
14:38:01 <cait> sorry, have to leave
14:38:13 <oleonard> I think we should move on
14:38:20 <marcelr> kidclamp: i will look for a wiki page to put it
14:38:21 <kidclamp> vote?
14:38:25 <marcelr> we already did
14:38:29 <kidclamp> heh
14:38:38 <kidclamp> not 'officially'
14:38:44 <marcelr> ok
14:38:47 <thd> We did but the question was not put in a formal form.
14:39:08 <kidclamp> #vote Should we stop adding [SIGNED_OFF] labels when signing off patches
14:39:22 <tcohen> yes
14:39:23 <marcelr> +1
14:39:27 <kidclamp> #startvote Should we stop adding [SIGNED_OFF] labels when signing off patches
14:39:27 <huginn`> Unable to parse vote topic and options.
14:39:32 <kidclamp> #startvote Should we stop adding [SIGNED_OFF] labels when signing off patches?
14:39:32 <huginn`> Begin voting on: Should we stop adding [SIGNED_OFF] labels when signing off patches? Valid vote options are Yes, No.
14:39:32 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
14:39:37 <Joubu> #vote yes
14:39:39 <slef> #vote yes
14:39:40 <kidclamp> #vote Yes
14:39:41 <oleonard> #vote Yes
14:39:44 <tcohen> #vote Yes
14:39:45 <marcelr> #vote Yes
14:39:48 <greenjimll> #vote yes
14:39:50 <Joubu> oleonard: you voted yes!
14:39:51 <thd> kidclamp: Can you ask the question with the exception for partial signoff?
14:39:54 <Joubu> :)
14:40:08 <Joubu> I think that's ok
14:40:17 <kidclamp> I think a partial signoff warrants comments on bug
14:40:17 <thd> #vote Yes # Assuming exception
14:40:50 <kidclamp> last chance
14:41:07 <kidclamp> #endvote
14:41:07 <huginn`> Voted on "Should we stop adding [SIGNED_OFF] labels when signing off patches?" Results are
14:41:26 <tcohen> thd: that can be mentioned on the attach subject
14:41:27 <Joubu> thanks a lot huginn`
14:42:05 <Joubu> 1+ yes, 0 no. Adapted
14:42:07 <Joubu> move on?
14:42:13 <kidclamp> #info results are unanimous yes (with one vote for partial signoff exception)
14:42:13 <marcelr> move on
14:42:22 <kidclamp> #topic Open roles for 18.05
14:42:59 <Joubu> I added this one, I think we should create the page now. Last general meeting will be too late
14:43:04 <Joubu> s/Last/Next
14:43:15 <marcelr> create a page for it
14:43:17 <kidclamp> #link https://wiki.koha-community.org/wiki/Roles_for_18.05 Roles for 18.05
14:43:23 <kidclamp> someone just needs to create it
14:43:36 <Joubu> I will
14:43:38 <marcelr> i guess Joubu is doing it now
14:43:41 <kidclamp> #info once there is a page, add your name / proposal
14:43:49 <kidclamp> #action Joubu is creating the page
14:44:28 <kidclamp> moving on
14:44:37 <Joubu> wait
14:44:38 <Joubu> 1sec
14:44:43 <kidclamp> ...
14:44:53 <Joubu> I am asking that because I am not sure I want to continue
14:45:09 <marcelr> no you should
14:45:13 <Joubu> so others can have time to think about 18.05 RM
14:45:50 <Joubu> we can discuss later if you want, not in the meeting :)
14:46:05 <Joubu> #topic Koha agenda
14:46:10 <Joubu> I cannot
14:46:15 <marcelr> too bad
14:46:24 <kidclamp> #topic Koha Agenda
14:46:25 <Joubu> kidclamp: ?
14:46:28 <Joubu> thx :)
14:46:41 <Joubu> I have created a google agenda to add Koha "events"
14:46:50 <Joubu> like GBSD, release dates, meeting dates, etc.
14:46:55 <Joubu> kohacon(?)
14:47:08 <Joubu> I added it to the website, the time is in UTC
14:47:29 <Joubu> you can add it to your own google agenda, to have the events displayed in your local tz
14:47:43 <Joubu> no troll please, feel free to suggest something else than google
14:47:52 <Joubu> I just wanted something quick and efficient
14:47:55 <kidclamp> #info you can add the calendar at koha-community.org to your local calender
14:48:05 <Joubu> and, something I forgot!
14:48:11 <Joubu> we need a new role for 18.05
14:48:14 <kidclamp> #link https://koha-community.org/calendar Community calendar
14:48:17 <kidclamp> ?
14:48:21 <greenjimll> +1 for Google calendar. You can export ICS subscriptions if you want them in something else anyway.
14:48:26 <Joubu> someone to chair the meeting, update the meetings wiki pages, maitain this calendar, etc.
14:48:45 <Joubu> ask me if you want write access to the calendar
14:49:32 <Joubu> (maybe we should script something for the meeting wiki pages, they are painful to create/update)
14:49:40 <kidclamp> +1
14:49:44 <Joubu> that's all
14:49:53 <kidclamp> we should have several who can chair
14:50:10 <kidclamp> is not as arcane as one may assume
14:50:31 <Joubu> (and maybe we should remove people from the RM team if they did not do their job)
14:50:31 <thd> Joubu++
14:51:06 <marcelr> Joubu: or encourage them to do it now
14:51:28 <kidclamp> #info a new role for 18.05 - scheduler? chair? something to kee porganized
14:51:39 <kidclamp> #topci Set time of next meeting
14:51:42 <kidclamp> #topic Set time of next meeting
14:52:10 <Joubu> October 25th 21 or 22 UTC
14:53:08 <greenjimll> Fine by me.
14:53:18 <Joubu> #action marcelr let's encourage people to contribute
14:53:21 <Joubu> :D
14:53:22 <kidclamp> any strong 21 or 22 preferences?
14:53:27 <thd> Is 22 still an issue for NZ at this season?
14:53:28 <oleonard> Nope
14:53:37 <thd> I strongly prefer 21
14:53:44 <tcohen> I strongly prefer 22
14:53:49 <tcohen> ha
14:53:52 <tcohen> I can adapt
14:53:57 <greenjimll> I strongly don't care. :-)
14:53:58 <thd> :)
14:54:10 <marcelr> Joubu: when voting someone could renew his intention to do the job
14:54:23 <marcelr> if he is not even there then it might be different
14:54:35 <kidclamp> #info Next meeting October 25th, 2017 21 UTC
14:54:36 <thd> I have to miss meetings in both cases, actually.
14:54:52 <marcelr> yeah no 21 or 22 for me too
14:55:12 <Joubu> let me check on the agenda :p
14:55:20 <kidclamp> well I already info'ed it :-)
14:55:37 <kidclamp> any last thoughts? complaints? compliments?
14:55:38 <Joubu> ha
14:55:45 <kidclamp> oleonard is a sharp dresser
14:55:48 <Joubu> so we are all good :)
14:55:53 <Joubu> I am at least
14:56:01 <slef> huginn`: oleonard?
14:56:01 <huginn`> slef: I'll give you the answer as soon as RDA is ready
14:56:16 <Joubu> compliments, you are a wonderful chairman
14:57:00 <kidclamp> marcelr really knows where his towel is
14:57:11 * oleonard is glad he didn't wear his t-shirt and sweatpants to work today
14:57:11 <marcelr> huh?
14:57:15 <kidclamp> #endmeeting