14:00:42 <kidclamp> #startmeeting Development IRC meeting 13 December 2017
14:00:42 <huginn`> Meeting started Wed Dec 13 14:00:42 2017 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <huginn`> The meeting name has been set to 'development_irc_meeting_13_december_2017'
14:00:48 <kidclamp> #topic Introductions
14:00:48 <wahanui> #info wahanui, a bot that has become sentient
14:00:58 <greenjimll> #info Jon Knight, Loughborough University
14:01:05 <kidclamp> #info Nick Clemens,ByWater Solutions
14:01:18 <LibraryClaire> #info Claire Gravely, BSZ Germany
14:01:41 <Joubu> #info Jonathan Druart
14:01:55 <josef_moravec> #info Josef Moravec, Municipal Library UO, Czech Republic
14:02:08 <Joubu> rmaints?
14:02:08 <wahanui> hmmm... rmaints is kidclamp (17.11), fridolin (17.05), rangi (16.11)
14:02:39 <fridolin> #info Fridolin Somers, Biblibre France
14:02:44 <thd> #info Thomas Dukleth, Agogme, New York City (In California for the end of the year)
14:02:59 <tuxayo> #Info Victor Grousset, Biblibre, France
14:03:12 <Joubu> qa_team is alex_a jajm marcelr khall kidclamp tcohen josef_moravec
14:03:14 <Joubu> qa_team?
14:03:15 <wahanui> qa_team is alex_a jajm marcelr khall kidclamp tcohen josef_moravec
14:03:32 <jajm> #info Julian Maurice, BibLibre
14:03:39 <Joubu> I will try not to abuse of these 2 "aliases" :)
14:03:47 <kidclamp> #topic Announcements
14:03:58 <kidclamp> anyone have things?
14:04:05 <thd> Yes
14:04:06 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_December_2017
14:04:07 <alex_a> #info Alex Arnaud, Biblibre France
14:04:34 <alex_a> qa_team?
14:04:35 <wahanui> qa_team is alex_a jajm marcelr khall kidclamp tcohen josef_moravec
14:04:35 <cait> #info Katrin Fischer, BSZ, Germany
14:04:38 <alex_a> :)
14:04:57 <thd> Today is my happy birthday.  Sadly, I will miss the next meeting for the party.
14:05:09 <kidclamp> thd++
14:05:12 <kidclamp> happy birthday
14:05:14 <greenjimll> Happy Birthday
14:05:36 <kidclamp> #topic Update from the Release manager (18.05)
14:06:00 <fridolin> happy birthday thd
14:06:12 * kidclamp whispers 'that's you Joubu'
14:06:23 <Joubu> nothing special for me, I have started 17.12 pushing quite lot of stuffs
14:06:53 <Joubu> and will continue like that, as far as the QAers send me stuffs to review
14:07:24 <kidclamp> #info Joubu is pushing all the things. QA more stuff, more stuff gets pushed.
14:07:36 <Joubu> as it's the beginning of the release cycle, let me know if you want to work on something big/special
14:07:38 <clrh> #info Claire Hernandez, BibLibre
14:07:44 * fridolin have seen there is in master a new dependancy on ES perl lib
14:07:49 <Joubu> and/or need help on specific works
14:07:52 <fridolin> not yet in koha-perldeps
14:08:23 <fridolin> this will brake sandboxes, one must install manually
14:08:26 <Joubu> I'd like to have a koha-es with zebra-equivalent features for 18.05
14:08:42 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:08:42 <Joubu> or at least to know what is work to be done to reach that state
14:09:06 <kidclamp> #info let Joubu know if you have projects so you can coordinate on what is needed
14:09:07 <Joubu> there is a wiki page created by Nick, you are pleased to add items to this list
14:09:12 <kidclamp> we have ES section later on too
14:09:13 <cait> koha-es?
14:09:26 <Joubu> koha / Elastic
14:09:28 <greenjimll> Wiki page URL?
14:09:28 <cait> ah.. not spanish, elastic search
14:09:33 <cait> *hides*
14:09:34 <fridolin> yep, juste saying koha-perldeps must be corrected
14:09:49 <fridolin> cause dependancy is mandatory even for zebra install
14:09:52 * oleonard hopes Bug 19474 will get some interest
14:09:52 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19474 enhancement, P5 - low, ---, oleonard, Needs Signoff , Convert staff client CSS to SCSS
14:09:54 <Joubu> kidclamp: do you have the wiki page link?
14:10:07 <clrh> so this page : https://wiki.koha-community.org/wiki/Elasticsearch_status I'll add things we saw or questionned last week
14:10:07 <kidclamp> #link https://wiki.koha-community.org/wiki/Elasticsearch_status#Elasticsearch_status_.28Updated_2017-12-07.29 ES status
14:10:22 <Joubu> yes thanks clrh
14:10:23 <kidclamp> yes please clrh - anyone should add or update
14:10:59 <Joubu> in my goal for 18.05: push all what oleonard write to move JS code (we will talk about that later)
14:11:00 <kidclamp> moving on
14:11:07 <kidclamp> sorry :-)
14:11:09 <Joubu> wait
14:11:24 <Joubu> I'd like to do some benchmarking (last ones are quite old)
14:11:34 <cait> Joubu++
14:11:40 <Joubu> and write more Selenium tests
14:11:43 * Joubu searches a link
14:12:01 <Joubu> see bug 19243 for selenium tests (and related)
14:12:01 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19243 enhancement, P5 - low, ---, alexbuckley, ASSIGNED , Selenium test for testing the administration module functionality
14:12:02 <kidclamp> #info ES, JS updates, benchmarking, selenium tests are some golas for 18.05
14:12:33 <Joubu> I will also push/support tcohen's work (and others) on REST API, ofc
14:12:49 <Joubu> more or less the big lines for 18.05
14:12:49 <fridolin> API++
14:12:52 <Joubu> That's all for me
14:13:02 <LibraryClaire> Joubu++
14:13:05 <Joubu> And the manual! :)
14:13:14 <kidclamp> #info also REST API and manual
14:13:21 <Joubu> will talk about that during the next doc meeting
14:13:22 <kidclamp> Joubu doesn't think small
14:13:46 <kidclamp> #topic Updates from the Release Maintainers
14:13:52 <cait> Joubu++ ;)
14:13:56 <josef_moravec> Joubu+
14:13:59 <josef_moravec> +
14:14:22 <kidclamp> I will be pushing stuff next two days and will announce string freeze for 12/15 to stick to release on 22nd
14:14:45 <kidclamp> #info 17.11 string freeze on 15th, pushing things now
14:14:50 <kidclamp> fridolin?
14:14:51 <wahanui> fridolin is busy at the moment, I asked him to backport the bug fix
14:15:00 * fridolin RMaint 17.05
14:15:13 <tuxayo> tests++
14:15:14 <fridolin> I'm now waiting on 17.11 aka stable pushes
14:15:42 <fridolin> althow i have some late patches in master i can backport
14:15:55 <fridolin> but no major ones normaly
14:16:00 <kidclamp> #info 17.05 waiting on 17.11 and pushing some others
14:16:20 <Joubu> to say something that is maybe not public: We will have secutiry fixes pushed in stable releases regularly. We are not going to announce them as "security releases", because the fixes are not critical. But we are going to follow a security workflow, in the sense of the fixes will not be published before the releases.
14:16:47 <fridolin> ++
14:17:08 <Joubu> We (RM+RMaints) are trying to work closely and in sync. The workflow is not perfectly defined yet...
14:17:44 <kidclamp> rangi si probably not here but he is an rmaint and we like him
14:18:07 <kidclamp> #topic Updates from the QA team
14:18:29 <thd> Joubu: Announcing after release seems to be an important part of "security workflow".
14:18:49 <cait> I have sent some questions to the QA team members to see what we can do to improve things, when people usually QA, how much time they can spend, and what topics we have not covered
14:19:05 <cait> I got some answers already - thx!
14:19:20 <cait> what we already see is that auth patches get stuck often and easily
14:19:27 <cait> because we lack the environment to test them with
14:19:41 <cait> would it be possible that we have a cas test server to access somewhere? LDAP? Shibb?
14:20:05 <cait> it's also about documentation, if we had simple tutorials on how to set that up, maybe they would be not as hard to tackle
14:20:18 <Joubu> (thd: the idea was to keep "security releases" when it's really needed, not to announce releases as "very important" every months)
14:20:20 <thd> cait++
14:20:33 <josef_moravec> cait++
14:20:34 <kidclamp> ldap testing is possible, there are test servers out there
14:21:01 <cait> so if someone wnat to help out there, that would be great
14:21:02 <kidclamp> shib is harder because you need koha accessible from outside and https
14:21:15 <cait> yeah, not doable with a kohadev, which rules me outmost of the time
14:21:26 <Joubu> I'd like to repeat that the severity should be used when you pick a patch to SO or QA
14:21:34 <Joubu> we have 21 majors
14:21:39 <Joubu> 6 waiting for QA
14:21:50 <cait> kidclamp: could you info my need for poeple helping with auth servers and tutorials?
14:22:22 <Joubu> there is no much sense to QA enhs when major bugs can be pushed and backported
14:22:25 <kidclamp> #info QA needs help with auth testing and tutorials is an area where we need more people
14:22:38 <cait> please also make sure you rebase/react as fast as possible once someone has started to qa your patches
14:22:47 <kidclamp> #info Reminder to hit majors and criticals before enhancements please
14:22:50 <cait> it's hard to start over when a lot of time is between testing and it eats our resources
14:22:59 <greenjimll> With SAML2 authentication its worth bearing in mind there's more than Shibboleth. We use simplesamlphp as our IdP for example.
14:23:07 <kidclamp> #info Cait sent a questionaire to QAers, please respond so we can plan how to cover all topics
14:23:22 <cait> and also... if you are interested to join QA - please let me know/sign up for vote at the next meeting, even if you just want to help with some specific part
14:23:48 <kidclamp> #info if interested in joining QA please let cait know or add to the next meeting agenda
14:23:50 <ashimema> we have saml2 working for simplesaml, shibboleth, athens and adfs idps
14:24:19 <greenjimll> Yep, works on our SAML2 IdP... but worth considering if testing patches.
14:24:20 <kidclamp> there are always small easy bugs to QA
14:24:29 <cait> #info looking for someone to help ease testing for Shibboleth, CAS and LDAP
14:24:34 <kidclamp> ashimema, write ups for any of those would be amazing
14:24:39 <kidclamp> the shib wiki is pretty well done
14:24:47 <Joubu> (and to rewrite C4::Auth)
14:24:48 <kidclamp> (not that I still don't muck it up)
14:24:56 <fridolin> rewrite C4::Auth ++
14:25:09 <fridolin> (but not by me)
14:25:30 <cait> #info Please rebase/answer questins from QA quickly, so things can be finished quickly once started
14:25:53 <cait> that's it from me - but others maybe?
14:26:36 <kidclamp> #info don't forget to assign yourself as QAer when looking at a bug
14:26:41 * jajm has nothing to add
14:26:44 <kidclamp> nothing more here
14:26:59 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:27:12 <Joubu> I am thinking of bypassing QA step for some patches, but I really would like to avoid that. There are 150+ bugs in SO
14:27:33 <cait> kidclamp: thx, i forgot that myself!
14:27:47 <Joubu> could we organise a "QA day" before end of the year?
14:28:06 <kidclamp> is a god idea, sprints have worked well
14:28:09 <cait> so far QAers seem to have a preference for Fridays
14:28:11 <kidclamp> s/god/good
14:28:22 <cait> bt next week might be too close to christmas?
14:29:18 <cait> jajm: kidclamp - what do you think?
14:29:23 <josef_moravec> next week would be ok for me ;)
14:29:23 <kidclamp> can't hurt to try? I will be here
14:29:57 <jajm> i won't be there from 18th to 29th, but i can do a full QA day this friday
14:29:59 <Joubu> let's see after the meeting. For the last one we use a doodle-like page to know the availabilities
14:30:04 <cait> sorry josef_moravec!
14:30:25 <cait> Joubu: this year is a bit hard :)
14:30:34 <cait> i will send a suggestion to qa team tonight
14:30:45 * oleonard will be around next week to help make sure the SO list doesn't get too short
14:30:48 <kidclamp> #action cait will try to arrange QA sprint before end of year
14:31:54 <thd> Almost anything should be tried including many other bad practises before actually bypassing QA.
14:32:31 <greenjimll> Bribing QA team with cake?
14:32:33 <cait> i agree with Joubu we need to get the numbers down right now
14:32:42 <cait> but we will try to do it properly first ;)
14:32:56 <cait> 150 is pretty hard to manage and lots probably will have to be rebased
14:33:13 <kidclamp> so just put them all 'doesn't apply'
14:33:16 <kidclamp> :-)
14:33:49 <josef_moravec> is the bot which made it for us still alive?
14:34:24 <Joubu> it has been disabled
14:34:50 <jajm> greenjimll, try with beer instead ;)
14:34:57 <cait> people complained about it :(
14:35:00 <Joubu> we could ask rangi, but not sure it is useful
14:35:14 <Joubu> I prefer someone ask me a rebase than a bot
14:35:31 <Joubu> a bot will not SO it, so I rebased it for nothing
14:35:57 <cait> valid point
14:36:25 <kidclamp> sure, but a tester can't test if doesn't apply
14:36:32 <josef_moravec> agree, that is good reason
14:36:52 <josef_moravec> it was to Joubu
14:36:53 <kidclamp> maybe have it only check bugs that are awaiting QA?
14:36:57 <Joubu> a tester is supposed to test when rebased, right? :)
14:37:17 <kidclamp> ideally
14:37:46 <greenjimll> What about a script that could tell the QA team which bugs pending QA don't apply cleanly, rather than the bug assignee?
14:38:47 <kidclamp> I think maybe QA and bot is good for next meeting? We havea few other topics for today we should cover
14:39:02 <Joubu> I'd suggest to move on, we have a long topic list today
14:39:27 <Joubu> we can continue the discussion on the ML if people has ideas
14:39:43 <cait> i have a quick question?
14:39:55 <Joubu> yep?
14:39:55 <wahanui> yep.
14:40:04 <Joubu> yep!
14:40:07 <cait> I was thinking similar to the questions I asked the QAers
14:40:20 <cait> shoudl we have a wiki page where we can collect 'experts' on topics and apis?
14:40:27 <cait> for people to sign up to if they want
14:40:40 <Joubu> like the "module maintainers"? :-/
14:40:45 <cait> less formal
14:40:55 <cait> just a... i am interested in those topics
14:40:56 <Joubu> yes we can try
14:41:27 <kidclamp> #action cait will add wiki page to list topics of interest/expertise to assist in SO and QA
14:41:28 <Joubu> it's basically writing down what we more or less know already. So yes it's good to have that list on the wiki
14:41:44 <cait> also maybe good for newcomers
14:41:54 <kidclamp> is tcohen here/needed for rest api disc?
14:42:12 <cait> pm me if you have a good name suggestion for the page
14:43:19 <kidclamp> #topic REST api
14:43:38 <kidclamp> from the agenda: Proposal to vote for: allowing devs working on the REST api implementation to change attribute names so they are more meaningfull for api consumers. For example, rename 'borrowernumber' for 'patron_id'. Pros: we can provide a readable API spec, and people unfamiliar to Koha internals will have better time using the api. Cons: some people might be using the current (3) endpoints and would need to change some
14:43:38 <kidclamp> attribute names.
14:43:41 <greenjimll> With the REST API attribute name changes, will there be support for existing attribute names to preserve existing scripts, or is it viewed as a clean break?
14:44:21 <Joubu> "Cons: some people might be using the current (3) endpoints and would need to change some attribute names"
14:44:36 <greenjimll> So clean break then?
14:44:45 <josef_moravec> yes
14:45:10 <Joubu> in that case we should change the version
14:45:17 <thd> Is the suggestion implying that the names currently in use in Koha are poorly chosen and should eventually be changed themselves?
14:45:20 <Joubu> was not it the purpose of the v1/v2...
14:45:21 <Joubu> ?
14:45:41 <greenjimll> That's usually the use of REST API versioning.
14:45:51 <josef_moravec> Yes, version change would be the ideal solution probably
14:45:53 <jajm> Joubu, yep, if you break compatibility, you should change the version
14:46:15 <greenjimll> Often older versions are kept (for a while at least) for backward compatibility
14:47:07 <greenjimll> And to smooth transition for external developers
14:47:16 <thd> There is some history behind some variable names in Koha for wider applicability than the name which might be most common.
14:47:17 <Joubu> I would like to have the list on the wiki, patron_id or user_id, etc.
14:47:48 <thd> Joubu++
14:47:55 <Joubu> thd: we are talking about borrowers/members/patrons/users
14:47:58 <Joubu> for instance...
14:48:44 <thd> I understand the topic of discussion and the history behind Koha's current naming choice.
14:48:47 <kidclamp> #info general discussion is version change would be good for this proposal
14:49:01 <kidclamp> #info and a listing of naming on the wiki
14:49:19 <kidclamp> should it be voted, or reworked with version change as proposal for vot enext meeting?
14:50:05 <Joubu> I think we all agree we need to pick good attribute names :)
14:50:10 <thd> An appeal to some ISO or other standard for library attribute usage would be good as a basis.
14:50:21 <Joubu> we need to discuss it with tcohen when we will be around
14:50:27 <Joubu> s/we/he
14:50:32 <greenjimll> If REST API is aiming for inclusion in 18.05 shouldn't we vote now to give folk time to work on it?
14:50:39 <Joubu> we need to discuss it with tcohen when he will be around*
14:50:55 <cait> i think the current case is the patron api
14:50:58 <cait> best to comment on the bu
14:50:59 <cait> g
14:51:02 <kidclamp> next meeting is two weeks so should still have time
14:51:06 <Joubu> greenjimll: we should vote with the name of the attributes
14:51:37 <thd> Joubu++
14:51:47 <cait> we already voted to match the GUI
14:51:56 <cait> intead of the database
14:52:10 <cait> that's why patron_id instead of borrowernumber for the api
14:53:04 <cait> i think if you want to vote on each, maybe have a separate meeting soon?
14:53:17 <cait> we need to move forward with the Rest API
14:53:28 <greenjimll> I assume its more than just "rename 'borrowernumber' for 'patron_id'" though as that's just one example. We don't have a list of attribute names to vote on do we?
14:53:55 <Joubu> no we don't
14:54:04 <kidclamp> #info vote postponed to next meeting so can discuss versioning with tcohen and get a list of attributes
14:54:18 <kidclamp> I think enough discussion to wait, let's move on
14:54:19 <thd> Why is the GUI actually different to the rest of the code?
14:54:55 <kidclamp> #topic SQL strict mode is not the default in MariaDB
14:54:57 <Joubu> lol
14:55:13 <Joubu> yes, for me. Just a sec
14:55:41 <Joubu> it's that one: bug 17860
14:55:41 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17860 normal, P1 - high, ---, gmcharlt, NEW , [SQL strict mode] MARC records will stage, but Manage for import shows 'no data in table'
14:55:46 <Joubu> see last comment
14:56:09 <Joubu> so basically we know for a while that Koha was not MySQL 5.7 compatible (with the default sql-mode option)
14:56:26 <Joubu> our suggestion was to switch to MariaDB
14:56:45 <Joubu> but they decided to follow MySQL and now also use the trans_strict_table sql mode
14:57:20 <kidclamp> #info Koha has compatability issues withMySQL 5.7 so we suggested mariadb, but they now follow MySQL and same problem occurring
14:57:23 <Joubu> if people are interested (I mean, really, SO+QA) I can take a look to estimate the work and provide patches
14:57:43 <Joubu> last time I did that (6months, 1y ago), nobody cared
14:58:20 <kidclamp> it should be done, we should work towards supporting the versions in stretch probably
14:58:28 <Joubu> we also need to update the wiki (install debian)
14:58:37 <thd> Would there be an issue for backwards compatibility to using earlier versions of MySQL or MariaDB?
14:59:00 <josef_moravec> looks like we should start to care about this
14:59:29 <cait> it's causing strange problems - reported on the mailing list and bugzilla
14:59:39 <cait> even with a workaround we should care
14:59:47 <Joubu> https://wiki.koha-community.org/wiki/Koha_on_ubuntu_-_packages#Ubuntu_16.04_and_MySQL_5.7
14:59:56 <Joubu> that section needs to be updated
15:00:00 * LibraryClaire has to run
15:00:05 <Joubu> #action?
15:00:45 <cait> not sure what to write - sorry
15:01:05 <Joubu> #info ping Joubu if you have time to dedicated to mariadb/mysql strict mode
15:01:20 * fridolin noob for SQL server
15:01:35 <Joubu> #action kidclamp Update the Koha_on_ubuntu_-_packages#Ubuntu_16.04_and_MySQL_5.7 section
15:01:38 <Joubu> :D
15:01:50 <kidclamp> man, I weas just typing for someone else, too, I don't know the answer
15:01:56 <kidclamp> I'll tell you when RDA is ready
15:02:15 <cait> lol
15:02:28 <kidclamp> #action kidclamp will send an email to the list about the db issues
15:02:47 <thd> I'll tell you when HTML 5 is ready :)
15:02:49 <kidclamp> Joubu (neither increment or decrement)
15:03:03 <kidclamp> #topic Elasticsearch status
15:03:25 <kidclamp> This was discussed earlier, there is more movement on ES lately, have been a few more testers out there
15:03:36 <kidclamp> please add anything you wish to the status page
15:04:01 <kidclamp> please focus for now on fixing the broken things and compatability so that 18.05 can havea stable ES
15:04:12 <Joubu> (the kanban may be more useful to keep an updated overview)
15:04:17 <kidclamp> once that is done there are many things that  can be added
15:05:03 <clrh> some BibLibre guys had a look to the existant Koha implementations, a lot of questions asked to ourselves, I must edit the wiki community page and continuing testing
15:05:27 <kidclamp> please do clrh and feel free to ping me for any questions
15:05:34 <kidclamp> biblibre++
15:05:48 <clrh> it was last week and only a "one day focus" but I must continue
15:06:01 <clrh> yep kidclamp thanks
15:06:22 <kidclamp> #topic Javascript in footer
15:06:30 <Joubu> oleonard: ?
15:06:56 <oleonard> Thanks to everyone who has helped move these patches quickly through
15:07:23 <oleonard> There are very few templates yet to do
15:07:59 <oleonard> Getting this done is an important step not just for performance reasons but to lay the groundwork to some JS preprocessing in the future
15:08:20 <Joubu> It is the kind of patches we should not wait long before pushing them, they do not survive to a lot of rebases
15:09:11 <kidclamp> josef_moravec++ for following QA there
15:09:20 <oleonard> Does anyone have any questions about this move, or about how to adapt to this new practice?
15:09:21 <Joubu> This is the current status: https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=17858
15:09:40 <kidclamp> #link https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=17858 JS move status
15:09:54 <josef_moravec> I plan to finish the QA of this as soon as possible
15:10:09 <Joubu> QA team need to be aware of that change, to avoid introducing JS code back in the header
15:10:41 <josef_moravec> We should have a rule for this probably
15:10:53 <Joubu> I have no idea how to write QA tests for that, please take a look if you want to add some
15:10:54 <cait> afk - phone call
15:12:10 <Joubu> you volunteer?
15:12:31 <Joubu> #action josef_moravec add a new coding guideline about the JS move to the footer
15:12:38 <Joubu> thanks josef_moravec ;)
15:12:48 <kidclamp> Joubu is on a roll today
15:13:15 <kidclamp> moving on?
15:13:16 <Joubu> 2 more topics, quickly?
15:13:45 <kidclamp> aside form the coding guidelines? go for it
15:14:16 <Joubu> nope, I was talking about the 2 coding guidelines
15:14:44 <kidclamp> #topic Review of coding guidelines
15:14:51 <josef_moravec> Joubu: not at all ;) I'll do it
15:14:51 <kidclamp> #info Don't use DBIX calls in updatedatabase
15:15:16 <kidclamp> #info see bug 19789 and bug 17292
15:15:16 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19789 major, P5 - low, ---, koha-bugs, NEW , Remove some indirect DBIx calls from updatedatabase
15:15:17 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17292 major, P5 - low, ---, kyle.m.hall, Pushed to Stable , Use of DBIx in updatedatabase.pl broke upgrade (from bug 12375)
15:16:26 <Joubu> did anyone take a look at that?
15:17:09 <kidclamp> looking now, seems reasonable
15:17:32 <Joubu> I though we already agreed on that, but did not find discussion or coding guidelines
15:17:36 <thd> Is the problem slightly different to what is supposed.
15:18:09 <Joubu> we need to write a coding guideline and vote it during the next meeting
15:18:24 <thd> Is the manner in which DBIx is being used in error rather than using DBIx instead of DBI?
15:18:41 <kidclamp> #action Joubu will write a coding guideline to not use DBIX in updatedatabase for voting at next meeting
15:18:50 <kidclamp> :D
15:19:00 <Joubu> #action Joubu write a coding guideline to forbid use of DBIX calls in updatedatabase (and C4/Koha ns?)
15:19:06 <Joubu> ha!
15:19:14 <cc_> No one problem is that during updatedatabase schema and db may not match
15:19:51 <Joubu> cc_: yes, that's the point
15:19:58 <kidclamp> #info Reminder  - git commit messages
15:20:15 <Joubu> so fetch/insert/etc must be done writing SQL queries
15:20:25 <thd> cc_: Yes, that is an underlying problem which should be fixed by better usage of DBIx should it not?
15:20:31 <kidclamp> #info ('Bug 12345: ', '(follow-up)', '(QA follow-up)', see git log) + what the patch does vs what the bug is.
15:20:31 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12345 enhancement, P5 - low, ---, oleonard, NEW , Can't Clear Reading History for Anonymous patron
15:21:05 <Joubu> A quick reminder about the commit messages (I need to write a coding guidelines too), please take a look at the last commit messages in master about the formating
15:21:48 <Joubu> I update them before push, but I may fail them soon if they are written after the anouncement
15:22:01 <kidclamp> #action Joubu will write a coding guidline on commmit message formatting for voting next meeting
15:22:52 <Joubu> an common mistake is also "what the patch does" vs "what the bug is"
15:22:52 <wahanui> okay, Joubu.
15:23:11 <jajm> is "(follow-up)" really needed ?
15:23:15 <Joubu> the commit message title must describe what the patch does, not a copy/paste of the bug report title
15:23:32 <Joubu> jajm: it's needed if you want to add a follow-up
15:23:58 <Joubu> I sent an email to the list few months ago about that, I explained when you should use it (in my opinion)
15:24:09 <greenjimll> Are the commit messages (for bug 19410) supposed to be examples of good or bad practice?
15:24:09 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19410 enhancement, P5 - low, ---, tomascohen, Pushed to Master , Add a helper function for generating object searches for the API
15:24:12 <jajm> Joubu, i'll reread this email
15:24:27 <Joubu> I need to write a guideline to vote and put that to the wiki
15:24:31 <thd> Joubu++
15:25:07 <Joubu> greenjimll: the commit messages on the bug report are different than the ones in master
15:25:22 <Joubu> I edit them before push
15:25:34 <greenjimll> I'm looking at the ones in `git log`, so are these bad/good?
15:25:36 <Joubu> but did not attach the updated patches to the bug report
15:25:50 <Joubu> git log origin/master should be ok
15:26:01 <Joubu> --oneline
15:26:06 <greenjimll> Ah, that's OK then as I couldn't see what you were complaining about. :-)
15:26:52 <Joubu> next meeting?
15:26:53 <wahanui> next meeting is https://wiki.koha-community.org/wiki/Next_IRC_meetings
15:27:22 <Joubu> #topic Set time of next meeting
15:27:29 <Joubu> I cannot
15:27:36 <kidclamp> #topic Set time of next meeting
15:27:48 <kidclamp> #chair Joubu
15:27:48 <huginn`> Current chairs: Joubu kidclamp
15:28:06 <Joubu> #topic Set time of next meeting
15:28:26 <Joubu> 27 December 2017, 20 UTC?
15:28:31 <kidclamp> +1
15:28:34 <Joubu> 27 December?
15:28:52 <greenjimll> Works for me. Something to do instead of eat sweets and watching bad Xmas TV. :-)
15:28:57 <tcohen> the 'Add pagination to vendors endpoint' and the one renaming attributes in patrons are good examples on how to use the helpers
15:29:17 * tcohen says while on a taxi
15:29:27 <Joubu> #info Next meeting: 27 December 2017, 20 UTC
15:29:32 * thd will be in an airplane returning to New York.
15:29:47 <Joubu> #endmeeting