14:03:13 <kidclamp> #startmeeting Development IRC meeting 13 September 2017
14:03:13 <huginn> Meeting started Wed Sep 13 14:03:13 2017 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:13 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:13 <huginn> The meeting name has been set to 'development_irc_meeting_13_september_2017'
14:03:27 <kidclamp> #topic Introductions
14:03:28 <wahanui> #info wahanui, a bot that has become sentient
14:03:36 <kidclamp> #info Nick Clemens, ByWater Solutions
14:03:41 <Joubu> #info Jonathan Druart
14:03:58 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_September_2017 #empty
14:04:27 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:04:44 <JesseM> #info Jesse Maseto, BWS
14:05:07 <mveron> #info Marc Véron Switzerland
14:05:10 <caboose> #info Michael Cabus, BWS
14:05:36 <barton> #info Barton Chittenden, BWS
14:06:07 <kidclamp> ping fridolin cait
14:06:52 <oleonard> #info Owen Leonard, Athens County Public Library, Ohio
14:07:01 <kidclamp> #topic Announcements
14:07:17 <Joubu> none from me
14:07:30 * oleonard seems to only attend meetings which he is inadvertently present for
14:07:42 <oleonard> pianohacker here?
14:08:02 <kidclamp> none from me
14:08:05 <dani> #info Danielle Elder, BWS
14:08:12 <tcohen> Can I?
14:08:19 <kidclamp> go for it tcohen
14:08:46 <tcohen> Jonathan and I are almost finished with dockerizing the jenkins tests
14:08:54 <tcohen> I expected to have it earlier
14:09:19 <tcohen> we might be capable of doing so for the stable branches
14:09:23 <tcohen> with a small effort
14:09:45 <tcohen> I repeat the request for people familiar with Docker to aid us
14:09:47 <tcohen> :-D
14:10:17 <tcohen> done
14:10:28 * oleonard once wore a pair of Dockers khakis, FWIW.
14:10:31 <kidclamp> #info Dockerizing jenkins is almost done, anyone with Docker experienced is welcome to help
14:10:47 <kidclamp> #topic Update from the Release manager (17.11)
14:10:58 <fridolin> #info Fridolin Somers, Franche, Biblibre
14:11:03 <Joubu> QA sprint was good, and NQA queue is growing again, so I guess we will organise another one soon.
14:11:04 <fridolin> RMint 17.05
14:11:31 <Joubu> I am going to announce feature freeze very early, as I do not want to see people active only the last month before the release.
14:11:39 <Joubu> So nothing marked as (real) enh will be pushed after October ~25th
14:11:48 <oleonard> Joubu++
14:11:55 <tcohen> Joubu++
14:11:56 <Joubu> If you want things to get pushed, it's now (and last 4 months...)
14:12:00 <kidclamp> #info QA sprint went well, will organise another as queue grows
14:12:11 <Joubu> I am waiting for the docker on jenkins to be ready to push Rest API related patches.
14:12:24 <kidclamp> #info early feature freeze, so get enhancements in before 10/25
14:12:44 <Joubu> on the dev side, I am going to work on bug 19297, there are very weird things in this area
14:12:44 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19297 enhancement, P5 - low, ---, jonathan.druart, ASSIGNED , Standardize "can place hold" calculations
14:12:45 <kidclamp> #info REST patches awaiting docker/Jenkins completion
14:13:11 <Joubu> and the move to OOP makes things more easy and understandable. I hope I will be able to clean that area
14:13:20 <Joubu> patches are coming soon
14:13:36 <Joubu> but it's not a RM related job, you can move on :)
14:13:55 <kidclamp> #info Joubu working on bug 19297 too
14:14:06 <kidclamp> #topic Updates from the Release Maintainers
14:14:11 <kidclamp> fridolin
14:14:12 <wahanui> fridolin is busy at the moment, I asked him to backport the bug fix
14:14:52 <fridolin> kidclamp: yep thanks
14:14:57 <Joubu> Ha! And security releases last month, next ones are going to include security stuffs as well
14:15:04 <fridolin> indeed
14:15:24 <fridolin> next release will be 17.05.04
14:15:49 <fridolin> not a lot of patches because of my vacansions
14:16:03 <fridolin> but i check on bugs major and more
14:16:18 <kidclamp> #info security releases last month and upcoming
14:16:27 <fridolin> and i've pushed patches about translation
14:16:30 <fridolin> nice work btw
14:16:45 <kidclamp> #info frido was away but now catchign up and pushing
14:17:14 <fridolin> I'm cool
14:17:15 <fridolin> cait ?
14:17:15 <wahanui> cait is probably the best friend you could ever have.
14:17:29 <kidclamp> cait said shemight catch end of metting
14:17:38 <kidclamp> so we can move on i thnk
14:17:57 <kidclamp> #topic Updates from the QA team
14:18:37 <kidclamp> I will just add I was out end of July and most of August getting back into routine now
14:18:54 <tcohen> kidclamp: we missed you :-D
14:19:13 <kidclamp> thanks
14:19:14 <oleonard> kidclamp vacations like a European
14:19:23 <tcohen> marcel said he would be out for three weeks
14:19:30 <tcohen> so, next two
14:20:36 <kidclamp> anything Joubu tcohen khall atheia ashimema?
14:20:46 <tcohen> Joubu: when do you want to do the QA sprint?
14:20:53 <Joubu> for the next topic, yes
14:20:53 <ashimema> huh.. wa
14:21:00 <ashimema> oops
14:21:03 <kidclamp> bag jajm
14:21:10 <Joubu> tcohen: I am going to do the same as last one, send a poll and see your availabilities
14:21:21 <tcohen> alright
14:21:24 <kidclamp> #info Joubu will send a poll for next QA sprint
14:21:33 <tcohen> maybe next friday :-P
14:21:35 <kidclamp> #info remember to set yourself as qa contact when looking at a bug
14:21:39 <kidclamp> ^is for me :-)
14:22:40 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:22:48 <Joubu> Commit messages - I sent a reminder about commit messages. You should all read it
14:23:03 <Joubu> commit messages + bug titles: they cannot be the same, it's not possible
14:23:13 <Joubu> one is the problem, one is the fix
14:23:16 <Joubu> unless it's a new ft
14:23:21 <Joubu> anyway, read it.
14:23:37 <Joubu> Then I'd like to see if we could agree on a way to standardize the commit messages
14:23:51 <Joubu> "Bug 12345: my commit message"
14:23:51 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12345 enhancement, P5 - low, ---, oleonard, NEW , Can't Clear Reading History for Anonymous patron
14:23:52 <kidclamp> #link http://lists.koha-community.org/pipermail/koha-devel/2017-August/043991.html Commit messages and bug titles guidelines
14:24:01 <fridolin> +1
14:24:06 <kidclamp> +1
14:24:07 <tcohen> +1
14:24:10 <oleonard> +1
14:24:15 <Joubu> and "Bug 12345: (qa-follow-up) a QA note about what my fix does"
14:24:33 <fridolin> I personnaluy copi from Bugzilla whitch is : "Bug xxx - toto"
14:24:35 <Joubu> and "Bug 12345: (follow-up) same commit msg as before"  # i.e. can be squashed
14:24:38 <mveron> https://wiki.koha-community.org/wiki/Commit_messages
14:24:46 <Joubu> the git log is aweful, and commit messages are often wrong
14:24:49 <tcohen> yeah, can we change BZ display?
14:24:53 <Joubu> you can blame me for that too ;)
14:25:27 <fridolin> everybody prefers ':' than '-'?
14:25:29 <Joubu> then you can write a git hook to replace it if you like
14:25:53 * oleonard doesn't care as long as we are consistent.
14:26:01 <oleonard> But I do like being able to copy from the Bugzilla heading
14:26:10 <kidclamp> so should this go into coding guidelines? so we have a standardized list of how to?
14:26:20 <fridolin> same has owen
14:26:28 * Joubu prefers ": ", there is one more char to describe the patch
14:27:01 <Joubu> you are not suppose to copy bugzilla headings :)
14:27:04 <fridolin> indeed ;)
14:27:14 <Joubu> pick the numbers from the url, and you are done
14:28:45 <oleonard> Even though pianohacker doesn't appear to be awake could we talk about the ES6 usage thread from the mailing list?
14:28:52 <oleonard> http://lists.koha-community.org/pipermail/koha-devel/2017-August/043910.html
14:29:44 <kidclamp> are we done on commit messages?
14:29:58 <Joubu> ok, so how do we process?
14:29:58 <Joubu> I send an email to koha-devel, either you do not agree and suggest a counter proposition, or it's validated and added to the guidelines?
14:29:58 <Joubu> I update the commit messages before push (do not resend to bz) for a month, then ask authors to follow guidelines (fqa)
14:30:15 <Joubu> ok, so how do we process?
14:30:23 <Joubu> I send an email to koha-devel, either you do not agree and suggest a counter proposition, or it's validated and added to the guidelines?
14:30:30 <Joubu> I update the commit messages before push (do not resend to bz) for a month, then ask authors to follow guidelines (fqa)
14:30:35 <kidclamp> joubu is in a loop
14:30:47 <Joubu> sorry, has been disconnected
14:30:56 <Joubu> did not know it was sent
14:31:17 <tcohen> hehe
14:31:28 <kidclamp> I think write up as guideline and then a vote to accept next meeting
14:31:54 <mveron> +1
14:32:10 <Joubu> k
14:32:39 <Joubu> something else? ES6?
14:32:46 <kidclamp> #info Joubu will draft a coding guideline for commit messages to be voted on next meeting
14:32:51 <kidclamp> #action Joubu will draft a coding guideline for commit messages to be voted on next meeting
14:32:57 <kidclamp> oleonard?
14:32:58 <wahanui> oleonard is still here, if you just wish hard enough. or Koha's master UI designer
14:33:38 <oleonard> #link http://lists.koha-community.org/pipermail/koha-devel/2017-August/043910.html
14:34:03 <oleonard> I think the discussion is boiling down to "When and how do we compile assets"
14:35:31 <oleonard> My thought is: Could we incorporate this build process into the release process, rather than the installation process?
14:36:10 <tcohen> it is the same discussion we could have about our less approach
14:36:25 <oleonard> Solving this issue will lay the groundwork for a lot of positive improvements to our front-end asset handling
14:36:36 <oleonard> (which is basically what tcohen just said)
14:36:48 <tcohen> I think we should have it as a release management process for now
14:36:53 <tcohen> to ease adoption
14:37:03 <Joubu> yes, just pick one and try
14:37:17 <Joubu> if it does not work, we test the other option
14:37:39 <tcohen> pick the one that hurts the less on the distribution/deployment side for the general public
14:37:51 <oleonard> Adding it to the release management process would slightly complicate the process for developers, but that's our job and we can handle it.
14:38:30 <tcohen> +1
14:38:31 <Joubu> so we just need a wiki page
14:39:19 <kidclamp> #action pianohacker should write a wiki page for compiling assets  in the release process
14:39:33 <kidclamp> that's what happens when you sleep in
14:39:49 <tcohen> hehe
14:40:04 <oleonard> No objections to that plan?
14:40:37 * kidclamp looks for dissenting views, sees none
14:40:43 <Joubu> silence means everybody agrees
14:40:58 <ashimema> +1
14:40:58 <oleonard> Thanks everyone :)
14:41:16 <kidclamp> #info release process is suggested as proper time to compile assets, put onus on developers
14:41:29 <kidclamp> @later tell pianohacker check the irc meeting minutes
14:41:29 <huginn> kidclamp: The operation succeeded.
14:41:49 <kidclamp> #topic Review of coding guidelines
14:41:56 <kidclamp> Anything here?
14:42:10 <tcohen> we should implement some workflow for UI development on kohadevbox, including watcher and some live-reload lib
14:42:16 <tcohen> sorry, OT
14:42:29 <oleonard> tcohen++
14:42:36 <ashimema> +1
14:43:06 <tcohen> oleonard: if you have any suggestions, file an issue on digibib/kohadevbox
14:43:43 <kidclamp> no worries tcohen
14:43:57 <tcohen> ok?
14:44:48 <kidclamp> anyone have anything else before we move to next meeting
14:45:23 <Joubu> QAers, please QA
14:45:42 <kidclamp> #info QAers, please QA all the things
14:45:52 <kidclamp> #topic Set time of next meeting
14:46:07 * oleonard thinks this pot of coffee could have used some QA
14:46:33 <kidclamp> prove t/bean_dependent/Brew.t
14:46:50 <tcohen> kidclamp: lol
14:47:19 <kidclamp> September 27th, 21 UTC?
14:47:37 <tcohen> +1
14:48:12 <oleonard> +1
14:48:19 <mveron> +1
14:49:08 <kidclamp> #info Next meeting: September 27th, 21 UTC
14:49:21 <kidclamp> last chance!
14:49:49 <kidclamp> #endmeeting