13:03:09 <kidclamp> #startmeeting Development IRC meeting 29 March 2017
13:03:09 <huginn`> Meeting started Wed Mar 29 13:03:09 2017 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:09 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:09 <huginn`> The meeting name has been set to 'development_irc_meeting_29_march_2017'
13:03:17 <marcelr> #info Marcel de Rooy
13:03:17 <kidclamp> #topic Introductions
13:03:18 <wahanui> #info wahanui, a bot that has become sentient
13:03:25 <kidclamp> #info Nick Clemens, ByWater Solutions
13:03:46 <marcelr> this will be a crowdy meeting
13:03:57 <marcelr> meeting !
13:04:20 <khall> #info Kyle Hall, ByWater Solutions
13:04:22 <kidclamp> Joubu?
13:04:23 <wahanui> i think Joubu is not sure how to fix that correctly
13:04:24 <Joubu> #info Jonathan Druart
13:04:25 <marcelr> 13utc was a good tome
13:04:28 <marcelr> time
13:04:43 <marcelr> but after changing the clock?
13:04:50 <magnuse> #info Magnus Enger, Libriotech, Norway
13:05:57 <kidclamp> last call..
13:06:14 <kidclamp> #topic Announcements
13:06:34 <marcelr> I still want to ask for a signoff on bug 9988. This development gets stuck in Needs Signoff.
13:06:34 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=9988 enhancement, P5 - low, ---, m.de.rooy, Needs Signoff , Leave larger authority merges to merge_authorities cronjob (pref AuthorityMergeLimit)
13:06:54 <marcelr> And there is a security bug too: 18019, awaiting some attention for weeks already.
13:06:59 <kidclamp> #info Bug 9988 needs sign off
13:07:23 <kidclamp> #info security bug 18019 is also in the sign off queue
13:07:23 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18019 is not accessible.
13:07:28 <marcelr> no in NSO
13:07:40 <marcelr> but we probably mean the same
13:07:46 <kidclamp> #info security bug 18019 is also in the needs sign off queue
13:07:47 <wahanui> okay, kidclamp.
13:07:56 <kidclamp> :-)
13:08:17 <Joubu> does not mean the same, in SO I would have QA it for weeks...
13:08:30 <kidclamp> was a typo
13:08:49 <Joubu> seems like people have trouble with security/critical/blocker
13:09:01 <Joubu> these bugs HAVE TO BE processed quickly
13:09:12 <Joubu> sounds like quite easy to undestand why
13:09:21 <marcelr> secu bugs are only seen by a few
13:10:32 <kidclamp> I can look at 18019 today and test
13:10:40 <marcelr> great
13:10:55 <kidclamp> anything else?
13:10:55 <wahanui> hmmm... anything else is just being crap
13:11:11 <kidclamp> #topic Update from the Release manager (17.05)
13:11:17 <kidclamp> khall
13:11:49 <khall> Not much to say, I've been pushing to master when I can, Brendan has also been pushing some as well.
13:12:08 <khall> The queue is pretty long now, so I'll take some time on Friday to clear it out
13:12:15 <marcelr> there is one about export.pl
13:12:27 <khall> marcelr: just pushed that ; )
13:12:29 <marcelr> oh you pushed it now
13:12:34 <marcelr> great
13:12:56 <kidclamp> we have a bit but reminder of slush/freezes khall?
13:13:13 <Joubu> push order is quite weird, how do you process it?
13:13:29 <khall> Joubu: not sure what you mean
13:13:36 <Joubu> LIFO does not sound like a good method to process it
13:13:52 <khall> I go by severity
13:14:07 <jenkins> Project Koha_Master_D8 build #137: STILL FAILING in 55 sec: https://jenkins.koha-community.org/job/Koha_Master_D8/137/
13:14:08 <jenkins> * kyle: Bug 18144: Restore pieces of C4/Auth to make Google OpenID Connect work
13:14:08 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18144 critical, P5 - low, ---, mtompset, Pushed to Master , Removal of persona broke Google OAuth2
13:14:09 <jenkins> * kyle: Bug 18312: Fix export unless a file is supplied
13:14:10 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18312 critical, P5 - low, ---, jonathan.druart, Pushed to Master , Export is broken unless a file is supplied
13:14:17 <Joubu> nope 13757 has been QA then push in the 2 hours
13:14:22 <Joubu> it's an enh
13:14:49 <khall> Joubu: I also take requests ; )
13:15:16 <khall> if something has passed qa and someone PMs be to request it gets pushed, more the likely I'll take care of it
13:15:47 <Joubu> k
13:15:54 <marcelr> be careful, you will be mailed a lot :)
13:15:59 <khall> lol
13:16:28 <khall> we must remember, when everything is a priority, nothing is a priority
13:16:56 <Joubu> > major and security are priority
13:17:01 <Joubu> nothing else is priority
13:17:24 <blou> khall: about taking requests,  is that a quote we can put on the "quote list" for the bot?  :)
13:17:33 <Joubu> I fix stuff in hours, then it takes day to see stuffs included
13:17:40 <khall> blou: sure!
13:17:49 <Joubu> 16.11 is going to spend one more month with a critical issue, just because SO+QA+push takes too long
13:18:46 <khall> Joubu: if it's not getting pushed to master fast enough, just ping me. I've been so bogged down bag was acting as the primary pusher in the recent past
13:18:52 <huginn`> New commit(s) kohagit: Bug 18312: Fix export unless a file is supplied <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=8dad1582c100017f8ad3e331c9a9b9cc9ed4e4d6> / Bug 18144: Restore pieces of C4/Auth to make Google OpenID Connect work <http://git.koha-community.org/gitweb/?p=koha.git;a=commitdiff;h=1a53b49980e913c55c6f2021d21b6aa99ac8cefd>
13:18:56 <marcelr> Joubu: it was in PQA friday
13:18:57 <Joubu> (do not want to be polemical, just saying, you can move on)
13:19:39 <kidclamp> moving on
13:19:48 <kidclamp> #topic Updates from the Release Maintainers
13:20:34 <kidclamp> I don't know if we have any here...cait, mtj, jajm?
13:21:51 <Brooke> *crickets*
13:21:54 <kidclamp> #info please watch for critical,major, security bugs for current releases and move these along
13:22:02 <kidclamp> #topic Updates from the QA team
13:23:18 <kidclamp> Joubu? marcelr?
13:24:06 <marcelr> no
13:24:17 <Joubu> nope
13:24:20 <Joubu> nothing new
13:24:30 <kidclamp> #info please help keep the queue down
13:24:45 <Joubu> Hea v2 is pushed
13:24:54 <Brooke> Nice!
13:25:00 <Joubu> will get backported on next release, will need to contact the RMaints
13:25:03 <kidclamp> I have been encouraging more to join for future - more members who can hit easier patches would keep things moving
13:25:12 <Joubu> and check with lds to update the production server
13:25:32 <kidclamp> #info Hea v2 has been pushed and will be backported in next release
13:25:45 <Brooke> is there someone on project with enough exp to tie hea into the wiki so we can get a nice map?
13:25:46 <Joubu> release*s* hopefully
13:26:18 <Joubu> Brooke: Hea v2 includes a map
13:26:21 <kidclamp> #info Hea v2 has been pushed and will be backported in next releases
13:27:35 <kidclamp> moving on
13:27:40 <kidclamp> #topic General development discussion (trends, ideas, ...)
13:29:25 <kidclamp> Just to mention there are number of things open for ES - would be nice to see them in to 17.05 so please test QA where you can
13:29:32 <kidclamp> I am working on submitting more as well
13:29:47 <Joubu> Is there a plan?
13:30:06 <Joubu> things that is going to be done, need to be done, will be done later?
13:30:11 <Joubu> are*
13:30:28 <kidclamp> I will try to send something out to the list before in the next week
13:30:33 <kidclamp> need to review what there is
13:30:51 <kidclamp> hackfest helped find a few things
13:31:19 <kidclamp> in general though we need testers to figure otu what is working and what is not
13:31:42 <kidclamp> #action kidclamp will send an update on ES to the lists
13:32:10 <kidclamp> bug 18189 would be good to get in
13:32:10 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18189 enhancement, P5 - low, ---, nick, Signed Off , Elasticsearch sorting broken
13:32:24 <kidclamp> it fixes sorting (somewhat) and some authority  issues
13:33:12 <Joubu> authority related stuffs are completely broken under ES
13:33:28 <kidclamp> in what way Joubu?
13:34:23 <Joubu> in a way that SearchAuthority sub is called instead of the compat method from Koha::SE
13:34:36 <caboose> I'd be happy to be a tester for ES
13:35:03 <Joubu> bug 18131
13:35:03 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18131 major, P5 - low, ---, jonathan.druart, Signed Off , Matching staged records when using elastic search fails
13:35:08 <blou> We (inLibro) also could find ressources to test ES.
13:35:37 <kidclamp> kohadevbox should work with ES5 out of box - frido worked on setting it up independently and may be have tips
13:35:48 <Joubu> guys, please tests then :)
13:35:54 <kidclamp> should be NSO
13:36:52 <kidclamp> #info ES needs testing as well - caboose and inlibro will try to help
13:37:12 <kidclamp> skipping coding guidelins unless anyone has anything for that?
13:37:25 <marcelr> no
13:37:31 <kidclamp> #topic Set time of next meeting
13:37:36 <marcelr> but we should add one for exceptions
13:38:07 <kidclamp> more please marcelr
13:38:18 <marcelr> :)
13:39:04 <kidclamp> #action marcelr will draft a coding guidelines exceptions policy for next meeting
13:39:07 <kidclamp> :b
13:39:14 <marcelr> ok ;)
13:39:47 <kidclamp> April 12th, but not this time for next meeting
13:40:10 <kidclamp> 12 April 2017, 19UTC?
13:40:11 <marcelr> we toggle between the two
13:40:20 <kidclamp> I think 19 was preferred to 20
13:40:35 <kidclamp> unless any new zealanders want to speak up
13:40:46 <eythian> they will be sound asleep I expect
13:40:48 <marcelr> they are kind of quite around this time
13:40:56 <kidclamp> yeah
13:41:02 <marcelr> except for eythian
13:41:03 <marcelr> of course
13:41:29 <kidclamp> #info next meeting 12 April 2017, 19UTC
13:41:54 <kidclamp> last call for comment, questions or snide remarks
13:42:09 <kidclamp> [off] such as opinions on oxford comma
13:42:35 <kidclamp> #endmeeting