22:00:43 <cait> #startmeeting Development IRC meeting 9 August 2017
22:00:43 <huginn> Meeting started Wed Aug  9 22:00:43 2017 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:43 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:43 <huginn> The meeting name has been set to 'development_irc_meeting_9_august_2017'
22:00:48 <cait> #topic Introductions
22:00:49 <wahanui> #info wahanui, a bot that has become sentient
22:00:51 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
22:00:58 <pianohacker> #info Jesse Weaver
22:00:59 <jenkins> Project Koha_Master_D8 build #237: UNSTABLE in 2 hr 2 min: https://jenkins.koha-community.org/job/Koha_Master_D8/237/
22:01:00 <jenkins> * Jonathan Druart: Bug 18906: Display all funds the logged in user can use
22:01:00 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18906 major, P5 - low, ---, jonathan.druart, Pushed to Master , Superlibrarian and budget_manage_all users should always see all funds
22:01:03 <jenkins> * Jonathan Druart: Bug 18898 - Some permissions for Reports can be bypassed
22:01:03 <cait> please introduce yourself with #info following tcohen's example
22:01:04 <jenkins> * Jonathan Druart: Bug 19023 - inventory tool performance
22:01:05 <jenkins> * Jonathan Druart: Bug 17829: (follow-up) Move GetMember to Koha::Patron - routing-lists.pl
22:01:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18898 major, P5 - low, ---, dcook, Pushed to Master , Some permissions for Reports can be bypassed
22:01:06 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19023 major, P5 - low, ---, fridolin.somers, Pushed to Master , inventory tool performance
22:01:06 <wizzyrea> #info Liz Rea, Catalyst IT
22:01:07 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17829 enhancement, P5 - low, ---, jonathan.druart, RESOLVED FIXED, Move GetMember to Koha::Patron
22:01:07 <rangi> #info Chris Cormack, Catalyst IT
22:01:13 <cait> #info Katrin Fischer, BSZ, Germany
22:01:14 <BobB> #info Bob Birchall, Calyx
22:01:23 <atheia> #info Alex Sassmannshausen, PTFS Europe, UK
22:01:30 <josef_moravec> #info Josef Moravec, Municipal LIbrary Usti nad Orlici, Czech Republic
22:01:31 <cait> #chair tcohen
22:01:31 <huginn> Current chairs: cait tcohen
22:01:36 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_August_2017 today's agenda
22:01:41 <LeeJ> #info Lee Jamison, Marywood University
22:02:07 <tcohen> hi everyone
22:02:12 <mtj> #info Mason James, NZ
22:02:17 <mtj> hi folks
22:02:31 <BobB> hi mtj
22:02:46 <pianohacker> hello, NZ :)
22:02:49 <cait> ready to continue? :)
22:02:51 <pianohacker> (/AUS)
22:02:58 <cait> #topic Announcements
22:03:21 <cait> anyone?
22:03:22 <wahanui> i heard anyone was free to organize one at any time :-)
22:03:28 <tcohen> I wanted add a small comment
22:03:43 <cait> #info We just added a section on how to add screenshots to the manual with gitlab
22:03:46 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_August_2017
22:03:49 <cait> hm wrong link
22:04:02 <cait> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual#Normal_-_Adding_screenshots_with_gitlab right link
22:04:12 <cait> tcohen:  go ahead
22:04:16 <bag> #info Bag Brendan gallagher
22:04:42 <tcohen> #info tcohen is doing QA full time this week, please help him notice things you consider important besides the ones the RM notes
22:04:43 <caboose> #info Michael Cabus, caboose
22:05:05 <josef_moravec> cait++
22:05:06 <cait> tcohen: the clean-up script
22:05:22 <josef_moravec> tcohen++
22:05:25 <bag> hackfest friday and saturday at kohaus
22:05:31 <tcohen> cait: yes, I've added a followup to it, and am discussing it with Joubu, its quite tricky
22:05:35 <josef_moravec> tcohen: bug 14826
22:05:35 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14826 enhancement, P5 - low, ---, kyle.m.hall, Signed Off , Resurrect account offsets table
22:05:37 <cait> yeah, it is
22:05:47 <tcohen> it would be great if people from oceania could take a look
22:05:50 <cait> maybe we can do the issues first, they seem less tricky than the others
22:05:51 <tcohen> while we sleep
22:06:16 <cait> looking for the bug number
22:06:18 <bag> I will we be trying to teach people how to use the sandboxes.  Also tcohen I may try to help some people set up their own kohadevbox - so I may need to ping you for help
22:06:25 <tcohen> josef_moravec: I did that too, asked for some followups khall promply submitted before I was released from others he
22:06:33 <cait> tcohen: do you have it on hand?
22:06:34 <tcohen> bag: np
22:06:43 <tcohen> cait: which?
22:06:43 <wahanui> which is the most maintainable
22:06:54 <tcohen> bug 19016
22:06:54 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19016 major, P5 - low, ---, jonathan.druart, In Discussion , Add a script to fix corrupted data
22:06:55 <cait> bag: if you can, please also encourage to try editing the manual
22:06:58 <LeeJ> bag: you should also mention they can help write the manual if they like to document! ;D
22:07:05 <LeeJ> haha
22:07:08 <bag> cait: I’m going to ask jzairo to lead that up
22:07:25 <bag> but rangi encouraged most here to do manual work :)
22:07:35 <cait> #info bug 19016 -  Add a script to fix corrupted data needs attention and testers
22:07:58 <cait> I will be around too if there are questions, i think at least some of the time
22:08:03 <tcohen> another thing I'd like to mention is that
22:08:26 <bag> thanks cait
22:08:44 <rangi> it's always a trip for me to see tables i created in 1999, that got removed, now coming back :-)
22:08:57 <cait> #info Koha-US Conference is taking place this week, it's broadcasted http://koha-us.net/index.php/2017_Koha-US_Conference
22:08:57 <bag> ha
22:09:07 <tcohen> our jenkins nodes design is quite difficult to keep in sync so it works with different dependencies
22:09:30 <tcohen> right now we have a situation in which pushing the needed REST api upgrade patches
22:09:47 <tcohen> would require newer deps, and break jenkins tasks for stable branches
22:09:54 <tcohen> to make it short
22:10:14 <tcohen> I'm trying to have a kohadevbox-derived docker image to use for jenkins
22:10:35 <tcohen> making it easier to keep running environments adjusted as needed
22:10:45 <cait> can you do your own #info plz? :)
22:10:52 <tcohen> anyone willing to help with opinions is welcome!
22:11:14 <tcohen> #info tcohen and Joubu are exploring ways of containerizing jenkins tasks
22:11:27 <bag> tcohen: larryb said he can create another node for you.  Get in touch with him
22:11:36 <tcohen> bag: thanks
22:11:43 <LeeJ> tcohen: I know that mtompset had been doing some work with koha/docker..he may have some input for you :)
22:12:03 <tcohen> #info ByWater is handing the community another jenkins node in the meantime
22:12:14 <tcohen> LeeJ: thanks
22:13:04 <cait> ok, moving on?
22:13:05 <tcohen> that's all from me
22:13:22 <cait> #topic Update from the Release manager (17.11)
22:13:42 <cait> #info Joubu left his apologies
22:14:08 <cait> #link https://koha-community.org/whats-on-in-koha-devel-14/ for recent information about urgent topics and new things
22:15:10 <cait> #info We will need help updating the manual and especially the help pages prior to 17.11 release in order to be able to switch it over to the Sphinx based one
22:15:51 <cait> we need to fix links
22:15:58 <cait> besides adding content of course
22:16:04 <cait> moving on
22:16:20 <cait> #topic Updates from the Release maintainers
22:16:30 <cait> fridolis is not around, mtj?
22:16:36 <cait> fridolin
22:16:37 <wahanui> well, fridolin is busy at the moment, I asked him to backport the bug fix
22:17:08 <cait> #info 16.11.11 will be the next 16.11.x release, planned on schedule, string freeze on the 15th, release on 22nd
22:17:35 <cait> I hope we can include the script to fix data by then or have at least a partial fix for the most urgent (issues/old_issues)
22:17:38 <cait> mtj?
22:17:38 <wahanui> mtj is the 16.5 Rmaint for the 16.11 release cycle
22:17:56 <mtj> #info 16.05.16 should be on schedule this month too
22:18:49 <cait> moving on?
22:19:00 <cait> #topic Updates from the QA team
22:19:10 <cait> anyone from the QA team around?
22:19:13 <oleonard> #info Owen Leonard, late.
22:19:30 <tcohen> yes
22:19:35 <pianohacker> 
22:19:40 <pianohacker> woops
22:19:56 <tcohen> #info QA team members are urged to spend some time on blockers and major bugs
22:20:26 <tcohen> as marcelr said, enhancements will start to get stuck
22:20:33 <tcohen> and we love enhancements
22:20:36 <bag> yeah
22:20:49 <tcohen> lets work on bugs (which we love to get fixed)
22:21:09 <tcohen> if possible, add the tests you consider are needed and PQA on them
22:22:28 <cait> fixing_bugs++
22:22:33 <cait> we got some evil ones to deal with atm
22:22:46 <cait> let's get this done and then add all the shiny features ;)
22:22:47 <pianohacker> brb
22:22:49 <cait> moving on?
22:22:54 <bag> yeah
22:22:58 <tcohen> yeah x2
22:23:13 <cait> #topic General development discussion (trends, ideas...)
22:23:20 <cait> pianohacker: please start :)
22:23:36 <pianohacker> hi
22:23:38 <pianohacker> back
22:24:09 <pianohacker> okay, short version: we need to figure out how we feel about IE working on the staff client
22:24:11 <pianohacker> long version
22:24:47 <pianohacker> I'm working on the (now) Preact-based circ rules editor (mockup very soon), and if we don't want to beat our head against a transpiler
22:25:00 <pianohacker> (a discussion which has gotten stuck a couple times now)
22:25:13 <oleonard> Let's beat our head against a transpiler
22:25:38 <bag> pianohacker: can we leave the current circ editor inplace and just add the other new one as a option if you so choose?
22:26:02 <bag> then IE people can still use the old version.  (yeah that is just a work around and doesn’t answer the question)
22:26:03 <pianohacker> bag: if people are okay with being locked out of the new shiny, that's totally okay with me
22:26:26 <wizzyrea> well, is it all IE, or only older versions
22:26:37 <pianohacker> oleonard: I would absolutely love to, but do we have a path forward that's not covered in bikesheds?
22:26:38 <wizzyrea> I thought the newer ones were better at standards
22:26:53 <pianohacker> wizzyrea: all IE for any ES6 features :/ edge works but is apparently not very common
22:27:02 <oleonard> We're back in the world where the latest IE is exclusive to the latest version of Windows
22:27:08 <pianohacker> yeah...
22:27:11 <bag> It would make it easier for inclusion - you could even systempref it (maybe?)  yay more sysprefs
22:27:28 <wizzyrea> ugh.
22:27:31 <oleonard> bag: I suspect that will make maintenance twice as difficult
22:27:34 <wizzyrea> yeah no
22:27:38 <wizzyrea> let's not do that to ourselves.
22:27:44 <bag> thanks oleonard that was what I was missing in my thoughts
22:27:46 <pianohacker> I would strongly prefer not to syspref it; AdvancedCatalogingEditor is currently enabled on 2/608 Koha installations in hea
22:27:53 <pianohacker> just to pick a random example ;)
22:27:57 <bag> right - maintaining two circ rules - that’s out
22:28:20 <LeeJ> pianohacker: my library is one! :D
22:28:21 <tcohen> thenew circulation rules also try to be more flexible too
22:28:36 <pianohacker> LeeJ: that does make me (and kidclamp) happy to hear :)
22:29:15 <pianohacker> yes; so the old interface isn't a perfect representation (since you don't have to set every value for every branch/category/itemtype)
22:29:21 <oleonard> As far as I'm concerned the idea of a preprocessor and/or transpiler isn't too bikeshedded really. It's just that I aimed to take the lead on it and then my Koha dev time was cut back drastically
22:29:52 <rangi> i like the new circ rules, but (as you all know) it's vitally important we get it right
22:30:17 <pianohacker> oleonard: do you think we have a decent shot at getting webpack/babel/npm into the Koha build/dev workflow?
22:31:04 <oleonard> I'm not confident that webpack will work well without doing major changes to the way we handle JavaScript in general, so I'm leaning towards gulp still
22:31:12 <cait> pianohacker: might be older versions on hea too? or just copy cataloguing
22:31:13 <oleonard> maybe you and I could talk about that another time
22:31:31 <pianohacker> because the only thing that has no obstacles (besides our sanity) is developing Preact using IE-compatible ES3.
22:31:48 <pianohacker> oleonard: agreed :)
22:32:41 <tcohen> as rangi says, code speaks, that's the only way to see the benefits of adopting new stuffs and changing workflows
22:32:52 <oleonard> I still think it's vital to Koha's front-end future that we choose /something/ to do preprocessing stuff
22:33:36 <pianohacker> It is theoretically possible, though gross, to check in the compiled code (like how we handle LESS)
22:33:37 <cait> silly question maybe, but what does a transpiler do?
22:33:49 <cait> translate code for different versions?
22:34:00 <pianohacker> yup, that's the main relevant feature.
22:34:57 <LeeJ> cait: perhaps add this to the info for reference? https://scotch.io/tutorials/javascript-transpilers-what-they-are-why-we-need-them
22:35:29 <pianohacker> okay, just to summarize; we would prefer not to have two parallel circ rule interfaces, for reasons of maintainability
22:35:40 <cait> #link https://scotch.io/tutorials/javascript-transpilers-what-they-are-why-we-need-them - we discussed about adding a trnaspiler / preprocessing stuff
22:35:53 <cait> i think it might get in the way fast
22:36:02 <cait> with the new stuff you want to add
22:36:07 <pianohacker> natively using ES6 features (without transpilation) is out, because we don't want to completely cut off the IE users
22:36:09 <cait> and also every new option will have to be added twice
22:36:12 <pianohacker> right
22:36:25 <cait> we stopped doing 2 opac templates because we didn't really manage that all too well
22:37:15 <pianohacker> there's two options left: a) work on including a transpiler b) continue to write JS that works in IE.
22:37:36 <tcohen> transpiler++
22:37:45 <LeeJ> transpiler++
22:37:46 <wizzyrea> um. concerns about dropping IE>
22:37:56 <josef_moravec> transpiler++
22:38:17 <oleonard> Can we agree on IE10+ ?
22:38:34 * wizzyrea signs off on that
22:38:37 <tcohen> I think requiring a specific browser for a tool is not a big deal
22:38:38 <rangi> yup
22:38:46 <LeeJ> oleonard: is IE10 the current standard minimum?
22:38:47 <wizzyrea> have you ever worked with government?
22:38:59 <wizzyrea> requiring a specific browser is a very. big. deal.
22:39:04 <rangi> i say go for the version ms still supports
22:39:05 <tcohen> hm
22:39:16 <oleonard> IE11 is the highest version still available on Windows 7
22:39:32 <oleonard> I'm not sure about Windows 8, but Windows 10 has IE "Edge"
22:39:33 <wizzyrea> I think 11+
22:39:34 <rangi> https://www.microsoft.com/en-us/windowsforbusiness/end-of-ie-support
22:39:37 <pianohacker> that's the main reason I actually agreed with dcook's mailing list post, as much is it made me grind my teeth.
22:39:52 <rangi> so 10 is not actually supported
22:40:09 <oleonard> Okay cool. 11+
22:40:17 <wizzyrea> MS has forced everyone up anyway I think
22:40:20 <rangi> yeah
22:40:30 <wizzyrea> i'm sure you'll find stragglers
22:40:35 <pianohacker> Okay. I will work (in conjunction with oleonard) on putting together some transpiler stuff. It may not be the perfect, ideal build pipeline, but it's a path forward.
22:40:57 <rangi> but we do them no favours leaving them on a browser thats had no security patches since jan 2016
22:41:10 <LeeJ> pianohacker++ oleonard++ transpiler++
22:41:24 <tcohen> https://www.microsoft.com/en-us/windowsforbusiness/end-of-ie-support
22:41:48 <cait> maybe start a wiki page with some of those links and information?
22:41:49 <pianohacker> Quick minivote; if it substantially eases getting this new project integrated, how bad would checking in the transpiled JS be?
22:41:52 <cait> it might beuseful later on
22:41:58 <jfowler> Does anyone know if it's possible to import multiple items from an individual MARC record? For example, if a MARC record has holding information for a multi-volume set with multiple barcodes, can Koha import both the bib and the item info?
22:42:07 <wizzyrea> jfowler, we are in a meeting can you hold on?
22:42:16 <jfowler> sure. Sorry guys.
22:42:19 <wizzyrea> sok :)
22:42:20 <pianohacker> we should be done soonish :) no worries
22:42:48 <tcohen> pianohacker: I'm not sure about that
22:43:22 <tcohen> I think transpiling might be better done on testing/packaging time
22:43:55 <pianohacker> it's not ideal, and if at all possible would not be permanent, but do we have any steps in the current dev workflow to include "npm build" or "npm watch"?
22:44:08 <oleonard> Let's postpone that discussion until pianohacker and I have had a chance to come up with a proposal
22:44:13 <pianohacker> kk
22:44:17 <bag> oh yeah hi pianohacker - great to have you here :)
22:44:26 <pianohacker> oh hi bag :)
22:45:42 <tcohen> oleonard: good idea
22:46:21 <cait> #action pianohacker and oleonard are going to work out a proposal for adding a transpiler into our workflow
22:46:21 <cait> hope that was right :)
22:46:21 <oleonard> Looks good to me
22:46:21 <pianohacker> yup! I think that wraps up that discussion for the time being
22:46:21 <cait> any last minute additions before i move on?
22:46:22 <cait> #topic Review of coding guidelines
22:46:22 <cait> we got no proposals on the wiki - someone has something?
22:46:22 <cait> #topic Review of coding guidelines
22:46:22 <cait> hm, didn't change
22:46:24 <cait> ah
22:46:30 <cait> huginn is sleepy
22:46:31 <huginn> cait: I've exhausted my database of quotes
22:46:39 <cait> you are exhausted... i understand
22:46:45 <pianohacker> amen
22:46:52 <cait> ok, moving on then
22:47:01 <cait> #topic Set time of next meeting
22:47:13 <cait> I got no idea of how this curerntly works
22:47:16 <cait> i think every 2 weeks?
22:47:34 <tcohen> yes, in 2 weeks
22:47:37 <pianohacker> alternating between, what, 10 and 22 UTC?
22:47:42 <tcohen> exactly
22:47:44 <cait> looks like 14 and 21
22:47:49 <cait> https://wiki.koha-community.org/wiki/IRC_Meetings
22:48:28 <pianohacker> I certainly prefer 14 ;)
22:48:35 <cait> 24th, 14?
22:48:42 <tcohen> 23rd
22:48:48 <cait> ok
22:48:53 <tcohen> wednesdays
22:48:53 <wahanui> wednesdays is when I stab people, same problem.
22:49:04 <cait> it's already thursday here :)
22:49:21 <cait> #agreed Next meeting will be on August 23, 14 UTC
22:49:27 <cait> thx all for attending!
22:49:32 <cait> #endmeeting