21:00:37 <cait> #startmeeting Documentation IRC meeting 19 October 2017
21:00:37 <huginn`> Meeting started Thu Oct 19 21:00:37 2017 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:37 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:37 <huginn`> The meeting name has been set to 'documentation_irc_meeting_19_october_2017'
21:01:00 <cait> #topic introductions
21:01:01 <wahanui> #info wahanui, a bot that has become sentient
21:01:14 <georgewilliams> #info George Williams, Northeast Kansas Library System
21:01:20 <cait> please introduce yourself using #info :)
21:01:25 <BobB> #info Bob Birchall, Calyx, Australia
21:01:26 <Joubu> #info Jonathan Druart
21:01:30 <caboose> #info Michael Cabus, ByWater Solutions
21:01:31 <cait> #info Katrin Fischer, BSZ, Germany
21:02:03 <cait> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_19_October_2017 today's agenda
21:02:06 <rangi> #info Chris Cormack, Catalyst NZ
21:02:15 <cait> #chair rangi
21:02:15 <huginn`> Current chairs: cait rangi
21:02:26 <cait> thx all cor coming!
21:02:39 <cait> #topic How does it work?
21:02:59 <cait> I don't have new information since the last meeting, instrcutions are available on the wiki
21:03:04 <cait> but are there any questions about the process?
21:03:37 <caboose> I'm just getting my act together (missed last( but will review instructions :)
21:03:55 <cait> let me know if I can help :)
21:04:13 <cait> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual Instructions on how to edit hte manual
21:04:18 <cait> moving on
21:04:23 <BobB> no contribution from me yet, cait, hoping to get to it in the next couple of weeks
21:04:56 <cait> BobB: thx! Irma has sent a merge request - waiting for her feedback on my comment
21:04:59 <cait> #topic What's been done so far
21:05:18 <cait> #info LeeJ has been cleaning up the cronjobs chapter and adding new things to it
21:05:49 <cait> #info Joubu fixed the problem with the screenshots that were not migrated correctly
21:06:07 <cait> #info jzairo has been working on a patron clubs feature - merged not long ago today
21:06:27 <cait> #info Documentation Sprint has been quite good, we got some first time contributors, more listed on the wiki
21:06:40 <cait> #link https://wiki.koha-community.org/wiki/2017-10-05_Documentation_Sprint_Day Past Documentation Sprint day
21:07:07 <cait> #info kellym has been updating the authorized values list
21:07:20 <cait> hope i didn't miss someone - every contribution is much appreciated
21:07:30 <kellym> #info kelly mcelligott bywater
21:07:33 <rangi> i fixed the search
21:07:40 <rangi> thats about all I got done
21:07:51 <cait> #info rangi fixed the search problem!
21:07:52 <cait> sorry :)
21:08:18 <cait> i'd like to move on to todo if that' sok
21:08:25 <cait> #topic Next steps
21:08:50 <cait> #link https://annuel2.framapad.org/p/KohaManualTodo todo list
21:09:20 <cait> we've listed some areas where descriptions are missing, authorised values and notices for examples
21:09:46 <cait> i think it would be good to take a look at the feature lists of the last releaess and check against the manuals what is missing
21:10:03 <cait> if someone wants to volunteer to fill up the list it would be nice :)
21:10:15 <cait> rangi, any technical todos?
21:10:49 <rangi> there are nicer ways to do translation than the way we currently do it for the old manual, id like to get one of those working
21:11:17 <cait> yes, translation is a big TODO
21:11:22 <rangi> https://pypi.python.org/pypi/sphinx-intl
21:11:44 <rangi> we can still use pootle, but there are easier was to generate the .po file
21:11:47 <reiveune> bye
21:12:13 <cait> hm but still po files then?
21:12:26 <cait> i thin one problem with pootle is if hte po files orders alphabetic
21:12:27 <rangi> yes
21:12:34 <cait> would be nice to have th estrings in the order they appear
21:12:48 <rangi> people can use transifex or anything they want with the .po file
21:13:12 <kellym-kohamtg> cait I can add to the to do list for 17.05 release including new sys pref and features
21:13:15 <rangi> its the currently the way we generate it, and regenerate the docs that is the messy bit
21:13:22 <Joubu> Are there notes somewhere already about that?
21:13:36 <rangi> Joubu: about what?
21:13:37 <cait> kellym-kohamtg: thx! sysprefs should be done up to 17.05, but everything else we didn't check
21:13:43 <Joubu> manual translation
21:13:58 <Joubu> the different possibilities, what has been tried already, etc.
21:13:58 <cait> #action kellym to add missing 17.05 features to to-do list
21:14:03 <rangi> i dont have the docs for the old docxml way, that was done by bernardo
21:14:15 <rangi> but this looks like the best way for sphinx
21:14:18 <rangi> http://www.sphinx-doc.org/en/stable/intl.html
21:14:21 <cait> for the old way there is inofrmation on the wiki
21:14:30 <rangi> and https://pypi.python.org/pypi/sphinx-intl
21:14:31 <cait> we haven't added anything there for sphinx yet
21:14:55 <Joubu> when will want to pick the strings that are already translated on the old manual I guess?
21:15:03 <Joubu> :s/when/we
21:15:10 <Joubu> (sorry, tired...)
21:15:15 <rangi> for the ones that are translated yes
21:15:28 <rangi> (which is spanish, french, chinese and german?)
21:15:38 <rangi> we can start fresh with the others
21:15:45 <cait> not german
21:15:48 <cait> but there are some
21:15:50 <cait> italian maybe too
21:16:02 <rangi> ah yes substitute italian for german
21:16:07 <cait> it's been a lot of work, would be good to save it
21:16:34 <rangi> the old way you get lots of duplicated stuff
21:16:44 <rangi> (like we do in our .tt)
21:17:12 <rangi> im hoping we can reduce lots of that
21:17:24 <Joubu> I will try to have a look at that, if nobody else does
21:17:29 <cait> ot as much in the manuals as in the interface i think, but yeah
21:18:14 <Joubu> why duplicated stuff?
21:18:30 <Joubu> strings should appear only once in the manual, so should not be picked twice
21:18:40 <rangi> heh no
21:18:44 <rangi> lots of strings repeat
21:18:59 <Joubu> ok sounds fun
21:19:16 <rangi> but i think sphinx-intl will do a much better job
21:19:43 <rangi> we will see :)
21:19:55 <cait> i still think translating in context would make up for repeats
21:20:10 <Joubu> ok, so the plan would be to first make it translatable easily, then reinject the strings that are already translated
21:20:16 <cait> not having context or knowing what the paragraph before referenced to is making things hard
21:20:19 <rangi> yeah
21:20:44 <cait> manual translation coudl be different to gui
21:21:45 <cait> ok
21:21:50 <cait> is there any action item we can look?
21:21:57 <rangi> i really dont want to build any more tools we have to look after
21:21:59 <cait> is someone volunteering to look into options?
21:22:16 <rangi> if we can use tools others are maintaining, rather than our own scripts its a massive win
21:23:12 <Joubu> I really would like to announce that the manual for 17.11 is ready, so I will try to have a look
21:23:21 <rangi> cool
21:23:22 <Joubu> at least estimate the amount of work we need
21:24:11 <rangi> thanks Joubu
21:24:49 <cait> #action Joubu is goingto look into options for manual translation
21:24:55 <cait> ok
21:24:59 <cait> something else?
21:24:59 <wahanui> well, something else is doing that, before you ran my rebuild
21:25:06 <Joubu> yes
21:25:07 <Joubu> wait
21:25:14 <Joubu> what's next? :)
21:25:26 <cait> getting more people involved
21:25:29 <Joubu> I would like to know what do we do for the new ft
21:25:40 <cait> new features?
21:25:40 <wahanui> new features are almost invariable meant for master
21:25:41 <Joubu> the ones that are going to be in 17.11
21:26:02 <cait> we have a possible backlog to 16.11 or 16.05, not sure yet
21:26:12 <cait> kellym-kohamtg:  was going to look at 17.05 release notes
21:26:24 <kellym-kohamtg> yes cait!
21:26:31 <cait> maybe we could provide 'alpha' release notes for 17.11 to get people started?
21:26:38 <rangi> they are there now
21:26:47 <cait> link?
21:26:47 <wahanui> link is both helpful/unhelpful
21:27:10 <rangi> https://koha-community.org/manual/17.11/html/
21:27:17 <rangi> its always that pattern
21:27:22 <Joubu> I would like to do something for the release notes, provide them very early and make the contribution/fix easy
21:27:25 <cait> yeah, but not release notes to see what will be added :)
21:27:38 <Joubu> and highlight what is missing (new)
21:27:39 <rangi> ah right, misread
21:27:52 <cait> Joubu: hm?
21:28:03 <rangi> Joubu: you could use gitlab ci or jenkins
21:28:14 <rangi> to publish them somewhere
21:28:19 <cait> constantly bulid them
21:28:20 <cait> could work
21:28:21 <Joubu> new ft will be highlighted in the release note, with the "release notes" field
21:28:26 <cait> ah
21:28:37 <Joubu> - Is it enough to put that in the manual?
21:28:38 <cait> jenkins sounds like a good idea to me
21:28:42 <cait> no
21:28:48 <Joubu> - Does we ask dev to make something bigger for the manual?
21:28:56 <Joubu> - It is not a job for dev
21:29:07 <cait> because you can't see where it should go and it's suppoed to be a summary I think - not instructions how to use
21:29:20 <Joubu> - Do we want to have all these ft with enough doc when 17.11 is out?
21:29:49 <cait> without having the list I fear that we might not have enough people rightnow
21:30:00 <cait> we could try to get more people involved by having such a list
21:30:13 <cait> and if peope send me text i can make the patches to include
21:30:16 <cait> if that's a barrier
21:30:21 <cait> add screenshots too if they are sent separately
21:31:02 <cait> Joubu: could you check where we could keep the pre-release notes? and then we send an email to the mailng list to aks people to send merge requests or texts to koha-docs mailing list to include?
21:31:31 <Joubu> Anyone around that is willing to help documenting the new 17.11 features?
21:32:06 <cait> caboose-afk: don't go... was going to ask you about styling the manual :)
21:32:09 <caboose-afk> I definitely want to get involved
21:32:22 <caboose-kohatmtg> yeah I want to help with that for sure cait!
21:32:47 <cait> someone left some notes about ways on how to do that on the todo list
21:32:57 <caboose-kohatmtg> sweet
21:33:09 <cait> haven't had time to review, but might be a starting point
21:33:15 <caboose-kohatmtg> cool, I am on it
21:33:59 <cait> #info caboose to look into styling/improving the manual look and feel
21:34:24 <cait> Joubu: willing to try, but can't do it alone, so let's try mailing list next
21:34:54 <cait> #info If people want to send text and screenshots instead of merge requests, cait will turn that into patches
21:35:16 <cait> #action caboose to look into styling/improving the manual look and feel
21:35:32 <cait> #action Joubu to generate pre-release notes for manual work
21:35:59 <cait> search has been fixed
21:36:07 * Joubu duplicates himself
21:36:08 <cait> so i think we covered about all of the next steps topics listed now
21:36:28 <cait> sounds good :)
21:36:33 <cait> moving on?
21:36:41 <cait> #topic Getting more people involved
21:36:48 <cait> actually that fits with the question about 17.11
21:37:07 <cait> i think too early for another sprint maybe
21:37:10 <cait> any other ideas?
21:37:10 <wahanui> any other ideas are welcome as well
21:38:30 <BobB> as a company we want to help ....
21:38:41 <Joubu> people should stop sleeping
21:38:50 <BobB> but there are so many competing demands on everyone's time
21:38:59 <cait> Joubu: not sure I can do with even less...
21:39:07 <BobB> somehow we really need to get users to own this - librarians
21:39:12 <wizzyrea> ^
21:39:19 <cait> BobB: we understand, it's just turning into a global problem :)
21:39:51 <georgewilliams> As a librarian I want to help too but, like BobB says, there are a lot of demands on my time
21:39:55 <cait> all the koha people are super busy, which is good, so we need more of us and get libraries involved
21:40:02 <BobB> so keep pounding the mailing list?
21:40:09 <cait> georgewilliams: what would make it easy for you?
21:40:16 <georgewilliams> If there were two of me
21:40:21 <BobB> LOL
21:40:22 <cait> heh
21:40:43 <cait> maybe another thought
21:40:51 * wizzyrea fires up the cloning machine
21:40:52 <Joubu> (just a number, this year we have ~20 authors per months, last years it was ~30)
21:40:57 <cait> #info Please think about putting your name down for documentation team 18.05
21:40:58 <georgewilliams> I'm being crushed by demands for help from the 51 libraries in our system, so my biggest issue is a complete lack of time
21:42:03 <cait> georgewilliams: maybe start small... you are lookign for something in the manual, don't find it, note it on the todo
21:42:15 <georgewilliams> That I can probably do
21:42:23 <cait> also when you notice a typo or whatever
21:42:26 <georgewilliams> That's a good idea - a good starting point
21:42:28 <Joubu> cait: maybe you should (just in case...) add a message on the kanba. There was a documation epic with lot of people interesting by contributing to the manual
21:42:33 <cait> the todo is made so it can't be done quickly, no log in or anything
21:42:36 <Joubu> kanban*
21:43:03 <cait> #info If you ntoice something missing on the manual, a typo, some error, please take a short moment to note on the to-do list!
21:43:16 <cait> #action cait to update the kanban with latest developments/needs
21:43:37 <cait> and if any of you know someone who would be good to contribute something, please ask them
21:44:00 <cait> moving onto setting a date for the next meeting ok?
21:44:04 <cait> it's awfully late here
21:44:05 <georgewilliams> And I'll also report on this meeting and the need for contributers at the next Koha-US meeting
21:44:14 <cait> excellent!
21:44:24 <caboose-kohatmtg> :)
21:44:35 <cait> #action georgewilliams to report about the documentation meeting and the need for contributors at the next Koha-US meeting
21:44:56 <cait> cool
21:45:18 <cait> #topic Set time of next meeting
21:45:26 <cait> so release is end of nov
21:45:31 <cait> should we meet agian before?
21:46:43 <Joubu> in 3 weeks
21:46:48 <caboose-kohatmtg> perfect
21:47:09 <cait> Joubu: can you suggest a date?
21:47:33 <Joubu> +3w, Now 8th :)
21:47:38 <Joubu> Nov
21:47:43 <cait> is that ok for everyone?
21:47:46 <kellym-kohamtg> yes
21:47:55 <caboose-kohatmtg> yep
21:47:57 <georgewilliams> yes
21:48:08 <cait> hm let me quickly chekc my calendar
21:48:33 <Joubu> ha, it's a Wed
21:48:36 <Joubu> maybe 9th then
21:48:41 <BobB> Nov 8 is a Wednesday
21:49:07 <cait> hm will be having trainign that week
21:49:22 <cait> so that week is generally bad for me, unless somoene else could chair
21:49:56 <cait> is a week later still ok? maybe monday?
21:50:05 <caboose-kohatmtg> that works for me
21:50:08 <cait> 13th
21:50:25 <cait> same time? at least we should go into winter time before that, so a little bette rfor me (if I calculated correctly)
21:50:49 <georgewilliams> 13th works here
21:50:52 <kellym-kohamtg> that date works for me!
21:52:04 <cait> #agreed next meeting will be on Monday, 13 November, 21 UTC
21:52:07 <cait> #endmeeting