22:00:44 <cait> #startmeeting Documentation IRC meeting 28 September
22:00:44 <huginn`> Meeting started Thu Sep 28 22:00:44 2017 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:44 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:44 <huginn`> The meeting name has been set to 'documentation_irc_meeting_28_september'
22:00:51 <cait> hope some people around
22:01:09 <rangi> #info Chris C Catalyst IT
22:01:11 <BobB> i'm around :)
22:01:22 <cait> #topic Introductions
22:01:23 <wahanui> #info wahanui, a bot that has become sentient
22:01:28 <cait> #info Katrin Fischer, BSZ, Germany
22:01:41 <BobB> #info Bob Birchall, Calyx, Australia
22:01:58 <cait> 3
22:02:01 <BobB> hi rangi
22:02:04 <cait> anyone else? :)
22:02:05 <rangi> hi BobB
22:02:31 <irma> #info Irma CALYX AUstralia
22:02:36 <irma> hi all :-)
22:02:45 <cait> hi Irma
22:02:46 <cait> schön dich zu sehen
22:02:59 <irma> Du auch
22:03:32 <BobB> if this meeting is in german i am going to struggle :)
22:03:45 <cait> we better keep it english then
22:03:52 <cait> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_28_September#Agenda Agenda
22:04:02 <cait> tajoli: are you here for the meeting?
22:04:38 <tajoli> yes
22:04:45 <BobB> hi zeno
22:04:55 <tajoli> #info Zeno Tajoli, CINECA, Italy
22:05:04 <cait> ok, let's move on
22:05:11 <cait> #topic How does it work?
22:05:25 <cait> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual
22:05:27 <bag> #info Brendan Gallagher ByWater
22:05:42 <cait> Instructions are on the wiki, please ask if there are any questions
22:05:57 <cait> there is a new link to a list of bugs on bugzilla related to documentation
22:06:06 <cait> #link https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=NEW&bug_status=REOPENED&bug_status=ASSIGNED&f1=keywords&f2=component&j_top=OR&known_name=Documentation%20To-do&o1=allwords&o2=equals&query_based_on=Documentation%20To-do&query_format=advanced&v1=Manual&v2=Documentation
22:06:27 <BobB> we (calyx) have had no time to look at this  at all cait, but we should have some time this coming week
22:06:45 <barton> #info Barton Chittenden, BWS
22:06:48 <cait> np, next week would be great :)
22:06:59 <cait> shoudl we move on then if there are no questions about the process?
22:07:29 <rangi> yep
22:07:44 <cait> #topic What's been done so far
22:07:53 <cait> some smaller progress since the last meeting
22:08:30 <cait> #link https://annuel2.framapad.org/p/KohaManualTodo
22:08:37 <cait> you can see the points striked out there
22:08:53 <cait> #info jzairo has patron clubs ready and is working on rancor
22:08:56 <cait> jzairo++
22:09:36 <cait> ok, moving on
22:09:42 <cait> #topic Next steps
22:10:22 <cait> People have asked about translations - I know bgkriegel is looking into it, but have no update right now
22:10:46 <rangi> I will email bernardo to ask about progress
22:10:58 <cait> thank you rangi
22:11:10 <cait> #action rangi to ask bgkriegel about progress on translations
22:11:37 <cait> I had the idea we could have a documentation sprint day
22:11:46 <cait> what do you think?
22:11:50 <rangi> that is a good idea
22:12:01 <tajoli> we can try
22:12:34 <tajoli> A question:  you will accept patches for 17.05 tree ?
22:12:46 <cait> patch master
22:12:58 <rangi> and we will backport
22:13:10 <rangi> just like normal dev
22:13:27 <cait> let's focus on fixing the most recent
22:13:42 <irma> if it is before October 10, I can participate in a documnetation sprint day
22:13:42 <cait> #info patches should be written against master, can backport when needed
22:13:45 <tajoli> In fact is more easy to write patch for 17.05 for me and after for master
22:13:52 <cait> #info focus should be to fix the most recent version
22:13:59 <cait> thx irma
22:14:16 <cait> hm should we have it next week? 5th maybe?
22:14:51 <rangi> they are incredibly close, there should be no need for different patches, if it applies on master it will apply on 17.05
22:14:58 <rangi> so patch master
22:15:06 <irma> the 5th is fine for me
22:15:09 <BobB> 5th is ok and 6th too (time zone allowance)
22:16:09 <tajoli> But to do a useful work for my user I need to translate 17.05, so I can patch to master only if I sure that will backported
22:16:10 <cait> #link https://koha-community.org/manual/17.11/html/ preview of 17.11 manual
22:17:06 <cait> if it makes sense and it applies it can be backported
22:17:16 <cait> maybe note in your commit message
22:17:27 <cait> the versions it applies to
22:17:49 <tajoli> The patches are not text
22:18:07 <cait> ?
22:18:26 <tajoli> there 130 images not migrated ftom DocBoot to new format
22:18:50 <cait> do you have a link of a page?
22:19:31 <cait> please file a bug report with examples
22:20:04 <BobB> cait when you say pls file a bug report ...
22:20:22 <cait> there is koha documentation i think
22:20:27 <BobB> do you mean in bugzilla, or is there a separate one for docs?
22:20:30 <rangi> in bugzilla
22:20:40 <BobB> ok
22:20:51 <rangi> in the documentation component
22:20:54 <cait> #info bugs about the manual/documentaiton should always be filed on bugzilla
22:21:09 <BobB> cool
22:21:11 <cait> i have another quick info to be discussed at the next general meeting
22:21:24 <cait> #link https://wiki.koha-community.org/wiki/Alternatives_for_help_files
22:21:47 <cait> Nicole used to update the help files form the written manual, which means it's a copy but without the images mostl
22:21:48 <cait> y
22:22:57 <irma> when training this week I found some "Help" pages were missing
22:23:05 <cait> yep
22:23:09 <cait> for example patron clubs
22:23:18 <BobB> but more basic ones too
22:23:18 <cait> we need to dicsuss how to handle them in the future
22:23:19 <irma> yep
22:23:22 <irma> I made a list
22:23:47 <cait> irma: maybe put it on the wiki page?
22:24:01 <BobB> good plan
22:24:08 <tajoli> I can fill a bug about this problem
22:24:09 <cait> the next thing I hope someone will have time to take a look at is search
22:24:19 <cait> I noticed that with EDI and EDIFACT you don't find the related chapters
22:24:21 <tajoli> The correct: http://manual.koha-community.org/16.05/en/patroninformation.html#patcheckout
22:24:34 <cait> it might be a problem with the sphinx version used, but I haven't been able to figure it out
22:24:39 <tajoli> The error: https://koha-community.org/manual/17.05/html/04_patrons.html#patron-information
22:24:53 <rangi> its probably mostly a problem with the manual being too big
22:25:02 <tajoli> See ‘My checkouts’My checkouts
22:25:07 <rangi> but ill look into it
22:25:16 <tajoli> The exact string
22:25:43 <cait> fix it on master please
22:25:46 <rangi> we need to add removing cruft as tasks too, and rewriting, theres a lots that way too verbose and make the manual big
22:25:51 <tajoli> There is a missing image with label "My checkouts"
22:26:10 <cait> and put the examples in a bug report :)
22:26:23 <cait> and one last thing someone could hlep with is some styling
22:26:36 <cait> for example i think it would work a bit better for us if the navigation on the left side was a bit wider
22:26:55 <cait> to make the manual a bit more readable, we could also use more 'Koha colors'
22:27:09 <irma> agree
22:27:16 <BobB> early days, but I have found searching for the right section is harder than in the old format
22:27:34 <rangi> the old format had no search
22:27:37 <BobB> I'll make that statement more concrete next week
22:27:42 <rangi> it was done by google
22:27:43 <irma> Also the number to each section has gone
22:27:57 <rangi> that can happen in the same way
22:28:00 <BobB> <ctl>f worked a treat :)
22:28:09 <rangi> but it'd be nicer to not rely on proprietary stuff
22:28:18 <cait> irma: which number?
22:28:26 <irma> 1.10. Logs
22:28:39 <irma> 1.10.2.6. IssueLog
22:28:43 <cait> hm true, I didn't notice that yet
22:28:56 <cait> I think in some cases splitting the chapters a bit more could be helfpul too
22:29:04 <rangi> yep
22:29:07 <irma> 4. Catalog Administration
22:29:08 <irma> 4.1. MARC Bibliographic Frameworks
22:29:21 <cait> got it
22:29:30 <cait> not sure if that could be generated automatically
22:29:37 <cait> numbers would keep changing quite a bit atm i guess
22:29:47 <rangi> on the upside, we've had more people contribute this year, than the entire rest of the history of the manual
22:29:56 <BobB> yes, for a while at least, as stuff is re-written
22:30:19 <cait> yep
22:30:43 <rangi> there are also a bazillion plugins for sphinx, i bet one does numbering if you tell it to in the config
22:30:48 <cait> #info more people contributing to the manual than ever before
22:31:02 <cait> #info Would be nice to get someone to help with styling
22:31:20 <cait> #action rangi to investigate search options/issues
22:31:34 <cait> oh and the documentation sprint
22:31:37 <cait> sorry, it's a little late
22:31:42 <cait> can i log that for 5th all day?
22:31:51 <cait> i will take care to fill up the to do list a bit before
22:31:53 <irma> yes cait
22:32:34 <irma> hi georgewilliams
22:32:45 <georgewilliams> hi irma
22:33:18 <cait> #action cait to announce Documentation Sprint Day for 5 October
22:33:37 <cait> moving on
22:33:43 <cait> #topic Getting more people involved
22:34:09 <cait> we still got lots to do and needs more hands
22:34:12 <georgewilliams> #info George Williams, Northeast Kansas Library System - sorry i'm late - got held up in another meeting
22:34:25 <cait> georgewilliams: thx for coming :)
22:35:14 <cait> no ideas?
22:35:44 <cait> #info please get in touch with documentation team if you want to help in any way
22:36:09 <cait> i think maybe the sprint will help a little, please don't hesitate to push people willing to help in our direction :)
22:36:18 <cait> should we finish?
22:36:48 <cait> #topic Set time of next meeting
22:37:20 <cait> would october 19 work ?
22:37:47 <georgewilliams> oct 19 looks good to me
22:38:36 <cait> we can do it at the same time if that works for people
22:38:43 <BobB> oct 19 looks ok for me
22:38:44 <cait> or we could try to push it, but then i will need a little help
22:39:13 <BobB> this is a good time here, so its a bad time for someone else :)
22:39:32 <cait> for me heh
22:39:35 <cait> but it's fine
22:39:41 <BobB> europe then
22:39:48 <cait> let's keep it at this time until we figure out something better
22:39:53 <BobB> its late there eh?
22:40:04 <tajoli> It is midnight
22:40:04 <cait> woudl one hour earlier work?
22:40:08 <cait> with timezones changing?
22:40:20 <cait> daylight savings i mean
22:40:29 <BobB> oh yeah, daylight time starts next week
22:41:24 <cait> 21 utc that would be then?
22:41:29 <tajoli> In fact 19 oct doesn't work for me at any hour so it is not important
22:41:52 <cait> #info next meeting will be on 19 october 21 UTC
22:42:05 <cait> thx all for being here (late or not :) )
22:42:14 <cait> #endmeeting