21:02:25 <cait> #startmeeting Documentation IRC Meeting 31 August
21:02:25 <huginn> Meeting started Thu Aug 31 21:02:25 2017 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:25 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:25 <huginn> The meeting name has been set to 'documentation_irc_meeting_31_august'
21:02:26 * BobB needs coffee
21:02:30 <cait> #topic Introductions
21:02:31 <wahanui> #info wahanui, a bot that has become sentient
21:02:31 <Freddy_Enrique> 16:00 p.m here
21:02:44 <cait> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_31_August Today's agenda
21:02:45 <bgkriegel> #info Bernardo Gonzalez Kriegel, Argentina
21:02:50 <BobB> #info Bob Birchall, Calyx , Australia
21:02:51 <LeeJ> #info Lee Jamison, Marywood University
21:02:57 <cait> #info Katrin Fischer, BSZ, Germany
21:03:02 <atheia> #info Alex Sassmannshausen, Brussels
21:03:03 <georgewilliams> #info George Williams, Northeast Kansas Library System
21:03:04 <clintD> #info Clint Deckard-Anact NZ
21:03:08 <jzairo> #info
21:03:19 <kellym> #info Kelly McElligott Bywater Solutions
21:03:24 <jzairo> #info Jessica Zairo - Tampa Florida  ByWater Solutions
21:03:25 <kholt> #info Karen Holt, ByWater Solutions
21:03:30 <Freddy_Enrique> #info Freddy Pelayo, Ensabap, Peru
21:03:37 <irma> #info Irma CALYX Australia
21:04:00 <cait> wow :)
21:04:04 <LeeJ> cait++
21:04:16 <cait> glad to see you all here to talk about documentation
21:04:19 <cait> moving on to our first topic
21:04:39 <cait> #topic How does it work?
21:04:55 <francharb> #info Francois Charbonnier, inLibro, Canada
21:05:16 <cait> some of you might be aware that we switched the tools used to write and generate the manual
21:05:42 <francharb> yes
21:05:44 <cait> up to 17.05 DocBook was used
21:05:53 <Joubu> #info Jonathan Druart
21:05:54 <cait> and the manual was one big XML file that was a challenge to edit
21:06:06 <cait> you'd need specific tools able to handle the file
21:06:35 <cait> so for 17.11 rangi has converted the manual to use reStructuredText and Sphinx for generating it
21:06:49 <cait> the new syntax is easier to edit
21:06:59 <cait> he has also split up the manual into several files
21:07:08 <bag> #info Brendan Gallagher ByWater
21:07:35 <cait> #info up to 17.05 the manual was using DocBook, now using reStructuredText and Sphinx
21:07:49 <Joubu> and the display is better :)
21:07:52 <cait> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual Information how to edit the manual
21:08:06 <cait> so now that the technical bits have been improved
21:08:17 <cait> we need to start working out how to move forward with how to keep it up to date
21:08:32 <cait> but as this is still the 'how does it work topic' - let's talk about this later
21:08:46 <cait> if you go to the wiki, you will see that we have tried to describe ways on how to edit the manual
21:08:53 <barton> #info Barton Chittenden, bws.
21:08:56 <cait> the easiest way is using gitlab, as it doesn't require you to install anything
21:09:25 <TGoat> #info TGoat
21:09:26 <wahanui> #info TGoat is going to work on fundraising
21:09:26 <cait> you can do it all in the browser, make changes to a file and create a 'merge request' that the documentation team will review and then merge into the manual
21:09:35 <LeeJ> and I took the liberty of creating a quick YouTube video to demonstrate how to make changes and commit them to be merged!
21:09:48 <cait> thx!
21:10:09 <LeeJ> #link https://www.youtube.com/watch?v=tiwH7-wO2Gs video tutorial how to use GitLab
21:10:10 <cait> #info LeeJ created a YouTube video to make the process easier to understand
21:10:13 <atheia> I can see it is linked in to the Getting_Involved page. That's cool :-)
21:10:24 <Freddy_Enrique> LeeJ++
21:10:29 <LeeJ> :)
21:10:42 <cait> nicely jzairo has created a new merge request just before the meeting, so I can show you ;)
21:10:48 <cait> #link https://gitlab.com/koha-community-devs-users/kohadocs/merge_requests Merge requests
21:10:53 <LeeJ> jzairo++
21:11:12 <cait> if one wants to, you can of course also use git locally and submit changes from there, there is also some instructions for that
21:11:23 <cait> and LeeJ has started work to add the tools to the kohadevbox
21:11:40 <cait> #info LeeJ has started to add the kohadoc tools to kohadevbox
21:12:03 <LeeJ> yes! with tcohen's help we have the ability to enable kohadocs as well as sync the kohadocs repo from the user.yml file
21:12:45 <cait> a great plus for Sphinx is that it#s super easy to generate the manual in different formats
21:12:58 <cait> html for our websites, but also epub
21:13:00 <cait> it's just one command
21:13:05 <LeeJ> with that being said, creating a merge request is yet untested via command line as I have had a hard time figuring out a way to connect the keys GitLab requires to do it
21:13:18 <cait> #link https://gitlab.com/koha-community-devs-users/kohadocs Instructions on how to create the manual locally
21:13:41 <LeeJ> so if anyone would like to help me figure out a way we'd be grateful :)
21:13:57 <cait> ok, any questions about the technical stuff? I will try to answer best I can :)
21:14:07 <francharb> yes
21:14:20 <Joubu> how do we translate it? :)
21:14:28 <cait> you are jumping topics heh
21:14:31 <francharb> is there a way to generate the manual for 16.05 with sphinx
21:14:33 <francharb> ?
21:14:57 <cait> both good questions
21:15:06 <cait> I think we will talk about translating a little later if that's ok?
21:15:16 <Joubu> yep
21:15:25 <cait> francharb: I think it would technically be possible, but I am not sure if it makes sense
21:15:38 <cait> with the conversion the links in the help files in Koha have to be changed
21:15:55 <cait> and also a lot of work has been done to fix some other problems with the conversion like fixing the links inside the manual between chapters
21:16:04 <francharb> it's because the translation would be easier from the splitted po files that comes with the new documentation process
21:16:09 <francharb> ok
21:16:12 <francharb> got it
21:16:38 <cait> Joubu++ for doing those 2 things for u
21:16:39 <cait> s
21:17:05 <Joubu> scripting++ :)
21:17:12 <francharb> @cait, @Joubu issues fixed manually?
21:17:13 <huginn> francharb: I'll give you the answer just as soon as RDA is ready
21:17:38 <Joubu> francharb: bug 18817
21:17:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18817 minor, P5 - low, ---, jonathan.druart, Pushed to Master , Update links in the help files for the new 17.11 manual
21:17:49 <Joubu> for the links from the Koha codebase
21:18:26 <Joubu> and this is the change for the manual: https://gitlab.com/koha-community-devs-users/kohadocs/merge_requests/34
21:19:08 <francharb> ok
21:19:15 <francharb> thanks
21:19:22 <cait> if it's ok i will move on
21:19:27 <cait> we will get to the translation bits sooner
21:19:36 <cait> #topic What's been done so far
21:19:49 <cait> #info We set up instructions and documentation on how to edit the manual
21:20:07 <cait> #info Alex Buckley added new chapters for the installation process and onboarding tool
21:20:16 <LeeJ> yay!
21:20:27 <Freddy_Enrique> heh :)
21:20:32 <cait> #info Lee J has updated and added missing system preference up to the current state of things
21:21:03 <cait> #info Joubu has fixed the inter-manual links and 17.11 will link to the new manual from the help files
21:21:18 <cait> #info Jessica Zairo has added information about the Article Request feature
21:21:27 <cait> did I forget something?
21:21:35 <LeeJ> uhhh...not that I can think of
21:21:40 <jzairo> me either
21:21:47 <cait> so we have started, but a lot of work remains :)
21:21:56 <wizzyrea> hi
21:21:56 <wahanui> hello, wizzyrea
21:22:10 <cait> since Nicole started her new job the manual hasn't been regularly updated and we need to do a bit of catch up there
21:22:34 <cait> #link https://annuel2.framapad.org/p/KohaManualTodo to-do list for manual work
21:22:39 <BobB> yeah, from time to time we come across the gaps
21:23:04 <cait> I have started a 'framapad' that works like an etherpad, so everyone can just go in and add something
21:23:27 <cait> #action all if you notice something is missing from the manual or needs to be corrected, please add a note to the to-do list
21:23:58 <cait> I have listed some of the bigger tasks at the top, but there is also a heading for every chapter
21:24:25 <cait> for example you could also help by taking the release notes and checking them against the manual, so we get a list of things to add
21:24:54 <cait> you can see that jzairo has added a note 'added JZ' to MarcItemFieldsToOrder (description needed)
21:25:09 <cait> that's the one in the merge request I showed earlier
21:25:14 <cait> jzairo++
21:25:30 <LeeJ> I'd also like to point out that from what I've looked over, the cronjobs section is a bit...haphazard :)
21:25:40 <cait> oh yes
21:25:45 <LeeJ> heh
21:26:01 <cait> #info Katrin has removed the SOPAC2 related chapters
21:26:11 <wizzyrea> cait++
21:26:19 <cait> #link https://koha-community.org/manual/17.11/html/ Sneak peak for the 17.11 manual created with Sphinx
21:26:36 <cait> peek...
21:26:39 <cait> ?
21:26:50 <wizzyrea> peek :)
21:27:00 <wizzyrea> (but it's ok)
21:27:13 <cait> at the moment that's generated manually by rangi - so it will not be updated immediately with a merge, but you will be able to see your changes there
21:27:22 <cait> and also good for checking what's still missing of course
21:27:55 <LeeJ> perhaps it might be helpful if whoever adds a note to the to-do list to include a bug number next to their entry if it would be helpful in documenting the item to be added
21:28:00 <francharb> is it planned to document how to generate the manual bu yourself?
21:28:02 <cait> it won't be linked to for now - as we are still working on things and 17.11 has not been released yet
21:28:18 <cait> francharb: we already have, take alook at the gitlab start page for the kohadocs I linked earlier
21:28:35 <cait> it's super easy, clone the kohadocs repo, install some packages, run vrey few commands
21:28:53 <francharb> perfect!
21:28:53 <wahanui> perfect is the enemy of good
21:29:32 <cait> kellym++ I just saw another merge request in my inbox :D
21:29:38 <cait> ok, now comes the hard part
21:29:50 <kellym> I am working with Jzairo on learning the process!
21:29:56 <cait> #topic Next steps
21:30:04 <cait> the manual is huuuuuuuge
21:30:26 <BobB> and getting huger :)
21:30:36 <cait> we think keeping it current can't be done by a single person - we need a team of people doing this
21:30:57 <LeeJ> ^exactly
21:31:04 <cait> so we worked to make it as easy as we can and we can help everyone who wants to give it a try
21:31:25 <Brooke> it's been a bear for a few years now
21:31:34 <barton> could we split it apart?
21:31:44 <cait> but rangi and me can't write it all :) even with the help we already got, the more the better it will be
21:31:55 <LeeJ> and I've been helping when I can :D
21:32:17 <cait> barton: if someone wanted to take on a chapter or so - just note it on the todo list
21:32:50 <francharb> @cait, to me the problem is that sometimes I'm not even sure how new features work
21:32:51 <huginn> francharb: I'll give you the answer just as soon as RDA is ready
21:33:14 <cait> #info manual writing is not a single person job - needs a team of people
21:33:21 <barton> ouch huginn, too soon.
21:33:26 <atheia> Part of this could be solved by making it a requirement of the QA process to have a draft chapter for the manual for new features perhaps?
21:33:31 <atheia> (was that already decided upon?)
21:33:36 <jzairo> teamwork!
21:33:39 <cait> not yet
21:33:42 <francharb> can we ask the sign-offer to do a bit of wrap up about what they tested and how the feature works?
21:33:52 <LeeJ> I second atheia's suggestion
21:33:57 <francharb> me too
21:34:01 <atheia> Well — personally I think it should be the dev's responsibility…
21:34:02 <cait> francharb: we could but actually the developers should provide that with their commit messages
21:34:04 <cait> and test plans
21:34:05 <wahanui> test plans are awesome.  at least it gives context for where to go even if minimal.
21:34:08 <LeeJ> that's actually a great idea
21:34:12 <cait> if anything is unclear, it's always ok to note on the bug and ask
21:34:26 <francharb> +1
21:34:40 <cait> also sign-offers can take notes of course, where something additional had to be set up
21:34:58 <atheia> agreed.
21:35:07 <cait> i try that when I run into sometihng, but not sure we can make it a general rule, but it#s a rule that we should have test plans and descriptive commit messages
21:35:16 <cait> Joubu just sent an emai ltoday to remind devs :)
21:35:17 <georgewilliams> I think asking sign-offers to do more is problematic considering how hard it can be to get people just to sign off on things
21:35:29 <cait> georgewilliams: yeah, I am a ibt worried about that too
21:35:34 <francharb> true
21:35:37 <atheia> +1
21:36:08 <TGoat> that's what so important about fundraising georgewilliams .. but that's a whole different topic
21:36:12 <cait> but yeah, if you don't understand, please ask and make notes
21:36:15 <cait> even documentation bug reports
21:36:22 <atheia> Whereas if an organization / individual has a stake in adding a feature, they would also have the incentive to document it (even if they don't enjoy that process)
21:36:38 <BobB> cait the 'todo' list is where everything is controlled?
21:37:00 <BobB> so if working on something, we should grab it there?
21:37:05 <cait> #action all - a 'Manual' keyword has been added to Bugzilla - please mark bugs that you think needs something added or changed in the manual (ideally with a comment)
21:37:22 <BobB> it would be sad to document something and then find someone else beat you to it
21:37:27 <cait> BobB: for now I think yes - I wanted to keep it a bit lower barrier than bugzilla even
21:37:31 <barton> I think that documentation should be a QA requirement -- not necessarily that the dev needs to do it themselves, but they should be responsible for making sure that it gets done.
21:37:32 <cait> if that doesn't work we can of course do something else
21:37:41 <Joubu> I think the developper must provide a description of what the new ft/enh is supposed to do. But it would make sense to have dedicated persons to "translate" developper language into manual sentences :)
21:37:56 <BobB> barton +1
21:38:04 <georgewilliams> Joubu+
21:38:14 <LeeJ> barton++ Joubu++
21:38:18 <atheia> Barton, I like your idea.
21:38:29 <irma> Joubu+
21:38:37 <Joubu> I will be terrible at describing correctly what my features do :)
21:38:38 <Freddy_Enrique> Joubu++
21:38:42 <cait> #action all - if you start working on some addition to the manual, please add a note on the to-do list (like 'cait working on this')
21:39:46 <rangi> here now
21:40:03 <cait> there is also a module for documentation on Bugzilla
21:40:13 <atheia> Whilst I understand your perspective Joubu [some people just aren't great communicators — or there might be language issues for devs], at the same time I feel devs should be expected to take responsibility for the code they add by documenting it.
21:40:14 <cait> I will try to add saved searches for both and the links to the wiki and the to-do list
21:40:28 <LeeJ> hi rangi
21:40:33 <indradg> #info Indranil Das Gupta, L2C2 Technologies, India
21:40:40 <atheia> That's why I like Barton's harder requirement of the dev/organization having responsibility to get someone to write the documentation.
21:40:46 <cait> #action cait to add saved searches and links to them for the Manual keyword and Documentation module from Bugzilla
21:40:51 <atheia> That could be a dedicated specialist or anyone else…
21:42:17 <cait> I am not sure we have the people for that
21:42:24 <Joubu> The manual needs to keep a certain homogeneity/consistency, if 30 different guys are going to describe features in 30 different ways... it will be a mess
21:42:25 <cait> but devs should try to document as best as they can
21:42:34 <rangi> Joubu: thats what editors do
21:42:39 <rangi> im happy to edit
21:42:43 <georgewilliams> rangi+
21:42:53 <rangi> but i dont have time to read everyones features to figure out what they do
21:42:58 <Joubu> I would prefer to work with someone, incrementaly
21:43:07 <rangi> if they write it as best they can, i can edit that
21:43:17 <rangi> (new features this is)
21:43:18 <bag> also that is too much work
21:43:31 <BobB> the workflow is that the documentor submits a merge request? then an editor can finesse it, is that right?
21:43:31 <Joubu> rangi: yes, it's more or less what we said, devs have to describe the feature in the commit message + test plan already
21:43:44 <rangi> Joubu: yeah, but they don't ;)
21:43:49 <rangi> BobB: yes
21:43:50 <barton> bag: supporting undocumented features is a lot of work too.
21:43:55 <cait> yep or can help the committer improve it
21:44:20 <Joubu> maybe they don't, but they should
21:44:24 <cait> yeah i think if we have a good manual, we are also less likely to break features noone knew about (hopefully) :)
21:44:31 <Joubu> (and have to)
21:44:31 <bag> I mean for an editor barton ;)
21:44:54 <rangi> bag: we have a coms team at work i can lean on for help
21:44:55 <atheia> Joubu — just to clarify, do you also agree that having this description, whether as a draft chapter or extensive commit messages, should be a QA requirement for new features?
21:45:06 <atheia> ah k,
21:45:11 <cait> atheia:  itis
21:45:14 <rangi> what they cant do is figure out from a 10 line commit message what the feature does
21:45:15 <atheia> sorry saw your later messag later :-)
21:45:30 <rangi> but they can certainly tidy up peoples english
21:45:35 <cait> i mean we already have rules about test plans and commit messages
21:46:36 <bag> sweet - up - let’s get all the commits first - and then we can figure out the quality aspect - and it looks like rangi’s got ideas for that
21:46:36 <rangi> we must all have some specs/docs from the people who want the feature right? even making them available would help
21:46:47 <cait> yep
21:47:07 <cait> and if a library writes something and is not sure about how to get it in the manual
21:47:08 <rangi> jzairo++
21:47:11 <cait> I am willing to format it
21:47:16 <LeeJ> would it be worth entertaining the idea of a documentation/manual notes textarea in the bug header? For example, say under the field "Text to go in the release notes"?
21:47:28 <LeeJ> in terms of bugs for new features
21:47:33 <rangi> i think its easier to find people to 'fix' stuff, than to write stuff :)
21:47:36 <bag> hmm not a bad idea
21:47:43 <Brooke> LeeJ +1
21:47:46 <wizzyrea> vaguely hard with screen shots.
21:47:53 <barton> LeeJ +1
21:47:59 <cait> I was going to suggest to revive the koha-docs mailing list for things like that
21:48:11 <cait> LeeJ: I am not sure, but the fields might be limited in size
21:48:14 <bag> good point wizzyrea - can we hack bugzilla to meet that need?
21:48:15 <indradg> cait +1
21:48:37 <rangi> i like the ml idea
21:48:43 <barton> I'd subscribe to koha-docs in a heartbeat.
21:48:44 <rangi> because people dont need a login for that
21:48:50 <cait> sec I wil get a link
21:48:55 <cait> hm they have to sign up tho
21:49:02 <rangi> yeah but thats it
21:49:07 <rangi> then the mail just arrives
21:49:08 <bag> is a login a big barrier - (I don’t know)
21:49:10 <Joubu> Why not use the regular one with a [koha-docs] tag? That can motivate people to be involved if they see stuffs going on
21:49:15 <LeeJ> wizzyrea maybe have some sort of annotation mark in the potential documentation textarea corresponding to a bug attachment of screenshots?
21:49:16 <cait> #link https://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-docs koha-docs mailing list - send us things for the manual!
21:49:46 <cait> LeeJ: the area is very small, maybe easier to just write a comment and set the keyword
21:49:52 <wizzyrea> my honest opinion is that bugzilla isn't the place for that
21:49:53 <cait> or sent an email to the koha-docs
21:49:54 <rangi> hell if people just put a letter in an envelope and mailed it to me
21:49:55 <wizzyrea> it's not the best tool.
21:50:01 <rangi> it would be better than now
21:50:08 <cait> +1
21:50:12 <rangi> but i think the ml is good, because lots of people can see it
21:50:12 <LeeJ> just throwing out ideas :)
21:50:25 <rangi> we can certainly use the release notes from bugzilla too
21:50:28 <cait> I think we need to built this up - we will happily take any submissions and help people who want to help
21:50:33 <rangi> teo
21:50:37 <rangi> yep even
21:50:55 <rangi> ill take it by carrier pigeon if need be :)
21:51:22 <cait> [off] https://wiki.koha-community.org/wiki/Chris_Cormack ? :)
21:51:37 <indradg> how about filing a linked documentation bug to every new feature / enhancement? The QA tool can check for existence linked doc bug for enh etc? The doc team / volunteers can track the open doc bugs and expand on the dev notes with screenshots and such?
21:51:41 <LeeJ> [off] hahahahahaha
21:51:56 <rangi> yes thats the documentation bird
21:52:30 <rangi> indradg: that would be good, ideally, but also just random pastes, etc are fine too, what we are lacking is content, not process :)
21:52:51 <bag> yes content is the key
21:52:54 <cait> it's also a little easier for now to just add the keyword to the bug
21:53:08 <cait> less work for the person going through those atm
21:53:21 <rangi> if suddenly we get so much, that we need to implement stricter process, we can deal with that, i will love that to happen, but for now, however people want to submit changes is great
21:53:24 <cait> but we might get to a more refined process once the ball is rolling
21:53:33 <rangi> yes, what she said
21:53:36 <rangi> :)
21:53:50 <bag> what is the current content rate - 2~3 a week?
21:53:59 <rangi> a month
21:54:10 <bag> wow
21:54:24 <cait> yep, we got room to improve ;)
21:54:33 <rangi> without LeeJ, jzairo, cait, and kelly .. its almost zero
21:54:40 <Freddy_Enrique> holy.....
21:54:41 <bag> That’s probably an important data point to be included as an #note or whateever in the meeting notes
21:54:42 <cait> to give some examples
21:54:47 <cait> we are looking for people to write:
21:54:50 <cait> - patron clubs
21:55:05 <cait> - advanced cataloguing editor (rancor)
21:55:25 <jzairo> I can get patrons clubs in there
21:55:26 <cait> - housebound
21:55:33 <jzairo> and an update for rancor
21:55:39 <cait> :)
21:55:44 <LeeJ> jzairo++
21:55:46 <cait> just to give examples for big stuff that is missing
21:55:49 <cait> and being missed!
21:56:05 <bag> awesome jzairo - we need to recruit others to help submit ;)
21:56:19 <bag> probably a good thing to bring to the kohaus meetings jzairo
21:56:20 <cait> Bywater has some great tutorials (love them) - a lot of that would make good manual content
21:56:22 <atheia> Ooh housebound has no documentation?
21:56:23 <LeeJ> cait: maybe a good starting point would be just to compile a list in the to-do of just the titles of missing entries?
21:56:38 <atheia> I should be able to get a draft for that…
21:56:40 <cait> atheia: developer missed to write it up ;)
21:56:41 <Joubu> vi misc/cronjobs/CONFIGURE.gmail
21:56:47 <atheia> indeed *blush*
21:56:47 <Joubu> oops, sorry
21:56:49 <TGoat> georgewilliams and CrispyBran are here jzairo
21:56:58 <bag> and TGoat ^^
21:57:00 <rangi> heh, multitasking Joubu
21:57:01 <Joubu> (wt is that??)
21:57:09 <cait> LeeJ: yep - I think release notes woudl be good starting point, check enh listed there
21:57:26 <cait> #action atheia to write something about housebound
21:57:36 <bag> atheia++   you’re all good dood
21:57:37 <rangi> with the tool alexbuckley_ is working on, it would be great to link the bits straight to the manual too
21:57:41 <cait> jzairo: do you really want to take on both? or start with patron clubs? :)
21:57:42 <CrispyBran> ???
21:57:49 <rangi> (the list of heres what changed in your upgrade too)
21:57:52 <rangi> tool even
21:58:00 <jzairo> I have been working with kidclamp on rancor
21:58:13 <rangi> cool
21:58:19 <jzairo> and khall talked  to me about patron clubs
21:58:31 <jzairo> so I can try and tackle both of those
21:58:48 <cait> #action jzairo to take on patron clubs and advanced cataloguing
21:59:39 <TGoat> jzairo++
21:59:46 <cait> cool :)
21:59:53 <cait> i am sure there will be more on the list to pick soon!
22:00:03 <cait> i'd like to add another topic to talk about translation, if that's ok?
22:00:14 <BobB> ok
22:00:15 <cait> #topic Translation
22:00:19 <Joubu> yes! :)
22:00:25 <cait> sorry you had to wait so long Joubu :)
22:00:28 <barton> #link https://bugs.koha-community.org/bugzilla3/buglist.cgi?cmdtype=runnamed&list_id=211550&namedcmd=Open%20Documentation
22:00:33 <TGoat> cheer up Joubu :D
22:00:55 <cait> barton: coudl you add in  Keyword = Manual? that would be awesome
22:01:03 <cait> hm not sure you can do or
22:01:04 <Joubu> barton: does not work
22:01:13 <cait> so translation
22:01:13 <wahanui> so translation is working now too?
22:01:24 <cait> with DocBook the translation was done using a po file
22:01:24 <bgkriegel> Hi, I was working on this a bit
22:01:31 <barton> Joubu: I think I need to make it public.
22:01:40 <cait> Sonia noted on the list that she would really like to add translated screenshots too
22:02:09 <bgkriegel> to translate you need to generate po files, and then translate them
22:02:30 <barton> cait: Keyword = Manual => Zarro Boogs found.
22:02:39 <bgkriegel> I need to install a tool, sphinx-intl
22:02:44 <cait> barton: hm can't be - I will try and take a look later
22:03:26 <bgkriegel> for example: make gettext; sphinx-intl update --language=fr; translate po in source/locale/fr/LC_MESSAGES/; make -e SPHINXOPTS="-D language='fr'" html
22:04:07 <bgkriegel> i used old translations, with a bit of scripting to fix things
22:04:32 <bgkriegel> here you can see the result: http://translate.koha-community.org/manual/16.11/
22:04:35 <francharb> which version are you working on @bgkriegel?
22:04:42 <bgkriegel> those are old languages
22:04:48 <francharb> ok
22:04:51 <francharb> 16.11
22:04:56 <bgkriegel> francharb: not the last one
22:05:04 <bgkriegel> but it's doable
22:05:13 <francharb> I think Sonia was also aksing how to get the manual files for 17.05
22:05:29 <cait> with all the changes coming in, i am not sure when it will make sense to start translating
22:05:34 <bgkriegel> each language adds 2~3 Mb of space, perhaps we could add the files to the repo
22:05:44 <bgkriegel> po files
22:05:45 <wahanui> po files are outdated
22:05:45 <cait> do the translations carry over if no changes?
22:05:58 <francharb> It should be
22:06:08 <atheia> I'm afraid I have to clock off — sorry for leaving mid-meeting. Au revoir!
22:06:11 <francharb> the same way translation works for the interface
22:06:22 <bgkriegel> yeap
22:06:35 <francharb> we don't stop translation for the interface because of new features...
22:07:13 <francharb> I guess it's doable having new material for the manuel and translating at the same time
22:07:14 <LeeJ> I too have to head out..I'm available by email if anyone needs to reach me :)
22:07:27 <bgkriegel> I added those po files on translation server: http://translate.koha-community.org/projects/man1611/
22:07:55 <cait> bgkriegel++
22:07:56 <francharb> thanks @<bgkriegel>
22:08:11 <cait> so what's the next step? i think the first Sphinx manual we have is 17.05 - right rangi?
22:08:21 <francharb> Question : how often should the manual po files be updated ?
22:08:21 <bgkriegel> but I need to do the same job for 17.05
22:08:22 <tajoli> #info Zeno Tajoli, CINECA, Italy
22:08:37 <bgkriegel> 16.11 use sphinx
22:09:25 <cait> ah, i htink we just didn't link it then
22:10:12 <cait> #info bgkriegel is working on creating po files for the new manuals
22:10:26 <cait> about the screenshots - I told Sonia it should be possible
22:10:27 <bgkriegel> The result is not good for arabic, perhaps I need to research a bit more how to do it for RTL languages
22:10:59 <cait> maybe sending the fiels with the same file names?
22:11:18 <cait> #info still some issues with Arabic (RTL languages)
22:11:48 <Joubu> so basically, what can we say to Sonia?
22:12:11 <Joubu> When will she be able to translate the manual in French?
22:12:14 <francharb> Is it planned to have this page http://translate.koha-community.org/manual/ generated automaticly every day, every week?
22:12:26 <Joubu> bgkriegel: (Hi!!) What need to be done to be ready? Do you need help?
22:12:29 <francharb> So we can work on the manual translation and see the results ?
22:12:30 <bgkriegel> yeap, will do it
22:12:59 <cait> i didn't know about that page!
22:13:06 <bgkriegel> ( Hi Joubu:)! )
22:13:09 <francharb> For now, we can't control the the translation easily
22:13:15 <cait> #link http://translate.koha-community.org/manual/ translated manuals overview page
22:13:24 <francharb> @cait, I discovered it recently as well
22:13:25 <huginn> francharb: I'll give you the answer just as soon as RDA is ready
22:13:39 <francharb> I love you huginn
22:14:26 <cait> ok, moving on? :)
22:15:03 <cait> #topic Getting more people involved
22:15:09 <cait> actually we talked a bit about this
22:15:14 <tajoli> About https://koha-community.org/documentation/ ?
22:15:21 <cait> please if you run across someone who you think would want to help, tell them :)
22:15:31 <cait> or if someone has a great documentation they could share
22:15:34 <Joubu> not sure I understood, maybe I missed something, will reread
22:15:38 <tajoli> There are missing link
22:15:41 <tajoli> links
22:16:24 <cait> ok, before we close
22:16:32 <cait> any questions left open? things people want to add?
22:16:48 <tajoli> Manuals in french and italian are not linked
22:17:04 <bgkriegel> tajoli: not generated yet
22:17:25 <bgkriegel> will do later
22:17:44 <cait> #topic Set date of next meeting
22:17:54 <cait> is there interest in holding another meeting, maybe in a month?
22:18:44 <jzairo> yes cait
22:18:54 <BobB> i think we should, for sure
22:18:55 <wizzyrea> someone please let me know when the manual links on the website need to be added for italian and french
22:18:56 <georgewilliams> yes
22:19:05 <cait> september 6th?
22:19:21 <wizzyrea> october you mean?
22:19:22 <BobB> that's next week cait
22:19:31 <cait> #info Let wizzyrea know when links need to be added to manuals on k-c.org
22:19:38 <cait> just can't read a calendar
22:19:41 <wizzyrea> :)
22:19:44 <georgewilliams> do you mean october 6?
22:19:51 <cait> 29th i think
22:19:55 <cait> was what i meant :)
22:20:00 <cait> last week of the next month
22:20:32 <BobB> not Friday please - it becomes Saturday here
22:20:47 <cait> i was aiming for thursday
22:20:50 <cait> it's too late for me :)
22:20:51 <cait> 28th
22:20:54 <cait> same time?
22:21:06 <BobB> same time works for me :)
22:21:15 <georgewilliams> same time is good here
22:21:26 <clintD> 28th Sept?
22:21:28 <francharb> thanks for the meeting. hope i can make it for the next one! anydate should work for me
22:21:30 <francharb> bye
22:21:31 <jzairo> good for me
22:21:32 <cait> yes clintD
22:21:48 <tajoli> About links to italian  manuals: I think could be added as soon as possibile. 3.20, 3.22 adnd 16.05 are 100% translated
22:21:56 <cait> #agreed Next meeting will be on 28th September, 22 UTC
22:22:06 <cait> #endmeeting