13:07:58 <kidclamp> #startmeeting General IRC meeting 7 June 2017
13:07:58 <huginn> Meeting started Wed Jun  7 13:07:58 2017 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:07:58 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:07:58 <huginn> The meeting name has been set to 'general_irc_meeting_7_june_2017'
13:08:07 <kidclamp> #topic Introductions
13:08:08 <wahanui> #info wahanui, a bot that has become sentient
13:08:19 <kidclamp> #info Nick Clemens, ByWater Solutions
13:08:28 <ashimema> #info Martin Renvoize, PTFS-Europe
13:08:29 <Joubu> #info Jonathan Druart
13:08:30 <BobB> #info Bob Birchall, Calyx, Australia
13:08:31 <felicia> # info Felicia Beaudry, Equinox Open Library Initiative
13:08:34 <schnydszch> #info Eugene Espinoza Philippines
13:08:39 <cc_> #info Colin Campbell, PTFS-Europe
13:08:40 <LibraryClaire> #info Claire Gravely, Germany
13:08:52 <atheia> #info Alex Sassmannshausen, PTFS Europe
13:09:19 <tcohen> morning
13:09:52 <BobB> talljoy?
13:09:53 <wahanui> I CRUNCH DATA or kicking butt at words with friends
13:09:59 <kidclamp> #topic Announcements
13:10:09 <kidclamp> Floor is open
13:10:15 <talljoy> #info Joy Nelson ByWater Solutions
13:10:20 <cait> #info Katrin Fischer, BSZ, Germany
13:10:23 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
13:10:51 <tcohen> #info Tomas Cohen Arazi. Theke Solutions
13:11:02 <khall> #info Kyle M Hall, ByWater Solutions
13:11:06 <barton> #info Barton Chittenden, BWS
13:11:10 <NateC> #info Nate Curulla ByWater
13:11:21 * kidclamp moved too quick :-)
13:11:47 <magnuse> #info Magnus Enger, Libriotech, Norway
13:11:48 * barton wonders how many other ways there are to say 'ByWater Solutions' ;-)
13:11:52 <Joubu> #linkhttps://wiki.koha-community.org/wiki/General_IRC_meeting_7_June_2017
13:11:56 <Joubu> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_7_June_2017
13:12:31 <Joubu> ok, just a few things for me:
13:12:38 <Joubu> I have started to push small things
13:12:45 <magnuse> Joubu++
13:12:48 <benjamin> #info Benjamin Rokseth, Oslo Public Library
13:12:52 <josef_moravec_> #info Josef Moravec, Municipal Library Usti nad Orlici
13:12:55 <Joubu> as usual, read the what's on in koha-devel email, lot of things in the last one
13:13:09 <Joubu> I suggested to move it to a collaborative approach
13:13:29 <Joubu> I am really happy with the feedback/answers I got from the poll
13:13:33 <Joubu> and the kanban
13:13:46 <Joubu> kanban is https://tree.taiga.io/project/joubu-koha-rm-1711/wiki/home
13:13:52 <Joubu> let me know if you want to join us
13:14:00 <fridolin> #info Fridolin Somers, Biblibre
13:14:05 <Joubu> we are 45 so far
13:14:12 <cait> yay :)
13:14:18 <tcohen> Joubu: do you think we could add how-to.pl to kohadevbox already?
13:14:25 <Joubu> I really (*really*) would like to see more regulars involved in the "top priority" tasks
13:14:40 <Joubu> which is "welcome new contributor"
13:14:54 <Joubu> one subtask is to update the wiki pages, to get entry points
13:15:03 <kidclamp> #link  https://tree.taiga.io/project/joubu-koha-rm-1711/wiki/home 17.11 kanban board
13:15:06 <Joubu> to clearly list how people can help us
13:15:22 <Joubu> our wiki is a mess, some pages are ok but need a bit refresh
13:15:29 <fridolin> indeed
13:15:33 <kidclamp> #info regulars please help with the "welcome new contributor" task and update wiki to make it easier/more welcoming for newcomers
13:15:57 <Joubu> I think 1h of 5 people and we are done
13:16:13 <Joubu> tcohen: yes, soon, I plan to do it
13:16:20 <Joubu> tcohen: but do if you like :)
13:17:12 <Joubu> I am gonna send a kind of results of the poll to the list
13:17:32 <tcohen> Joubu++
13:17:33 <Joubu> to highlight how people are willing to help and what they are expecting for the next release
13:17:46 <Joubu> that's all for me
13:17:56 <kidclamp> #action Joubu will send his poll results out to the lists
13:18:01 <kidclamp> Joubu++
13:18:20 <cait> Joubu++
13:18:22 <kidclamp> Anyone else for announcements?
13:18:39 <Joubu> (ha, and jenkins tells master is not stable, but it's wrong :))
13:19:06 <kidclamp> okay moving ahead
13:19:07 <atheia> ehm… Bug 11897 is looking for testers — hoping to get it to QA fast in this release cycle.
13:19:07 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=11897 new feature, P5 - low, ---, alex.sassmannshausen, Needs Signoff , Stock Rotation for Koha
13:19:08 <tcohen> jenkins--
13:19:23 <ashimema> naughty jenkins
13:19:28 <kidclamp> #info looking for testers for bug 11897
13:19:33 <atheia> If you are willing to test it, but need help, contact me!
13:20:07 <kidclamp> #info contact atheia if you have any questions
13:20:09 <Joubu> Another announcement, from drojf:  "17.05 packages ETA next monday due to release delay and local holidays."
13:20:22 <kidclamp> #info 17.05 packages ETA next monday due to release delay and local holidays.
13:20:22 * oleonard is having another go at it atheia
13:20:53 <atheia> oleonard++
13:20:53 <kidclamp> #topic Update on releases
13:21:13 <thd> #info Thomas Dukleth, Agogme, New York, [still no dial tone or internet from home, waaah]
13:21:17 <kidclamp> fridolin?
13:21:18 <wahanui> rumour has it fridolin is busy at the moment, I asked him to backport the bug fix
13:21:52 <kidclamp> cait?
13:21:52 <wahanui> i heard cait was the best friend you could ever have.
13:22:06 <cait> I plan to stick to schedule
13:22:12 <cait> but following in fridolin's step now :)
13:22:29 <kidclamp> #info 16.11 on schedule but following patches from 17.05
13:22:30 <cait> I have caught up with master, so waiting for the first things he pushes now
13:22:44 <cait> well caught up to 17.05 release tag
13:22:49 <kidclamp> :-)
13:22:59 <cait> i still got 2 failing tests on jenkins that i don't know how to fix
13:23:21 <kidclamp> #info 2 tests failing on 16.11.x
13:23:24 <cait> i'd be very happy to see it 'blue' again
13:23:25 <tcohen> cait: those are jenkins problems
13:23:33 <tcohen> your branch is stable
13:23:48 <kidclamp> #info branch is stable, jenkins is having issues (poor jenkins)
13:23:53 <tcohen> yesterday we spent some time with Joubu trying to find the issue
13:23:59 <tcohen> and fix it
13:24:06 <kidclamp> mtj fridolin around?
13:24:14 <Joubu> 16.05.12 and 16.05.13 are buggy (cannot modify patron's passwd), see bug 18740
13:24:14 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18740 major, P5 - low, ---, jonathan.druart, Signed Off , [16.05.12-16.05.13] Cannot modify patron password
13:24:17 <cait> cool thx!
13:24:45 <BobB> its 1am where mtj is, but he's committed to maintaining 16.05
13:24:54 <kidclamp> #info 16.05.12 & 16.05.13 are buggy (cannot modify patron's passwd), see bug 18740
13:25:05 <kidclamp> BobB++
13:25:08 <kidclamp> mtj++
13:25:29 <kidclamp> you have something for manual cait? for 17.05 or later?
13:26:50 <fridolin> kidclamp: yes
13:26:59 <kidclamp> anything to add?
13:27:02 <fridolin> i prepare for RMaint
13:27:16 <fridolin> but git branch is not yet created : 17.05/x
13:27:19 <fridolin> .x
13:27:27 <fridolin> i'm not allowed to do it
13:27:28 <fridolin> :D
13:27:59 <kidclamp> #info frido needs a git branch for 17.05.x and is prepared to start
13:28:02 <Joubu> fridolin: will do
13:28:03 <cait> sorry here
13:28:22 <fridolin> cool
13:28:41 <fridolin> ill try to do some each day
13:28:53 <cait> fridolin++
13:29:05 <cait> manual?
13:29:06 <wahanui> hmmm... manual is at http://www.koha-community.org/documentation
13:29:15 <Joubu> fridolin: I cannot
13:29:16 <BobB> #action Joubu to prepare a 17.05 git branch for frido
13:29:21 <cait> the new manual for 17.05 has been generated and added to the website
13:29:37 <cait> there is an easy workflow for editing it with gitlab - no installation or downloads required, just web based
13:29:50 <cait> I have tested it with rangi and will write up a wiki page
13:29:59 <tcohen> cait: have you talked with bgkriegel about making a translation available?¡
13:30:03 <oleonard> cool!
13:30:07 <cait> we have a lot of documentation to catch up on as not much has happened since Nicole left
13:30:14 <cait> so i hope to get as many volunteeers to help out as possible
13:30:15 <kidclamp> #info cait and rangi working on a gitlab based update system for the manual
13:30:29 <kidclamp> #info wiki page to follow, should lower the bar
13:30:30 <cait> it would possibly be best to work from the old release notes - I will think about a way to create a list of chapters we miss
13:30:47 <cait> tcohen: i think not yet - but it's planned
13:31:06 <cait> but anyone who wants to contribute or help out, please get in contact :)
13:31:25 <cait> i think Joubu has a list from the form - maybe we can start with those and use taiga, but I really want to make it as easy as possible
13:31:35 * ashimema would love to see a coding guideline to require doc update with new feature submissions.
13:31:37 <kidclamp> #info contact them in interested in helping
13:31:42 <cait> so if a library contributes in word or something, we will look for someone to convert it
13:32:03 <cait> ashimema: i think we have that - but yep, i will try to hunt down people in this release cycle to do that :)
13:32:12 <ashimema> :)
13:32:17 <cait> and hope others will help to keep an eye on it
13:32:20 <atheia> cait++ & ashimema++
13:32:25 <Joubu> I can ask for a description before pushing enh/ft if we agree on that
13:32:28 <cait> maybe qa?
13:32:35 <atheia> (also aware I didn't write anything for housebound…! 8-/ )
13:32:36 * ashimema has been bad at QA then if there's a guideline for that.. oops :(
13:33:00 <cait> lt met quickly check the coding guidelines
13:33:01 <barton> jzairo's in a conference call, but said that she was interested in volunteering for documentation.
13:33:08 <ashimema> atheia.. I think you just vounteered to write the housebound docs patch ;)
13:33:09 <kidclamp> ashimema want to write something up for devmeeting and send to lists?
13:33:10 <tcohen> I think enhancements are filled with longer descriptions for inclusion in the release announcement, but that might not be enough  for the manual
13:33:28 <cait> hm i might have been wrong, can't spot it
13:33:31 <cait> so we shoudl have one
13:33:34 <atheia> ashimema: seems only fair.
13:33:41 <ashimema> will try to fit it in kidclamp :)
13:34:28 <kidclamp> #info ashimema proposed doc requirements for new enhancements will try to have proposal fro next dev meeting
13:34:29 <cait> kidclamp: action a coding guideline for that?
13:34:37 <cait> :)
13:35:04 <cait> once we have the workflow down and documented, we could also have a documentation day/documentation party
13:35:07 <ashimema> the bit that was holding me back on that front was it's wasn't hugely clear how to submit doc patches at the time I was trying to go through it.
13:35:19 <ashimema> cait++
13:35:24 <cait> that's all from me
13:35:30 <kidclamp> cait++
13:35:36 <cait> rangi++
13:35:36 <kidclamp> alright, anything else or move to Kohacon?
13:35:37 <thd> All programs should also be written to display their own documentation on command.
13:35:47 <oleonard> i
13:35:48 <Joubu> I do not think the dev should provide the whole doc, but at least enough info to explain the doc team to understand it easily
13:35:53 <cait> he came up with it, just have to write it up now
13:36:00 <Joubu> Is that what we are saying?
13:36:05 <cait> i think that makes sense
13:36:07 <kidclamp> yes, devs can write in dev speak with basic feature
13:36:15 <ashimema> I believe so Joubu
13:36:18 <cait> yeah, the technical descriptions are good
13:36:27 <cait> but sometimes we miss the user understandable part :)
13:36:29 <BobB> if devs start the doco, non-devs can improve it
13:36:48 <Joubu> ok perfect
13:36:53 <atheia> But it should definitely be a patch to the manual, not just in perlpod or some such, right?
13:37:06 <ashimema> so there's at least a starting point in the docs for anyone to embellish.. if you've done development write you'll have written a spec for the enhancement and that spec should go a long way towards becoming a documentation :)
13:37:29 <Joubu> my understanding was that the dev should fill the "text for the release notes" field on bugz
13:37:35 <barton> I think we also need to test documentation...
13:37:36 <Joubu> s/should/must
13:37:37 <ashimema> patch to the manual in my opinion.. partially depends... but that'll come down to the QAer reviewing it ;)
13:38:09 <cait> for the moment rangi and i iwll be able to merge
13:38:13 <kidclamp> I think as long as they can provide the text in the bug we can see about patch submission
13:38:18 <ashimema> I see 'text for release notes' as a minor summary of what the feature does.. whereas the docs are more of a 'how to use this new shiny feature'
13:38:22 <barton> ... i.e. have people follow instructions and make sure that they work, and are understandable.
13:38:23 <cait> i think no qa yet for the manual, but that would be nice once we actually have documentation written :)
13:38:34 <cait> ashimema +1
13:39:19 <kidclamp> moving us on
13:39:26 <Joubu> wait
13:39:32 * kidclamp pauses
13:39:40 <atheia> Yeah I'm with kidclamp, barton and ashimema here: a new feature should provide a text that at least describes what the feature does and how you use it, as part of the bug.
13:39:43 <Joubu> then we need the "text for release notes" + a comment with a "doc" tag for instance?
13:39:54 <atheia> Not sure whether it should be in "text for the release notes" or somewhere else.
13:39:57 <Joubu> to explain more deeply what the ft does/how it works?
13:40:12 <atheia> Yeah, Joubu, I would think so?
13:40:16 <ashimema> so for ptfs-e's patches these days we're slowly moving to more of a team inclusive model.. support + customer refined a spec, dev develops it, support turns spec + development screenshots into documentation.. dev submits the feature along with the docs..
13:40:27 <ashimema> that's a model I'd love to see taken more widely.
13:40:28 <cait> oh just one mor ething: we got 2 shiny new chapters for the web installer and the onboarding tool!
13:40:35 <Joubu> will be a mess to find it in the comment of bugz, but maybe the tag can help
13:40:41 <cait> if you want to check that out :)
13:40:52 <kidclamp> #info manual has new chapters for web installer and the onboarding tool! (shiny new chapters)
13:40:54 <atheia> Couldn't one simply add it as a non-patch attachment?
13:41:27 <kidclamp> I like that idea
13:41:30 <ashimema> I'll talk to cait and rangi about docs patches workflow
13:41:47 <cait> i think if you attached to the bug report a 'docs team' could use it
13:41:48 <kidclamp> I like this discussion but think we should send to list and work up proposal fro dev meeting
13:41:50 <cait> but we need to found one :)
13:41:53 <ashimema> personally.. I'd like to see a pull request opened on the doc gitlab and a link to it from the bugzilla bug
13:41:53 <Joubu> let's move on and vote for the guidelines next dev meeting?
13:41:56 <ashimema> yup
13:42:04 <ashimema> agreed.. lets move on.. :)
13:42:09 <cait> ashimema: kidn of how we want it to work
13:42:11 <cait> merge request tho
13:42:16 <cait> pull is github
13:42:35 <kidclamp> #action cait ashimema rangi will talk manual submissions for enhancments and prepare for dev meeting
13:42:36 <ashimema> merge/pull.. same thing ;)
13:42:41 <kidclamp> @topic KohaCon
13:42:42 <huginn> kidclamp: I'll give you the answer just as soon as RDA is ready
13:42:42 <tcohen> the manual is a lot about style and ways of telling a message
13:42:46 <kidclamp> #topic KohaCon
13:42:57 <tcohen> I think the doc managers should be the ones to talk to devs
13:43:02 <tcohen> or the other way around
13:43:09 <kidclamp> schnydszch, around?
13:43:09 <tcohen> but no need to add a new guideline
13:43:32 <schnydszch> Hi all! Eugene here from Manila, Philippines
13:43:44 <schnydszch> Yes kidclamp.
13:43:44 <wahanui> Sandwich King of the Northeast
13:44:28 <schnydszch> Just to update you all, kohacon2017 is just two weeks. The organizers are pretty excited and working double time.
13:45:09 <schnydszch> The current registration stands at 275 participants, 50+ foreign, 200+ local.
13:45:46 <kidclamp> #info Kohacon2017 is 2 weeks away - 275 participants - excitement is high :-)
13:46:06 <schnydszch> We posted a week before regarding the situation in the Southern part of the Philippines which is 2000 km away from Makati City
13:47:07 <kidclamp> #info see lists for update about situation in souther phillipines
13:47:08 <cait> is it still possible to register?
13:47:14 <cait> I know of someone in Manila who woud like to attend
13:47:19 <schnydszch> The organizers have seek security clearance from local police. The venue has its own security so we assure safety of the participants during the event
13:47:37 <kidclamp> #info he organizers have seek security clearance from local police. The venue has its own security so we assure safety of the participants during the event
13:47:45 <schnydszch> to those who want to register, they can email us at kohacon17@gmail.com or aslplibrarians@gmail.com
13:48:06 <schnydszch> *who still want to register
13:48:18 <kidclamp> #info to who still need to register may email kohacon17@gmail.com or aslplibrarians@gmail.com
13:48:27 <cait> thx schnydszch - i will forward that
13:49:24 <kidclamp> anything more schnydszch?
13:49:26 <schnydszch> Paul Poulain and Gaetan Boisson will be coming over. Joann Ransom declined participation upon hearing the isolated accident which happened at Resorts World Manila, that some media tagged it as done by ISIS
13:51:03 <schnydszch> ..But recent investigation, it's only done by a lone gunman. But we assure the participants safety during the event as we already seek security clearance from local police
13:51:33 <schnydszch> Can I say something re: sponsor?
13:51:54 <kidclamp> yes
13:53:08 <schnydszch> Yeah I see BWS people here, nick and nathan, will you still be donating for kohacon2017? We're still willing to accept donations :)
13:53:34 <oleonard> :D
13:53:37 <schnydszch> We're working on the livestream part, we've got some volunteers from a local university
13:54:18 <schnydszch> who will be helping us for the livestream and event video.
13:54:42 <kidclamp> #info working on livestream and video for kohacon2017
13:55:01 <thd> schnydszch: Will you be recording the livestream?
13:55:12 <schnydszch> yep
13:55:31 <cait> ++
13:55:33 <cait> :)
13:55:41 <thd> :)
13:55:48 <kidclamp> schnydszch++
13:55:53 <tcohen> schnydszch++
13:56:00 <kidclamp> anything more or set time for next meeting?
13:56:44 <kidclamp> #topic Next meeting
13:56:47 <schnydszch> nothing else, if you have questions
13:57:18 <kidclamp> July 5th, 20 UTC?
13:57:28 <tcohen> +1
13:57:50 <Joubu> kidclamp: did not we switch with 21?
13:57:55 <thd> Have we been using 21?
13:58:22 <kidclamp> we can do 21, that works for NZ better - but I didn't know if it ciost us anyone so trying it intermittently
13:58:27 <thd> Also, is 5th to close to US independence day for good participation?
13:58:27 <kidclamp> 21 is good for me
13:58:34 <thd> s/to/too/
13:58:49 <BobB> better for AU too
13:58:57 <kidclamp> I think most should be at work on the 5th
13:59:02 * oleonard agrees
13:59:38 <kidclamp> July 5th 21 UTC
13:59:46 <thd> Yes, good the dates fall for good return.
14:00:12 <thd> Sadly, KohaCon dates overlap ALA this year.
14:00:29 * oleonard will take a break from sharpening sticks and hoarding gasoline in his post-apocalyptic fear-cave to attend the meeting
14:00:50 <kidclamp> last chance for dissent on date
14:00:51 <BobB> LOL
14:01:07 <kidclamp> #info next meeting: July 5, 2017, 21 UTC
14:01:16 <kidclamp> #endmeeting