#koha: Development IRC meeting 11 April 2018

Meeting started by Joubu at 14:01:37 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:01:45)
    1. wahanui, a bot that has become sentient (wahanui, 14:01:46)
    2. Owen Leonard, Athens County Public Libraries, USA (oleonard, 14:02:01)
    3. Jonathan Druart (Joubu, 14:02:02)
    4. Marcel de Rooy, Rijksmuseum, NL (marcelr, 14:02:05)
    5. Thomas Dukleth, Agogme, New York City (thd, 14:02:10)
    6. Andreas Hedström Mace, Stockholm University Library (andreashm, 14:02:16)
    7. Julian Maurice, BibLibre (jajm, 14:02:20)
    8. Josef Moravec, Municipal Library Ústí nad Orlicí, Czech Republic (josef_moravec, 14:02:24)
    9. Colin Campbell, PTFS-Europe (cc_, 14:02:26)
    10. Nick Clemens, ByWater Solutions (kidclamp, 14:02:48)

  2. Announcements (Joubu, 14:03:59)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_11_April_2018 (Joubu, 14:04:04)
    2. wiki page for the 18.11 roles is created - https://wiki.koha-community.org/wiki/Roles_for_18.11 (Joubu, 14:04:33)
    3. Katrin Fischer, BSZ, Germany (cait, 14:05:14)
    4. Claire Gravely, Germany (calire, 14:05:23)

  3. Update from the Release Manager (18.05) (Joubu, 14:06:14)
  4. Updates from the Release Maintainers (Joubu, 14:07:13)
  5. Updates from the QA team (Joubu, 14:08:47)
  6. General development discussion (trends, ideas, ...) (Joubu, 14:12:22)
  7. REST api (Joubu, 14:12:45)
    1. https://wiki.koha-community.org/wiki/Acquisitions_orders_endpoint_RFC (Joubu, 14:14:07)
    2. https://wiki.koha-community.org/wiki/Acquisitions_funds_endpoint_RFC (Joubu, 14:14:12)
    3. https://wiki.koha-community.org/wiki/Acquisitions_vendors_endpoint_RFC (Joubu, 14:14:15)
    4. https://wiki.koha-community.org/wiki/Biblios_endpoint_RFC (Joubu, 14:14:19)
    5. Kyle M Hall, ByWater Solutions (khall, 14:16:59)
    6. Brendan Gallagher, ByWater (bag, 14:19:06)
    7. Jon Knight, Loughborough University (greenjimll, 14:20:47)
    8. VOTE: Voted on "To vote: RFC endpoints for orders, funds and vendors in acq, biblios. Do you agree with the RFCs and comments as they are?" Results are, yes: 4, abstain: 4 (cait, 14:24:29)
    9. AGREED: RFCs for funds, vendors, orders and biblios have been agreed upon, no blocker concerns, write the code and then we adjust. (cait, 14:25:22)
    10. 4 yes, 4 lates yes and 4 abstains (cait, 14:25:44)
    11. VOTE: Voted on "Should we use users instead of patron in the case of the funds RFC (users /patrons able to use a specific fund for odering)?" Results are, yes: 11, abstain: 2 (cait, 14:31:05)
    12. AGREED: We will users in the case of the funds RFC (11 yes, 2 abstain) (cait, 14:31:24)

  8. REST API Authentication (Joubu, 14:31:48)
    1. ACTION: ashimema will read code of bug 20402 and give feedback on the bug report (Joubu, 14:48:46)
    2. ACTION: jajm will work on linking to existing patrons, tcohen and josef_moravec will test/qa (Joubu, 14:48:53)
    3. jajm will take a look at the existing Mojolicious plugin (instead of using Net::OAuth2::.. directly) (Joubu, 14:49:16)
    4. try to already note long running db updates in the release notes properly (cait, 14:51:27)

  9. Set time of next meeting (Joubu, 14:54:45)
    1. Next meeting: 25 April 2018, 21 UTC (Joubu, 14:56:14)


Meeting ended at 14:56:27 UTC (full logs).

Action items

  1. ashimema will read code of bug 20402 and give feedback on the bug report
  2. jajm will work on linking to existing patrons, tcohen and josef_moravec will test/qa


Action items, by person

  1. ashimema
    1. ashimema will read code of bug 20402 and give feedback on the bug report
  2. jajm
    1. jajm will work on linking to existing patrons, tcohen and josef_moravec will test/qa
  3. josef_moravec
    1. jajm will work on linking to existing patrons, tcohen and josef_moravec will test/qa


People present (lines said)

  1. cait (89)
  2. Joubu (73)
  3. huginn (19)
  4. thd (16)
  5. ashimema (15)
  6. greenjimll (11)
  7. jajm (11)
  8. marcelr (11)
  9. bag (9)
  10. andreashm (7)
  11. josef_moravec (6)
  12. oleonard (6)
  13. wahanui (5)
  14. cc_ (4)
  15. kidclamp (4)
  16. fridolin (3)
  17. khall (2)
  18. matts (2)
  19. calire (2)


Generated by MeetBot 0.1.4.