20:00:43 <kidclamp> #startmeeting Development IRC meeting 22 August 2018
20:00:43 <huginn`> Meeting started Wed Aug 22 20:00:43 2018 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:43 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:43 <huginn`> The meeting name has been set to 'development_irc_meeting_22_august_2018'
20:00:53 <kidclamp> #topic Introductions
20:01:02 <ashimema> #info Martin Renvoize, PTFS Europe
20:01:02 <kidclamp> #info Nick Clemens, ByWater Solutions
20:01:03 <greenjimll> #info Jon Knight, Loughborough University
20:01:11 <kidclamp> #chair cait
20:01:11 <huginn`> Current chairs: cait kidclamp
20:01:22 <bag> #info Brendan gallagher Bywater
20:01:32 <josef_moravec> #info Josef Moravec, Municipal Library Usti nad Orlici
20:02:24 <kidclamp> I scared cait off
20:02:40 <cait> sorry
20:02:44 <kidclamp> :-)
20:02:45 <cait> did we info already?
20:02:53 <kidclamp> waiting for you
20:03:00 <cait> #info Katrin Fischer, BSZ, Germany
20:03:04 <cait> Laptop froze... restarted
20:03:10 <cait> thx for waiting
20:03:25 <kidclamp> #topic Announcements
20:03:54 <kidclamp> #link https://wiki.koha-community.org/wiki/Working_with_SCSS_in_the_OPAC_and_staff_client SCSS for staff and OPAC
20:04:07 <kidclamp> #link https://wiki.koha-community.org/wiki/Coding_Guidelines#HTML9:_filter_all_the_variables Global XSS fix
20:04:28 <cait> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_22_August_2018 Agenda
20:04:35 <kidclamp> Hey, we made some big changes! Exciting! SCSS now has a yarn build process that Owen highlighted
20:04:43 <kidclamp> Joubu made all the filters for all the variables happen
20:04:59 <cait> oleonard++ Joubu++
20:05:07 <kidclamp> please test master, we expect to shake out somedisplay issues with these and want to clear them before release
20:05:33 <thd> #info Thomas Dukleth, Agogme, New York City
20:05:40 <ashimema> Well done all involved in those
20:05:42 <kidclamp> Owne and Joubu both took off after these were pushed, so volunteer them for any fixes :-)
20:06:04 <kidclamp> anyone else? Bag?
20:06:19 <bag> nada
20:06:50 <bag> Joubu++
20:07:03 <bag> oleonard++
20:07:11 <kidclamp> #topic Update from the Release manager (18.11)
20:07:17 <kidclamp> Hey, that's me :-D
20:07:48 <cait> kidclamp++ too :)
20:07:53 <kidclamp> Trying to get the queue caught up, still some bug things I would like to see more of (Mana, Stock rotation) bug me if you have anything you want :-)
20:08:44 <kidclamp> That's all from me really, except to keep poking master for any bugs
20:09:06 <kidclamp> #topic Updates from the Release Maintainers
20:09:09 <kidclamp> ashimema:
20:09:16 <cait> Rmaints?
20:09:19 <cait> RMaints?
20:09:33 <cait> only Joubu can do the magic it seems :)
20:09:36 <ashimema> It's been a bumpy month with holiday, but we've been steadily pushing. I've delayed today's release by a week so we can do the three releases close to each other
20:09:51 <ashimema> Lining up annual leave, always fun 😉
20:10:42 <ashimema> That's it from me too really.. fridolin is out this week..
20:10:48 <kidclamp> #info releases delayed for coordinated release, holidays
20:10:58 <bag> I do have an announcement - sorry to be late with it…  HACKFEST!!!  kidclamp is running the show - please help him out and bring ideas for what to do
20:11:07 <kidclamp> #topic Updates from the QA team
20:11:15 <cait> do you want them before or just bringing them?
20:11:17 <kidclamp> #info HACKFEST!!!  kidclamp is running the show - please help him out and bring ideas for what to do
20:11:26 <bag> just bring them cait
20:11:32 <cait> started a list already :)
20:11:35 <kidclamp> #info email kidclamp if you have things you want done or ideas
20:11:47 <kidclamp> let me knwo too ;-)
20:11:51 <greenjimll> Is HACKFEST a physical or virtual thing?
20:11:55 * ashimema will be attempting to join hackfest virtually 😉
20:12:03 <cait> both
20:12:17 <bag> both for sure
20:12:20 <kidclamp> Hackfest is a state of mind (and freedom to ignore everythign that isn't a bug)
20:12:44 <kidclamp> QA updates cait?
20:12:45 <cait> @quote add Hackfest is a state of mind (and freedom to ignore everythign that isn't a bug)
20:12:45 <huginn`> cait: Error: You must be registered to use this command. If you are already registered, you must either identify (using the identify command) or add a hostmask matching your current hostmask (using the "hostmask add" command).
20:12:50 <cait> ah yes
20:12:58 <cait> sorry, missed the topic change
20:13:02 <kidclamp> @quote add Hackfest is a state of mind (and freedom to ignore everything that isn't a bug)
20:13:02 <huginn`> kidclamp: Error: You must be registered to use this command. If you are already registered, you must either identify (using the identify command) or add a hostmask matching your current hostmask (using the "hostmask add" command).
20:13:12 <kidclamp> I bet bag has super powers
20:13:23 <cait> #info queue is in reasonable shape, can always be better, but bugs are being taken care of fast, enh a little slower
20:13:41 <kidclamp> josef_moravec++ welcome back :-)
20:13:48 <cait> I had added an idea on my proposal, that i'd like to try out
20:13:50 <bag> @quote add Hackfest is a state of mind (and freedom to ignore everything that isn't a bug)
20:13:50 <huginn`> bag: The operation succeeded.  Quote #332 added.
20:13:51 <cait> QA topic experts
20:14:09 <ashimema> +1
20:14:11 <cait> people the qa team can call in for certain topics
20:14:16 <kidclamp> +1
20:14:35 <josef_moravec> +1
20:14:38 <cait> an additonal code review might be done, but otherwise a sign-off would count as qa
20:14:54 <cait> matts volunteered (kind of) for CAS and Shibboleth
20:15:26 <ashimema> Hehe, well volunteered matts
20:15:34 <kidclamp> matss++
20:15:48 <kidclamp> [off] I give up on typing today
20:15:51 <cait> #info QA team is looking for QA topic experts - sign off counting for qa, additional code review from qa team as needed, volunteers welcome - please also feel free to suggest people
20:15:58 <cait> matts++
20:16:29 <cait> i'd add them to the roles page for 18.05 as we find them, ok?
20:16:34 <cait> um 18.11
20:16:38 <kidclamp> +1
20:16:42 * ashimema will try to talk colin_c back into sip and edit topic expert roles
20:16:49 <cait> sounds good
20:16:52 <bag> I’d be willing to do SIP and LDAP things (I still have that set up from my RM days)
20:16:55 <cait> we are also lookign for an ldap person
20:16:57 <ashimema> Brill
20:17:02 <cait> ... and if possible someone for linked data/rdf
20:17:10 <ashimema> Awesome bag
20:17:22 <cait> cool
20:17:23 <cait> bag++
20:17:25 <josef_moravec> david cook for rdf?
20:17:38 <cait> #action bag to volunteer as QA topic expert for LDAP and SIP
20:17:43 <bag> I won’t put a passed QA on it - unless I volunteer to be on the team again - so I like the idea of just another sign-off
20:17:48 <cait> josef_moravec: looking for someone to look at his patches :)
20:17:50 <cait> so yes... an dno
20:18:05 <josef_moravec> cait: I see ;)
20:18:31 <ashimema> Yup.. what she said
20:18:44 <cait> #info other topics: RDF, authentication
20:19:09 <kidclamp> would you send soemthing to the lists cait?>
20:19:17 <cait> i thnk with a second qa again, we should be good with a code review
20:19:44 <cait> hm i could, but not sure what exactly?
20:19:44 <ashimema> Agreed
20:19:59 <kidclamp> just to let people know and see if anyone jumps on other things
20:20:00 <cait> hm second sign-off... good for qa with a code review
20:20:04 <cait> i better give up on writing too
20:20:24 <cait> i'll try :)
20:20:43 <kidclamp> anything else?
20:21:10 <cait> not from me right now
20:21:14 <kidclamp> #topic General development discussion (trends, ideas, ...)
20:21:25 <cait> tcohen?
20:21:39 <kidclamp> #info [VOTE] REST API: public vs. private API. how do we handle
20:22:07 <cait> i'll have to read that quickly
20:22:14 <cait> ... and then probably have someone explain
20:22:17 <kidclamp> ashimema: have you talked with tomas on this?
20:23:20 <cait> i think the idea is different routes
20:23:41 <kidclamp> I think the gist is - rather than rework the current API stuffs, just make it all private (authenticated) and add new routes for public info for where it is neee
20:23:47 <kidclamp> exactly cait
20:23:48 <cait> like we have a libraries end point with all information and another for just getting a pull down of libraries that can be open, right?
20:24:02 <cait> well not a pull down... list of library names or so
20:24:18 <cait> i like it
20:24:33 <cait> but i was always the one worried about exposing this data - so of course i like it :)
20:24:37 <kidclamp> any questions/objections?
20:25:06 <ashimema> Yeah, we've discussed it.. it's a perfectly sane approach and I'm game for it
20:25:08 <greenjimll> As long as is well documented I don't have an issue. Will there be an API version number included too?
20:25:47 <kidclamp> I think that can be done as detail work, for now is broad concept vote?
20:25:52 <greenjimll> ok
20:26:19 <cait> greenjimll: i think we already have a version number, currently still 1 as things are mostly unfinished
20:26:27 <kidclamp> ok, lemme phrase something
20:26:37 <cait> phrasing as a question... i hated that
20:27:22 <ashimema> Semantic versioning in the API I believe.. don't think k we'veade any breaking changes yet
20:27:30 <thd> Was anyone favouring everything in the API running without authentication?
20:27:46 <kidclamp> #startvote Should we adapt current API as 'private' and build new '/public' namespace for simple information endpoints (as outlined in agenda)? Yes, No, Abstain
20:27:46 <huginn`> Begin voting on: Should we adapt current API as 'private' and build new '/public' namespace for simple information endpoints (as outlined in agenda)? Valid vote options are Yes, No, Abstain.
20:27:46 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
20:27:55 <kidclamp> #vote Yes
20:28:02 <thd> #vote Yes
20:28:09 <greenjimll> #vote Yes
20:28:14 <cait> thd: the initial idea was to see data without where it made sense and then more when authenticated, but it's difficult with the way koha handles things like visibliity
20:28:20 <cait> #vote Yes
20:28:20 <josef_moravec> #vote Yes
20:28:44 <ashimema> #vote yes
20:28:53 <kidclamp> last call...
20:29:20 <kidclamp> #endvote
20:29:20 <huginn`> Voted on "Should we adapt current API as 'private' and build new '/public' namespace for simple information endpoints (as outlined in agenda)?" Results are
20:29:20 <huginn`> Yes (6): greenjimll, cait, josef_moravec, ashimema, kidclamp, thd
20:29:22 <bag> #vote yes
20:29:26 <kidclamp> so close
20:29:40 <thd> cait: We need to the way Koha handles (visibility|word readability).
20:29:43 <kidclamp> #info It's unanimous - do that thing
20:29:52 <kidclamp> #action Tomas will do that thing
20:30:09 <cait> kidclamp: there is #agreed :)
20:30:29 <ashimema> I thought tcohen was here..
20:30:37 <kidclamp> #agreed We want the current api to be private and add a public namespace for needed info endpoints
20:30:42 <cait> @later tell matts got you a new job :) https://wiki.koha-community.org/wiki/Roles_for_18.11
20:30:43 <huginn`> cait: The operation succeeded.
20:30:46 <thd> kidclamp: I shall interpret "that thing" to be whatever I please unanimously :)
20:30:48 <kidclamp> #topic Review of coding guidelines
20:31:03 <cait> that was me again
20:31:07 <cait> alex_a brought it up today
20:31:18 <cait> Perl 9 is still targetted at C4
20:31:30 <cait> but we have been pushing people to do snake case in the new Koha namespace
20:31:34 <cait> so we should at least amen dit
20:31:36 <cait> amend it
20:31:59 <kidclamp> +1
20:32:04 <cait> #link https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL9:_Subroutine_naming_conventions Coding guideline for soubroutine naming conventions
20:32:32 <greenjimll> Heh, I always did snake case myself until at work one of my colleagues put camel case into the coding guidelines. It'll be fun to say, "no, Koha requires it". ;-)
20:32:37 <cait> eythian suggested that perl leans towards snake case for subs and camel case for module names
20:32:44 <cait> which seems to make sense with how we do things now
20:33:31 <ashimema> Well spottef
20:33:34 <thd> What happens when a subroutine is abstracted to become a module?
20:33:42 <cait> i was about to say something about tumbleweed :)
20:34:02 <cait> thd: i don't think it works that way?
20:34:22 <ashimema> Yup
20:34:27 <ashimema> What eythian said is what I've seen too
20:34:46 <cait> we could divide the rule up, sec
20:34:51 <kidclamp> Do you have wording proposal, or just vote on the idea and get it worded after?
20:34:53 <thd> cait: Yes, I know because there is subsidiarity in the namespace for the module.
20:36:16 <cait> please refresh wiki
20:36:27 <cait> refining i'd leave up to a dev :)
20:36:32 <cait> well... a more full time dev
20:37:12 <greenjimll> So when you say "snake case for subs and camel case for module names" do you mean camel case for module public methods and snake for internal functions?
20:37:49 <cait> for th ename of the package is what i understood
20:37:56 <cait> so it's PatronAttributes.pm
20:37:59 <cait> i might be mistaken
20:38:06 <greenjimll> Perl 9 seems to be talking about methods though in camel case.
20:38:07 <kidclamp> yes, that is what i understand
20:38:18 <greenjimll> eg: AddBiblio
20:38:27 <cait> yeah that's how things are in C4
20:38:32 <kidclamp> that is in the C4 deprecated section
20:38:35 <cait> well... mostly
20:38:49 <cait> please feel free to change it up
20:39:02 <greenjimll> Ah, I misunderstood. I thought you wanted to do what was in Perl 9 everywhere outside C4 as well.
20:39:14 <kidclamp> when we rewrite Koha in C# we will remove all inconsistencies :-)
20:39:21 <cait> hah
20:39:36 <cait> maybe we should use something more esoteric
20:39:38 <greenjimll> Don't joke... that's a frightening idea.
20:39:49 <kidclamp> ready to vote?
20:39:50 <cait> whitespace
20:40:06 <kidclamp> or can we just accept it :-)
20:40:07 <greenjimll> Er, what is it we're voting on... I'm still a bit unclear?
20:40:21 <kidclamp> the amendment to the rule (that already happened)
20:40:21 <cait> greenjimll: did you see the slightyl changed wiki page?
20:40:31 <cait> kidclamp: can always be undone, it's a wiki :)
20:40:51 <greenjimll> I'm looking at https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL9 which was in the agenda
20:41:06 <cait> try refreshß
20:41:08 <cait> ?
20:41:26 <cait> C4 namespace [outdated]  and everything above is new
20:41:32 <kidclamp> #vote Should we adapt the PERL9 guideline to state us of snake_case for subroutines in the Koha namespace and the use of CamelCase for modules? Yes, No, Abstain
20:41:38 <kidclamp> #vote Yes
20:41:41 <josef_moravec> #vote Yes
20:41:43 <cait> #vote yes
20:41:48 <cait> #vote Yes
20:41:51 <greenjimll> #vote Abstain
20:41:52 <thd> s/shoudl/should/
20:41:59 <ashimema> #vote yes
20:42:05 <thd> #vote Yes
20:42:25 <kidclamp> last call
20:42:42 <kidclamp> #endvote
20:42:55 <kidclamp> #nedvote
20:42:59 <kidclamp> #endvote
20:43:11 <kidclamp> #startvote Should we adapt the PERL9 guideline to state us of snake_case for subroutines in the Koha namespace and the use of CamelCase for modules? Yes, No, Abstain
20:43:11 <huginn`> Begin voting on: Should we adapt the PERL9 guideline to state us of snake_case for subroutines in the Koha namespace and the use of CamelCase for modules? Valid vote options are Yes, No, Abstain.
20:43:11 <huginn`> Vote using '#vote OPTION'. Only your last vote counts.
20:43:16 <kidclamp> #vote Yes
20:43:27 <kidclamp> heh, i knew something was wrong :-)
20:43:30 <josef_moravec> #vote Yes
20:43:31 <ashimema> #vote yes
20:43:40 <cait> #vote Yes
20:43:50 <kidclamp> last call
20:44:01 <kidclamp> #endvote
20:44:01 <huginn`> Voted on "Should we adapt the PERL9 guideline to state us of snake_case for subroutines in the Koha namespace and the use of CamelCase for modules?" Results are
20:44:02 <huginn`> Yes (4): kidclamp, cait, josef_moravec, ashimema
20:44:33 <kidclamp> #agreed PERL9 will (has been) be updated to reflect Koha namespace capitlization guidelines
20:44:49 <kidclamp> #topic Set time of next meeting
20:44:55 <greenjimll> OK, so just to be clear, the "verb and noun" requirement that was in C4 for subroutine names has been ditched as well now?
20:45:15 <cait> i'd say so
20:45:28 <kidclamp> wait until after Kohacon?
20:45:52 <kidclamp> if the devs don't talk to each other there something has gone horribly wrong
20:46:16 <kidclamp> Sepetember 19th, 14UTC?
20:46:58 <josef_moravec> ok for me
20:47:10 <thd> +1
20:47:12 <greenjimll> +1
20:47:51 <thd> Wait is that not 2 days after KohaCon?
20:48:37 <kidclamp> it is, i think most will be home by then, or we can at least record what all we did :-)
20:48:37 <bag> KohaCon is 10th~12th
20:48:40 <cait> i won't make that one
20:49:00 <cait> but i trust you to make good decisions heh
20:49:06 <bag> :)
20:49:14 <kidclamp> #info Next meeting: 19 September 2018, 14 UTC
20:49:20 <kidclamp> #endmeeting