#koha: Development IRC meeting 28 February 2018

Meeting started by tcohen at 19:01:03 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_28_February_2018 (tcohen, 19:01:14)

  1. Introductions (tcohen, 19:01:40)
    1. Jonathan Druart (Joubu, 19:01:56)
    2. Lee Jamison, Marywood University (LeeJ, 19:01:59)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 19:02:10)
    4. Josef Moravec, Czech Republic (josef_moravec, 19:02:20)
    5. Owen Leonard, Athens County Public Libraries, USA (oleonard, 19:02:27)

  2. Announcements (tcohen, 19:03:43)
    1. brendan gallagher bywater (bag, 19:04:20)
    2. Nick Clemens, ByWater Solutions (kidclamp, 19:05:41)
    3. Jonathan will be mostly AFK during March, Nick will be in charge as RM assistant (tcohen, 19:05:44)

  3. Update from the Release manager (18.05) (tcohen, 19:09:27)
    1. Staff client CSS to SCSS patches are waiting for love and are important (tcohen, 19:11:53)

  4. Update from the Release Maintainers (tcohen, 19:12:23)
    1. Nick is making sure 17.11.x is as close to master as possible (tcohen, 19:14:07)
    2. 17.11.04 will be delayed a couple days due to Marseille's THE hackfest (tcohen, 19:14:40)

  5. UPdates from the QA team (tcohen, 19:15:06)
    1. Katrin has been pushing the QA team members, if you are looking for QA attention, contact her (tcohen, 19:17:25)

  6. REST api (tcohen, 19:18:05)
    1. Signoff-ers and QA-ers, please look at this crazy graph https://bugs.koha-community.org/bugzilla3/showdependencygraph.cgi?id=15449 (tcohen, 19:20:22)
    2. Jonathan mentions (again) he thinks the REST api development should be done on top of Koha::Object(s)-based classes (tcohen, 19:31:47)
    3. Josef agreed some work on the backend-side is needed for actions on the illrequests endpoints (besides LIST) (tcohen, 19:41:07)
    4. https://vufind.org/wiki/development:plugins:ils_drivers#changepassword (josef_moravec, 20:13:09)
    5. AGREED: RFC for password change is accepted (cait, 20:23:47)

  7. Set time of next meeting (cait, 20:25:26)
    1. Next meeting: 14 March 2018, 14 UTC (cait, 20:26:46)


Meeting ended at 20:27:00 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. tcohen (136)
  2. Joubu (43)
  3. josef_moravec (27)
  4. cait (25)
  5. bag (9)
  6. kidclamp (7)
  7. oleonard (6)
  8. huginn (5)
  9. LeeJ (4)
  10. jenkins (2)
  11. m23_ (2)
  12. notarock (1)


Generated by MeetBot 0.1.4.