14:01:10 <kidclamp> #startmeeting Development IRC meeting 9 May 2018
14:01:10 <huginn> Meeting started Wed May  9 14:01:10 2018 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:10 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:10 <huginn> The meeting name has been set to 'development_irc_meeting_9_may_2018'
14:01:22 <kidclamp> #topic Introductions
14:01:22 <wahanui> #info wahanui, a bot that has become sentient
14:01:24 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:01:31 <kidclamp> #info Nick Clemens, ByWater Solutions
14:01:36 <Joubu> #info Jonathan Druart
14:01:47 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_May_2018
14:01:48 <thd> #info Thomas Dukleth, Agogme, New York City
14:01:52 <davbo_> #info David Bourgault, Solutions InLibro
14:01:52 <cc_> #info Colin Campbell, PTFS Europe Ltd
14:01:56 <marcelr> #info Marcel de Rooy
14:01:58 <blou> #info Philippe Blouin, Solutions inLibro
14:02:25 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:02:43 <khall> #info Kyle M Hall, ByWater Solutions
14:03:08 <oleonard> cait? calire? josef_moravec?
14:03:23 <Joubu> qa_team?
14:03:23 <wahanui> well, qa_team is alex_a jajm marcelr khall kidclamp tcohen josef_moravec
14:03:26 <Joubu> rmaints?
14:03:26 <wahanui> rmaints is kidclamp (17.11), fridolin (17.05), rangi (16.11)
14:03:26 <oleonard> tuxayo?
14:03:45 <fridolin> hi there
14:03:56 <fridolin> #info Fridolin Somers, Biblibre, France
14:04:28 <cait> #info Katrin Fischer, BSZ, Germany
14:04:39 <cait> coming out of another meeting, sorry to be late
14:04:56 <tuxayo> hi!
14:04:56 <tuxayo> #info Victor Grousset, BibLibre, France
14:04:59 * fridolin has proposed to maintain 17.11.x after 18.05 release
14:05:01 <tuxayo> thanks oleonard :D
14:05:07 <fridolin> keeping maintaining oldstable
14:05:11 <calire> #info Claire Gravely, BSZ, Germany
14:05:54 <kidclamp> #topic Announcements
14:06:02 <kidclamp> anyone?
14:06:02 <wahanui> Anyone? Anyone? Bueller? Bueller?
14:06:59 * oleonard is ready to dump piles of patches on y'all as part of Bug 20654
14:06:59 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20654 enhancement, P5 - low, ---, oleonard, ASSIGNED , Omnibus: Update two-column templates to use Bootstrap grid
14:07:11 <calire> oleonard++
14:07:15 <cait> more piles of patches? oy
14:07:58 <kidclamp> #topic Update from the Release manager (18.05)
14:08:05 <kidclamp> Mr Joubu
14:08:17 <Joubu> 18.05 will be released quite soon
14:08:23 <kidclamp> confetti!
14:08:24 <wahanui> o/ '`'`'`'`'`'`'`'`
14:08:25 <Joubu> we are in string freeze already
14:08:26 <khall> oleonard+++ indeed!
14:08:30 <Joubu> *but*
14:08:56 <Joubu> I am going to make an exception and push the OAuth patchset
14:09:03 <Joubu> certainly today
14:09:08 <cait> +1
14:09:11 * oleonard mutters Seems like all my friends have a big *but*
14:09:19 <tcohen> +1
14:09:19 <Joubu> people should focus on signoff/qa of bugfixes
14:09:22 <Joubu> and catch bugs
14:09:24 <cait> i think the strings involved there will be ok until the .01
14:09:30 <kidclamp> +1
14:09:36 <Joubu> it's not useful to rebase or dev new enhancements ;)
14:09:58 <cait> ther are some patches for the marc freameworks that don't involve translation
14:09:58 <Joubu> a side note about 18.11: we really need release maintainers
14:10:03 <Joubu> and that's all for me
14:10:08 <kidclamp> #info 18.05 release in string freeze but exception being made for OAuth patches, please focus on bugs and testing
14:10:11 <cait> i think it might be nice to be up to the latest standard with release
14:10:27 <cait> i signed off the first, waiting for qa *hint* :)
14:10:48 <kidclamp> bug number cait?
14:11:25 <cait> sec
14:11:44 <tuxayo> Joubu: " we really need release maintainers" : at least 18.05 Or is 17.05 really needed also?
14:11:47 <Joubu> ha, it would be nice to have bug 20720 into 18.05 (I will not have time to write a patch)
14:11:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20720 enhancement, P5 - low, ---, koha-bugs, In Discussion , Add libraries (sponsors) to the about page
14:12:14 <cait> bug 19835
14:12:14 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19835 enhancement, P5 - low, ---, koha-bugs, Signed Off , Update MARC frameworks to Updates 23+24+25 (Nov 2016, May and Dec 2017)
14:12:32 <Joubu> tuxayo: we should maintain at least 3 stable releases.
14:12:38 <cait> bug 20710
14:12:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20710 minor, P5 - low, ---, bgkriegel, Needs Signoff , Update MARC21 frameworks to Update 26 (April 2018)
14:12:55 <Joubu> but if everybody is willing to run master, it's fine by me
14:13:05 <fridolin> ^^
14:13:11 <kidclamp> #info please look at bugs 20270 19835 20710 for release
14:13:17 <kidclamp> moving on?
14:13:21 <cait> 18.05 and 17.11 is needed, we could drop 17.05 if noone is willing to
14:13:27 <cait> but it would be much nicer to have 3
14:13:41 <fridolin> +1
14:14:11 <tcohen> hi rangi
14:14:23 <kidclamp> #topic Updates from the Release Maintainers
14:14:45 <kidclamp> I am going to ush some this week before string freeze, will try not o leave a mess for frido :-)
14:14:56 <tuxayo> Joubu: Indeed, if many people will stay stuck on 17.05 that would be useful: https://hea.koha-community.org/systempreferences
14:14:58 <tuxayo> Or could it be an incentive to upgrade to not have 17.05 maintained? (just a idea, not sure if good at all)
14:16:26 * kidclamp points at khall
14:16:49 <khall> yes, I'd be willing to rmaint 17.05
14:16:55 <Joubu> ashimema_: ?
14:17:01 <marcelr> khall++
14:17:05 <tcohen> khall++
14:17:13 <cait> so what's our lineup? 18.05?
14:17:29 <tcohen> we need someone for 18.05
14:17:31 <tcohen> ?
14:17:57 <Joubu> ashimema is volunteering
14:18:32 <josef_moravec> #info Josef Moravec, library Ústí nad Orlicí
14:18:38 <josef_moravec> I am late, sorry
14:18:55 <khall> kk
14:19:29 <kidclamp> #info kidlcmap will push for 17.11 this week
14:19:35 <kidclamp> any notes frido?
14:19:40 <fridolin> Joubu: is Bug 20144 for stable branches also ?
14:19:40 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20144 normal, P5 - low, ---, jonathan.druart, Pushed to Master , Test suite is failing with new default SQL modes
14:19:44 <cait> still confused, but think people will hopefully sign up on the wiki :)
14:20:08 <Joubu> fridolin: nope (yet)
14:20:21 <fridolin> I m not proposing for RMaint 18.05 i will not have enough time
14:20:31 <fridolin> oki cool (so much patches)
14:20:56 * fridolin is ok
14:20:57 <kidclamp> #action ashimema has (been?) volunteered for 18.05 RMaint - he should update the wiki :-D
14:21:13 <Joubu> (Martin asked me few days ago how he could help for 18.11, and if he could be RMaint, that's why I said that)
14:21:28 <Joubu> (we will catch him when he will be around)
14:21:51 <kidclamp> moving on
14:21:51 <fridolin> ashimema++
14:21:59 * tuxayo prepares a net to catch ashimema
14:22:12 <kidclamp> #topic Updates from the QA team
14:22:13 <cait> work load wise the newer the more work
14:22:17 <fridolin> prepare beers for that
14:23:20 <kidclamp> cait
14:24:23 <cait> Nothing much
14:24:35 <cait> what Joubu said, focus now should be on bug fixes mostly
14:24:44 <cait> anything that is needed to get us to the release
14:25:07 <cait> and then we will start over, there are some quite big featues in the queue that we will need to tackel after release
14:25:14 <cait> stock rotation, mana and recalls to name some
14:25:27 <kidclamp> - #info cait says fix all the bugs or she won't qa your patches anymore ever
14:25:36 <cait> happy to see we have quite a good team ready for the next release
14:25:56 <cait> true
14:26:05 <cait> never ever again ;)
14:26:05 <kidclamp> #info QA please focus on bugs, after release there are big patches to look towards
14:26:25 * Joubu is going to remove the "Database Documentation Manager" role
14:26:29 <cait> can i jump in with a releas team question?
14:26:46 <cait> tcohen++ signed up for module maintainer rest api
14:26:49 <cait> which i thin is a great thing
14:26:57 <tcohen> thanks
14:27:02 <cait> maybe we could also find someone to coordinate elasticsearch?
14:27:16 <tcohen> I think the RM will be very involved
14:27:16 <kidclamp> clrh_
14:27:17 <Joubu> kidclamp is doing it
14:27:20 <cait> right now we have a lot of bugs and patches waiting, but i don't see how they depend on eacho ther clearly and what is most urgent
14:27:26 <cait> someone to coordinate that woudl be great
14:27:27 <kidclamp> I will, but some help too
14:27:30 <cait> keeping the big picture
14:27:55 <cait> kidclamp++
14:27:55 <greenjimll> #info Jon Knight, Loughborough University
14:28:03 <cait> all from me then, qa_team?
14:28:07 <cait> qa team?
14:28:07 <wahanui> i think qa team is hunting all the bugs!
14:28:10 <cait> hm.
14:28:14 <marcelr> cait++
14:28:15 <cait> you know who you are
14:28:20 <kidclamp> been trying to point out conflicts and guide, clrh_ doc has been helpful we should update it for 18.11 goals
14:28:52 <kidclamp> moving on
14:28:54 <cait> maybe a most important elasticsearch bug for the weekly qa email? :)
14:29:00 <kidclamp> +1
14:29:26 <kidclamp> #info kidclamp will corordinate ES efforts for 18.11 - may tap individuals for help along the way
14:29:27 <Joubu> maybe it's time to contribute to the what's on in koha-devel?
14:29:38 <kidclamp> also +1
14:30:16 <Joubu> https://annuel2.framapad.org/p/What_s_on_in_koha-devel
14:30:23 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:30:57 <ashimema> #info Martin Renvoize, PTFS Europe
14:31:11 <ashimema> But only lurking.. On school run duties
14:31:20 <tuxayo> "what's on in koha-devel" Oh great idea! :D
14:31:55 <Joubu> irony?
14:31:55 <wahanui> well, irony is of course that he learns it all from humans. ;)
14:32:41 <kidclamp> #topic Way to authenticate patron for REST API - what about Bug 17004
14:32:41 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17004 enhancement, P3, ---, lari.taskula, In Discussion , REST API: add route to authenticate patron (Single Sign On - SSO)
14:32:50 <fridolin> miam miam
14:33:31 <kidclamp> lari tcohen jajm ^
14:33:41 <greenjimll> In "whats on in koha devel" is it worth mentioning trying to sweep up old bugs/ideas?
14:33:57 <tcohen> is marcelr around?
14:33:58 <tuxayo> Joubu: "irony": no no no, not at all. It's nice to contribute that less people (including me) are out of the loop
14:34:11 <marcelr> yes tcohen
14:34:42 <josef_moravec> .I added it, we need an easy way to authenticate a patron by username and password
14:34:43 <kidclamp> #link https://annuel2.framapad.org/p/What_s_on_in_koha-devel To contribute for 'What's on in koha devel"
14:34:55 <tcohen> the main problem with that proposal is that is just replicating the current cookie based authentication we have
14:35:08 <fridolin> i think jajm is at the beach
14:35:21 <tcohen> I'm not against having it for people needing it, but the goal is to have full support for other OAuth2 flows
14:36:26 <greenjimll> confidential client OAuth2 flows so that back end servers can use it for bulk updates?
14:36:34 <tcohen> I mean, until we cover the other flows, we could replace the current controller scripts with this kind of endpoint, but it is a short-term thing
14:36:42 <barton> #info Barton Chittenden, BWS
14:36:54 <tcohen> greenjimll: that's probably getting into 18.05 already
14:37:15 <tcohen> this one is for generating session cookies
14:37:18 <greenjimll> tcohen: Great - that's really useful for systems integration.
14:37:22 <tcohen> which could be in turn used for that
14:37:25 <tcohen> separate thing
14:38:02 <tcohen> the thing is we don't have that many hands working on this things
14:38:12 <tcohen> so, where to put the energy
14:39:25 <tcohen> I wouldn't block this dev as the way we currently deal with OAuth authentication is far from standard-ish (we do oauth2 for google, but generate a session cookie instead of using the token, etc)
14:39:37 <tcohen> there's a long road to go
14:39:40 <josef_moravec> ok, I will try to think about it more for next time, this was requirement from an external API user, but with full OAuth2 flow, we could maybe do it better...
14:40:03 <tcohen> ashimema: thoughts?
14:40:03 <wahanui> thoughts are that this might help us fix a lot of extended-unicode bugs
14:40:43 <kidclamp> #info bug 17004 may be covered by OAuth developments - involved parties should talk about coordinating :-)
14:40:43 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17004 enhancement, P3, ---, lari.taskula, In Discussion , REST API: add route to authenticate patron (Single Sign On - SSO)
14:40:58 <tcohen> right
14:41:01 <kidclamp> moving on but feel free to continuye discussion
14:41:06 <kidclamp> #topic Review of coding guidelines
14:41:21 <kidclamp> #topic HTML8: use Asset TT plugin for linking javascript and css files
14:41:45 <kidclamp> #link https://wiki.koha-community.org/wiki/Coding_Guidelines#HTML8:_use_Asset_TT_plugin_for_linking_javascript_and_css_files Use Asset TT plugin for linking js and css files
14:41:46 <josef_moravec> does make sense, thanks tcohen and others for discussion!
14:42:03 <Joubu> this one is pushed already actually, I did not know we had to vote it :)
14:42:18 <kidclamp> we better vote yes then :-)
14:42:27 <josef_moravec> bug 20538
14:42:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20538 enhancement, P5 - low, ---, julian.maurice, Pushed to Master , Remove the need of writing [% KOHA_VERSION %] everywhere
14:42:45 <tcohen> we are voting the guidelines change, which is ok
14:43:25 <kidclamp> #startvote should we adopt coding guideline HTML8 as written?
14:43:25 <huginn> Begin voting on: should we adopt coding guideline HTML8 as written? Valid vote options are Yes, No.
14:43:25 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
14:43:34 <kidclamp> #vote Yes
14:43:36 <oleonard> #vote Yes
14:43:39 <josef_moravec> #vote yes
14:43:42 <Joubu> #vote yes
14:43:43 <greenjimll> #vote Yes
14:43:57 <marcelr> #vote yes
14:44:00 <calire> #vote Yes
14:44:03 <kidclamp> last call
14:44:08 <thd> #vote Yes
14:44:18 <kidclamp> #endvote
14:44:18 <huginn> Voted on "should we adopt coding guideline HTML8 as written?" Results are
14:44:42 <kidclamp> #info 8 yes, unanimous
14:44:47 <tuxayo> #vote Yes
14:45:14 <kidclamp> #topic PERL17.1 Unit tests should be grouped into sensible subtests that create their own data.
14:46:00 * tuxayo curses the latency of using an IRC bridge (from Matrix/Riot) instead of actually being on IRC
14:46:05 <Joubu> I think cait added after a discussion with me
14:46:22 <Joubu> it should be applied strictly, but the idea is to have 1 subtest for 1 method
14:46:43 <tcohen> Joubu: we've been kind of enforcing it on QA
14:46:56 <Joubu> unless 2 methods are strongly linked and it will need to dup too much code to test them separated into 2 subtests
14:47:20 <Joubu> tcohen: yes, that's why cait wanted it in the guidelines
14:47:29 <kidclamp> yes, while it easier to add a test using existing data, it is harder to fix/maintain
14:47:38 <tcohen> would it involve having the transaction inside the subtest?
14:47:39 <marcelr> ¨unless we have good reasons to do otherwise¨ :)
14:47:56 <josef_moravec> marcelr++
14:48:14 <tcohen> TestBuilder helped get here
14:48:16 <Joubu> basically, in 90% of the time, if you add a new method, add a separate subtest, see t/db_dependent/Koha/Patrons.t for an example
14:48:24 <tcohen> before, it was a pain
14:48:38 <Joubu> and it's still a pain
14:48:48 <kidclamp> is there a proposed rule (i.e. what's the wording?)
14:49:06 <tcohen> yohann++
14:49:36 * tcohen volunteers to write it as a draft (with examples, etc) for voting next dev meeting
14:50:05 <kidclamp> #action tcohen will draft a rule (with examples and qa escape clause)
14:50:27 <kidclamp> #topic Proposal: Officially apply Perl indentation rules to all file types. 4-space indentation for new/changed templates, JS, CSS, etc. -- oleonard
14:50:57 <kidclamp> oleonard?
14:50:57 <wahanui> hmmm... oleonard is still here, if you just wish hard enough. or Koha's master UI designer
14:51:04 * kidclamp wishes so hard
14:51:37 <oleonard> We've got a lot of templates, especially newer ones, with two-space indentation. The rules aren't very clear because they only refer to Perl scripts
14:51:50 <oleonard> I'd prefer that we make the rule global
14:52:14 <marcelr> what about changes?
14:52:28 <marcelr> lots of files with indentation troubles
14:52:39 <oleonard> Re-indent changed lines, just like we've done with files that have tab indentation
14:53:03 <Joubu> popcorn time
14:53:10 <marcelr> may be not that simple in a bad template
14:53:55 <Joubu> same as previously for this rule, it should not be applied strictly:
14:54:00 <Joubu> 1. new file: 4 spaces
14:54:12 <Joubu> 2. changes in existing and dirty files should be:
14:54:34 <Joubu> 2a: use the same identation as the block you are editing (unless it's tab)
14:54:45 <Joubu> 2b: there is not b actually
14:55:11 <tcohen> the .editorconfig file should probably be updated
14:55:40 <oleonard> I think the choice is pretty simple: Either the 4-space indentation is global or: it isn't, and there's no standard at all for other file types.
14:56:12 <oleonard> ...because if someone wants to say the rule for .tt is two spaces we've got the same argument and ALSO two different standards.
14:56:17 <marcelr> i am all for a relaxed migration to four spaces ;)
14:56:32 <kidclamp> +1
14:56:58 <kidclamp> #chair tcohen Joubu
14:56:58 <huginn> Current chairs: Joubu kidclamp tcohen
14:57:00 <greenjimll> I experienced this yesterday playing with basketgroup.tt.  I tried to make my changes fit in with what was already there but its a pain with mixed HTML and Perl in the templates.
14:57:08 <thd> Relaxed and provision for exceptions when files have extensive indentation.
14:57:19 * tcohen secretly loves to shift 2 spaces left TT-specific lines to be able to read HTML more clearly
14:57:30 <kidclamp> I have to run, good luck all
14:57:45 <tcohen> kidclamp: how could you do this to us
14:57:55 <marcelr> stay and talk about tabs
14:58:02 <thd> Exceptions should be noted as a comment in the file header.
14:58:11 <oleonard> Shall we vote?
14:58:14 <marcelr> +1
14:58:59 <thd> s/extensive/extensive levels of/
14:59:26 <greenjimll> Whichever way we vote I guarantee I'll keep getting it wrong. :-)
14:59:27 <tuxayo> I vote Yes for the proposal of voting
14:59:34 * ashimema frantically tries to catch up now he's back from the school run
15:00:14 <marcelr> ashimema: you are Rmaint in the meantime :)
15:00:34 <marcelr> my vote is Yes for 4 spaces
15:00:56 * tuxayo throws a net on ashimema_
15:01:00 <Joubu> Is everybody waiting for kidclamp to write the vote proposal?
15:01:03 <Joubu> because he left
15:01:10 <marcelr> the chair left :)
15:01:14 <tcohen> #startvote should we adopt 4-space indentation globally?
15:01:14 <huginn> Begin voting on:  should we adopt 4-space indentation globally? Valid vote options are Yes, No.
15:01:14 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
15:01:22 <marcelr> #vote Yes
15:01:25 <tcohen> #vote Yes
15:01:29 <cc_> #vote Yes
15:01:39 <greenjimll> #vote Yes
15:01:44 <thd> #vote Yes
15:01:48 <ashimema> Indeed.. that somewhat caught me by surprise.. I hadn't realised the boss had actually volunteered me.. we'd had the chat but I didn't realise it had reached it's conclusion ;)
15:01:48 <ashimema> all good
15:01:49 <Joubu> #vote no
15:01:49 <tuxayo> #vote Yes
15:01:55 * ashimema likes 2 space indentation for perl personally
15:02:09 <Joubu> lol
15:02:23 <tcohen> ashimema: LOL but that's not under discussion hehe
15:02:26 * ashimema uses the mojolicious projects perltidy config for all projects other than Koha to date..
15:02:43 <ashimema> #vote no
15:03:00 <ashimema> lol
15:03:23 <tcohen> ok
15:03:30 <Joubu> I am voting no because it should be applied strictly. ok for new files, new blocks, not to add a 4 spaces alignement inside a 2 space align block
15:03:40 <tuxayo> Should the vote have been between various alternatives?
15:03:42 <Joubu> maybe it's a yes then
15:04:18 * thd prefers tab indentation which may appear as two spaces in editor but I think that is a lost position in Koha.
15:04:27 <tcohen> Joubu: you agree, you are talking about how we phase into that
15:05:02 <tcohen> thd: anyone can 'see' it as they like with tabs
15:05:30 <tcohen> ok
15:05:30 <josef_moravec> #vote yes
15:05:36 <tcohen> #endvote
15:05:36 <huginn> Voted on " should we adopt 4-space indentation globally?" Results are
15:05:39 <thd> tcohen: Exactly, which is why I like tabs.
15:06:08 <tuxayo> thd: tcohen : With tabs we loose some possibilities of alignment which require a fixed size
15:06:40 <tcohen> coward
15:06:59 <greenjimll> So does this now mean we've a "you touch it, you fix it" rule for tweaking indentation in existing files?
15:07:05 <tcohen> #info Yes: 7, No: 2
15:07:05 <tuxayo> But the balance could still be in favor of tabs is the pros are heavier
15:07:31 <Joubu> nothing else?
15:07:31 <wahanui> nothing else is priority
15:07:38 <Joubu> #topic Set time of next meeting
15:07:47 <thd> tuxayo: It would be fixed according to however you set your view of tabs or am I missing something?
15:07:53 <tuxayo> greenjimll: what is "it": whole file, method, block, line?
15:08:57 <thd> Did we vote about about any issue of strict or relaxed?
15:09:08 <Joubu> Next meeting: 23 May 2018, 19, 20, 21 UTC?
15:09:14 <greenjimll> tuxayo: Good question. What I was playing with yesterday did bits all over basketgroup.tt and basketgroup.pl. Having to fix the whole file would be a pain, but it would fit in with the "strict spacing".
15:09:38 <thd> 20 is now better for me most of the time.
15:10:49 <Joubu> last dev meeting at 21, we were 3...
15:10:57 <tuxayo> thd "Did we vote about about any issue of strict or relaxed"
15:10:57 <greenjimll> Before we close the meeting are we going to decide on what the 4 space rule applies to when making patches?
15:10:57 <tuxayo> +1
15:11:28 <thd> 19 would be even better for me but perhaps not for others.
15:12:02 <greenjimll> 20 or 21 UTC for me.
15:12:55 <Joubu> #Next meeting: 23 May 2018, 20UTC?
15:12:57 <Joubu> #endmeeting