14:02:55 <caroline> #startmeeting Documentation IRC meeting 14 August 2018
14:02:55 <huginn`> Meeting started Tue Aug 14 14:02:55 2018 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:55 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:55 <huginn`> The meeting name has been set to 'documentation_irc_meeting_14_august_2018'
14:03:17 <caroline> #topic Introductions
14:03:35 <caroline> (please use "#info" in front of your introduction to have it show up in the automatic minutes)
14:03:53 <caroline> Oh right, wahanui is not here
14:03:58 <Joubu> #info Jonathan Druart
14:04:08 <caroline> #info Caroline Cyr La Rose, inLibro
14:04:41 <caroline> cait?
14:04:41 <ashimema> #info Martin Renvoize, PTFS Europe
14:04:47 <cait> #info Katrin Fischer, BSZ, Germany
14:04:52 <cait> sorry, too easily distracted today
14:05:25 <caroline> #topic What's been done so far
14:06:02 <caroline> So LeeJ is not here, I guess he would be more up to date as to what has been done
14:06:22 <cait> i think we have some patches waiting to be merged right now
14:06:28 <cait> like your work on homebound?
14:06:28 <caroline> I've seen that there are a couple of merge requests on gitlab
14:06:31 <lucyvh> #info Lucy Vaux-Harvey, PTFS Europe
14:06:46 <georgew> #info George Williams, NEKLS
14:07:25 <caroline> Yes, about homebound, maybe you've seen my rant on Taiga
14:07:33 * ashimema reminds himself whats on the taiga
14:07:35 <cait> ah, not got the email, maybe i shoudl check!
14:07:44 <cait> caroline: can you share a link maybe?
14:07:58 <cait> you can use #link for the logs
14:07:59 <caroline> one sec
14:08:20 <cait> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_14_August_2018 Agenda
14:08:26 <cait> logs = minutes
14:08:58 * ashimema finds taiga hard to navigate
14:09:27 <caroline> #link https://tree.taiga.io/project/ldjamison-kohadocs-1805/task/561
14:09:49 <cait> ii ttakes a little getting used to, but i like it
14:09:53 <caroline> I was thinking we could get someone who's using the module to maybe write a use case?
14:10:09 <caroline> Sorry, context:
14:10:14 <ashimema> this one: https://tree.taiga.io/project/ldjamison-kohadocs-1805/task/561
14:10:38 <caroline> I wrote the housebound section, but I'm having a hard time getting an idea how this would be used in real life
14:10:41 <ashimema> lucyvh: do we have any internal docs regarding housebound we can share to help caroline
14:10:47 <cait> ashimema:  you have some using it i think?
14:11:13 <cait> i think the functionality in Koha is not the issue... but as she states, how to you actually use the features for organizing the workflow
14:11:17 <cait> i think maybe reports?
14:11:36 <cait> and caroline++ :)
14:11:44 <caroline> :)
14:12:00 <cait> i am totally with you on explaining how to use things real life
14:12:43 <ashimema> I just asked one of our trainers above ^ if we have some internal docs we can share.. it's been a while since we've trained it though.. customers use it.. but not large numbers of them
14:13:17 <caroline> do they have like procedures that they use? I could include that in the section maybe?
14:13:27 <cait> #action ashimea to see about sharing internal docs for homebound/real use case info
14:13:36 <cait> hm not sure i can action, but like that :)
14:13:42 <ashimema> yeah.. she typo'd that.. can't be me ;)
14:13:42 <lucyvh> We've probably got a training powerpoint, not any scenarios though
14:13:56 <caroline> thank you cait, I keep forgetting :)
14:14:37 <ashimema> thanks lucyvh
14:14:47 <caroline> lucyvh: can you send the ppt to me? I'll see if I can get more info out of it
14:15:28 <lucyvh> Caroline, will do
14:15:35 <caroline> thanks!
14:15:52 <caroline> #action lucyvh will send training ppt to caroline
14:16:06 <cait> :)
14:16:33 <caroline> anybody else want to share what they've done?
14:16:53 <cait> I've rewritten patron import a bit and updated it - i think it needs to be merged still
14:17:06 <cait> and i've split up another chapter on LeeJ's request
14:17:14 <caroline> yes, I'm looking at the merge requests right now
14:17:22 <caroline> #link https://gitlab.com/koha-community/koha-manual/merge_requests
14:17:34 <caroline> I see ashimema has been active too
14:17:40 <cait> https://tree.taiga.io/project/ldjamison-kohadocs-1805/task/440
14:18:11 <ashimema> not all that recently.. but I am trying to set an example by submitting a docs patch along with any developments we submit of late
14:18:14 <cait> ashimema++
14:18:33 <caroline> cool! ashimema++
14:19:31 <caroline> Joubu has also been adding issues to gitlab
14:20:18 <caroline> maybe we can talk about this in the next topic
14:20:25 <caroline> #topic Workflows
14:21:04 <caroline> Who added the https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual to the section?
14:21:22 <cait> hm?
14:21:30 <cait> sorry, to which section?
14:21:35 <cait> I wrote some of the page
14:21:48 <caroline> There is a bullet point in the Workflow topic about Editing the manual
14:21:59 <cait> aah
14:22:02 <caroline> I'm guessing someone wanted to talk about it
14:22:13 <cait> i think it might have carried over
14:22:21 <cait> from last meetings
14:22:21 <ashimema> davidnind by the looks
14:23:02 <cait> i think it was just there when he added the page from the last one
14:23:17 <cait> but maybe a workflow question would be where to encourage people to add new issues
14:23:24 <cait> not all people have taiga accoutns
14:23:26 <caroline> I don't know if I did that since the last meeting or before, but I added a section to that wiki page about working in a local repository
14:23:43 <cait> shoudl we encourage using the issues on gitlab too or better not? we also have a keyword in bugzilla
14:23:45 <cait> and a module
14:23:59 <cait> caroline++ again for that :)
14:24:52 <caroline> I don't know if I'm being too anal, but I have a feeling we are dispersing the tasks
14:25:18 <caroline> We have a framapad too, in addition to gitlab issues and taiga
14:25:24 <cait> disperse?
14:25:32 <ashimema> mmm..
14:25:39 <ashimema> I felt that.. there's too many places this stuff lives..
14:25:39 <cait> ah yes, sorry, had to look up the word :)
14:25:46 <cait> that's my feeling too, too many entry points
14:25:46 <ashimema> It's really hard to know where to look
14:25:56 <cait> i think maybe we could kill the framapad
14:26:04 <cait> i used that before taiga was introduced
14:26:55 <caroline> Could we maybe add a footer in the manual saying that if readers see errors or something that is missing they should file a bug in bugzilla?
14:27:13 <ashimema> do you guys use the WIP flag in your merge requests
14:27:15 <cait> not sure how the footer works, but we could definitely put something in the beginning of the manual
14:27:33 <georgew> If we got rid of the framapad, I'd be in favor of caroline's suggestion about filing a bug in bugzilla
14:27:45 <cait> yes, i think that makes most sense
14:27:56 <cait> encouraging people to use bugzilla is good and registration is easy
14:28:06 <georgew> I come to these meetings mostly so I can tell the people in koh-US what's going on and one of the things I like about the Framapad is that it's easy
14:28:06 <ashimema> to date I've used it to highlight that my submission is awaiting the bug being pushed from bugzilla before it makes sense to go into the manual (adding WIP at the beggining of the merge request name prevent an early merge)
14:28:17 <caroline> on the other hand, the framapad is easy and no registration is needed
14:28:21 <georgew> But, I've never seen anyone that I've encouraged to use it actually use it.
14:28:37 <caroline> georgew: lol!
14:29:42 <caroline> do we have an email address where people who don't have bugzilla account could just send us a quick email?
14:29:45 <cait> looking at it.... we should at least clean it up
14:29:50 <cait> there is a list
14:29:57 <cait> koha-docs i think, sec
14:30:18 <cait> i didn't have power of that in the beginning, but sent LeeJ the password when handing over
14:30:19 <cait> http://lists.koha-community.org/cgi-bin/mailman/listinfo/koha-docs
14:30:29 <cait> so we have admin there and it should now work as the other lists (I hope)
14:30:44 <cait> but no public archives it appears hm
14:31:00 <cait> maybe requires someone to look over the config
14:31:31 <cait> so we got: framapad, bugzilla, gitlab-issues, taiga and mailing list...
14:31:48 <caroline> Is there a default assignee for documentation bugs on bugzilla?
14:31:52 <georgew> that's too many
14:32:03 <cait> if we keep the framapad I suggest cleaning - and maybe discourage use of gitlab-issues?
14:32:31 <georgew> is there a way to connect gitlab issues and taiga?
14:32:43 <cait> i am not sure
14:33:05 <caroline> There is an integration with gitlab
14:33:25 * ashimema likes gtlab issues + bugzilla.. no idea what going on in taiga or framapad
14:33:33 <ashimema> https://tree.taiga.io/support/integrations/gitlab-integration/
14:34:24 <caroline> I like taiga more than bugzilla because I find it easier to use, but maybe that's just because I use it more
14:34:35 <caroline> and also, it's prettier! :)
14:35:09 <caroline> I know you devs don't worry about pretty, but it's important! ;)
14:35:41 <cait> hehe
14:35:50 <cait> i think it could still be useful as an internal tool for core docs team
14:35:54 * ashimema isn't a fan of bugzilla.. but it's what the community have been using for dev for ever
14:36:18 <caroline> so we keep bugzilla for sure since it's core to koha
14:36:43 * ashimema likes pretty.. and functional
14:36:54 <bag> bug 14697
14:36:54 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=14697 enhancement, P5 - low, ---, kyle.m.hall, NEW , Extend and enhance "Claims returned" lost status
14:36:54 <cait> we also have the release notes there and need to refer to it, so i think it makes sense
14:36:56 <caroline> we still have taiga, framapad, gitlab issues and mailing list
14:37:04 <bag> bug 20210
14:37:04 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20210 enhancement, P5 - low, ---, jesse, NEW , Claimed Return
14:37:31 <cait> I advertised the mailing list, but if I didn't miss anything, it's not really been used
14:37:32 <georgew> I'm reading the gitlab integration and it looks like if we integrate the two, gitlab issues will get pushed to taiga
14:37:36 <cait> so maybe we can just ignore it for now
14:37:40 <caroline> I haven't seen anything in the mailing list for a while
14:37:45 <cait> or we could have it killed
14:37:59 <georgew> so if we do that, discouraging gitlab issues stops being a problem
14:38:10 <caroline> maybe ppl use the main mailing list for questions relating to the manual
14:38:50 <cait> it's low maint for us right now... so it hink keeping it is not an issue
14:38:55 <caroline> ok
14:39:03 <caroline> framapad?
14:39:04 <cait> the framapad needs someone to look at it regularly
14:39:07 <cait> that's more an issue i think
14:39:18 <cait> mail pushes into your inbox, no need to think about it (mailing list)
14:39:29 <caroline> do we know if there are any changes to framapad recently?
14:39:40 <cait> georgew: do you think registration for bugzilla would be too much of a hurdle if there was no framapad?
14:39:46 <cait> i think it has a time line
14:39:54 <georgew> no, I don't think that's a problem at all
14:39:56 <cait> we could always save a last version too
14:40:47 <caroline> I see that a lot has been added to taiga already
14:41:07 <caroline> I could go through and add the rest and then delete it
14:41:09 <georgew> the biggest barrier for end users is, when they have a problem, they don't know what to do to solve the problem - they don't know who to contact or how to contact them
14:41:12 <cait> +1
14:41:19 <cait> if you can't delete - put a big note to use bugzilla
14:41:20 <cait> :)
14:41:30 <cait> and delete from wiki
14:41:41 <caroline> that's what I think too that's why I was proposing to add a note to the manuel
14:41:45 <caroline> *manual
14:41:52 <georgew> that's why having too many avenues for contact is a bigger problem than having too few
14:42:17 <cait> so maybe just tell them: manual - make a new bug with module "Documentation"
14:42:55 <caroline> #action caroline will go through the framapad and add what needs to be added to taiga and then either close it or send ppl over to bugzilla
14:42:59 <georgew> yes.  that's simple enough
14:43:17 <georgew> for my own libraries, I just tell them to tell me
14:43:26 <caroline> we could add a section to the manual on how to file a bug for the manual XD
14:43:29 <georgew> and some of them actually do that
14:43:31 <cait> so we agree recommended point of entry is bugzilla? then we could add it as #agreed
14:43:40 <cait> caroline: +1
14:44:00 <caroline> #agreed the recommended point of entry for documentation issues is bugzilla (module Documentation)
14:44:15 <cait> #idea Add a section to the manual on how to file a bug for the manual
14:44:27 <georgew> cait: +1
14:44:31 <caroline> it was a joke but ok! :)
14:44:36 <cait> no, i like it :)
14:45:03 <caroline> gitlab issues? Joubu seems to use it more?
14:46:07 <caroline> Joubu what are the advantages of this vs the other methods?
14:46:11 <caroline> (is he still here?)
14:46:30 <Joubu> as we moved our sideprojects to gitlab it would make sense to use gitlab
14:46:51 <Joubu> given the numbers of contributors it should not be a problem anyway
14:47:30 <cait> Joubu: the contribs here are librarians
14:47:32 <cait> for filing issues
14:47:36 <cait> i think gitlab might be too scary
14:47:52 <cait> also then they need to differentiate - manual goes to gitlab, others go to bugzilla
14:48:14 <Joubu> I would just say "use whichever it better for you" :)
14:48:26 <cait> maybe as gitlab is not so much used, postpone and see?
14:48:31 <caroline> I think we agreed that bugzilla is for librarians/end users
14:48:42 <cait> yep
14:48:44 <georgew> yes
14:48:44 <caroline> the rest is more of a workflow question
14:48:49 <caroline> for us
14:49:18 <cait> i took careof the only content issueon gitlab
14:49:28 <cait> the others are for how the manual works/is generated
14:49:46 <caroline> ok good to know
14:50:09 <cait> #link https://gitlab.com/koha-community/koha-manual/issues
14:50:39 <caroline> so we keep bugzilla for end users, taiga for us, gitlab issues for manual generation
14:50:53 <caroline> would that make sense?
14:51:06 <cait> we can try it out :)
14:51:18 <caroline> kill framapad and status quo on the mailing list
14:51:35 <caroline> #info we keep bugzilla for end users, taiga for us, gitlab issues for manual generation
14:51:38 <caroline> #info kill framapad and status quo on the mailing list
14:51:49 <georgew> sounds awesome
14:51:53 <caroline> right, anything else on this topic?
14:52:05 <cait> nope, just that i need to leave soon
14:52:09 <caroline> #topic Next steps
14:52:18 <caroline> We'll go faster
14:52:32 <caroline> There was a discussion point about Translation?
14:52:57 <caroline> anybody want to comment?
14:53:28 <caroline> we can also keep it for next time when LeeJ and/or davidnind are here
14:54:07 <cait> i think also a standing topic
14:54:16 <ashimema> was it translation that was holding back bug 19817 in part?
14:54:16 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19817 new feature, P5 - low, ---, jonathan.druart, Needs Signoff , Merge local and online documentations
14:54:16 <cait> could postpone to next meeting
14:54:23 <cait> ashimema: it's solved
14:54:26 <cait> translations work now
14:54:34 <caroline> #info Translation discussion is postponed to next meeting
14:54:49 <caroline> #topic Set time of next meeting
14:54:54 <cait> #link https://koha-community.org/documentation/ Translated 18.05 manuals from Sphinx
14:55:31 <cait> just don't look at the German one - we didn't get very far yet
14:55:42 <caroline> There is already a general meeting on Sept 5
14:55:42 <ashimema> we need a signoff and qa on that bug.. I'm overloading myself with bugs at the minute already.. but I do feel that one should go into master sooner rather than later again
14:55:53 <cait> very true
14:56:09 <cait> bit the same for me right now :(
14:56:26 <cait> i could try and do QA
14:56:30 <caroline> #info bug 19817 need signoff and qa
14:57:40 <cait> move on?
14:57:42 <caroline> is everyone ok for a meeting sept 4? or after kohacon?
14:57:58 <cait> sept 4 would work for me
14:58:12 <georgew> september 4 is good here
14:58:15 <caroline> what time are we at in the rotation?
14:59:03 <caroline> 14UTC is Europe and America only
14:59:06 * Joubu did not pay ashimema to bring attention on 19817
14:59:07 <cait> meeting before this was 21 utc
14:59:17 <caroline> we should do one where NZ is present
14:59:33 <cait> i thnk that's 7 am there
14:59:34 * ashimema may have had to probe Joubu to remind him of the bug number though ;)
14:59:43 <cait> but my calc might be totall yof
14:59:45 <cait> off
15:00:00 <cait> oh yes it is
15:00:05 <cait> 21 shoudlwork for nz
15:00:11 <cait> late in europe - 11pc
15:00:12 <cait> pm
15:00:27 <caroline> ok so 21UTC on sept 4?
15:00:39 <ashimema> :+1:
15:00:48 <cait> +1
15:00:54 <georgew> +1
15:01:12 <caroline> #info Next meeting: 4 september 2019, 21 UTC
15:01:21 <caroline> #endmeeting