21:09:15 <LeeJ> #startmeeting Documentation IRC meeting 4 September 2018
21:09:15 <huginn`> Meeting started Tue Sep  4 21:09:15 2018 UTC.  The chair is LeeJ. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:09:15 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:09:15 <huginn`> The meeting name has been set to 'documentation_irc_meeting_4_september_2018'
21:09:30 <LeeJ> #topic Introductions
21:09:40 <LeeJ> #info Lee Jamison, Marywood University
21:09:58 <caroline_> #info Caroline Cyr La Rose, inLibro
21:10:14 <kellym> #info Kelly McElligott Bywatert
21:10:23 <davidnind> #info David Nind, Wellington, New Zealand
21:11:03 * LeeJ pokes cait
21:11:39 <cait> #info Katrin Fischer, Germany
21:11:54 <LeeJ> #topic What's been done so far
21:12:30 <LeeJ> for a change, I'm relying on all of you for this one :) haha
21:12:51 * caroline_ raises hand
21:12:58 <LeeJ> caroline_: all you :)
21:13:47 <caroline_> Last meeting we discussed closing the framapad in favour of Taiga, so I went through all the points in the pad and added them to taiga
21:13:56 <LeeJ> caroline_++
21:14:04 <LeeJ> caroline_: thank you :)
21:14:18 <caroline_> The pad now has a link to bugzilla for people who might have favourited it and want to report documentation "bugs"
21:14:32 <caroline_> that's all
21:14:37 <LeeJ> I agree with that since that was the original intention of moving from framapad to taiga
21:15:12 <LeeJ> caroline_: hmm..should that go to bugzilla? or to the gitlab issues under koha-manual?
21:15:44 <LeeJ> cait davidnind kellym thoughts?
21:15:58 <caroline_> LeeJ: to keep you up to speed, the decision was to use bugzilla for regular people to filed documentation requests, taiga for the docs team and gitlab issues for issues concerning the "generation" of the manual
21:16:05 <caroline_> *file
21:16:09 <LeeJ> ah!
21:16:24 <LeeJ> disregard my question then..that makes sense
21:16:34 <cait> I removed the link to the framapad from the wiki
21:16:36 <caroline_> we also decided on a status quo for the mailing list since it's not very busy
21:17:08 <LeeJ> I'll have to go through the last meeting's minutes tonight/tomorrow to catch up haha
21:17:17 <kellym> I am not sure!
21:17:38 <LeeJ> kellym: disregard my question..caroline cleared it up1
21:17:40 <LeeJ> *up!
21:17:52 <kellym> good- I too will have to look at last months notes
21:18:36 <LeeJ> #link https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_14_August_2018
21:18:46 <kellym> thanks leej
21:19:02 <LeeJ> anyone have anything else to add before we talk about what to do moving forward?
21:19:21 <davidnind> nothing from me - have started a couple of more easier tasks, just need to finish and submit!
21:19:31 <LeeJ> davidnind++
21:19:37 <davidnind> have been very lazy....
21:19:58 <LeeJ> davidnind: I see your lazy and raise you lazy but busy :P
21:20:32 <LeeJ> okay then!
21:20:42 <LeeJ> #topic Next steps
21:21:56 <LeeJ> #info currently 6 merge requests in queue - 2 WIP, 2 ready to merge, and one to address with the person who submitted it (since LeeJ forgot/neglected to respond about it previously)
21:22:46 <LeeJ> caroline_ davidnind cait kellym anything to add regarding moving forward towards release? suggestions/things to point out/ideas, etc.?
21:23:11 <cait> nothing to add from me
21:23:20 <cait> busy with qa, might join documentation efforts late
21:23:22 <caroline_> do release notes come out one by one or all at the same time?
21:23:31 <cait> depends on RM
21:23:39 <caroline_> last release I know davidnind and LeeJ added all the release notes to taiga
21:23:50 <kellym> no, I would like to help, but need to get more familiar with the new way of updating. Was there going to be a tutorial on adding images to the manual for edits/updates? I am excited for Kohacon presentation about Documentation
21:23:54 <cait> Joubu generate d them regularly and early, not sure if that script still works
21:24:08 <LeeJ> caroline_: correct..last release Joubu had a rolling release notes doc that davidnind and I scraped from
21:24:10 <davidnind> mainly LeeJ did that
21:24:16 <cait> kellym: we can cover that at the hackfest maybe
21:24:18 <cait> wil you be there?
21:24:44 <kellym> I won’t be at Hackfest, just the first few days. Cait will you be there, can we catch up about this?
21:24:56 <cait> i will be there and we can try
21:24:57 <LeeJ> kellym I'm always available to discuss via phone/email or give help with..but probably the presentation will cover it...unfortunately I can't attend this year :(
21:25:08 <cait> not sure if we will get to images
21:25:25 <caroline_> I can add a section on images on the wiki
21:25:30 <LeeJ> caroline_++
21:25:40 <caroline_> On this page : https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual
21:25:46 <cait> but asking caroline might work even better :)
21:25:50 <kellym> I heard you wouldn’t be there LeeJ - too bad!  But once I see the presentation, maybe I will get in touch with you after the conference at some point,  Awesome Caroline_
21:26:07 <kellym> or I will ask caroline_
21:26:12 <caroline_> #action caroline_ will add a section on the wiki about adding images to the manual
21:26:27 <LeeJ> kellym either way works for me :)
21:26:36 <kellym> awesome
21:26:45 <LeeJ> anything else to add from anyone? :)
21:27:07 <davidnind> would like to categorise the images somehow - it's getting to be a loooong list - will post ideas on docs mailing list
21:27:09 <caroline_> kellym: I'll try to do it before kohacon (if I have time) so you can read it and follow up with question
21:27:20 <caroline_> davidnind: good idea!!
21:27:28 <caroline_> davidnind++
21:27:36 <LeeJ> davidnind++
21:27:38 <kellym> that would be great caroline_
21:27:43 <kellym> @caroline_++
21:27:44 <huginn`> kellym: I suck
21:27:52 <kellym> caroline_++
21:28:04 <kellym> davidnind++
21:28:22 <davidnind> everyone ++ :)
21:28:50 <cait> davidnind maybe we could have different areas of numbers for different sections?
21:29:01 <cait> i think the image are going to conflict a lot if everyone tries to use the next number
21:29:12 <cait> not sure how to solve that best
21:29:37 <cait> caroline_++ davidnind++
21:29:57 <LeeJ> cait: perhaps that could be a thinking point between now and next meeting?
21:30:21 <cait> sure
21:30:27 <davidnind> that was my thought e.g. 01 for cataloguing, then a sequential number e.g. 01-001-image-name
21:30:46 <LeeJ> davidnind: I like that format
21:31:10 <davidnind> there are some librarians around, 'we' could come up with some sort of categorisation scheme I'm sure :-D
21:31:16 <caroline_> as long as it's not tied to chapters because those tend to change
21:31:43 <caroline_> mwahaha! images will be classified like a boss!
21:31:44 <LeeJ> what if it's tied to modules...?
21:31:46 <davidnind> tied to modules I think
21:31:57 <kellym> modules is the best way
21:32:01 <LeeJ> like 01 for cataloging, 02 for circulation, etc.
21:32:10 <davidnind> yep
21:32:35 <LeeJ> which would make it basically a namespace (for my fellow OOP-minded individuals)
21:32:58 <davidnind> it would still get to be a long list, but at least you would be looking in the right area
21:33:07 <cait> maybe it oculd also be cat0001
21:33:08 <cait> ?
21:33:11 <cait> memo codes
21:33:20 <LeeJ> cait: that too!
21:33:21 <caroline_> and it would creat less conflicts like cait said
21:33:43 <lavamind> ouch, we're being bitten by https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18723
21:33:43 <huginn`> 04Bug 18723: critical, P5 - low, ---, victor.grousset, BLOCKED , Dot not recognized as decimal separator
21:34:07 <lavamind> any idea if this is going to be fixed in a upcoming point release ?
21:34:31 <LeeJ> lavamind: we're currently in a meeting, would you mind waiting until after and you can get some help?
21:34:51 <lavamind> LeeJ: oh of course, sorry about that!!
21:35:01 <LeeJ> lavamind: no problem at all :)
21:35:38 <LeeJ> I think cait 's suggestion of prefixing with a 'module identifier' of sorts might make it easier for quick reference
21:35:59 <caroline_> I like that too
21:36:19 <LeeJ> so say cat0001, circ0002, acq0003, ser0004, cres0005, etc.
21:36:53 <LeeJ> thanks to davidnind for getting the ball rolling...the thought never crossed my mind :)
21:37:48 <davidnind> Trying to solve my own problem - working out what image is what without duplicating (or minimising any way)
21:38:38 <LeeJ> davidnind: and you always manage to help everyone else out simultaneously :)
21:39:50 <LeeJ> #action submit a RFC of sorts to the mailing list to determine a new naming/organization scheme for the koha-manual images which can be voted on in the October 2018 meeting
21:39:58 <LeeJ> sound good everyone?
21:40:04 <cait> +1
21:40:05 <caroline_> +1
21:40:08 <kellym> +1
21:40:09 <davidnind> +1
21:40:11 <LeeJ> sweet :)
21:40:51 <LeeJ> if no one has anything else we can wrap this meeting up
21:42:32 <LeeJ> #topic Set time of next meeting
21:43:16 <LeeJ> how do we feel about October 4th at the same time? Any objections?
21:43:50 <caroline_> October 3?
21:44:08 <cait> both should work for me
21:44:12 <LeeJ> *facepalm* I do that every time lol
21:44:20 <cait> weekend? holiday?
21:44:22 <cait> conflict?
21:44:32 <caroline_> No LeeJ it's not you. I just can't on Thursdays
21:45:04 <cait> ah first wednesday usually is general meeting
21:45:05 <davidnind> works fine for me - hope it is not tooo late or early for everyone else
21:45:15 <LeeJ> hmm...I just realized that would cut it close with my one class ending lol...October 2nd at the same time (tuesday)?
21:45:35 <caroline_> works for me
21:45:43 <davidnind> fine with me
21:45:48 <kellym> yup!
21:46:40 <LeeJ> #info Next meeting: 2 October 2018, 21:00 UTC
21:46:57 <LeeJ> #endmeeting