14:01:58 <kidclamp> #startmeeting General IRC meeting 10 January 2018
14:01:58 <huginn> Meeting started Wed Jan 10 14:01:58 2018 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:58 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:58 <huginn> The meeting name has been set to 'general_irc_meeting_10_january_2018'
14:02:06 <kidclamp> #topic Introductions
14:02:07 <wahanui> #info wahanui, a bot that has become sentient
14:02:20 <kidclamp> #info Nick Clemens, ByWater Solutions
14:02:25 <marcelr> #info Marcel de Rooy, Rijksmuseum
14:02:48 <Joubu> #info Jonathan Druart
14:02:49 <Joubu> qa_team?
14:02:50 <wahanui> well, qa_team is alex_a jajm marcelr khall kidclamp tcohen josef_moravec
14:02:51 <Joubu> rmaints?
14:02:51 <wahanui> rumour has it rmaints is kidclamp (17.11), fridolin (17.05), rangi (16.11)
14:03:09 <fridolin> yep
14:03:10 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:03:12 * kidclamp waves twice more
14:03:15 <alex_a> master_of_the_world?
14:03:24 <fridolin> #info Fridolin Somers, Biblibre, France
14:03:28 <alex_a> lol
14:03:30 <cait> #info Katrin Fischer, BSZ, Konstanz
14:03:35 <Joubu> #info last meeting was http://meetings.koha-community.org/2017/development_irc_meeting_27_december_2017.2017-12-27-20.08.html - votes on coding guidelines have been made
14:03:42 <jajm> #info Julian Maurice, BibLibre
14:03:45 <Joubu> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_10_January_2018
14:03:50 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_January_2018
14:04:05 <Joubu> #info both general and dev meetings now
14:04:18 <alex_a> #info Alex Arnaud, Biblibre, France
14:04:25 <ebegin> #info Eric Bégin, inLibro, Canada
14:04:41 <caroline> #info Caroline Cyr La Rose, inLibro, Canada
14:04:58 <ebegin> Salut caroline :-)
14:05:27 <kidclamp> #topic Announcements
14:05:31 <kidclamp> anybody?
14:05:31 <wahanui> The #koha IRC channel is populated by people from many timezones, sometimes even on weekends. However, if no one is here right now and you need help you should take a look at http://koha-community.org/support/
14:05:40 <nickr> #info Nick Rosasco - (back after a >12 year absence?!) - who might be able to scare up some free labor if the right thing can be found - Indiana, USA
14:05:53 <jzairo> #info Jessie Zairo, ByWater Solutions, USA
14:06:29 * Joubu should not have used #info in the intro...
14:06:53 <cait> too impatient ;)
14:06:56 <cait> h nickr!
14:06:59 * oleonard digs up evidence of nickr's existence from 2014
14:07:26 <josef_moravec_> #info Josef Moravec, Municipal library Usti nad Orlici, Czech Republic
14:07:36 <kidclamp> calling again for any announcements
14:07:46 <kidclamp> #info Happy belated birthday bag and paul_p
14:07:54 <cait> :)
14:08:05 <NateC> #info Nate Curulla, ByWater
14:08:08 <LeeJ> #info Lee Jamison, Marywood University
14:08:21 <Joubu> #info Happy non birthday tcohen
14:08:22 <mtompset> #info Mark Tompsett
14:08:30 <caboose> #info Michael Cabus, ByWater
14:08:53 <kidclamp> #topic Update from the Release manager (18.05)
14:08:59 <kidclamp> Joubu
14:09:16 <Joubu> Yep
14:09:41 <ebegin> Can we still make announcements ? :)
14:09:44 <Joubu> nothing important to tell
14:10:11 <Joubu> #info announcement - Hackfest in Marseille, registrations open ! http://lists.koha-community.org/pipermail/koha-devel/2018-January/044244.html
14:10:14 <Joubu> ebegin: yes :)
14:10:52 <ebegin> #infp annoncement - I want to let you know that francharb (former inLibro and BibLibre) has left the Koha community to work with multiple universities in Quebec in order to help them pick their next ILS. We will miss him :-( Thanks Francois for what you did for Koha !
14:10:53 <Joubu> #info refactoring still in progress, see email to koha-devel - http://lists.koha-community.org/pipermail/koha-devel/2018-January/044242.html
14:11:12 <Joubu> the point of the refactoring is to make the code cleaner, add code coverage and make it easier to maintain
14:11:29 <cait> francharb++ we will miss you and all the best for the future!
14:11:32 <Joubu> I really would like to see people involve in the SO and QA process. These patches are easy to write, but hard to maintain
14:11:58 <kidclamp> #info annoncement - I want to let you know that francharb (former inLibro and BibLibre) has left the Koha community to work with multiple universities in Quebec in order to help them pick their next ILS. We will miss him :-( Thanks Francois for what you did for Koha !
14:12:10 <Joubu> ebegin: what will be their next ILS? Koha?
14:12:21 <oleonard> Easy job ;)
14:12:53 <ebegin> I wish ! nothing is set yet.  This is a group of 19 university of so
14:13:02 <fridolin> francharb thanks for the mapple sirop you had sent ;)
14:13:18 <Joubu> #info I am waiting for Bernardo's answer to improve update of the manual po files (pottle <=> git repo)
14:14:07 <Joubu> #info I am waiting for drojf[m]'s answer to improve our packages building infrastucture
14:14:22 <khall> #info Kyle Hall, ByWater Solutions
14:14:46 <Joubu> #info I am waiting for QA team to QA all the things
14:14:59 <cait> heh
14:15:12 <kidclamp> #topic Update on releases
14:15:30 <kidclamp> #info 17.11 pushing patches now - will announce string freeze for 15th and release on 22nd
14:15:47 <kidclamp> #info 17.11.01 (and other stable) were released late but should be all set
14:16:21 <kidclamp> #info thanks all for help on my first release! (I didn't break all the Kohas!)
14:16:26 <kidclamp> fridolin?
14:16:27 <wahanui> it has been said that fridolin is busy at the moment, I asked him to backport the bug fix
14:16:49 <fridolin> kidclamp: release of 17.05.07
14:16:56 <fridolin> nothing special
14:17:21 <fridolin> just I saw you merged branch from security repo kidclamp
14:17:35 <fridolin> so I see a lot of commits twice
14:17:43 <fridolin> in 17.11.x branch
14:17:52 <kidclamp> ah
14:17:56 <kidclamp> i did break all the kohas
14:17:58 <fridolin> i think you should avoid merging
14:18:21 <Joubu> yes, please cherry-pick instead
14:18:28 <kidclamp> will do from now on
14:18:33 <Joubu> or rebase
14:18:57 <fridolin> i'd say push the same branch on security repo and gitmaster
14:19:12 <fridolin> i'm done
14:19:21 <Joubu> note for Rmaints: we asked Bernardo to create the PR with a valid commit author name/email, instead of "root"
14:19:40 <Joubu> something like "Koha Translate Team" will be used
14:19:42 <fridolin> +1
14:19:43 <mtompset> use sudo echo tee's to append one line at a time from git format-patch's. ;)
14:19:52 <cait> pushing should work - did it like that in the past
14:20:04 <kidclamp> #topic Updates from the QA team
14:20:20 <kidclamp> cait
14:20:25 <cait> typing sec
14:20:49 <cait> #info QA Team had a QA Sprint day on 21 December, queue went down from 154 to 118, currently around 90
14:20:58 <cait> #link https://wiki.koha-community.org/wiki/2017-12-21_QA_Sprint_Day QA Sprint Day 21 December
14:21:31 <andreashm> #info Andreas Hedström Mace, Stockholm University Library
14:21:34 <cait> will put more work on getting the older bugs out of the queue hopefully and I hope we can get the numbers further down
14:21:47 <andreashm> (late to the party as ever)
14:21:54 <cait> one more thing
14:21:54 <wahanui> hmmm... one more thing is I'm installing this new koha for and old version dumped database. besides kohaeupgrade-schema instancename     what shall i do?
14:22:25 <cait> #info New info page for QA on the wiki: https://wiki.koha-community.org/wiki/How_to_QA - read if you want to join us or to learn how the QA team works!
14:22:28 <Joubu> and please pick bug fixes before enhs, as always
14:22:33 <cait> it's WIP, but some info is there
14:23:08 <cait> the QA team is also looking for tutorials on:
14:23:09 <wahanui> okay, cait.
14:23:47 <cait> #info QA team is looking for tutorials on: Authentication - how to set up LDAP, CAS, Shibboleth, testing translatability
14:24:05 <cait> #info ... and a test database with a good amount of acq and/or subscription data
14:24:12 <Joubu> testing translatability?
14:24:29 <cait> how to check if something is translatable - i might take care of that one
14:25:26 <cait> that's it from me :)
14:25:46 <cait> [off] wahanui forget one more thing
14:26:03 <Joubu> QAers?
14:26:21 <kidclamp> nothing from me, hitting what I can when I can
14:26:33 <kidclamp> QAteam++
14:28:02 <kidclamp> #topic General development discussion (trends, ideas, ...)
14:28:12 <Joubu> yes, 2 from me
14:28:17 <Joubu> #topic refactoring
14:28:35 <Joubu> As I told previously, it is important to spend time on testing and make them in quickly
14:28:38 <ebegin> Joubu: I hate that topic :)
14:28:49 <Joubu> it's painful to maintain, and... easy to write
14:29:00 <Joubu> looking at the diff will show you how useful it is
14:29:21 <Joubu> the code after refactoring is much more easier to read and make much more sense (at least to me...)
14:29:36 <kidclamp> refactoring++
14:29:56 <Joubu> the goal is to uniformize the code: instead of having several routines that do the same things, we have only 1 method (with tests)
14:30:07 <cait> tests++
14:30:14 <Joubu> I'd like to say that Alex worked on Selenium tests as well
14:30:18 <cait> also we get rid of a lot of dead code I think
14:30:44 <ebegin> Are we the only one to have difficulties following those ?  This is really hard on us to update the submitted patches and keeping up to date.
14:30:44 <Joubu> there are 2 patches waiting for signoff, it's a start (and so blocker) for other patches.
14:31:07 <Joubu> I'd like to have much more selenium tests in 18.05, they are important to catch regression
14:31:10 <Joubu> s
14:31:25 <ebegin> I agree that this is important, however, I believe that we should also attack the performance issues
14:31:46 <Joubu> ebegin: that is the point, now it is hard to track what is perf killer
14:31:55 <Joubu> with everything in one place, it's much more easier
14:32:23 <ebegin> But when "everything" will be in place ?  I don't see the end.  Maybe you do :)
14:32:51 <Joubu> if we have Koha::Object (on top of dbic) everywhere (and clean our controller scripts) I could focus on how to improve perf
14:32:54 <cait> it's not a short process rewriting your API :)
14:33:09 <Joubu> what I see is that these patches do not get the attention I'd like
14:33:16 <kidclamp> long process, but each step helps
14:33:17 <Joubu> and so I have to wait 6 months to continue this work
14:33:25 <Joubu> I cannot rewrite everything in one go
14:33:26 <cait> we need more testers and testing to speed it up
14:33:31 <Joubu> steps by steps...
14:33:47 <cait> Members is almost gone now right?
14:34:13 <Joubu> For instance, we have a patch to improve zebra index (retrieve item's info), but it is specific to only 1 table/object (item)
14:34:33 <Joubu> so it is adding more and more code, but not generic => too much code to maintain, error prone, etc.
14:35:01 <Joubu> ebegin: do you face perf issues?
14:35:30 <Joubu> if yes, report it on bugzilla with benchmark and the area to blame
14:35:44 <ebegin> Mostly with use of Date/Time which are really really slow.
14:36:00 <Joubu> calendar related then?
14:36:21 <ebegin> Yep!  We actually submit patches related to this.
14:37:00 <ebegin> https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17015
14:37:00 <huginn> 04Bug 17015: enhancement, P5 - low, ---, david.bourgault, Signed Off , New Koha Calendar
14:37:37 <Joubu> so nothing new to report :)
14:37:55 <Joubu> next?
14:37:56 <wahanui> next is packaging manager... do we have a volunteer for that?
14:38:03 <Joubu> forget next
14:38:03 <wahanui> Joubu: I forgot next
14:38:22 <Joubu> #topic Merge local and online documentations
14:38:31 <Joubu> #link bug 19817
14:38:31 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19817 new feature, P5 - low, ---, jonathan.druart, In Discussion , Merge local and online documentations
14:38:43 <ebegin> Blou : if you have other performance issues other than the calendar, its a good time to report them :)
14:38:44 <LeeJ> yay documentation :D
14:38:45 <Joubu> I need feedback on that bug, if you are using the local help editor
14:38:54 <Joubu> I am going to work on that, but I need to know how people use it
14:39:14 <Joubu> I have time now to dedicate on that, I do not know if I will have in 2 months
14:39:27 <Joubu> so please have a look and tell me if you (or customers) are using it
14:39:34 <Joubu> and how we could improve it
14:39:44 <LeeJ> Joubu: perhaps we consider sending out some sort of questionnaire to the lists?
14:39:56 <Joubu> basically I am going to remove the local help pages (to point to the online manual), then add the ability to create local help pages
14:40:09 <caboose> love it Jobu
14:40:15 <ebegin> I was able to set Sphinx up to build the documentation but it was quite painful... especially the PDF version
14:40:43 <Joubu> and so remove the ability to *edit* the official manual (for that, you can contribute to the official version)
14:41:01 <Joubu> ebegin: it's quite easy, ping me late if you have questions (I only tested html IIRC)
14:41:10 <cait> epub works nicely too
14:41:11 <Joubu> mater*
14:41:12 <Joubu> later*
14:41:25 <cait> tested with Ubuntu
14:41:47 <LeeJ> Joubu: let me know if there's anything I can do to help you with the documentation merge :)
14:42:01 <Joubu> LeeJ: by answering my comment :)
14:42:12 <Joubu> and look at the patches I already submitted
14:42:21 <LeeJ> Joubu: I'm looking over the bug now
14:42:33 <ebegin> I didn't have any problem with epub and HTML.  PDF is harder and when we answer RFP, the PDF version is often the best version to provide :-)
14:42:45 <LeeJ> Joubu: I didn't have an answer because no one at our library uses the help files...because they just come straight to me to ask
14:42:47 <mtompset> Oopx... was slow on the draw... who is the packaging manager? Because unstable is 17.06... shouldn't it be 17.12?
14:42:56 <Joubu> I will test that after the meeting then
14:43:28 <Joubu> LeeJ: that's the point! How would you like to provide them a manual which could replace you? :D
14:43:35 <Joubu> they will stop bother you ;)
14:43:49 <cait> the main goal of deduplicating is also to ease maintenance - manual and help files drift apartand translators have to translate both separately right now
14:44:01 <ebegin> joubu : can you review the wiki for the installation of Sphinx ?  It was not really helpful : https://wiki.koha-community.org/wiki/Koha_Manual
14:44:08 <LeeJ> Joubu: haha fair enough
14:44:16 <cait> it's all in the readme
14:44:25 <cait> no need to duplicate to the wiki
14:44:45 <ebegin> So the wiki should be removed then.
14:44:46 <Joubu> ebegin: https://gitlab.com/koha-community-devs-users/kohadocs
14:45:03 <Joubu> I am expecting make pdf to do the job, but as I said I did not test it
14:45:06 <cait> it's linking to it, the kohadocs part was kept for historical reasons
14:45:47 <Joubu> Another "General development discussion" topic?
14:45:57 <nickr> Maybe?
14:45:57 <wahanui> i think Maybe is a momentaneous error
14:45:57 <kidclamp> just to ask for feedback on a few bugs
14:46:02 <kidclamp> bug 18639
14:46:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18639 major, P5 - low, ---, nick, Needs Signoff , Separate replacement cost and retail price fields in acquisitions
14:46:07 <ebegin> joubu : you're expectation are wrong :) there is no pdf, you have to use make latexpdf (and configure it before hand)
14:46:19 <kidclamp> bug 18736
14:46:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18736 critical, P5 - low, ---, nick, Needs Signoff , Problems in order calculations (rounding errors)
14:46:26 <kidclamp> bug 19166
14:46:26 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19166 enhancement, P5 - low, ---, nick, Needs Signoff , Add the ability to add adjustments to an invoice
14:46:49 <kidclamp> acq ultimatley needs some refactoring, but these bugs try to fix some large issues without making too many changes
14:48:30 <kidclamp> anyone else?
14:49:06 <kidclamp> #topic Set time of next meeting
14:49:07 <nickr> I'm not sure I'm in the correct (meeting) spot for this one, but I was
14:49:46 <nickr> told IRC was the place.... I'm a teach @ a midsize US University, and one of the courses I run (starting today, in fact) is the project course for CS majors.
14:50:08 <cait> nickr: one sec
14:50:16 <nickr> OK
14:50:17 <cait> i think we are strating the dev meeting after this one?
14:50:35 <cait> kidclamp: another meeting part? or are we done? because i think nickr has a topic for us :)
14:50:57 <kidclamp> we can add topic if you give a title :-)
14:51:16 <kidclamp> #chair cait
14:51:16 <huginn> Current chairs: cait kidclamp
14:51:19 <cait> eek
14:51:20 <kidclamp> #chair Joubu
14:51:20 <huginn> Current chairs: Joubu cait kidclamp
14:51:28 <cait> nickr: how sould we call it?
14:51:57 <nickr> "possible source of labor but with some overhead cost"?
14:52:08 <cait> heh
14:52:21 <cait> maybe just koha student projects? and then you can explain?
14:52:24 <nickr> Yep.
14:52:31 <cait> #topic Koha student projects
14:52:33 <cait> please start
14:52:39 <Joubu> erk
14:52:42 <nickr> OK
14:52:45 * Joubu has been disconnected
14:53:16 <nickr> I've got students in the "capstone" sort of course.  They get to pick a project (but I exercise some control by prepping the options/menu)
14:53:51 <nickr> Typically, they work in a team - so 2-4 or so students, sometimes with a bit of a spread in skills!.
14:54:47 <nickr> If there's something identifiable - either a somewhat contained redo/refactor? or something from scratch? - that they could work on, I'm willing to put a Koha "task" on their list.
14:55:08 <nickr> Preferably someone currently contributing would be ID'd as the liaison.
14:55:37 <Joubu> We indeed have a lot to do for students, it mostly depends on what they want to do
14:55:53 <kidclamp> should people email you wiht ideas nickr?
14:56:03 <ebegin> nickr : we start the training of most of our interns asking them to do a plugin.
14:56:11 <Joubu> The big step is to understand how the community work (workflow) and the code (it is quite huge)
14:56:24 <oleonard> nickr: rangi helps run student work on Koha during Catalyst Academy. He'd be a good person to hit up for strategies
14:56:31 <ebegin> That is a good way to learn the libraries without having to go to deep in the core
14:56:40 <nickr> Nod... I recall the hugeness (I'll confess to being involved about 12 years ago, mostly on the docs side of things)
14:57:15 <oleonard> Learn the process, learn the workflow, test some patches, submit some minor bug fixes. Work up from there.
14:57:17 <nickr> Emailing me w/ ideas would be great....
14:57:34 <Joubu> first things to do is 1. install a dev env, 2. signoff, 3. read the code, 4. bugfixes. And finally you can deep into the code :)
14:57:34 <cait> working on the manual might be good too, there are also related projects to koha like Hea that might be a bit more contained
14:57:35 <nickr> I'll also happily talk to rangi.
14:57:53 <kidclamp> can you send an email to the list to explain and ask suggestions nickr?
14:58:00 <nickr> sure, will do.
14:58:03 <cait> Catalyst Academy has it's project week next week
14:58:10 <nickr> gotcha. :)
14:58:23 <cait> maybe keep an eye on this one to see what they are working on: https://wiki.koha-community.org/wiki/Catalyst_Academy
14:58:27 <nickr> If it looks like too much setup hassle, it isn't an emergency for me!
14:58:31 <kidclamp> #info nickr is looking for Koha projects to assign to temas of CS students, email him with suggestions
14:58:48 <kidclamp> #info nickr will email the lists with more info
14:59:07 <nickr> Thanks so much!
14:59:14 <nickr> I'll be in touch...
14:59:37 <nickr> Part of the trick is to find something that'll motivate/intrigue them a bit. : )
15:00:16 <Joubu> we could also find something new, around the project
15:00:29 <nickr> ... and I'll freely admit I know from longtime mail list lurking and earlier volunteer work few places have this crowd beat on being a supportive community.
15:00:32 <LeeJ> nickr: I second the idea of plugins...they're fun to work on and help as a good primer about how Koha works :)
15:00:37 <kidclamp> any more topics?
15:00:43 <nickr> (thanks all!)
15:01:20 <cait> might have to make some suggestions,as they are not so familiar with libraries
15:01:37 <kidclamp> #topic Review of coding guidelines
15:01:54 <Joubu> #info tcohen is not around. "New rule SQL12: Booleans" vote is postponed
15:02:04 <ebegin> welcome back nickr :)
15:02:17 <Joubu> from the last meeting " action: cait improve the coding guidelines related to the use of SQL queries " did you?
15:02:19 <mtompset> What was SQL12 Booleans?
15:02:27 <cait> oops
15:02:30 <cait> sorry, not quite ready
15:02:35 <Joubu> mtompset: http://meetings.koha-community.org/2017/development_irc_meeting_27_december_2017.2017-12-27-20.08.html
15:02:40 <cait> please postpone
15:02:59 <kidclamp> #info Reminder to all - please add topics to the agenda :-)
15:03:03 <Joubu> #info "New rule "No DBIx::Class in atomic updates"" is postponed
15:03:10 <Joubu> #action cait cait improve the coding guidelines related to the use of SQL queries
15:03:30 <Joubu> To all, please...  "Write good commit messages"
15:03:52 <Joubu> see the last meeting minutes, I am going to be rude on the bug report, sorry in advance...
15:03:57 <Joubu> reports*
15:04:14 <marcelr> should that be on the guidelines too ?
15:04:19 <kidclamp> you can be strict and polite :-D
15:04:32 <Joubu> "Read https://wiki.koha-community.org/wiki/Commit_messages to know how to write valid commit messages (Joubu, 20:58:15)"
15:04:56 <Joubu> like
15:04:57 <Joubu> 1sec
15:05:02 <LeeJ> Joubu: you need to give tough love to all of us to make the product better :)
15:05:10 * mtompset crosses fingers.
15:05:14 <Joubu> 1. Patch's title starts with "Bug 12345: "
15:05:14 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=12345 enhancement, P5 - low, ---, oleonard, NEW , Can't Clear Reading History for Anonymous patron
15:05:26 <Joubu> 2. (QA follow-up) and (follow-up) are ok
15:05:37 <marcelr> hmm the good example is rather ugly
15:05:46 <Joubu> 3. Bug report titles are different from commit titles
15:06:15 <marcelr> authority searches in auth_finder error out
15:06:16 <Joubu> marcelr: I wrote the "examples" section
15:06:38 <Joubu> I'd also like to say:
15:06:42 <marcelr> nobody comes that far ;)
15:06:55 <Joubu> #info IMPORTANT - no need to add new subroutines to C4 namespace, it will be rejected
15:07:13 <Joubu> #info IMPORTANT - no need to add or update methods without test coverage, it will be rejected
15:07:44 <cait> scary Joubu
15:07:45 <Joubu> otherwise you and us are wasting our time
15:08:01 <cait> I'd also encourage devs to run qa tools if you don't already
15:08:13 <cait> Joubu: could we add something checking for new subroutines without test coverage?
15:08:24 <marcelr> we will reject your code unless stated otherwise ;)
15:08:39 <Joubu> cait: well, now people adds empty POD to make the script happy...
15:09:07 <cait> might have been by mistake
15:09:21 <Joubu> nope
15:09:25 <Joubu> next meeting?
15:09:26 <wahanui> next meeting is https://wiki.koha-community.org/wiki/Next_IRC_meetings
15:09:35 <mtompset> Plus adding test coverage means less regressions, and proof your code works. Harsh but good.
15:09:36 <clrh> you could have a "check before committing" in the wiki page with these "Important"
15:10:02 <kidclamp> #topic Set time of next meeting
15:10:11 <kidclamp> wiki page is good idea
15:10:28 <kidclamp> are these already in coding guidelines?
15:10:54 <Joubu> kidclamp: ? the mandatory tests and C4 deprecation?
15:10:57 <Joubu> yes ofc
15:11:00 <kidclamp> :-)
15:11:17 <cait> we might want to restructure and highlight
15:11:28 <kidclamp> Next dev meeting 24 January 2017 20 UTC?
15:11:29 <cait> part of my forgotton homework
15:11:36 <cait> I won't be there - travelling
15:11:47 <cait> but don't let that stop you :)
15:11:55 <kidclamp> Next General meeting 7 Feburary 2017 20 UTC?
15:11:57 <Joubu> #action clrh Add a "important check before committing/submission" to the wiki page
15:11:57 <Joubu> :D
15:12:21 <clrh> Joubu: I am trying
15:12:35 <Joubu> kidclamp: nope, 1month
15:12:38 <clrh> probably not in your good place :p
15:12:44 <Joubu> kidclamp: do not break the bot
15:12:58 <kidclamp> yes, wil only info the general
15:13:27 <kidclamp> hehe 2018 for both
15:14:21 <LeeJ> yay for different days for meetings! :D
15:14:43 <Joubu> I will not be around on 24th, but ok for me
15:15:01 <kidclamp> #info Next meeting: 7 February 2018, 20 UTC
15:15:14 <kidclamp> last call!
15:15:34 <kidclamp> #endmeeting