14:01:45 <kidclamp> #startmeeting General IRC meeting 14 November 2018
14:01:45 <huginn> Meeting started Wed Nov 14 14:01:45 2018 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:45 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:45 <huginn> The meeting name has been set to 'general_irc_meeting_14_november_2018'
14:01:56 <kidclamp> #topic Introductions
14:01:59 <ashimema> no-one added their name
14:02:05 <kidclamp> #info Nick Clemens, ByWater Solutions
14:02:06 <ashimema> #info Martin Renvoize, PTFS Europe
14:02:16 <magnuse> #info Magnus Enger, Libriotech, Norway
14:02:17 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:02:40 * magnuse gotta run in 30 minutes
14:02:43 <davidnind> #info David Nind, Wellington, New Zealand
14:02:57 <kidclamp> this should be quick, this was just to elect 18.05 maint and translation manager
14:03:17 * oleonard waves to 3AM in New Zealand
14:03:36 <magnuse> https://wiki.koha-community.org/wiki/Roles_for_19.05
14:03:52 <magnuse> davidnind++
14:04:23 <davidnind> waves, sleepily
14:04:25 <oleonard> Is fridolin here?
14:04:33 <fridolin> yep
14:04:48 <fridolin> #info Fridolin Somers, Biblibre, France
14:04:52 <kidclamp> #topic Announcements
14:05:04 <kidclamp> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_14_November_2018 Agenda
14:05:06 * fridolin current RMaint 17.11.x
14:05:23 <kidclamp> #info feature freeze is here, fix all the bugs!
14:05:26 <fridolin> David have a coffe or a bier
14:05:28 <kidclamp> anyone else?
14:05:47 <oleonard> I would like to announce that I'd like to get signoffs on a couple of bugs with simple fixes: Bug 21813 and Bug 21814
14:05:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21813 major, P5 - low, ---, oleonard, Needs Signoff , In-page JavaScript causes error on patron entry page
14:05:47 <davidnind> tea?
14:05:48 <ashimema> haha
14:05:49 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21814 major, P5 - low, ---, oleonard, Needs Signoff , System preferences save button can be hidden by language menu
14:05:50 <ashimema> +1
14:05:55 <ashimema> fix all th things
14:06:11 <oleonard> I think those two could make the release if we get them tested.
14:07:03 <ashimema> release notes are being rebuilt regularly now.. so point out the errors and lets get cleaning those up too
14:07:22 <kidclamp> #topic Update on releases
14:07:33 <kidclamp> fridolin ashimema
14:07:42 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:08:36 <ashimema> sorry.. someone dragged me to the door
14:08:39 <ashimema> bloomin cold caller
14:08:59 <ashimema> right.. no updated from me past what we said last week
14:09:06 <ashimema> manically catching up on the queue but as fast as I empty mine you fill it back up kidclamp ;)
14:09:20 <fridolin> jenkins broken on 17.11.x but its from jenkins
14:10:04 <fridolin> otherwise nothing special
14:10:39 <kidclamp> and I am just polishing the release etc. thanks to all for hard work in getting things fixed and ready to go
14:11:04 <kidclamp> #info stable releases continue, master is being prepared for release
14:11:34 <kidclamp> #topic Roles for 19.05 - 18.05 Rmaint and translation manager
14:12:33 <Joubu> #info Jonathan Druart
14:12:49 <kidclamp> Indranil has volunteered if bernardo isn't around and bernardo said he would go if no one else does - so we elect them both?
14:12:57 <kidclamp> :-)
14:13:20 <kidclamp> for 18.05 JesseM and lukeG volunteered with Kyle backing them up
14:13:23 <ashimema> sounds like a plan to me.. spread the load
14:14:29 * ashimema thinks kidclamp has been bullying colleagues 😉
14:14:52 <kidclamp> little old me?
14:15:13 <Joubu> yes, both sounds good to me
14:15:24 <Joubu> Bernardo needs to share his knowledges
14:15:53 <kidclamp> ok, ready to vote then?
14:16:07 <oleonard> I vote we vote
14:17:05 <ashimema> go for it
14:17:49 <kidclamp> #startvote Do we accept the 19.05 roles for 18.05 Rmaint and Translation manager teams as listed on the wiki page roles for 19.05? Yes, No, Abstain
14:17:49 <huginn> Begin voting on: Do we accept the 19.05 roles for 18.05 Rmaint and Translation manager teams as listed on the wiki page roles for 19.05? Valid vote options are Yes, No, Abstain.
14:17:49 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
14:17:54 <kidclamp> #vote Yes
14:17:57 <Joubu> #vote yes
14:17:59 <oleonard> #vote Yes
14:18:02 <ashimema> #vote Yes
14:18:06 <magnuse> #vote Yes
14:18:06 <davidnind> #vote yes
14:18:24 <Joubu> "as listed" :) when? what was listed?
14:18:34 <kidclamp> they are listed there now
14:18:47 <ashimema> it got listed just before he wrote the vote ;)
14:18:54 * ashimema refreshed to check
14:19:20 <kidclamp> heh, you voted before asking
14:19:24 <kidclamp> last call
14:19:25 <oleonard> As listed -- Oh no kidclamp is now dictator for life!
14:19:41 <kidclamp> bwahahahahahaa
14:19:50 <Joubu> so Indranil is not on the list
14:19:50 <kidclamp> #endvote
14:19:50 <huginn> Voted on "Do we accept the 19.05 roles for 18.05 Rmaint and Translation manager teams as listed on the wiki page roles for 19.05?" Results are
14:19:50 <huginn> Yes (6): Joubu, magnuse, davidnind, oleonard, ashimema, kidclamp
14:20:06 <kidclamp> he is, they are both listed for translation manager
14:20:16 * oleonard starts growing the now mandatory handlebar mustache
14:20:17 * ashimema just saw kidclamps job title at bywater and giggled
14:20:23 <kidclamp> #chair Joubu
14:20:23 <huginn> Current chairs: Joubu kidclamp
14:21:10 <Joubu> https://wiki.koha-community.org/wiki/Roles_for_18.11
14:21:21 <Joubu> "Translation Manager "
14:21:28 <kidclamp> https://wiki.koha-community.org/wiki/Roles_for_19.05
14:21:38 * Joubu hides
14:21:44 <Joubu> lol, sorry
14:21:57 <kidclamp> heh
14:22:11 <kidclamp> congratulations (condolences) to all
14:22:21 <Joubu> already 19.05!
14:22:39 <kidclamp> you want to introduce a new topic Joubu/
14:22:50 <Joubu> I would like to add more confusion, yes
14:23:05 <Joubu> #topic just yet another topic
14:23:15 <kidclamp> hah
14:23:27 <Joubu> maybe it does not make sense, but I am wondering if we should add a "rule" in the community
14:23:30 <Joubu> about the ML
14:24:00 <Joubu> should not we ask people to contact Koha developers *before* sending advertisement on the list?
14:24:29 <kidclamp> context?
14:24:32 <Joubu> if they do not, we could send a standard message saying that this tool/app/stuff is unknown by us and that we do not recommend using it
14:24:52 <Joubu> "Koha opac" app, for instance
14:25:14 <ashimema> yeah.. I'd be happy with that
14:25:39 <Joubu> I seem important to warn the user that we have no idea what these stuffs are
14:25:42 <Joubu> It*
14:25:47 <oleonard> How would we define 'advertisement?'
14:26:00 <oleonard> How would we police it?
14:26:13 <ashimema> we couldn't really
14:27:06 <Joubu> when Koha is written "KOHA" could be a first validation step
14:27:09 <kidclamp> I like protecting users, I don't like the idea of trying to limit posts
14:27:19 <Joubu> it's not limiting post
14:27:47 <Joubu> it's just: either or contact us first, or we will reply with a standard message to tell people we do not know what it is
14:27:53 <ashimema> I'm not sure about a rule preventing posts..
14:28:10 <ashimema> but I equaly don't have an issue with some clause saying that nothing said on the list is endorsed by the list
14:28:17 <Joubu> it happened 3x this year. Sometimes it's free software, other times it's not
14:28:35 <kidclamp> what will we do when they contact us?
14:28:44 <Joubu> [off] when it was free software the code was potentially dangerous
14:28:45 <oleonard> And who is "us" ?
14:28:51 <Joubu> koha-devel
14:29:15 <Joubu> I am not asking to take a decision know, just asking if it makes sense first
14:29:23 <Joubu> then if we should think about it
14:29:53 <kidclamp> I think a clause saying we don't endorse the list makes sense, and maybe a response to say that we don't endorse products and user should be awar who tey are installing from
14:30:01 <Joubu> [off] the idea could also be to prevent regional battles on the list
14:31:05 <kidclamp> are there guidelines for the list somewhere?
14:31:22 <Joubu> I do not think so
14:31:52 <oleonard> Not on the signup page
14:32:14 <kidclamp> I think this should be a list discussion maybe? I don't think we have enough people here, I am more for general guidelines about posts, but then we need moderators
14:32:44 <Joubu> yes sure, I wanted to launch the discussion, nothing more :)
14:32:50 <kidclamp> Joubu++
14:33:09 <ashimema> Joubu++
14:33:31 <Joubu> we could also have other things, like: if you want to report a bug, answer the following questions: 1. Koha version, 2. exact error message, etc.
14:34:32 <ashimema> ML guidelines/code of conduct would be good.. I wouldn't advocate any official moderation but rather if anyone feels sometihng goes against the guidlnes, make a case and discuss and one of the general meetings before a ban or similar
14:34:35 * oleonard would favor an automated rule rejecting posts which were cross-posted to more than one list
14:34:35 <kidclamp> yes, and something about "You found a security bug? please do not post instructions on exploiting it to the public list"
14:35:16 <kidclamp> #action Joubu will send an email to the mailing lists about setting guidelines for the mailing lists
14:35:23 <kidclamp> #topic Next meeting
14:36:05 <kidclamp> Dece,mber 5, 2018, 20 UTC?
14:36:25 <ashimema> +1
14:36:51 <davidnind> +1
14:36:58 <kidclamp> i did three weekes since this was a 'bonus' meeting
14:37:12 <oleonard> +1
14:37:15 <Joubu> do not mess the next meeting info! :D
14:37:27 <davidnind> we love our meetings :)
14:37:30 <ashimema> lol
14:38:01 <kidclamp> #info Next meeting: 5 December 2018, 20 UTC
14:38:22 <kidclamp> last chance to be recorded for posterity
14:38:52 <kidclamp> #endmeeting