14:03:50 <kidclamp> #startmeeting General IRC meeting 7 November 2018
14:03:50 <huginn> Meeting started Wed Nov  7 14:03:50 2018 UTC.  The chair is kidclamp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:50 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:50 <huginn> The meeting name has been set to 'general_irc_meeting_7_november_2018'
14:03:57 <kidclamp> #topic Introductions
14:04:05 <cait> #info Katrin Fischer, BSZ, Germany
14:04:06 <Joubu> #info Jonathan Druart
14:04:17 <ashimema> #info Martin Renvoize - PTFS Europe
14:04:20 <kidclamp> #info Nick Clemens, ByWaterSolutions
14:04:22 <andreashm> #info Andreas Hedström Mace, Stockholm University Library
14:04:25 <kidclamp> #chair cait
14:04:25 <huginn> Current chairs: cait kidclamp
14:04:28 <kidclamp> #chair Joubu
14:04:28 <huginn> Current chairs: Joubu cait kidclamp
14:04:38 <georgew> #info George Williams, Northeast Kansas Library System
14:04:44 <Joubu> qa_team?
14:04:49 <Joubu> wahanui: ?
14:04:49 <wahanui> i don't know, joubu
14:04:52 <AndrewIsh> #info Andrew Isherwood, PTFS Europe
14:04:56 <Joubu> rmaints?
14:04:56 <wahanui> hmmm... rmaints is ashimema and fridolin are the rmaints
14:05:07 <Joubu> wahanui: qa_team?
14:05:07 <wahanui> joubu: wish i knew
14:05:13 <fridolin> #info Fridolin Somers, Biblibre France
14:05:17 <fridolin> hé bonjour
14:05:24 <cait> memory loss?
14:05:33 <cait> Rmaints?
14:05:33 <wahanui> it has been said that Rmaints is ashimema and fridolin are the rmaints
14:05:43 <cait> Qa_team
14:05:45 <thd> #info Thomas Dukleth, Agogme, New York City
14:05:49 <kidclamp> QAteam?
14:05:50 <oleonard> #info Owen Leonard, Athens County Public Libraries, USA
14:06:02 <davidnind> #info David Nind, Wellington, New Zealand
14:06:05 <kidclamp> ppor wahanui
14:06:20 <cait> qa?
14:06:47 <cait> davidnind: sleep walking?
14:07:04 <ashimema> qa team
14:07:06 <fridolin> davidnind nice to see you :D
14:07:09 <kidclamp> alex_a, jajm, marcelr, khall, tcohen, josefmoravec, ashimema,rangi
14:07:21 <Joubu> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_7_November_2018
14:07:30 <davidnind> cait: feels like it!  Keep on waking up at ridiculous times!
14:07:37 <kidclamp> #topic Announcements
14:07:41 <davidnind> hi fridolin!
14:07:46 <ashimema> wahanui (IRC): qa team
14:07:46 <wahanui> qa team are the real gatekeepers, send cookies their way
14:07:55 * cait shrugs
14:08:02 <cait> he is not that wrong.... coooookies
14:08:22 <kidclamp> anybody have announcements?
14:08:44 <ashimema> feature slush ;)
14:09:04 <kidclamp> yup
14:09:27 <georgew> koha-US has a meeting today at 16:30 UTC
14:09:35 <cait> #info koha-US has a meeting today at 16:30 UTC
14:09:50 <georgew> I had the link a second ago.  hold on.
14:10:05 <cait> #info We have reached feature slush last Friday, going into feature freeze this Friday
14:10:25 <oleonard> I don't know the dates of the release stages... Don't see them on the calendar.... So feature freeze is when? String freeze?
14:10:26 * cait hopes that was right
14:10:36 <cait> oleonard: there as an email to the list sec
14:10:38 <kidclamp> #info Koha Development IRC meeting later today as well
14:10:45 * ashimema sent a long message:  < https://matrix.org/_matrix/media/v1/download/matrix.org/rVKjeagJmrvZSUhIwPPOTIQH >
14:11:07 <cait> long message thing
14:11:18 <kidclamp> sorry oleonard , i got your later and did not get them set there
14:11:20 <Joubu> November   9 - Feature freeze - only bugfixes will pushed after this - 1st draft of release notes
14:11:20 <cait> Sep 25, 2018; 12:06pm 	 					 		Koha 18.11 Dates
14:11:23 <Joubu> November 16 - String Freeze - 2nd draft of release notes
14:11:25 <Joubu> November 27 - Release
14:11:25 <ashimema> Joubu, you're the calandar gatekeeper aren't you.? can those be added?
14:11:44 <Joubu> yep
14:12:00 <cait> #action Joubu to add release/freeze dates to calendar
14:12:06 * ashimema thinks his irc client is playing up again..
14:12:15 <Archie^> Does Koha has any tablespace for ISIL codes of Libraries?
14:12:39 <kidclamp> moving on?
14:12:45 <ashimema> Archie^ We're in a meeting right now.. any change you could ask your question again in half hour or so?
14:12:46 <cait> Archie^: the column from earlier - only you. we put the ISIL as branchcode, MarcOrgCode is also the isil usually
14:12:59 <cait> and meeting :)
14:12:59 <caroline> good morning!
14:13:03 <oleonard> Hi caroline, welcome to the meeting
14:13:04 <kidclamp> #topic Update on releases
14:13:10 <kidclamp> fridolin
14:13:10 <wahanui> i think fridolin is indeed, but maybe not on Rmain 18.11
14:13:11 <fridolin> caroline: bien le bonjour
14:13:16 <oleonard> Joubu++
14:13:16 <caroline> #info Caroline Cyr La Rose, inlibro
14:13:32 <Archie^> sorry, yes
14:13:57 <ashimema> Nothing major to report..
14:14:08 * fridolin preparing 17.11.12 release, nothing special
14:14:25 <ashimema> I'm just cathcing up on my rmaint queue at the moment after spending a couple of weeks before the freeze on qa/so
14:14:26 <cait> password recovery with email is broken in 17.11.11
14:14:29 <fridolin> i will continue RMaint 17.11.x after 18.11 release
14:14:45 <fridolin> ah yes cait wich bug nb ?
14:14:56 <kidclamp> #info Stable releases moving as usual
14:15:07 <fridolin> Bug 21771
14:15:07 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21771 major, P5 - low, ---, m.de.rooy, Pushed to Master , Password recovery is broken (see 20023)
14:15:08 <ashimema> :)
14:15:09 <kidclamp> #info ahsimema catching up after focusing on so/qa for master
14:15:18 <cait> bug 21771
14:15:21 <cait> too slow :)
14:15:23 <ashimema> :boring: rmaints.. it's good to be boring :)
14:15:27 <kidclamp> #info bug 21771 is needed for stab;e
14:15:44 <fridolin> ashimema: tell me when you push it
14:16:04 <fridolin> i will read your release note to see i have all major+ bugs
14:16:12 <kidclamp> already mentioned, 18.11 is in slush, freeze on Friday. I will be out Friday so pushing things is my priority now
14:16:34 <ashimema> will do fridolin
14:16:38 <kidclamp> Please focus on bugs to fix jenkins and get blockers/criticals/majors cleaned up
14:17:08 <kidclamp> Lots of good things to get in, but lots of cleanup to be done as well :-)
14:17:16 <fridolin> yep, had one jenkins failure because of Bug 21396
14:17:16 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21396 normal, P5 - low, ---, jonathan.druart, RESOLVED FIXED, Missing use statements in Koha::Account
14:17:21 <fridolin> i reverted it
14:17:44 <fridolin> i mean i did not backport in the end
14:18:02 <fridolin> strange circular dependancy issue
14:18:18 <fridolin> Joubu: if you can look ^
14:18:26 <kidclamp> #info kidclamp is pushing to master, tryiing to clear the queue, needs help in moving along bugs to fix jenkins failures and bugs needed for release
14:18:34 <Joubu> fridolin: Fixed already
14:18:39 <kidclamp> bug 21526
14:18:39 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21526 blocker, P5 - low, ---, jonathan.druart, Signed Off , TT variables used to build a link should be uri filtered
14:18:39 <wahanui> bug 21526 is going to make me rebase all oleonard's patches again isn't it :|
14:19:00 <oleonard> Well you could make me rebase them kidclamp
14:19:08 <Joubu> About 18.11, I'd like to note that QA members and other tech guys should take a look at bug 21610 and bug 21526.
14:19:08 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21610 major, P5 - low, ---, jonathan.druart, In Discussion , Koha::Object->store needs to handle incorrect values
14:19:13 <cait> save the time of the RM...
14:19:24 <cait> more things pushed, there are really some goodies in that queue
14:19:40 <marcelr> could 21610 still make it then ?
14:19:52 <marcelr> thought it was for the next cycle
14:19:54 <ashimema> 21610 is on my list to revist after this meeting :)
14:20:19 <Joubu> marcelr: I'd say it depends on feedback we get
14:20:26 <kidclamp> if we had consensus and well tested I would consider - if not it is priority for next release
14:20:36 <kidclamp> what Joubu said :-)
14:21:23 <kidclamp> bug 21770
14:21:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21770 normal, P5 - low, ---, chris, Signed Off , t::lib::QA::TemplateFilters should allow html_entity in href
14:21:31 <kidclamp> ^ to fix jenkins
14:21:39 <kidclamp> that's all i got for now
14:22:10 <kidclamp> #topic Roles for 19.05 - Elections!
14:22:24 <cait> we are missing 2 - translation manager and rmaint 18.05
14:22:46 <ashimema> I looked at bug 21770 earlier.. was just debating which version to lean towards.
14:22:58 <kidclamp> is  bernardo out? or just didn't sign up?
14:23:06 <ashimema> both have merrits.. I think I'm leaning towards Joubu's version at the moment
14:23:25 <cait> I've had some trouble reaching him lately
14:23:32 <cait> I don't know if it's by mistake or not
14:23:39 <cait> tcohen: ?
14:23:46 <Joubu> He was late last release as well
14:24:42 <Joubu> (trying to reach him)
14:24:56 <kidclamp> can we ask tcohen or someone to reach out and tentatively vote him in?
14:25:27 <cait> maybe resolve next meetingß
14:25:40 <cait> and pretend he stays on until a successor is found or we hear back
14:25:44 <Joubu> we do not have another choice anyway
14:25:58 <caroline> I vote for waiting until we hear back
14:26:46 <kidclamp> 18.05 maint, any volunteers?
14:27:13 <cait> let's have another meeting for that in a week or so? and another call on mailing list
14:27:30 <marcelr> seems a good idea to me
14:27:35 <fridolin> would be cool to have someone new
14:27:41 <cait> true
14:27:48 <cait> and second oldest is a good one to start with
14:28:03 <ashimema> :)
14:28:08 <fridolin> :)
14:28:48 <ashimema> would be good to get new blood involved :)
14:28:49 <fridolin> if its realy needed i could do it with 17.11 but I'd like to change
14:29:26 <ashimema> happy to share all I've learned this cycle (and the old bregade are here to help still too I'm sure)
14:29:37 <ashimema> if pushed, we could perhaps share it fridolin?
14:29:45 <fridolin> indeed
14:29:56 <ashimema> hard to commit fully.. but lets see if we can get some new blood first
14:30:04 <fridolin> let see what comes
14:30:11 <ashimema> who do we want to send out a chaser email for those two roles?
14:30:13 <kidclamp> #action kidclamp will email list to ask for volunteers for needed roles, will schedule special meeting for vote in a week
14:30:17 <kidclamp> :-D
14:30:17 <ashimema> I sent the last chaser
14:30:36 <kidclamp> i took it ashimema
14:30:39 <ashimema> brill
14:30:57 <kidclamp> beyond that, can we vote on the remaining in a single call? or wait until next week and do the whole shebang
14:31:51 * ashimema thinks we can vote on whats there and just leave to the two missing ones to next meeting
14:31:51 <Joubu> kidclamp: I did not find your proposal
14:32:40 <cait> yeah, don't let people jump off now :)
14:32:41 <kidclamp> that's true - same as before, but finish the things I did not and work on community involvement? I can write more if you wish
14:33:14 <cait> +1 for one vote
14:33:16 * ashimema is happy to link to your 18.11 proposal for you if it's the same..
14:33:33 * ashimema is happy for you to 'continue as before'
14:33:34 <andreashm> lets vote
14:33:59 <kidclamp> yes, mainly the same, except now I know how muich time it takes, and am slightly better at it
14:34:08 <marcelr> its more or less everything statys the same
14:34:34 * oleonard would like kidclamp
14:34:44 <oleonard> 's continuing reign to include more fire and brimstone
14:35:08 <marcelr> like critical bugs and so ?
14:35:14 <kidclamp> okay, lemme phrase this
14:35:31 <Guest2299> Project Koha_Master_D9 build #598: STILL UNSTABLE in 31 min: https://jenkins.koha-community.org/job/Koha_Master_D9/598/
14:35:50 <cait> ... as a question
14:35:53 <Guest2299> Project Koha_Master_U18 build #87: STILL UNSTABLE in 30 min: https://jenkins.koha-community.org/job/Koha_Master_U18/87/
14:35:55 <cait> i could never come up with one .)
14:36:10 <marcelr> do we agree on .. ?
14:36:33 <kidclamp> #startvote Do we vote to accept the roles for 19.05 as proposed on the wiki page "Roles for 19.05" with the exception of Translation manager" and "18.05 Maintainer" to be voted on their own special meeting in a week? Yes, No, Abstain
14:36:33 <huginn> Begin voting on: Do we vote to accept the roles for 19.05 as proposed on the wiki page "Roles for 19.05" with the exception of Translation manager" and "18.05 Maintainer" to be voted on their own special meeting in a week? Valid vote options are Yes, No, Abstain.
14:36:33 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
14:36:39 <kidclamp> #vote Yes
14:36:51 <kidclamp> #link https://wiki.koha-community.org/wiki/Roles_for_19.05 Roles for 19.05
14:36:57 <Joubu> #vote yes
14:36:58 <caroline> #vote Yes
14:36:59 <oleonard> #vote Yes
14:37:00 <ashimema> #vote yes
14:37:00 <andreashm> #vote Yes
14:37:00 <marcelr> #vote Yes
14:37:11 <Joubu> Note that I ask for push permissions!
14:37:18 <davidnind> #vote Yes
14:37:18 <tcohen> #vote yes
14:37:22 <thd> #vote yes
14:37:25 <georgew> #vote Yes
14:37:25 <marcelr> didnt you have them already ? joubu
14:37:27 <ashimema> #vote Yes
14:37:28 <AndrewIsh> #vote Yes
14:37:29 <cait> #vote yes
14:37:35 <tcohen> marcelr: formally
14:37:44 <cait> #vote Yes
14:37:45 <Joubu> marcelr: I do not think so, if I have them I did not use them this release
14:37:50 <cait> not sure if that's case sensitive
14:38:03 <kidclamp> last call
14:38:08 <ashimema> me either.. hense the double vote ;)
14:38:22 <cait> yes.. please not we are not trying to cheat :)
14:38:44 * ashimema wonders what tcohen just said formeally for?
14:38:51 <kidclamp> #endvote
14:38:51 <huginn> Voted on "Do we vote to accept the roles for 19.05 as proposed on the wiki page "Roles for 19.05" with the exception of Translation manager" and "18.05 Maintainer" to be voted on their own special meeting in a week?" Results are
14:38:51 <huginn> Yes (13): Joubu, andreashm, davidnind, thd, AndrewIsh, georgew, oleonard, ashimema, marcelr, kidclamp, cait, tcohen, caroline
14:39:18 <kidclamp> heh, unanimous
14:39:24 <oleonard> huginn: Has cait been sent to prison for voter fraud?
14:39:25 <huginn> oleonard: downloading the Perl source
14:39:28 <ashimema> :)
14:39:44 <kidclamp> #info roles for 19.05 are accepted with translation manager and 18.05 maint tbd
14:39:56 <marcelr> kidclamp: i propose to send the patch for 18.11 release team on master; as i did last versions
14:40:03 <marcelr> it must be done still
14:40:06 <kidclamp> #topic MIscellaneous
14:40:08 * ashimema likes that there's a good list of topic experts there and intends to throw work their way when he needs QA help ;)
14:40:17 <kidclamp> thanks marcel
14:40:35 <kidclamp> anyone have anything for Misc?
14:40:40 <cait> ah
14:40:41 <cait> yes
14:41:16 <Joubu> I do too.
14:41:19 <cait> For elastic search, the next one we need is bug 19893
14:41:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19893 enhancement, P1 - high, ---, glasklas, Needs Signoff , Alternative optimized indexing for Elasticsearch
14:41:51 <cait> i talked to Ere, he said it's the next one we need to go in - so advertising it a bit
14:42:04 <cait> we currently have some libraries using Elasticsearc, but none on a released version
14:42:14 <cait> thy all use additional patches that haven't been included yet
14:42:36 <cait> I think we should work towards fixing that
14:42:43 <kidclamp> I would love to get all the big es fixes in for 19.05 (would have loved for 18.11 )
14:42:46 <ashimema> agreed
14:42:50 <cait> not everyone has in-house devs capable to do that .)
14:43:17 <marcelr> just mentioning bug 21336 here for the next cycle too (gdpr)
14:43:17 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21336 enhancement, P5 - low, ---, m.de.rooy, Needs Signoff , GDPR: Handle unsubscribe requests automatically by optional (administrative) lock, anonymize and remove
14:43:53 * ashimema needs to get back on top of his rmaint queue.. but then intends to get back to ES.. likely not quick enough for this cycle though.. 19.05 early I reckon
14:44:17 <cait> just trying to give some direction - there is a lot with elastic and we need to get them in in some sensible sequence
14:44:48 <kidclamp> mayeb this is conversation for the dev meeting?
14:44:54 <ashimema> agreed
14:44:55 <cait> yep sorry
14:45:08 <cait> Joubu?
14:45:08 <wahanui> i think Joubu is kidding, right ;)
14:45:13 <Joubu> But I did not think about it closely, so it will be messy. I would like people to think about how we could improve our communication. I think we are missing a tool/channel to keep track of 1. the urgent topics/bug# we need to focus on and 2. the tasks affected to someone. IRC (laters or pm) and bugzilla comments are not sufficient, at least for me.
14:45:37 <Joubu> I'd people to think a bit about it, then maybe we could discuss that later during the dev meeting
14:45:37 <ashimema> would be good to agree some shared targets for next release.. I can see a few patterns emarging right near the end of this cycle.. be good to keep the pressure on those for early next cycle
14:45:52 <kidclamp> Joubu++
14:46:01 <cait> an issue is that after release things tend to get quiet
14:46:04 <cait> losing momentum again
14:46:11 <cait> not good .)
14:46:22 <ashimema> Joubu++
14:46:28 <cait> shoudl we info?
14:46:39 <Guest2299> Project Koha_Master_D8 build #94: STILL UNSTABLE in 38 min: https://jenkins.koha-community.org/job/Koha_Master_D8/94/
14:46:40 <ashimema> yes
14:46:48 <Joubu> we need different views: the "big things" (who/what/when), the release things, and the urgent things
14:47:17 <cait> maybe another go with taigo?
14:47:26 <Joubu> I suggested taiga, and I still think it's a tool we need. But I am open to anything else
14:47:26 <marcelr> it didnt work
14:47:27 <cait> can someone summarize for info? i am struggling
14:47:32 * ashimema uses the dashboard as a part of his workflow.. perhaps we could extend it a little to help keep dev team on the same page a bit more?
14:47:34 <cait> the docs team is using it
14:47:38 <ashimema> talk next meeting
14:47:44 <cait> yes
14:48:05 <thd> Do we have no alternative to the CPU wastage of Tagia?
14:48:11 * ashimema fins taiga hard to work with personally
14:48:26 <Joubu> I think people did not really try it
14:48:33 <ashimema> I tried
14:48:38 <marcelr> i thought that we concluded that yet another tool was too much for a lot of people
14:48:39 <Joubu> read the wiki page as well?
14:48:49 <ashimema> I found I was using alot of time just trying to navigate it.. perhaps I need some lessons
14:48:50 <kidclamp> #info We need a method of organizing priorities and who is handling them during the release, taiga is a possibility, but we need a tool all will use, please consider and discuss at next meeting(s)
14:48:51 <caroline> I could do a short tutorial for taiga?
14:49:04 <Joubu> I do not need "lot of people", I just want few people, the active ones
14:49:12 <Joubu> we are less than 10
14:49:18 <Joubu> ... or 6
14:49:28 <thd> I quite like Taiga except for its consumption of system resources with unnecessary JavaScript.
14:49:33 <ashimema> agreed.. only needs to be the real core folks really
14:49:41 <Joubu> working on a daily basis on bug fixes, tests, etc.
14:49:54 <kidclamp> have the taiga link handy Joubu?
14:50:01 <ashimema> not 'invitation only'.. but not hugely promoted either.. agreed upon by a core group I think
14:50:11 <cait> sounds good
14:50:25 <Joubu> thd: please stop
14:50:34 <cait> some place to list urgent tasks and for people to grab them=
14:50:35 <cait> ?
14:50:39 <Joubu> https://tree.taiga.io/project/joubu-koha-rm-1711/wiki/about
14:50:51 <cait> ok, ending meeting quickly? :)
14:50:54 <kidclamp> #link https://tree.taiga.io/project/joubu-koha-rm-1711/wiki/about Taiga for koha
14:51:03 <kidclamp> #topic Next meeting
14:51:25 <kidclamp> one week? to vote for things
14:51:44 <cait> yes
14:51:49 <cait> quick one
14:51:56 <ashimema> +1
14:51:58 <kidclamp> November 14, 14:00 UCT?
14:52:10 <marcelr> depends on reactions?
14:52:38 <cait> having a deadline before release would be good I think
14:52:40 <cait> we can still postpone
14:52:54 <oleonard> +1
14:52:55 <ashimema> lets try for that date.. we can't go on indefinitely if there is no feedback we need to reconsider our position
14:53:26 <kidclamp> #info Next meeting: 14 November 2018, 14 UTC
14:53:41 <kidclamp> #endmeeting