#koha: Development IRC meeting 10 April 2019

Meeting started by kidclamp at 14:00:05 UTC (full logs).

Meeting summary

  1. Introductions (kidclamp, 14:00:14)
    1. Nick Clemens, ByWater Solutions (kidclamp, 14:00:28)
    2. Katrin Fischer, Germany (cait, 14:00:29)
    3. Kyle M Hall (khall, 14:00:37)
    4. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:00:45)
    5. Thomas Dukleth, Agogme, New York City (thd, 14:00:58)
    6. Andrew Isherwood, PTFS Europe, UK (AndrewIsh, 14:01:01)
    7. Josef Moravec (josef_moravec, 14:01:14)
    8. Martin Renvoize, PTFS Europe (ashimema, 14:01:48)

  2. Announcements (kidclamp, 14:02:05)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_April_2019 Agenda (cait, 14:02:27)
    2. Liz Rea, doer of things (wizzyrea, 14:03:37)

  3. Update from the Release manager (19.05) (kidclamp, 14:04:11)
    1. https://wiki.koha-community.org/wiki/Roles_for_19.11 Roles for 19.11 (cait, 14:05:53)

  4. Updates from the Release Maintainers (kidclamp, 14:08:10)
    1. 18.11.x has been coming along nicely, the team are all working really well. (ashimema, 14:08:58)
    2. ACTION: ashimema to send an meail to the mailing list about sighing up for 19.11 release team (kidclamp, 14:09:20)
    3. ACTION: ashimema to send an meail to the mailing list about sighing up for 19.11 release team (cait, 14:09:39)
    4. 17.11.18 will be final release (kidclamp, 14:11:26)
    5. 18.05 is going steady, no notes at the moment (kidclamp, 14:11:54)
    6. Next Maint release dates are set: 29th for release, with String Freeze on 22nd (attempting to avoid Easter) (ashimema, 14:12:12)

  5. Updates from the QA team (kidclamp, 14:12:57)
    1. 2 blockers, 1 critical and 20 majors waiting to be written, tested and QA'd (cait, 14:14:50)
    2. ACTION: QA Team to qa all the things! And then they get cookies (kidclamp, 14:14:53)

  6. General development discussion (trends, ideas, ...) (kidclamp, 14:20:57)
    1. REST API (kidclamp, 14:21:12)
    2. https://wiki.koha-community.org/wiki/Checkouts_endpoint_RFC#Update_-_Circulation_history_aka_old_checkouts Checkouts RFC (kidclamp, 14:21:30)
    3. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17005 (josef_moravec, 14:24:33)
    4. VOTE: Voted on "should we accept the amendment to the checkouts api rfc to allow for retrieving historical circulation info?" Results are, Yes: 4, Abstain: 2 (kidclamp, 14:28:49)
    5. amendment to checkotus rfc accepted (kidclamp, 14:29:36)
    6. https://wiki.koha-community.org/wiki/Illbackends_endpoint_RFC Illbackends RFC (kidclamp, 14:30:03)
    7. VOTE: Voted on "Should we accpt the Illbackend endpoint RFC as proposed on the wiki?" Results are, Yes: 5, Abstain: 2 (kidclamp, 14:44:59)

  7. (kidclamp, 14:45:21)
  8. #startvote Should we accpt the Illbackend endpoint RFC as proposed on the wiki? Yes, No, Abstain (kidclamp, 14:45:26)
  9. Review of coding guidelines (kidclamp, 14:45:34)
    1. bug 22407 OMNIBUS: Use DBIC relations to fetch related object rather than searching for the object (kidclamp, 14:46:06)
    2. VOTE: Voted on "do we accept the new coding guideline as proposed on bug 22407comment #7?" Results are (kidclamp, 14:57:28)
    3. guideline accepted (kidclamp, 14:58:40)
    4. ACTION: ashimema will add the guideline :-) (kidclamp, 14:58:50)

  10. Review of coding guidelines (kidclamp, 14:59:03)
  11. Set time of next meeting (kidclamp, 14:59:10)
    1. guideline added :) (ashimema, 14:59:12)
    2. Next meeting: 24 April 2019, 19 UTC (kidclamp, 15:00:40)


Meeting ended at 15:00:45 UTC (full logs).

Action items

  1. ashimema to send an meail to the mailing list about sighing up for 19.11 release team
  2. ashimema to send an meail to the mailing list about sighing up for 19.11 release team
  3. QA Team to qa all the things! And then they get cookies
  4. ashimema will add the guideline :-)


Action items, by person

  1. ashimema
    1. ashimema to send an meail to the mailing list about sighing up for 19.11 release team
    2. ashimema to send an meail to the mailing list about sighing up for 19.11 release team
    3. ashimema will add the guideline :-)


People present (lines said)

  1. kidclamp (84)
  2. ashimema (41)
  3. cait (39)
  4. huginn` (27)
  5. josef_moravec (14)
  6. thd (13)
  7. wizzyrea (11)
  8. oleonard (9)
  9. AndrewIsh (8)
  10. fridolin (8)
  11. wahanui (4)
  12. khall (1)


Generated by MeetBot 0.1.4.