15:00:51 <ashimema> #startmeeting Development IRC meeting 9 October 2019
15:00:51 <huginn> Meeting started Wed Oct  9 15:00:51 2019 UTC.  The chair is ashimema. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:51 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:51 <huginn> The meeting name has been set to 'development_irc_meeting_9_october_2019'
15:01:16 <ashimema> #topic Introductions
15:01:26 <ashimema> #info Martin Renvoize, PTFS Europe
15:01:45 <ashimema> Sorry for the delay all.. the git repo is happy again at least :)
15:01:47 <reiveune> bye
15:01:56 <thd> #info Thomas Dukleth, Agogme, New York City
15:02:47 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio
15:03:42 <ashimema> Quiet today
15:04:02 <khall> #info Kyle Hall, ByWater Solutions
15:04:03 <ashimema> well.. people will join us when they're ready.. so lets move on to busines
15:04:04 <ashimema> #topic Announcements
15:04:08 <bag> tcohen and khall I had the same thing yesterday
15:04:23 <corilynn> #info Cori Lynn Arnold, DGI (lurking)
15:04:34 <bag> never found a fix (still reading through the scrollback)
15:04:43 <bag> ahh meeting time (sorry)
15:04:51 <bag> #info Brendan Gallagher, ByWater
15:04:57 <ashimema> haha, no worries baf
15:05:00 <ashimema> bag, even
15:05:06 <bag> baf - lol
15:05:14 <ashimema> I fixed git btw.. so you shoudn't have that issue any more
15:05:23 <bag> oh sweet :)
15:05:53 <ashimema> #info Freeze dates email will be going out tonight, provisional dates are already in the calendar
15:06:07 <ashimema> #link https://koha-community.org/calendar/ Calendar
15:06:40 <oleonard> Got the link to today's agenda handy ashimema?
15:06:45 <ashimema> #info If you noticed an issue with the git repositories over the last 24 hours, please be aware the issue should now be resolved.
15:06:59 <ashimema> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_October_2019 Agenda
15:07:04 <ashimema> oops.. I always forget to do that :S
15:07:40 <ashimema> it's a very sparse one.. I looked back at the past coupe of agenda's and couldn't see anything that really needed bringing forward.. but please add anything if you want to
15:08:21 <thd> There is an issue which tcohen would like us to resolve but is he absent again?
15:08:45 <ashimema> anyone else have any anouncements they'd like to minute?
15:08:53 <thd> He was here at the original meeting time.
15:09:54 <ashimema> I've poked him in slack, with any luck he'll magically appear
15:09:57 <ashimema> but for now
15:10:02 <ashimema> #info Update from the Release manager
15:10:33 <ashimema> #info The release is starting to take shape and provisional dates are now set
15:10:56 <ashimema> #info Feature slush is scheduled for the 30th November - Thats three weeks today
15:11:23 <ashimema> #info Feature freeze is scheduled for the 6th November - One week later
15:11:47 <ashimema> #info String freeze is scheduled for the 13th November - One week later again
15:11:52 <fridolin> #info Fridolin Somers, Biblibre, France
15:12:20 <ashimema> #info Release all being well will be the 27th November - Giving two weeks for translations.
15:13:08 <ashimema> It's been a slow cycle, I did some statistics at the Hackfest and we've pushed less than half the bugs compared to the last three releases.
15:13:28 <ashimema> I'm hopeing it's a blip and we'll be back up to speed for the 20.05 cycle.
15:14:29 <ashimema> Having asked around I believe all the big contributors have simply been run off their feet with deployments and customers this cycle.
15:14:47 <ashimema> Jonathan D being away has also not helped on the numbers front.
15:15:11 <ashimema> #topic Updates from the Release Maintainers
15:15:27 <ashimema> fridolin: Over to you..
15:15:33 <fridolin> yop
15:15:51 <fridolin> 19.05.x is at v19.05.05
15:15:59 <fridolin> i think everything is fine
15:16:24 <fridolin> we prepare for a release before next cyrcle
15:16:40 <fridolin> maybe embed security fixes in it
15:17:42 <bag> joubu should be back soon :)
15:17:47 <oleonard> We have a lot of bugs which I think should be 'resolved fixed' but I'm not sure
15:17:54 <ashimema> #info 19.05.x is at 19.05.05 presently and is feeling reliable and stable
15:17:55 <oleonard> I think some cleanup needs to be done
15:18:23 <ashimema> #topic Updates from the QA team
15:18:40 <ashimema> #info Pace seems to have picked up the last week, keep it up :)
15:18:50 <ashimema> #topic General development discussion
15:19:21 <ashimema> #info oleonard notes that there is a large number of bugs that appear to need updating to 'RESOLVED FIXED'
15:19:46 <ashimema> #action ashimema will look into this prior to the next cycle starting
15:20:00 <fridolin> yep
15:20:08 <ashimema> #info We should have Joubu back for the next cycle, which should get the numbers back on track
15:20:14 <fridolin> its usually for Rmmait of oldoldstable
15:20:20 <ashimema> tcohen.. did you appear again yet?
15:21:05 * fridolin was wondering about versions in pottle
15:21:21 <fridolin> shoud we close versions < 18.05 ?
15:21:27 <ashimema> I believe there's a process in place which cait and rangi usually do to mark bugs as RESOLVED FIXED in bulk.. it relies on them disabling email notifications behind the scenes so we don't spam everyone.
15:21:53 * ashimema has a script to do the change, but won't run it for fear of spamming everyone on bugzilla
15:22:45 <oleonard> Speaking of rmaints, hi wizzyrea
15:22:51 <ashimema> #info Fridolin raises that pootle still contains a number of officially unsupported koha versions.. perhaps we should tidy up there too.
15:23:10 <fridolin> on 20.05 start
15:23:15 <thd> Go ahead and spam me.  The whole multiverse does :)
15:23:28 <fridolin> ^^
15:24:56 <fridolin> french translation group did a great job during hackfest but was not sure on which version to work
15:25:29 <ashimema> #info I'm contemplating a 'fail fast' attitude early next cycle.. still to be fleshed out and discussed.. but the initial thoughts are that I will push some more experimental bugs (on developer request and my own judgement) early in the release with the expectation of getting quick followups for any breakage.  Idea being it helps alleviate some of the QA backlog of the most technical bugs where we don't have so many people capable of
15:25:30 <ashimema> understanding the code to qa it.
15:25:44 <thd> People should at least be satisfied in the knowledge that their work on translation will actually be used.
15:26:57 <ashimema> any other general discussion points from anyone?
15:27:24 <ashimema> ok.. moving on then
15:27:26 <ashimema> #topic Review of coding guidelines
15:27:31 <wizzyrea> kia ora
15:28:41 <ashimema> tcohen raises the question of whether we should start officially deprecating the /svc api namespace.
15:29:00 <ashimema> #info tcohen raises the question of whether we should start officially deprecating the /svc api namespace.
15:29:33 <bag> perhaps adding to that - who is using it?
15:29:39 <ashimema> generally I feel this is a direction we should be moving, but we need to be somewhat pragmatic about it..
15:29:42 <thd> Is anyone known to currently use svc?
15:30:02 <koha-jenkins> Project Koha_Master_U18 build #394: SUCCESS in 57 min: https://jenkins.koha-community.org/job/Koha_Master_U18/394/
15:30:22 <ashimema> a few area's of the front end use it.. I think it's mostly used internally though a small number of things are more publically documented.
15:30:39 <oleonard> We have our hold slips set up to use svc/barcode
15:30:52 <ashimema> one example is the reports apis.. I believe catalyst customers use those reasonably frequently
15:31:49 <ashimema> I would certainly back a move to stop adding to/enhanceing existing /svc and block all new /svc
15:32:09 <oleonard> +1
15:32:23 <ashimema> one area I see needing attention would be the few datatables that use /svc for their ajax implimentation..
15:32:49 <ashimema> our rest api's don't lend themselves to 'the datatables way'.. but I'm sure there are work arounds available to us
15:32:58 <thd> Deprecation should be a long process where there is any reasonable belief that there are users who have not converted to the replacement and the replacement should be certain to satisfy all the needs of existing users.
15:33:00 <bag> I think the oclc connexion client uses /svc
15:33:09 <bag> and maybe marcedit?
15:33:26 <ashimema> perhaps one to bring in for the next cycle with a new coding guideline and qa scripts to capture
15:34:01 <ashimema> good points bag.. I'd forgotten about marcedit support entirely
15:34:41 <ashimema> I (or tcohen) will draft something to vote on for the next meeting.
15:34:52 <ashimema> did anyone have anything else they wanted to raise?
15:35:31 <oleonard> Did we ever vote on my ESLint proposal?
15:36:11 <thd> Those present at least approved of ESLint in principle.
15:36:31 <ashimema> I think we all agreed to it..
15:36:44 <ashimema> did I not minute that back when.. I bet I forgot
15:37:04 <oleonard> I dunno... I shall proceed as if I have approval :D
15:37:22 * oleonard loves cleanup patches
15:37:25 <thd> It is possible we did not vote without the presence of oleonard.
15:37:39 <ashimema> ah, perhaps.
15:38:05 <ashimema> I'm happy to proceed with it anyway.. another one to really push for in the next cycle :)
15:38:45 <ashimema> ok.. last topic then
15:38:56 <ashimema> #topic Set time of next meeting
15:39:58 * oleonard found a record of the vote... thank you for your support
15:40:40 * oleonard 's opponents were all in the pocket of Big JsHint
15:40:44 <ashimema> I'm thinking stick to the same two weeks.. that gives us a week before feature slush to discus anything important and start planning the next cycle (we should also have started talking about the next team by then after the next general meeting)
15:41:52 <ashimema> 23 OctoberSeptember 2019, 21:00 UTC
15:41:59 <ashimema> * 23 October 2019, 21:00 UTC
15:42:15 <ashimema> does that suit the majority.. lets NZ join again I believe
15:42:55 <oleonard> +1
15:43:34 <thd> +1
15:43:40 <ashimema> #info Next meeting: 23 October 2019, 21:00 UTC
15:43:42 <ashimema> brill
15:43:51 <ashimema> thanks all for your attendance, my appologies for the last minute delay to proceedings
15:43:56 <ashimema> #endmeeting