14:08:48 <caroline1> #startmeeting Documentation IRC meeting 4 April 2019
14:08:48 <huginn`> Meeting started Thu Apr 4 14:08:48 2019 UTC. The chair is caroline1. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:08:48 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:08:48 <huginn`> The meeting name has been set to 'documentation_irc_meeting_4_april_2019'
14:09:06 <caroline1> #topic Introductions (please use "#info" in front of your introduction to have it show up in the automatic minutes)
14:09:11 <wizzyrea> #info Liz Rea, doer of things
14:09:18 <caroline1> #info Caroline Cyr La Rose, inLibro
14:09:34 <davidnind> #info David Nind, Wellington, New Zealand
14:10:23 <caroline1> lucyvh
14:10:28 <lucyvh> #info Lucy Vaux-Harvey, PTFS Europe
14:10:53 <caroline1> Is that everybody?
14:11:11 <davidnind> Looks like it!
14:11:11 <wahanui> i heard looks like it was some of the characters in your bz password - has gone past the koha-gitify task in the setup now, so looking better good now!
14:11:20 <caroline1> #topic Action points
14:11:23 <wizzyrea> forget looks like it
14:11:23 <wahanui> wizzyrea: I forgot looks like it
14:11:33 <caroline1> davidnind, that was you
14:11:39 <caroline1> Automated screen captures
14:11:56 <caroline1> #info Automated screen captures
14:12:43 <davidnind> Automated screen capture: not much progress, just trying to get some documentation - have added a few more
14:13:22 <davidnind> Want to add some documentation so others can add some as well
14:13:36 <caroline1> #info Automated screen capture, still in development
14:14:32 <davidnind> Seems to work reasonably well, but still trying to figure out how to do some of the tabbed interface elements
14:14:49 <caroline1> Great!
14:15:02 <caroline1> Is the documentation available somewhere?
14:15:18 <caroline1> We could do the things that work
14:15:36 <davidnind> Will put in the repository
14:16:47 <davidnind> Repository is here https://gitlab.com/davidnind/koha-automated-screenshots
14:17:05 <caroline1> #link https://gitlab.com/davidnind/koha-automated-screenshots
14:17:30 <caroline1> davidnind++
14:17:38 <davidnind> Haven't committed in a while - so will update shortly
14:18:05 <caroline1> how would the transition work?
14:18:32 <caroline1> Do we have to do all of them at the same time? Is there a way to mark that this screen capture is automated and this one is not?
14:19:03 <davidnind> Still trying to figure that out - will still need some manual ones
14:19:37 <davidnind> may need to differentiate using folders
14:20:27 <caroline1> Ok, we will need to come up with a plan
14:21:06 <davidnind> will do
14:21:30 <caroline1> Let us know when the tool is ready to start and we will plan the transition
14:21:51 <caroline1> #action plan transition from manual to automated screen captures
14:22:15 <caroline1> Next is Koha bibliography in Zotero
14:22:34 <davidnind> Koha bibliography: have made good progress
14:23:02 <caroline1> #info Koha bibliography in Zotero
14:23:09 <davidnind> Link: https://www.zotero.org/groups/6684/koha/items
14:23:15 <caroline1> #info Koha bibliography in Zotero in progress
14:23:23 <caroline1> #link https://www.zotero.org/groups/6684/koha/items
14:23:47 <davidnind> All existing entries updated (links, tags, abstracts, etc)
14:23:57 <caroline1> wow! that looks great!
14:24:36 <davidnind> Adding new ones progressively - have a long list of things to add!
14:24:58 <wizzyrea> \o/
14:25:32 <davidnind> Will file a bugzilla request thing to get kc.org website updated
14:26:17 <caroline1> #action davidnind will file a bugzilla to update kc.org re:zotero
14:26:25 <wizzyrea> you just need that url instead of the old one?
14:26:35 <wizzyrea> I could do it right now :P
14:27:00 <davidnind> Thinking of only having some selected entries at https://koha-community.org/documentation/koha-bibliography/ with the link to the full list
14:27:31 <davidnind> that would be great wizzyrea!
14:27:34 <wizzyrea> would you like to have access to edit that page?
14:27:39 <wizzyrea> if you have a vision for it
14:27:51 <wizzyrea> (i'm happy to but you may have a specific idea and I trust you :P)
14:28:25 <davidnind> that would be great, then I don't need to bother you
14:28:35 <wizzyrea> its never a bother <#
14:28:36 <wizzyrea> <3
14:28:49 <caroline1> #action scratch last action :)
14:29:31 <davidnind> does anyone have any thoughts on having the full bibliography, selected bibliography, or just a link on the kc.org site?
14:29:32 <caroline1> #action wizzyrea will give davidnind access to modify koha bibliography page on kc.org
14:29:46 <wizzyrea> so this https://www.zotero.org/groups/6684/koha/items instead of this http://www.zotero.org/groups/koha
14:29:59 <wizzyrea> (for a start)
14:30:23 <caroline1> I don't know if it is possible, but could we have a tag "selected" to mark specific articles that we find particularly important and have those show on the page?
14:30:33 <caroline1> (in an automated way I mean)
14:30:55 <caroline1> Or maybe the 10 most recent articles
14:31:00 <davidnind> I think so - the later one shows what is new
14:31:30 <wizzyrea> maybe caroline1
14:31:33 <davidnind> I was leaning towards a selected list
14:32:17 <caroline1> Oh right, I see you created a folder
14:32:50 <davidnind> haven't added many to it yet...
14:32:52 <wizzyrea> is there an api for zotero I haven't checked
14:33:17 <davidnind> not sure, will have a look
14:33:24 <wizzyrea> https://wordpress.org/plugins/zotpress/ this might be useful
14:33:38 <davidnind> Also created some guidelines https://wiki.koha-community.org/wiki/Bibliography_Guidelines_for_Koha_Using_Zotero
14:34:00 <wizzyrea> #info https://wordpress.org/plugins/zotpress/ might be a useful plugin for this page - testing is required
14:34:48 <caroline1> alright, to explore
14:35:08 <caroline1> next is Style/content development guide (unless you had more to add)
14:35:15 <wizzyrea> I don't
14:35:39 <davidnind> Style/content development guide: no progress on this, hopefully something by next meeting
14:36:03 <caroline1> #info Style/content development guide : tbc
14:36:39 <caroline1> #topic What's been done so far
14:36:54 <caroline1> anybody have special mentions?
14:37:10 <davidnind> apologies for adding all the action points - more so that I don't forget what I should be working on!
14:37:33 <caroline1> I have not been able to go through release notes, but I will make it my priority before next meeting
14:37:33 <davidnind> nothing from me...
14:37:45 <caroline1> #action caroline release notes!!!
14:38:25 <caroline1> #topic Workflow
14:38:41 <caroline1> anybody have questions/comments/things to say about the workflow?
14:39:51 <wizzyrea> sorry to do uthis to yo
14:39:55 <wizzyrea> what is the workflow :P
14:40:11 <wizzyrea> (you can point me to a wiki page if you have it handy)
14:40:18 <davidnind> https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual
14:40:25 <caroline1> #link https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual
14:41:07 <caroline1> this is for editing per se, we don't really have a workflow for the whole process (like what to do in taiga, in bugzilla, etc...)
14:41:23 <caroline1> I will make a note to map it
14:41:26 <wizzyrea> Ahh
14:41:28 <wizzyrea> right ok
14:41:47 <caroline1> #action caroline will map documentation workflow from a to z
14:42:12 <wizzyrea> so for the release notes, are you going over what the RM produces?
14:42:29 <wizzyrea> and modifying those
14:42:42 <wizzyrea> or is that all tbd
14:43:00 * ashimema has just got back from school run
14:43:05 <wizzyrea> hi ashimema
14:43:14 <ashimema> you guys all know about https://gitlab.com/koha-community/koha-release-notes right
14:43:24 <ashimema> gets rebuilt pretty much daily
14:43:43 <ashimema> so you can watch the release notes and catch thing you feel need cleaning up/adding to throughout the cycle
14:44:06 <ashimema> that might be out of context.. I only read wizzyrea's last comment about release notes ;)
14:44:23 <wizzyrea> nah it's fine I didn't know that existed
14:44:28 <wizzyrea> we should put that on the website somewhere :P
14:44:42 <wizzyrea> you guys make stuff and I miss it
14:45:00 <ashimema> it's kinda pre-release.. though could be helpful
14:45:08 <wizzyrea> i mean you do something cool like that you oughta at least @later me :P
14:45:14 <ashimema> once a release is released of course the notes become static
14:45:37 <wizzyrea> ofc
14:45:38 <caroline1> hi sorry, just had a call from the vet...
14:45:41 <caroline1> reading back
14:45:43 <wizzyrea> that's alright
14:45:47 <ashimema> but up to that point they're getting rebuilt.. which is nice.. but also means they can change as we add stuff to bugzilla to clean up and improve the notes
14:45:48 <davidnind> should we insist that something goes in the "Text to go in release notes" field in bugzilla
14:46:11 <caroline1> yes, that is what I go through to update what needs to be documented
14:46:21 <wizzyrea> It should if the bug description is bad or not helpful
14:46:30 <wizzyrea> definitely for features
14:46:34 <wizzyrea> and maybe for enhancements
14:46:37 <wizzyrea> maybe not for bugs
14:47:04 <ashimema> [off] /me fishes something out of dogs mouth.. man this puppy can find something to eat anywhere
14:47:24 <wizzyrea> [off] DOGGIE
14:47:34 <ashimema> davidnind
14:47:34 <wahanui> davidnind is answering corilynn's questions before I can formulate them
14:47:48 <caroline1> go davidnind! XD
14:48:05 <davidnind> hehe - not sure that is true though!
14:48:13 <ashimema> I'm in the habbit of adding the 'release-notes-needed' keyword for anything I see that hasn't got them and is a 'New Feature', 'Enhancement' or a bug that looks like it changes functionality significantly enough that it needs explaination
14:48:30 <caroline1> cool!
14:48:35 <ashimema> I don't know that there's any workflow for removing those tags again once notes have been added.. or indeed for anyone to add them
14:48:47 <wizzyrea> no I"m sure there isn't
14:48:54 <ashimema> I also tend to try and update them before each rmaint release if I have the time.. but that's not always the case
14:49:18 <ashimema> #info Martin Renvoize, PTFS Europe
14:49:31 <caroline1> oh hi there ashimema ;)
14:49:34 <ashimema> sorry.. wasn't here for the beggining of the meeting ;(
14:49:35 <caroline1> hehe
14:49:49 <caroline1> no worries
14:50:11 <ashimema> I also add the Manual keyword a fair bit.. when I QA stuff
14:50:22 <ashimema> again.. no idea if there's a workflow picking that all up..
14:50:22 <caroline1> I have another meeting at 11 (in 10 minutes), so maybe I will have to pass chairing to someone else
14:50:54 <caroline1> ashimema, for the manual, I look through it sometimes, and I know other people do too
14:51:26 <ashimema> brill
14:51:34 <caroline1> I have a shortcut to "Documentation to-do" which I guess is the open bugs with manual keyword?
14:51:58 <ashimema> I do try to get devs to submit stuff to the manual.. but right now there's not hard guidline to say they have to so I can't fail QA for missing manual entries
14:52:11 <tcohen> File not found : lib/jquery/plugins/jquery.rating.js at /home/vagrant/kohaclone/Koha/Template/Plugin/Asset.pm line 83.
14:52:19 <tcohen> anyone seen it in the OPAC?
14:52:26 <tcohen> (in the logs, master)
14:52:31 * ashimema would kinda like to be able to.. new features should require a corresponding merge request for the manual in my opinion (even if that's not done by the dev, but by someone related)
14:52:43 <caroline1> I have to switch rooms, may lose the connection for a bit
14:52:48 <caroline1> #chair davidnind
14:52:48 <huginn`> Current chairs: caroline1 davidnind
14:52:57 <caroline1> #chair wizzyrea
14:52:57 <huginn`> Current chairs: caroline1 davidnind wizzyrea
14:53:07 <davidnind> I think we can get through the rest of the items quickly...
14:53:07 <caroline1> feel free to move on when you're ready
14:54:08 <corilynn> wahanui, you talking to me?
14:54:08 <wahanui> corilynn: i haven't a clue
14:54:27 <davidnind> #topic Next steps
14:54:56 <davidnind> Having a sprint day would be good
14:55:16 <davidnind> Any suggestions for a day that suits?
14:55:58 * wizzyrea has no preference
14:56:23 * ashimema suggests sprint dayS
14:56:24 <ashimema> ;)
14:56:53 <davidnind> okeleydokely!
14:58:06 <wizzyrea> I am happy to write release notes summaries for people
14:58:10 <wizzyrea> just saying
14:58:23 <wizzyrea> you can say "wizzyrea, I need a release note summary for bug blah blah blah"
14:58:27 <wizzyrea> and I'll give it a go
14:58:49 <davidnind> #action davidnind to post a day(s) that suit for a doc sprint (in conjunction with caroline)
14:58:50 <wizzyrea> beware I might ask you questions if I can't understand what the bug does.
14:59:53 <davidnind> #info wizzyrea can be instructed.. to write a release note summary for a bug
15:00:02 <davidnind> wizzyrea++
15:00:18 <wizzyrea> I have actual time for these things now
15:00:58 <davidnind> so great that you can do these things wizzyrea!
15:01:01 <wizzyrea> (same for signoffs or bugs that need cleanup or qa fixups)
15:01:34 <davidnind> think I will defer the rest of the items for next meeting
15:02:05 <davidnind> #topic Set time for next meeting
15:03:52 <davidnind> 9 May 14:00 UTC unless anyone has other ideas?
15:04:13 <wizzyrea> hehe
15:04:16 <wizzyrea> no other ideas
15:04:28 <davidnind> #info Next meting 9 May 2019 14:00 UTC
15:04:37 <davidnind> I'm sure you do!
15:04:54 <davidnind> #endmeeting