#koha: General IRC meeting 11 December 2019

Meeting started by ashimema at 14:00:38 UTC (full logs).

Meeting summary

  1. Introductions (ashimema, 14:00:39)
    1. Please introduce yourselve with an #info to appear in the minutes. (ashimema, 14:00:56)
    2. Martin Renvoize, PTFS Europe, UK (ashimema, 14:01:04)
    3. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 14:01:08)
    4. Jonathan Druart (Joubu, 14:01:18)
    5. https://wiki.koha-community.org/wiki/General_IRC_meeting_11_December_2019 Today's agenda (ashimema, 14:01:45)
    6. David Nind, Wellington, New Zealand (davidnind, 14:02:10)

  2. Announcements (ashimema, 14:05:41)
    1. Magnus Enger. Libriotech, Norway (magnuse, 14:05:57)
    2. The 19.11 release happened, all be it a little late. Thanks go out to Mason for stepping in and doing the packaging at the last minute. (ashimema, 14:06:21)
    3. Nick Clemens, BYWater Solutions (kidclamp, 14:06:30)
    4. 19.11, 19.05.x and 18.11.x releases all included security patches this recent release (ashimema, 14:06:58)
    5. Extended closing date for Kohacon20 proposals for talks is 13 December (davidnind, 14:08:15)

  3. Update on releases (ashimema, 14:09:06)
  4. 20.05 (next release) (ashimema, 14:09:29)
    1. 19.11 have been branched and master is now the working version for the next feature release, 20.05 (ashimema, 14:10:01)
    2. As is the pattern, we will be sticking to bugfixes only up until the end of the month, but then I hope to start pushing enhancements early January, focusing on the more experimental one's first to give us a large a section of the release cycle to fix any subsequent bugs before release. (ashimema, 14:11:09)
    3. `fail fast` and `experiment and stabalise` (ashimema, 14:11:53)
    4. Caroline Cyr La Rose, inlibro (caroline_catlady, 14:13:32)
    5. koha-US is planning an online conference (Koha-a-thon) for 24 April, call for talks closes 10 January (davidnind, 14:14:57)
    6. Rmaints are tentatively starting to push bugs to their respective branches. (ashimema, 14:15:02)
    7. Details for the Koha-a-thon https://lists.katipo.co.nz/pipermail/koha/2019-December/053991.html (davidnind, 14:15:09)
    8. The dates for the BibLibre Koha Hackfest in Marseille are 23-27 March 2020 (davidnind, 14:16:08)

  5. Any Other Business (ashimema, 14:20:06)
  6. Proposal to try rocket.chat as an alternative/compliment of IRC (ashimema, 14:20:20)
    1. the 3rd Koha Pakistan International Conference is 16-18 April 2020 http://2020.kohapakistan.org/ (davidnind, 14:20:27)
    2. I've discussed with a few people the prospect of adding an alternative to IRC as it seems to be a barrier to entry for some. (ashimema, 14:21:50)
    3. After a little research I'm proposing the creation of a rocket.chat server (I'll try to take on setting one up for a trial) and having it bridge to the existing IRC room. (ashimema, 14:23:49)
    4. After a little research I'm proposing the creation of a rocket.chat server (I'll try to take on setting one up for a trial) and having it bridge to the existing IRC room. (ashimema, 14:25:37)
    5. https://rocket.chat/ (caroline_catlady, 14:26:17)
    6. ACTION: ashimema is going to investigate setting up a bridged rocket.chat server to allow a more modern form of instance communication for the community. (ashimema, 14:34:40)

  7. Shall we bring back an internation bug squashing day? (ashimema, 14:37:39)
    1. https://wiki.koha-community.org/wiki/Category:Global_bug_squashing_days (davidnind, 14:40:15)
    2. https://wiki.koha-community.org/wiki/Catalyst_Academy (Joubu, 14:42:56)
    3. ACTION: ashimema to send out a global bug squashing day announcement email (ashimema, 14:47:55)
    4. Next global bug squashing day to take place 17th January (ashimema, 14:48:12)

  8. Are we happy with the existing release process and cycle? (ashimema, 14:49:02)
    1. liz rea (wizzyrea, 14:55:26)
    2. Joy Nelson (talljoy, 14:56:27)
    3. ACTION: ashimema will summarise the release cycle discussion on a wiki page and invite people to contribute/comment via as many comms methods as he can muster. (ashimema, 15:21:13)

  9. Time of next meeting (ashimema, 15:22:53)
    1. Next meeting: 8 January 2020, 20 UTC (ashimema, 15:27:06)


Meeting ended at 15:27:17 UTC (full logs).

Action items

  1. ashimema is going to investigate setting up a bridged rocket.chat server to allow a more modern form of instance communication for the community.
  2. ashimema to send out a global bug squashing day announcement email
  3. ashimema will summarise the release cycle discussion on a wiki page and invite people to contribute/comment via as many comms methods as he can muster.


Action items, by person

  1. ashimema
    1. ashimema is going to investigate setting up a bridged rocket.chat server to allow a more modern form of instance communication for the community.
    2. ashimema to send out a global bug squashing day announcement email
    3. ashimema will summarise the release cycle discussion on a wiki page and invite people to contribute/comment via as many comms methods as he can muster.


People present (lines said)

  1. ashimema (157)
  2. cait (43)
  3. talljoy (36)
  4. Joubu (29)
  5. davidnind (26)
  6. oleonard (22)
  7. caroline_catlady (20)
  8. magnuse (11)
  9. kidclamp (6)
  10. wizzyrea (6)
  11. huginn (6)
  12. kellym (6)
  13. tcohen (5)
  14. eythian (2)
  15. jzairo (2)
  16. georgew (2)
  17. TGoat (2)


Generated by MeetBot 0.1.4.