#koha: Development IRC meeting 12 August 2020
Meeting started by Joubu at 14:00:05 UTC
(full logs).
Meeting summary
- Introductions (Joubu, 14:00:10)
  - https://wiki.koha-community.org/wiki/Development_IRC_meeting_12_August_2020
    (Joubu,
    14:00:15)
- Jonathan Druart (Joubu,
    14:00:20)
- Marcel de Rooy (marcelr,
    14:00:24)
- Martin Renvoize, PTFS Europe, UK (ashimema,
    14:00:53)
- Nick Clemens (kidclamp,
    14:01:55)
- Tomas Cohen Arazi, Theke Solutions (tcohen,
    14:02:10)
 
 
- Announcements (Joubu, 14:02:27)
  - Owen Leonard, Athens County Public Library,
    Ohio, USA (oleonard,
    14:04:26)
- Marcel sent an email about 24544 on the dev ML
    - more feedback welcome! (Joubu,
    14:06:23)
- Update from the Release manager (20.11)
    (Joubu,
    14:06:55)
- Focus must be on bug 20168, bug 22417 and bug
    20271 for the next couple of weeks (Joubu,
    14:09:12)
- Bookmark
    https://frama.link/koha_bz_RM_priority (Joubu,
    14:09:30)
- Updates from the Release Maintainers
    (Joubu,
    14:15:44)
- ACTION: ashimema is
    going to add his stamp on 20168 (Joubu,
    14:16:39)
 
 
- Updates from the QA team (Joubu, 14:19:17)
  - There is a bunch a major waiting for SO or QA,
    would be good to prioritize them (Joubu,
    14:22:04)
 
 
- Actions from last meeting (Joubu, 14:23:05)
 
- ashimema will get back to qa bug 15522 (Joubu, 14:23:17)
  - I've left a note on the bug.. I'm generally
    happy with the way it all works from an end user perspective.. We
    had the PTFS-E educators have a chat with the ByWater educators to
    work through it.. they're all happy. (ashimema,
    14:24:28)
- My next move is to start digging into the
    code.. I'd love to see a vue alternative submitted somewhere so we
    could do a comparison for code clarity between the two
    frameworks... (ashimema,
    14:25:11)
- This bug shouldn't be blocked by a lack of
    decision on framework.. but also feels like if it gets pushed as is,
    it makes the implicit decision for us. (ashimema,
    14:25:44)
- ACTION: ashimema is
    collecting notes about bug 15522 and is going to review and dig a
    bit more into the code (Joubu,
    14:28:24)
 
 
- ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed) (Joubu, 14:28:48)
  - ACTION: ashimema to
    propose a guideline ragarding using direction object notation rather
    than indirect object notation (postponed) (Joubu,
    14:29:12)
 
 
- tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (Joubu, 14:29:21)
  - ACTION: tuxayo
    integrate the RMaint-handover-draft into the "release maintenance"
    wiki page (postponed) (Joubu,
    14:30:15)
 
 
- davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (Joubu, 14:30:34)
  - ACTION: davidnind
    Find and update relevant places to record Perl version required,
    including release notes, manual and wiki (one source of the truth):
    update - still working on this (postponed) (Joubu,
    14:31:00)
 
 
- General development discussion (trends, ideas, ...) (Joubu, 14:31:11)
 
- Set time of next meeting (Joubu, 14:32:20)
  - Next meeting: 26 August 2020, 14 UTC
    (Joubu,
    14:33:14)
- If you prefer another hour of the meeting, like
    19, 20, 21, please contact Joubu on IRC and we will modify it
    (Joubu,
    14:35:10)
 
Meeting ended at 14:35:16 UTC
(full logs).
Action items
  - ashimema is going to add his stamp on 20168
- ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code
- ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
- tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
- davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
Action items, by person
  -  ashimema 
    - ashimema is going to add his stamp on 20168
- ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code
- ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
 
- UNASSIGNED
    - tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
- davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
 
People present (lines said)
  - Joubu (82)
- ashimema (30)
- marcelr (15)
- huginn (13)
- tcohen (9)
- wahanui (6)
- oleonard (3)
- kidclamp (1)
Generated by MeetBot 0.1.4.