#koha: Development IRC meeting 16 December 2020

Meeting started by Joubu at 15:00:39 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 15:00:54)
    1. Jonathan (Joubu, 15:00:57)
    2. Martin Renvoize, PTFS Europe (ashimema, 15:00:58)
    3. Jonathan Druart (Joubu, 15:01:00)
    4. Nick Clemens, ByWater Solutions (kidclamp, 15:01:08)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_16_December_2020 (Joubu, 15:01:08)
    6. Andrew Fuerste-Henry, ByWater Solutions (AndrewFH, 15:01:14)
    7. tuxayo/Victor Grousset, France (tuxayo, 15:01:22)
    8. Lucas Gass, ByWater Solutions (lukeG1, 15:01:36)

  2. Announcements (Joubu, 15:02:57)
  3. Update from the Release Manager (21.05) (Joubu, 15:03:58)
    1. Please follow https://frama.link/koha_bz_rel_20_11_candidate for the urgent things to backport into the next 20.11.x (Joubu, 15:04:48)
    2. A 4G swap file has been added to the Git server, hopefully it will fix OOM (Joubu, 15:05:53)
    3. ES5 support dropped by bug 27070 (Joubu, 15:06:52)
    4. Fridolin Somers, Biblibre, France (fridolin, 15:08:36)

  4. Updates from the Release Maintainers (Joubu, 15:15:38)
  5. Updates from the QA team (Joubu, 15:19:10)
    1. Next minor releases are planned for beginning of the year, on Jan 5th (Joubu, 15:19:47)

  6. Actions from last meeting (Joubu, 15:23:01)
    1. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate) (Joubu, 15:23:31)
    2. ACTION: amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc. (Joubu, 15:23:40)

  7. General development discussion (trends, ideas, ...) (Joubu, 15:24:02)
    1. https://lists.koha-community.org/pipermail/koha-devel/2020-December/046177.html (Joubu, 15:25:21)
    2. The release notes are a requirement for 21.05 (Joubu, 15:25:41)
    3. If you have patches that reach the "Passed QA" status and that the bug report does not have release notes, RM will add the "release-notes-needed". The patches won't be reviewed and pushed until (Joubu, 15:26:06)
    4. release notes have been correctly added. (Joubu, 15:26:18)

  8. Set time of next meeting (Joubu, 15:38:12)
    1. Next meeting: 30 December 2020, 20 UTC (Joubu, 15:39:11)


Meeting ended at 15:39:47 UTC (full logs).

Action items

  1. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate)
  2. amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.


People present (lines said)

  1. Joubu (98)
  2. tuxayo (17)
  3. fridolin (14)
  4. ashimema (9)
  5. kidclamp (9)
  6. huginn (6)
  7. AndrewFH (3)
  8. caroline (2)
  9. Stefan (1)
  10. inlibro (1)
  11. oleonard (1)
  12. lukeG1 (1)
  13. wahanui (1)


Generated by MeetBot 0.1.4.