13:00:27 <Joubu> #startmeeting Development IRC meeting 17 June 2020
13:00:27 <huginn> Meeting started Wed Jun 17 13:00:27 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:27 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:27 <huginn> The meeting name has been set to 'development_irc_meeting_17_june_2020'
13:00:33 <Joubu> #topic Introductions
13:00:47 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_17_June_2020
13:00:54 <Joubu> #info Jonathan Druart
13:00:55 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
13:01:00 <Joubu> #chair cait1
13:01:00 <huginn> Current chairs: Joubu cait1
13:01:04 <khall_> #info Kyle M Hall, ByWater Solutions
13:01:04 <Joubu> #chair ashimema
13:01:04 <huginn> Current chairs: Joubu ashimema cait1
13:01:06 <tuxayo> #info tuxayo/Victor Grousset, France
13:01:17 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
13:01:48 <talljoy> #info Joy Nelson, ByWater Solutions
13:01:58 <davidnind> #info David Nind, Wellington, New Zealand
13:02:06 <marcelr> #info Marcel de Rooy, Rijksmuseum, Netherlands
13:02:07 <Joubu> rmaints?
13:02:07 <wahanui> lukeG, aleisha, and tuxayo, I SUMMON THEE!!
13:02:09 <Joubu> qa_team?
13:02:09 <wahanui> qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall
13:02:13 <ashimema> #info Martin Renvoize, PTFS Europe.
13:02:15 <HenryB> #info Henry Bolshaw, House of Lords Library, UK
13:02:23 <cait1> #info Katrin Fischer, BSZ, Germany
13:02:58 <Joubu> no wahanui, qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
13:02:58 <wahanui> okay, Joubu.
13:03:11 <tuxayo> qa_team is also matts alex_a jajm
13:03:11 <wahanui> okay, tuxayo.
13:03:14 <Joubu> #topic Announcements
13:03:30 <tuxayo> oops
13:03:31 <Joubu> Anyone have something?
13:03:37 <tuxayo> Sorry Joubu
13:05:03 <tuxayo> qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
13:05:06 <Joubu> #info I am planning to upgrade and move our git server. The plan is to have a new server and suggest gitea as a replacement of the couple gitweb/gitolite
13:05:23 <Joubu> I will send an email to the list in the next couple of weeks
13:05:28 <tuxayo> Joubu++
13:05:43 <tcohen> Joubu++
13:05:45 <Joubu> something else?
13:05:56 <ashimema> Joubu++
13:05:57 <tuxayo> wahanui: why do you ignore me when I'm trying to fix my mistake!
13:05:57 <wahanui> tuxayo: huh?
13:05:58 <ashimema> loving this move and modernisation
13:06:38 <ashimema> see Joubu's.. it's subtly different tuxayo ;)
13:06:48 <Joubu> #topic Update from the Release manager (20.11)
13:06:48 <ashimema> nothing from me
13:06:51 <cait1> what happens to the git statistics?
13:07:21 <cait1> does gitea have a similar feature or the ability that we can add that to the new server as well?
13:07:24 <Joubu> Nothing much to tell, I am starting slowly to push things. Jenkins is back to green for master, and stable branches should get back to an happy state soon
13:08:13 <Joubu> cait1: it's gitstats, something different. That will be kept (either keep gitstats or replace with something a bit more fresh)
13:08:40 <tcohen> gitea must have something like that
13:08:44 <ashimema> the current gitstats are a bit weird ;)
13:08:46 <tuxayo> ashimema: thanks, I fixed it via PM to wahanui to stop spaming here
13:08:50 <cait1> i like them :)
13:08:52 <ashimema> but I do like how they breakdown in theory.. I'm sure gittea has similar
13:08:58 <Joubu> There is not much alternatives however
13:09:05 <ashimema> under the activity tab no doubt
13:09:07 <cait1> can you please add it to the list? (if there is one?
13:09:08 <davidnind> https://codeberg.org/Codeberg/gitea
13:09:10 <Joubu> they are nicer, but lack info
13:10:04 <Joubu> I can share an admin account to a test install I have if somebody wants to play with it
13:10:11 <mtj> #info Mason James, NZ
13:10:17 * ashimema has been thinking of learning Go.. perhaps I could add some gitstats inspired extras ;)
13:10:35 <marcelr> looks like you have a contributors tab ?
13:10:44 <tuxayo> marcelr: yes
13:10:44 <marcelr> with github like stats ?
13:10:58 <oleonard> Just what you need ashimema, new projects :D
13:11:09 <ashimema> hehe
13:11:09 * cait1 vetoes
13:11:16 <cait1> i think yo have other stuff to finish :P
13:11:18 * ashimema doesn't see a contributors tab
13:11:29 <Joubu> moving on?
13:11:33 <tuxayo> marcelr: wait, I mixed up, it seems not!
13:11:36 <cait1> i see incomplete german transaltion and cannot switch it
13:11:42 <ashimema> yeah.. lets move on
13:11:45 <Joubu> no, gitea does not provide the same views as we have now with gitstats
13:11:57 <cait1> found it, it's at the bottom
13:12:10 <Joubu> that's why we will certainly keep gitstats, unless we found something else. gitstats is super old and not maintained
13:12:13 <Joubu> #topic Updates from the Release Maintainers
13:12:51 <Joubu> lukeG1 maybe?
13:13:13 <Joubu> I will take over lukeG1 for 20.05.01 as he won't be around
13:13:24 <tuxayo> I'm getting used to the workflow :) Let's see how the release goes.
13:13:25 <tcohen> He's on vacation
13:13:44 <Joubu> We are actively discuting with Rmaints to backport some important patches (related with the Mojo version issues)
13:14:09 <Joubu> And mtj is doing a great job to refresh the debian package repo to make it easier to maintain
13:14:31 <tuxayo> vacation of lukeG1: only after the 18th IIRC, so two days to get them before the return on the 28th.
13:15:16 <Joubu> tuxayo: anything to add about 19.05?
13:16:08 <Joubu> #topic Updates from the QA team
13:16:24 <tuxayo> Joubu: Not much in addition to the above message. The CI is a great help. And Mojo version issue don't impact oldoldstable :P
13:16:26 <ashimema> doing a great job rmaints
13:17:00 <tuxayo> Koha testing docker also is a great help
13:17:08 <Joubu> cait1 maybe? Are you happy with your new team? :)
13:17:22 <ashimema> lots of QA to do
13:17:24 <marcelr> "new"
13:17:42 <Joubu> not your marcelr :D
13:17:49 <Joubu> you*
13:18:00 <marcelr> ahh
13:18:18 <cait1> oh sorry
13:18:24 <cait1> work distracted
13:18:26 <ashimema> nice to see a slightly more even spread of QA between the team.. be nice to have a little more competition at the top of the leaderboard though ;)
13:18:34 <cait1> I am very happy with the team
13:18:42 <cait1> the Friday squad has grown :)
13:18:53 <ashimema> :)
13:19:00 <Joubu> yes it's nice to see activities on Friday
13:19:02 <cait1> i hope activity will increase a bit more
13:19:08 <marcelr> there should be more fridays
13:19:23 <Joubu> But keep in mind that we are going to enter the "push all the big things" window
13:19:33 <tuxayo> yay :D
13:19:34 <Joubu> it's time to focus on the big moves :)
13:19:50 <ashimema> :)
13:19:51 <Joubu> I won't list them, you know what they are
13:19:51 * oleonard 's favorite window
13:20:18 <cait1> I was hoping to get some dates and tiems set for testing some of the bigger things in the community
13:20:18 <Joubu> and most of see could get 2 pair of eyes from QA, don't wait for them to arrivein the QA queue
13:20:23 <Joubu> them*
13:20:28 <cait1> the idea is... give it lots of exes for an hour or so
13:20:45 <cait1> eyes,... not exes
13:20:48 <marcelr> ok
13:20:59 <Joubu> ha yes, we have something on the agenda about that!
13:21:06 <cait1> that shoudl not keep anyone from looking at them anytime
13:21:09 <Joubu> #topic     Community testing events for 'big stuff' bugs (example: Bug 20271, Bug 20168)
13:21:11 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20271 enhancement, P1 - high, ---, jonathan.druart, Needs Signoff , Merge deleted biblio, biblioitems, biblio_metadata, and items tables
13:21:12 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20168 enhancement, P5 - low, ---, oleonard, Needs Signoff , Update of the OPAC bootstrap template to bootstrap v4
13:21:14 <tuxayo> > I won't list them, you know what they are
13:21:16 <tuxayo> For anyone out of the loop, I guess the bugzilla keywords RM_priority and rel_20_11_target are where they are.
13:21:20 <tuxayo> (among other things)
13:21:47 <Joubu> cait1: what did you have in mind?
13:22:01 <Joubu> like we focus on 1 or 2 a given day?
13:23:31 <tcohen> there's a couple really game changing ones like
13:23:32 <ashimema> If you suggest a particular bug for a team effort each week in your newsletter cait, I would jump on board with joining the effort
13:23:36 <tcohen> the task queue
13:23:38 <Joubu> we could setup a branch with them applied, and test the branch?
13:23:39 <cait1> sorry, demanded from all sites right now :)
13:23:57 <cait1> i thught i'd start a free doodle with some suggestions, but we can also just agree on times
13:24:02 <cait1> would fridays be generally suitable?
13:24:17 <cait1> ashimema: that's a good suggestion
13:24:20 <cait1> merge one first?
13:24:34 <ashimema> sounds good
13:25:13 <cait1> i will suggest as "bug of the week" and also suggest a time for gathering to test or 2
13:25:16 <Joubu> #action cait Organise a testing day for "big stuffs"
13:25:38 <cait1> but we can also advertise outside of the qa team, doesn't hurt
13:25:48 <cait1> Joubu: can you make sure it's rebased for next week?
13:26:09 <Joubu> yes sure, I rebased it last week so it will be easy
13:26:34 <Joubu> #topic General development discussion (trends, ideas, ...)
13:26:38 <ashimema> merge one sound like a good place to start :)
13:26:56 <Joubu> the move to bootstrap 4 could be tested at the same time
13:27:21 <Joubu> it's a bit boring (imo) to test the UI, so better to test something else and notice UI changes/regressions :)
13:27:31 <cait1> i can advertise both together on the mailing list
13:27:37 <cait1> i will think about something until the end of the week
13:27:49 <Joubu> #topic Generic example template for new pages in the OPAC
13:27:54 <Joubu> the agenda says "We should add a generic example template for new pages in the OPAC (and perhaps staff client) that follows all the best current best practices to aid develops adding new pages. "
13:28:35 <Joubu> ashimema: you added that
13:28:45 <ashimema> ah yes
13:28:48 <Joubu> did you open a bug report already?
13:28:53 <oleonard> My hope is that my Bootstrap 4 work will be approved soon enough that we should wait until after that
13:29:02 * oleonard crosses his fingers
13:29:13 <cait1> :)
13:29:25 <talljoy> yay!
13:29:30 <ashimema> well.. whilst going through templates for accessibility fixing reasons i noted how much disparity there is
13:30:16 <cait1> sorry, have to run - will read back later
13:30:16 <Joubu> ashimema: we use to have the "city" code as an example
13:30:19 <ashimema> I wanted to suggest we ship a 'template' template.. at least for the opac, which can be used as a starting point when developers want to add new pages..
13:30:26 <ashimema> best practices
13:30:48 <ashimema> indeed.. but city is only staff side.. I'm thinking opac side
13:30:52 <Joubu> (we don't have city at the OPAC)
13:30:54 <Joubu> yes, that
13:31:06 <tcohen> we could have  an extra project, that allows us to scaffold things
13:31:06 <mtj> congrats on the opac bootstrap-4 stuff, oleonard++
13:31:29 <ashimema> it was mostly thinking aloud
13:31:35 <oleonard> mtj: Don't congratulate me until after testing :)
13:31:43 <Joubu> a koha-lite with simple stuffs and examples to follow
13:31:44 <tcohen> like yeoman, but targetting Koha uses: templates, Koha::Object classes
13:31:47 <ashimema> we're very inconsistent with heading nesting levels and things
13:32:01 <ashimema> be good to have a template and use it in the guidelines
13:32:06 <oleonard> There is some documentation on page structure here, but specific to the staff interface: https://wiki.koha-community.org/wiki/Interface_patterns#Page_layouts
13:32:09 <ashimema> sounds great to me tcohen
13:32:28 <oleonard> ...but having a complete example would be good
13:32:31 <ashimema> ooh..
13:32:52 <ashimema> that's exactly the sort of thing I was thinking oleonard.. but perhaps at the koha repo level as a file
13:32:58 <Joubu> Don't we have different structures? Only one template won't be enough in that case
13:33:04 <ashimema> and of course.. with some OPAC examples as well as staff
13:33:04 <oleonard> Correct
13:33:57 <ashimema> I'm not sure how many different structures we have.. and if we should have lots of different structures to be honest ;)
13:34:30 <marcelr> with includes and block processing fun ?
13:34:45 <tcohen> koha-template --name somepage --include holds, datatable --target opac --dest-dir .
13:34:58 <Joubu> #action open a bug report to introduce the idea of having a "skeleton" template we could copy for new pages
13:35:14 <ashimema> as dcook mentioned.. using the WRAPPER tt directive could help a bit
13:35:16 <Joubu> we don't create many new pages :)
13:35:38 <ashimema> tcohen I love that idea.. but don't have a clue where to start on that front ;)
13:35:40 <tcohen> [off] In fac twe should stop creating pages ;-)
13:35:59 <ashimema> okies..
13:36:03 <oleonard> [off] Koha is done. Shut it all down!
13:36:10 <ashimema> you are indeed correct..
13:36:11 <oleonard> [off] ;)
13:36:18 <tcohen> [off] Just pick a damn toolkit and ...
13:36:22 <talljoy> [off] turns off her computer
13:36:23 <ashimema> but it would be nice to get our existing pages more consistent
13:36:34 <ashimema> move on Joubu
13:36:38 <ashimema> ;)
13:36:39 <marcelr> [on]
13:36:56 <Joubu> oleonard: does the move to bootstrap 4 modifies/unifies the structures?
13:37:52 <oleonard> The grid markup is completely changed, the page structure overall is basically the same. I did some work on improving consistency but it wasn't my primary goal
13:38:07 <Joubu> ok
13:38:13 <Joubu> #topic Routes for authorised values (RFC)
13:38:20 <Joubu> tcohen?
13:38:20 <wahanui> somebody said tcohen was the man you want to thank
13:38:26 <oleonard> Thanks tcohen
13:38:28 <Joubu> thanks tcohen
13:38:37 <tcohen> LOL
13:38:39 <ashimema> I think we need guidelines as to what the consistency is before we can clearly work towards it.. that's kinda my point here
13:39:36 <tcohen> I noticed a pattern on the authorised values logic that would complicate implementing the original RFC: library limits
13:40:22 <tcohen> the RFC needs some love in terms of attribute names
13:40:24 <tcohen> and the guidelines
13:40:46 <Joubu> bug 17390
13:40:47 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17390 enhancement, P5 - low, ---, koha-bugs, Needs Signoff , Add REST API endpoint for Authorised Values
13:40:50 <tcohen> but overall, the problem here is that having a general /authorised_values route
13:40:53 <Joubu> #link https://wiki.koha-community.org/wiki/Authorised_values_endpoint_RFC
13:41:01 <tcohen> will be complicated to implement
13:41:27 <tcohen> if it needs to acknowledge permissions, library limits and will probably not be used
13:41:52 <tcohen> you can only query all auth values in a simple way if you are a superlibrarian
13:42:07 <tcohen> so I proposed a simpler implementation, changing the routes design
13:42:23 <tcohen> and I also suggested on the bug
13:42:32 <tcohen> that if the only thing that is going to be used
13:42:41 <tcohen> is a POST to add a new value to a category
13:42:46 <tcohen> then just implement that
13:43:18 <tcohen> one of the errors we made at the beginning of the API development was to
13:43:25 <Joubu> Do we need to review the other (if exist) endpoint RFCs?
13:43:37 <tcohen> forget about how it was going to be used, so when we needed to used to routes, they lacked many things
13:43:38 * ashimema supports implementing things piecemeal if it means things actually end up in.. all too often we see 'all or nothing'.. and then you end up with nothing.
13:44:53 <tcohen> Joubu I'm not sure about that, auth values is specially tricky IMHO
13:45:01 <ashimema> I'm only quickly looked at the av bug.. but I agree it needs a level of routing which I think the current implimentation doesn't have.. but I need to test it before really commenting deeply.
13:45:11 <tcohen> and design should consider translations which is something that is waiting on the queue
13:45:13 <ashimema> av is a very hard area
13:45:27 <Joubu> there is no current implementation
13:45:40 <Joubu> or, the patches on the bug report you mean?
13:46:12 <Joubu> tcohen: translations is another endpoing IMO
13:46:12 <tcohen> bug 20307
13:46:13 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20307 new feature, P5 - low, ---, jonathan.druart, BLOCKED , Language overlay for authorized values
13:46:25 * ashimema is hopeing jajm will pick up the translations bug again.. it felt like he was making some foor progress on that alternative implimentation
13:46:53 <Joubu> ok, moving on?
13:47:00 <tcohen> Joubu now we can embed things, how a translated description will be fetched needs to be thought at the root of this
13:47:16 <Joubu> indeed
13:47:25 <Joubu> I was thinking "post/put"
13:47:33 <tcohen> ah, you're correct
13:47:48 <ashimema> happy to move on
13:47:52 <Joubu> #topic Review of coding guidelines
13:48:00 <Joubu> #topic We should require all OPAC pages always contain a single 'maincontent' class to denote the main content of the page Bug 22807
13:48:01 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22807 enhancement, P5 - low, ---, martin.renvoize, Signed Off , Accessibility: Add 'Skip to Main Content' link
13:48:09 <Joubu> ashimema: did you add this one?
13:48:26 <ashimema> another case of the accessibility work highlighting some area's we've been missing in QA
13:49:12 <ashimema> it looks like we started add 'maincontent' classes to pages a while back to aid in displaying the main part of the page when collapsed for small screens
13:49:42 <ashimema> but.. we haven't consistently ensured each page has one such class
13:50:23 <ashimema> it become additional important with my work on bug 22807, which adds 'Skip to main content' links for added accessability which utilise these classes
13:50:33 <ashimema> so.. I wanted to propose adding a guideline as such
13:50:53 <ashimema> and then enforcing at at the QA level.. if we can
13:51:32 <oleonard> +1
13:51:35 <Joubu> at first glance I think we can have a test in the QA script easily
13:51:59 <ashimema> perhaps we could even do with an 'Accessibility' section of the guidelines.. it's becoming more and more internationally important as far as I'm aware
13:52:24 <tuxayo> > 'Accessibility' section of the guidelines
13:52:24 <tuxayo> +1
13:52:27 <ashimema> this would just be the first of a few such guidelines I'm likely to suggest whilst I go through my massive report
13:52:27 <Joubu> you are close to get another action ashimema
13:52:32 <ashimema> lol
13:52:43 <ashimema> sounds like people are generally onboard then..
13:52:58 <ashimema> I'll draft up a guideline for us to vote next meeting.. sound fair?
13:53:03 <marcelr> +1
13:54:05 <ashimema> #action ashimema to draft the first 'Accessibility' guideline; All OPAC pages require a single 'maincontent' classed block.
13:54:09 <ashimema> ok.. brill
13:54:10 <Joubu> #action ashimema write a guideline about mandatory 'maincontent' class (OPAC)
13:54:10 <ashimema> next :)
13:54:13 <tuxayo> ashimema++
13:54:22 <ashimema> hehe
13:54:51 <Joubu> #topic We should add a coding guideline for language involving allow/deny lists Bug 25708 and using inclusive language
13:54:52 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25708 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Use allow/disallow terminology in code
13:54:59 <oleonard> kidclamp?
13:54:59 <wahanui> kidclamp is reply i guess kidclamp is the first RM not to be bribed
13:55:06 <talljoy> he's on vacation
13:55:16 <talljoy> i worked with him on that bug
13:55:17 <Joubu> wahanui: that's wrong
13:55:17 <wahanui> Joubu: huh?
13:56:05 <oleonard> talljoy did you and kidclamp talk about specific wording for a coding guideline?
13:56:32 <talljoy> just briefly.  i was going to talk to tcohen about some ideas today.
13:57:17 <talljoy> if you want to action item that i can work on it and submit a proposed change to vote on at the next meeting
13:57:30 <tcohen> +1
13:57:31 <marcelr> git grep -l black|wc -l 165
13:57:32 <Joubu> what's the idea?
13:57:32 <wahanui> i guess the idea is of Koha::Cron is nice, I just do not like creating some "system" user in patrons database...
13:57:40 <marcelr> git grep -l white|wc -l 675
13:58:24 <marcelr> is whitespace no longer allowed ? ;)
13:58:37 <oleonard> Terms like "blacklist" can either have racist origins or racist overtones, and we should avoid them
13:58:40 <talljoy> the terms blacklist and whitelist are problematic for us
13:58:54 <tuxayo> marcelr: tabs I guess aren't :P
13:59:10 <talljoy> oleonard++
13:59:14 <talljoy> for clarity :)
13:59:17 <ashimema> it follows the same logic that 'master' is bad in git..
13:59:27 <oleonard> Yes absolutely ashimema
13:59:31 <ashimema> and 'master', 'slave' is bad in db's
13:59:32 <ashimema> etc
13:59:42 <talljoy> i noticed github changed from master to main.
13:59:49 <Joubu> yes, master in git does not make sense.
14:00:06 <ashimema> I'm happy for us to do it to save future arguaments.. even though personally I find it somewhat absurd
14:00:27 <talljoy> whitelist/blacklist?
14:00:29 <marcelr> gradual improvements ?
14:00:30 <Joubu> same
14:00:47 <ashimema> allowlist/denylist works for me
14:00:56 <marcelr> +1
14:00:57 <talljoy> it's more clear to function also
14:01:04 <oleonard> I don't find the idea of eliminating problematic terminology absurd. I find it essential.
14:01:22 <Joubu> blacklist is used in different languages
14:01:26 <ashimema> even though blacklist etimology has absolutely nothing to do with skin colour in the first place..
14:01:41 <oleonard> We strive to be as open and inclusive as we can and we should set an example in our use of language
14:01:45 <talljoy> communication is not about the words used, but what is heard.
14:01:46 <ashimema> I can certainly see how some people might take offence
14:02:17 <tuxayo> > even though blacklist etimology has absolutely nothing to do with skin colour in the first place..
14:02:22 <tuxayo> +1, after double checked that in wikipedia before the meeting
14:02:23 <tuxayo> > I can certainly see how some people might take offence
14:02:23 <tuxayo> +1
14:02:56 <Joubu> so, action?
14:03:14 <talljoy> i'm happy to work on a proposal for the coding guidelines.
14:03:29 <marcelr> a general one ?
14:03:31 <ashimema> what I find absurd is that people are taking offence at things that long predate the argument.. I do think we should do something about it so people have no excuse to take offence
14:03:33 <oleonard> Is anyone willing to investigate what would be involved with doing away with the term "master" in our projects?
14:03:37 <ashimema> that's the point I was trying to get at..
14:03:50 <ashimema> not that it's absurd we do it..
14:04:05 <tuxayo> ashimema++
14:04:09 <oleonard> <thumbsup.png>
14:04:11 <Joubu> #action talljoy Propose a guideline for "inclusive langage" (whitelist/blacklist vs allowlist/denylist)
14:04:19 <talljoy> will do!
14:04:33 <marcelr> we dont need a guideline for each term ?
14:04:43 <tuxayo> oleonard: is depend if we accept slavery for our machines. But someday they might raise against us!
14:04:47 <tuxayo> talljoy++
14:04:48 <ashimema> to be honest.. we probably do
14:04:51 <Joubu> are there other problematic terms?
14:04:56 <Joubu> or just blacklist?
14:05:03 <talljoy> that's a bigger discussion for the group.
14:05:13 <khall_> that's all I've noticed so far Joubu
14:05:22 <Joubu> ok, moving on then
14:05:25 <talljoy> i can speak from my perspective (from the US), but their may be other perspectives worth considering
14:05:26 <ashimema> we're an international community.. unless someone specifically brings my attention to a word like blacklist being offensive I really wouldn't have guessed it ;)
14:05:34 <Joubu> something else to add before the last (and best) topic?
14:05:37 <ashimema> hence I feel it needs to be written down
14:05:47 <oleonard> It will be an ongoing process as we learn
14:05:52 <talljoy> agreed.
14:05:56 <ashimema> indeed..
14:06:13 <ashimema> each time we come up with one we need to add it to a list somewhere
14:06:15 <ashimema> one a QA person can refer to and point at
14:06:17 <gmcharlt_> Joubu: it's currently done via an RSS feed from gitweb
14:06:43 <oleonard> If you're going to chime in you'll have to #info gmcharlt ;)
14:07:31 <Joubu> #topic Set time of next meeting
14:07:31 <tuxayo> > each time we come up with one we need to add it to a list somewhere
14:07:31 <tuxayo> A denylist list of course.
14:07:54 <ashimema> :'(
14:08:06 <ashimema> we have a terminology page.. we should just add it to that I recon
14:08:07 <tuxayo> > something else to add before the last (and best) topic?
14:08:07 <tuxayo> I got something aboyt RMaint handover on each cycle
14:08:56 <ashimema> someone fancy adding 'blacklist' and 'whitelist' to https://wiki.koha-community.org/wiki/Terminology
14:08:58 <Joubu> go tuxayo
14:10:23 <tuxayo> The time frame between the last point release (22th) and the release of the 20.05
14:10:24 <tuxayo> was unclear about which team should RMaint (backport) during that time/
14:10:41 <tuxayo> Various assumptions can make sence
14:10:58 <tuxayo> But if not everyone make the same, then we can miss patch to review
14:11:03 <tuxayo> *patches
14:11:12 * ashimema adds terms to wiki
14:11:50 <talljoy> I agree that some coordination on handoffs would be helpful
14:11:50 <Joubu> ashimema: I'd wait for the guideline
14:12:29 <talljoy> For 19.11 I spoke (in IRC) with aleisha letting her know the moment i was stepping away and she was now owner of that branch
14:12:44 <Joubu> tuxayo: I guess it happened because the release went out with delay
14:12:48 <talljoy> do you have a suggestion tuxayo?
14:13:07 <Joubu> the 20.05.00 release I mean
14:14:09 <tuxayo> Could we have that formally in the process of team switching? And about which team should process the gap,
14:14:11 <tuxayo> I think the previous team should.
14:14:12 <tuxayo> I'm sure I'm will find easier to continue one week more of backporting
14:14:13 <tuxayo> than having to catch up one week during the first month when the branch isn't known yet well.
14:14:31 <talljoy> good point
14:15:05 <tuxayo> But the actual this is to have the [holy] "RMaint cursor" explicitly transmitted
14:15:12 <tuxayo> (wherever it is)
14:16:11 <tuxayo> *But the important thing
14:16:29 <Joubu> #action tuxayo write a proposal for handing over stable branches
14:16:39 <Joubu> ok? :)
14:16:40 <tuxayo> And also transmit the bugs that touch strings that have been put on hold during the string freeze
14:16:41 <talljoy> this is a great idea!
14:16:43 <tuxayo> Ok
14:17:01 <ashimema> :)
14:17:18 <Joubu> maybe send an email to the other RMaints to collect ideas, then write something down together
14:17:29 <tuxayo> Like a draft for a new section of the Release_maintenance wiki pages?
14:17:30 <tuxayo> *page
14:17:35 <Joubu> yes
14:17:56 <tuxayo> ok!
14:18:01 <Joubu> Next meeting: 1 July 2020, 20 UTC?
14:18:03 <tuxayo> We can move on
14:18:20 <Joubu> #info Next meeting: 1 July 2020, 20 UTC?
14:18:45 <Joubu> #endmeeting