#koha: Development IRC meeting 18 November 2020
Meeting started by Joubu at 15:00:34 UTC
(full logs).
Meeting summary
- Introductions (Joubu, 15:00:42)
  - Jonathan Druart (Joubu,
    15:00:51)
 
  - Martin Renvoize, PTFS-Europe (ashimema,
    15:01:12)
 
  - Nick Clemens, ByWater Soluitions (kidclamp,
    15:01:32)
 
  - Lucas Gass, ByWater Solutions (lukeG1,
    15:01:45)
 
  - Tomas Cohen Arazi, Theke Solutions (tcohen,
    15:02:50)
 
 
- Announcements (Joubu, 15:03:16)
  - Kyle M Hall, ByWater Solutions (khall,
    15:03:17)
 
  - Katrin Fischer, BSZ, Germany (cait,
    15:03:40)
 
 
- Update from the Release manager (20.11) (Joubu, 15:04:02)
  - https://gitlab.com/koha-community/koha-release-notes/-/blob/master/release_notes_20_06_00.md
    (Joubu,
    15:05:59)
 
  - Search for the rel_20_11_target to follow
    what's missing for 20.11 (Joubu,
    15:07:06)
 
  - D11 issues will certainly be fixed for 20.11
    (see 26893) (Joubu,
    15:07:21)
 
  - Have a look at the technical release notes, and
    the usual ones (Joubu,
    15:07:35)
 
  - https://annuel.framapad.org/p/koha_20.11_tech_release_notes
    (Joubu,
    15:07:40)
 
  - https://gitlab.com/koha-community/koha-release-notes/-/blob/master/release_notes_20_06_00.md
    (Joubu,
    15:07:43)
 
  - Fridolin Somers, Biblibre, France (fridolin,
    15:08:41)
 
  - Git server move planned on Nov 23th
    20UTC (Joubu,
    15:08:51)
 
 
- Updates from the Maintainers (Joubu, 15:09:52)
  - The Rmaints are finishing up their final
    release of the cycle. Seems thing to be proceeding well!
    (Joubu,
    15:10:13)
 
 
- Updates from the QA team (Joubu, 15:11:00)
 
- Actions from last meeting (Joubu, 15:16:41)
  - ACTION: amoyano
    advertise 15522 and ask the list for feedback [after 20.11 is
    released], setup a sandbox, etc. (Joubu,
    15:16:55)
 
  - ACTION: davidnind
    Find and update relevant places to record Perl version required,
    including release notes, manual and wiki (one source of the truth)
    (still working on this) (Joubu,
    15:17:06)
 
 
- ashimema Open an omnibus bug to fix the existing occurrences of input type "number" (Joubu, 15:17:13)
  - Bug 26926 - Update all occurrences of <input
    type="number"> to apply ACC2 coding guideline (ashimema,
    15:18:05)
 
  - http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26926
    Bug 26926 (ashimema,
    15:18:21)
 
 
- oleonard ask the list if someone use OpacGroupResults somewhere (Joubu, 15:18:28)
  - email about deprecation of OpacGroupResults has
    been sent (Joubu,
    15:18:43)
 
  - https://lists.katipo.co.nz/pipermail/koha/2020-November/055362.html
    (Joubu,
    15:18:47)
 
  - https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20410
    (Joubu,
    15:18:54)
 
 
- General development discussion (trends, ideas, ...) (Joubu, 15:19:19)
 
- Bug 26947 - we should update the kohastructure file as part of the release process (Joubu, 15:20:30)
 
- Set time of next meeting (Joubu, 15:28:09)
  - Next meeting: 2 December 2020, 20 UTC
    (Joubu,
    15:28:29)
 
 
Meeting ended at 15:29:02 UTC
(full logs).
Action items
  - amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
 
  - davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this)
 
People present (lines said)
  - Joubu (82)
 
  - ashimema (33)
 
  - cait (22)
 
  - huginn (22)
 
  - wahanui (5)
 
  - kidclamp (5)
 
  - fridolin (2)
 
  - tcohen (2)
 
  - lukeG1 (2)
 
  - koha-jenkins (2)
 
  - khall (1)
 
Generated by MeetBot 0.1.4.