#koha: Development IRC meeting 20 May 2020

Meeting started by Joubu at 14:00:02 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 14:00:12)
    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_20_May_2020 (Joubu, 14:00:21)
    2. Jonathan Druart (Joubu, 14:00:44)
    3. Martin Renvoize, PTFS-Europe (ashimema, 14:00:48)
    4. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard_, 14:00:52)
    5. Katrin Fischer, BSZ, Geramny (cait, 14:01:01)
    6. liz rea (wizzyrea, 14:01:07)
    7. Nick Clemens, ByWater Solutions (kidclamp, 14:02:42)
    8. Thomas Dukleth, Agogme, New York City (thd, 14:03:07)

  2. Announcements (Joubu, 14:03:17)
    1. Owen is working a Bootstrap 4 update for the OPAC, see bug 20168. It will be ready for 20.11 (Joubu, 14:05:03)
    2. Joubu will announce plans for the next cycle at the next development meeting.. first of the next cycle :) (ashimema, 14:06:48)

  3. Update from the Release Manager (20.05) (Joubu, 14:07:14)
    1. 20.05 is nearly ready.. I'm still aiming for a release on the 22nd but withhold the right to postpone if Jenkins isn't looking happy or I don't get the OK from the packaging team. (ashimema, 14:08:30)
    2. Thanks must go out to all those devs who have been working day and night the last couple of weeks to polish and fix bugs.. they know who they are.. fantastic effort to get us over the line guys! (ashimema, 14:09:19)
    3. community++ (Joubu, 14:09:51)

  4. Updates from the Release Maintainers (Joubu, 14:10:06)
  5. Updates from the QA team (Joubu, 14:11:54)
    1. QA queue is still high, but mostly enh (110 reports, 17 bugs) (Joubu, 14:12:39)
    2. Joy Nelson Bywater (talljoy, 14:13:50)

  6. General development discussion (trends, ideas, ...) (Joubu, 14:16:26)
  7. Catching errors caused by missing itemtype, homebranch, holdingbranch (see discussion on Bug 24331) (Joubu, 14:16:48)
    1. ACTION: Joubu add a fix for 25449 (Joubu, 14:39:39)
    2. ACTION: cait signoff on 25449 (Joubu, 14:39:51)
    3. ACTION: kidclamp QA 25449 (Joubu, 14:39:57)
    4. Package bugs for 20.05 (Joubu, 14:40:32)
    5. ACTION: mtj provide a "alpha" version of the Koha 20.05 package (Joubu, 14:42:55)

  8. Some tests are failing randomly (Bug 25551) (Joubu, 14:43:21)
    1. Review of coding guidelines (Joubu, 14:53:21)

  9. Review of coding guidelines (Joubu, 14:53:35)
    1. AGREED: Use "and" instead of "&" w (Joubu, 14:55:59)

  10. Set time of next meeting (Joubu, 14:58:08)
    1. Next meeting: 3 June 2020, 20 UTC (Joubu, 14:58:30)


Meeting ended at 14:59:09 UTC (full logs).

Action items

  1. Joubu add a fix for 25449
  2. cait signoff on 25449
  3. kidclamp QA 25449
  4. mtj provide a "alpha" version of the Koha 20.05 package


Action items, by person

  1. cait
    1. cait signoff on 25449
  2. Joubu
    1. Joubu add a fix for 25449
  3. kidclamp
    1. kidclamp QA 25449


People present (lines said)

  1. Joubu (110)
  2. cait (50)
  3. ashimema (49)
  4. huginn (19)
  5. wizzyrea (17)
  6. kidclamp (11)
  7. talljoy (7)
  8. oleonard_ (7)
  9. wahanui (6)
  10. kohaputti (5)
  11. davidnind (1)
  12. tcohen (1)
  13. nsk (1)
  14. thd (1)


Generated by MeetBot 0.1.4.