14:00:54 <Joubu> #startmeeting Development IRC meeting 26 August 2020
14:00:54 <huginn> Meeting started Wed Aug 26 14:00:54 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:54 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:54 <huginn> The meeting name has been set to 'development_irc_meeting_26_august_2020'
14:00:58 <Joubu> #topic Introductions
14:01:08 <Joubu> #info Jonathan Druart
14:01:08 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:01:57 <Joubu> qa_team
14:01:59 <Joubu> qa_team?
14:01:59 <wahanui> qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
14:02:01 <Joubu> rmaints?
14:02:01 <wahanui> lukeG, aleisha, and tuxayo, I SUMMON THEE!!
14:02:21 <kidclamp> #info Nick Clemens, ByWater Solutions
14:02:49 <marcelr> #info Marcel de Rooy
14:02:56 <kohaputti> #info Joonas Kylmälä
14:04:26 <Joubu> #topic Announcements
14:04:29 <Joubu> Anyone have something?
14:04:52 <tcohen> can we self promote our devs?
14:04:52 <tcohen> he
14:05:13 <marcelr> good idea
14:05:27 <tcohen> Bug 22343 is ready for testing
14:05:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22343 new feature, P5 - low, ---, tomascohen, Needs Signoff , Add SMTP configuration options to Administration
14:05:36 <marcelr> smtp again
14:05:43 <tcohen> kudos to khall, ashimema[m] and JOubu for QA feedback
14:06:04 <Joubu> #info the SMTP configuration admin page feature is ready for testing! bug 22343
14:06:25 <Joubu> marcelr, do you have one?
14:06:35 <Joubu> I have 3, but I have a dedicated section for that ;)
14:06:52 <marcelr> every bug that i submitted :)
14:07:13 <tcohen> I have another announcement
14:07:20 <Joubu> #info Marcel has patches waiting for signoff!
14:07:34 <tcohen> I'm working on merging the Koha2Koha ILL backend into core Koha
14:07:55 <tcohen> once I have it working I'll file a bug and submit the patches, the challenges are translatability
14:08:02 <tcohen> on the current layout
14:08:18 <koha-jenkins> Project Koha_Master_U20 build #80: SUCCESS in 44 min: https://jenkins.koha-community.org/job/Koha_Master_U20/80/
14:08:42 <Joubu> why translatibility?
14:09:20 <tcohen> there are some bad design decisions on the ILL stuff, that prevent it
14:09:21 <Joubu> #info Tomas is going to adjust the Koha2Koha ILL backend to have it into Koha core
14:09:30 <Joubu> k
14:09:32 <Joubu> something else?
14:09:36 <tcohen> shortcuts
14:09:52 <Joubu> #topic Update from the Release Manager 20.11
14:09:56 <Joubu> I forgot:
14:09:57 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_26_August_2020
14:10:12 <koha-jenkins> Project Koha_Master_D9 build #1416: SUCCESS in 46 min: https://jenkins.koha-community.org/job/Koha_Master_D9/1416/
14:10:14 <Joubu> I am harassing the QA team to have them on the^Mmy 3 top priority bugs: task queue, merge deleted* table, and the move to bootstrap 4
14:10:33 <kidclamp> i am going over the merge
14:10:33 <Joubu> You must watch regularly and put your attention on https://frama.link/koha_bz_RM_priority
14:10:45 <Joubu> there are 2 major bugs that are waiting for too long already
14:10:54 <tcohen> I'm looking at the bootstrap one and communicating with oleonard about the things I find
14:10:55 <Joubu> yep, thanks kidclamp!
14:11:34 <Joubu> I don't have anything to say apart that it's now or... maybe never
14:11:49 <Joubu> at least not for 20.11 if not ready very soon
14:11:53 <marcelr> push the merge one now
14:12:01 <Joubu> and I will certainly drop some of them (tired of rebasing them)
14:12:01 <tcohen> yeah, push it
14:12:02 <tcohen> haha
14:12:14 <Joubu> I don't want to bypass QA for such big changes
14:12:23 <tcohen> Nick is on it
14:12:24 <marcelr> i try the task q friday?
14:12:33 <Joubu> you will like it marcelr!
14:12:43 <tcohen> Joubu about the holds table, does your message imply that you expect a regression test for that?
14:13:06 <Joubu> the task queue opens door for a lot of great feature, and will fix lot of the long standing issues we have with the background jobs
14:13:16 <cait2> #info Katrin Fischer, BSZ, Germany
14:13:30 <Joubu> tcohen: I was thinking about it, and had to drop the idea somehwere, nothing else
14:13:42 <tcohen> ok, that concern is covered
14:13:52 <tcohen> I can take a look at tests, just in case
14:13:56 <cait2> sorry for being a little late
14:14:15 <Joubu> cait++
14:14:18 <Joubu> for being late
14:14:21 <Joubu> :D
14:14:29 <cait2> that's a first - what did you sign me up for already?
14:14:29 <Joubu> #topic Updates from the Release Maintainers
14:14:50 <Joubu> I don't think we have any
14:14:54 <Joubu> #topic Updates from the QA team
14:15:03 <Joubu> you are actually right in time for your topic :)
14:15:06 <marcelr> just in time cait2
14:15:21 <cait2> oh oops
14:15:27 <marcelr> she cut the queue remarkably
14:15:28 <Joubu> #info Stable releases are coming soon!
14:15:40 <cait2> #info QA queue is in pretty good shape right now, but needs work to stay that way, big patches waiting
14:15:50 <Joubu> FQA is pretty bad :D
14:15:58 <cait2> yes, but some complicated things remain, i hope to get your help with that
14:16:10 <marcelr> and how about In discussion :)
14:16:12 <cait2> and some will jump back into the queue when their devs return from holidays probably :)
14:16:28 <cait2> i especially woudl be happy about help with SIP patches
14:16:36 <cait2> and the aformentioned big 3
14:17:01 <Joubu> bug 21979
14:17:01 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21979 enhancement, P5 - low, ---, kyle, Signed Off , Add option to SIP2 config to send arbitrary item field in CR instead of collection code
14:17:06 <Joubu> bug 25541
14:17:06 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25541 enhancement, P5 - low, ---, kyle, Signed Off , Add ability to prevent checkin via SIP of items with holds
14:17:08 <cait2> also someone else running the Elasticsearch.t  and see if they can reproduce my failure
14:17:38 <Joubu> Who around is familiar with SIP?
14:17:42 <cait2> bug 26250
14:17:42 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26250 major, P5 - low, ---, jonathan.druart, Signed Off , Test suite does not pass if Elastic is used as search engine
14:17:51 <kohaputti> cait2, I can help with SIP
14:18:05 <Joubu> thanks kohaputti!
14:18:12 <cait2> that would be great
14:18:20 <cait2> note: bug 25261 also has a sip component
14:18:20 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25261 enhancement, P5 - low, ---, martin.renvoize, Signed Off , Multiple parts handling - confirmation alert
14:18:29 <cait2> so if someone could take care of that, i am happy to test in the GUI
14:18:51 <koha-jenkins> Project Koha_Master_D10 build #335: SUCCESS in 53 min: https://jenkins.koha-community.org/job/Koha_Master_D10/335/
14:18:59 <koha-jenkins> Project Koha_Master_U18 build #879: ABORTED in 53 min: https://jenkins.koha-community.org/job/Koha_Master_U18/879/
14:19:16 <Joubu> Also, I need some QA help on bug 25758, more brainstorming.
14:19:16 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25758 major, P5 - low, ---, jonathan.druart, In Discussion , Items scheduled for automatic renewal do not show that they will not renew due to a hold
14:19:18 <cait2> i probably forgot something, but that's it from me basically :)
14:19:34 <Joubu> kidclamp is going to ask some Bywater educators, but additional feedback would be great
14:19:42 <cait2> ah, it seemed to work well on staff side, more issues found? have to check on that later
14:20:02 <Joubu> cait2: I cheat, lot of changes from the patch were not advertised
14:20:28 <Joubu> so it's not only opac-user that needs to be tested
14:20:50 <Joubu> ok, moving on
14:20:55 <Joubu> #Actions from last meeting
14:20:58 <Joubu> #topic Actions from last meeting
14:21:07 <Joubu> #topic ashimema is going to add his stamp on 20168
14:21:10 <Joubu> It's done!
14:21:23 <cait2> bug 20168
14:21:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20168 enhancement, P5 - low, ---, oleonard, ASSIGNED , Update of the OPAC bootstrap template to bootstrap v4
14:21:24 <Joubu> #info ashimema signed off 20168, thanks!
14:21:35 <Joubu> #topic ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code
14:21:35 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Signed Off , New interface for revamped circulation rules
14:21:37 <Joubu> still in progress
14:21:48 <Joubu> #action ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
14:21:57 <Joubu> #topic ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
14:22:17 <cait2> wrong tag?
14:22:18 <Joubu> #info A guideline for remove indirect object notation has been written and available at  https://wiki.koha-community.org/wiki/Coding_Guidelines#PERL29:_Direct_Object_Notation
14:22:43 <Joubu> I don't think we need to vote on it
14:23:02 <Joubu> #info there is a bug ready for testing: Bug 25898 - Prohibit indirect object notation
14:23:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25898 enhancement, P5 - low, ---, julian.maurice, Needs Signoff , Prohibit indirect object notation
14:23:06 <marcelr> We are not going to change all occurrences ?
14:23:13 <Joubu> yes we are
14:23:19 <Joubu> the patch is there already
14:23:19 <marcelr> rebase party?
14:23:31 <Joubu> easy conflicts :)
14:23:46 <marcelr> conflicts--
14:23:50 <Joubu> most of the occurrences are new CGI
14:24:03 <Joubu> better now than later IMO
14:24:15 <Joubu> we will certainly have to do it anyway
14:24:53 <marcelr> perl 7
14:24:59 <cait2> is it just style or does/will have it an effect?
14:25:03 <cait2> ah, deprecation?
14:26:12 <marcelr> but we vote for the guideline not for the bulk change
14:26:26 <Joubu> I did not plan to vote on that
14:26:30 <Joubu> should we?
14:26:45 <marcelr> well not for me, it is obvious better
14:26:58 <Joubu> :)
14:27:11 <marcelr> just making the difference
14:27:12 <tcohen> let's fix it
14:27:14 <Joubu> I opened a perl 7 omnibus, in case we have other things to deal with
14:27:29 <Joubu> bug 26303
14:27:29 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26303 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Preparing for Perl 7
14:27:33 <tcohen> we could make a rule: you touch a file with indirect calls, you're oblighed to fix it inline
14:27:54 <Joubu> I would prefer a fix all at once patch
14:28:34 <cait2> maybe we could add a link to the perl 7 thing to the cuideline
14:28:36 <Joubu> let's continue the discussion on the bug report if you want to
14:28:39 <cait2> as a reminder of why
14:28:59 <Joubu> there is a link to https://www.effectiveperlprogramming.com/2020/06/turn-off-indirect-object-notation/
14:29:13 <cait2> oh sorry, i missed that
14:29:16 <cait2> i was expecting it on top
14:29:44 <cait2> can we have the QA tools look for it as well please?
14:29:44 <Joubu> #info tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
14:29:53 <Joubu> I talked with him, he will get back to it soon
14:29:57 <Joubu> #action tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
14:30:04 <Joubu> #info davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
14:30:14 <Joubu> and I don't have news from this
14:30:34 <Joubu> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth): update - still working on this (postponed)
14:30:59 <Joubu> #topic General development discussion (trends, ideas, ...)
14:31:07 <Joubu> ha cait2, got it now :)
14:31:11 <Joubu> I am slow you now
14:31:21 <Joubu> indeed, I mixed info and topic
14:31:25 <Joubu> subtopic is missing
14:31:30 <Joubu> #subtopic
14:31:50 <Joubu> anyone, an additional discussion?
14:31:52 <Joubu> ideas?
14:31:52 <wahanui> ideas are good!
14:32:24 <cait2> not right now
14:32:33 <cait2> maybe just a reminder: please write nice commit messages
14:32:41 <cait2> the trend is to minimalistic
14:32:45 <marcelr> i have two patches underway dealing with availability on opac xslt results
14:33:04 <marcelr> always candidates for In Discussion
14:33:55 <cait2> tricky area, haven't read yet
14:34:08 <Joubu> marcelr: bug numbers?
14:34:17 <marcelr> bug 21260
14:34:17 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21260 normal, P5 - low, ---, m.de.rooy, Needs Signoff , Improve the Availability line of OPAC XSLT search results
14:34:23 <marcelr> bug 26302
14:34:23 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26302 enhancement, P5 - low, ---, m.de.rooy, ASSIGNED , OPAC XSLT Results: List variable number of itemcallnumbers
14:34:39 <marcelr> some nasty xslt there
14:34:58 <marcelr> with keys and generate etc
14:35:20 <cait2> also quite a bit of configuration options at play whne i remember correctly
14:35:24 <Joubu> I wrote that few weeks ago and pushed yesterday, maybe related? bug 26139
14:35:24 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26139 normal, P5 - low, ---, jonathan.druart, Pushed to master , 'Place hold' button isn't hidden in all detail views if there are no items available for loan
14:35:30 <Joubu> it's not about xslt, but availability
14:35:31 <cait2> always have refused to try and customize that
14:36:51 <Joubu> not really
14:37:01 <Joubu> marcelr: how do you want to promote them?
14:37:14 <marcelr> good question; an old problem
14:37:35 <Joubu> maybe you could detail the gain it will bring, and ask the general ML for a signoff?
14:38:06 <marcelr> my impression is that mailing the regular ML does not trigger signoffs
14:38:19 <Joubu> it depends on how you sell it :)
14:38:33 <marcelr> good developers cannot sell
14:38:39 <Joubu> haha, true
14:38:42 <marcelr> and the opposite around
14:39:32 <Joubu> I think it could help to list the different situations
14:39:42 <Joubu> the bad old ones, and how your patch will fix them
14:39:49 <Joubu> even for us, developers
14:40:03 <Joubu> or maybe it's the test plan from comment 8
14:40:39 <marcelr> we'll see
14:40:42 <Joubu> ok
14:40:50 <Joubu> I think a before vs after could help
14:40:55 <kidclamp> I only looked quickly marcel, but it seems you remove some info from non-available items, I think that should be optional
14:41:14 <kidclamp> rather hide dsipaly than take it away entirely
14:41:45 <marcelr> good observation
14:41:57 <Joubu> #info
14:42:14 <Joubu> #info Please have a look at bug 21260 (Improve the Availability line of OPAC XSLT search results)
14:42:14 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=21260 normal, P5 - low, ---, m.de.rooy, Needs Signoff , Improve the Availability line of OPAC XSLT search results
14:42:38 <Joubu> ok moving on
14:42:41 <Joubu> #topic Review of coding guidelines
14:42:45 <Joubu> we have something!
14:42:45 <marcelr> kidclamp: there is even an old report asking for callnumbers on all statuses
14:42:58 <Joubu> #info Don't use input type "number" in favor of using a pattern check instead
14:43:06 <Joubu> #link https://technology.blog.gov.uk/2020/02/24/why-the-gov-uk-design-system-team-changed-the-input-type-for-numbers/
14:43:13 <Joubu> #link https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17098
14:43:13 <huginn> 04Bug 17098: normal, P5 - low, ---, gmcharlt, NEW , Validation problems with form field type "number" (decimal separator)
14:44:07 <Joubu> cait2: did you add that?
14:44:20 <Joubu> was the idea to vote or propose a guideline at the next meeting?
14:44:28 <marcelr> how often did we use that ?
14:44:45 <Joubu> it happens
14:44:53 <Joubu> twice last week ;)
14:45:21 <marcelr> 10-15 files
14:45:32 <marcelr> 20
14:45:33 <Joubu> #action Joubu open a bug report for the QA script to catch input type number
14:46:13 <Joubu> I read the .gov.uk link when ashimema[m] sent it and it made sense
14:46:28 <marcelr> yes, it makes sense
14:46:41 <Joubu> now I have to admit I cannot remember what was the arguments
14:47:22 <Joubu> ok, Martin is on vacation so...
14:47:30 <marcelr> could be coming from the accessiblity community
14:47:52 <Joubu> #action ashimema write a guideline to forbid usage for type "number"
14:48:13 <Joubu> and we are good I think
14:48:36 <Joubu> it said "review of the coding guideline" but there is no guideline
14:48:51 <Joubu> anything more, anyone?
14:48:56 <Joubu> #topic Set time of next meeting
14:49:39 <Joubu> #info Next meeting: 9 September 2020, 20 UTC
14:50:08 <Joubu> @later tell rangi the next dev meeting is scheduled for 9 September 2020, 20 UTC. Can you confirm 20 UTC is good for nz/au?
14:50:08 <huginn> Joubu: The operation succeeded.
14:50:13 <Joubu> #endmeeting