19:01:36 <Joubu> #startmeeting Development IRC meeting 29 July 2020
19:01:36 <huginn> Meeting started Wed Jul 29 19:01:36 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:36 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:36 <huginn> The meeting name has been set to 'development_irc_meeting_29_july_2020'
19:01:47 <Joubu> #topic Introductions
19:01:53 <Joubu> #info Jonathan Druart
19:02:02 <Joubu> anybody around?
19:02:02 <wahanui> anybody around is connected with an IPv6 address?
19:02:15 <Joubu> IPv4 can work
19:02:29 <davidnind> #info David Nind, Wellington, New Zealand
19:02:57 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
19:03:18 <lisettelatah> #info Lisette Scheer, Latah County Library District, Idaho, USA
19:03:28 <thd> #info Thomas Dukleth, Agogme, New York City
19:04:56 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
19:05:05 <Joubu> #topic Announcements
19:05:09 <Joubu> Anyone have something?
19:05:13 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_29_July_2020
19:06:20 <Joubu> #topic Update from the Release Manager (20.11)
19:06:36 <Joubu> not much to say, I pushing stuffs in block when they get PQA
19:06:50 <Joubu> I really (but *really* *really*) would like to push
19:06:59 <Joubu> bug 22417
19:07:00 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22417 new feature, P5 - low, ---, jonathan.druart, Signed Off , Add a task queue
19:07:04 <Joubu> and bug 20271
19:07:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20271 enhancement, P1 - high, ---, jonathan.druart, Signed Off , Merge deleted biblio, biblioitems, biblio_metadata, and items tables
19:07:06 <Joubu> ASAP
19:07:30 <Joubu> #info RM is requesting urgent QA on bug 22417 and bug 20271
19:07:47 <Joubu> they need to be pushed before it's too late in the cycle
19:07:54 <tuxayo> +1
19:07:56 <Joubu> #topic Updates from the Release Maintainers
19:07:58 <Joubu> rmaints?
19:07:58 <wahanui> lukeG, aleisha, and tuxayo, I SUMMON THEE!!
19:09:01 <Joubu> I don't have much to say for them, they are following quite ok master and their relative n+1 branch
19:09:32 <davidnind> excellent!
19:09:32 <wahanui> darn tootin' it is.
19:09:34 <Joubu> [off] security releases are coming next month, we will need to coordinate, be ready for the update
19:09:42 <tuxayo> #info Second release (for branch 19.05.x) was a breeze. :D Thanks to the predecessor for the great process.
19:09:56 <tuxayo> Yep, lets see how the next one goes
19:10:10 <Joubu> #topic Updates from the QA team
19:10:16 <Joubu> qa_team?
19:10:16 <wahanui> qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
19:10:47 <cait> oh sorry
19:10:56 <cait> #info Katrin Fischer, BSZ, Germany
19:11:11 <cait> I have to keep an eye on my spaghetti cooking (just a warning)
19:11:16 <kidclamp> /away
19:11:20 <tuxayo> lol
19:11:29 <tuxayo> #info tuxayo/Victor Grousset, France
19:11:31 <Joubu> something for the QA part cait?
19:11:33 <tuxayo> oops, forgot also
19:11:38 <cait> QA queue is full, i wanted to highlight bug 20271 again
19:11:42 <Joubu> apart from the usual "numbers are high"
19:11:49 <cait> no wahanui?
19:12:05 <Joubu> last one to be displayed here
19:12:08 <tuxayo> is spaghetti code low?
19:12:17 <cait> There has a lot of things suggested that haven't been tested yet: https://lite.framacalc.org/9hdw-bug_20271
19:12:23 <tuxayo> wahanui: worked a few minute ago. Might have got lazy
19:12:23 <wahanui> tuxayo: i'm not following you...
19:12:44 <cait> and i am not sure about the current state of things - I think there was talk about maybe preserving the old table names by changing the new ones?
19:13:28 <Joubu> we won't discuss it here, but yeah people need to be involved
19:13:33 <Joubu> once pushed it will be too late
19:13:49 <cait> I can also announce that numbers are too high... and that I will be on vacation for the next 2 weeks so might be here a bit less frequent, but hope to spend some time on the bigger bugs that I currently fall asleep on whenever I try :)
19:14:31 <Joubu> great, enjoy, cait!
19:14:38 <cait> anything else from rest of QA team members?
19:15:21 <Joubu> moving on then
19:15:25 <Joubu> # Actions from last meeting
19:15:28 <Joubu> #topic Actions from last meeting
19:15:41 <Joubu> not sure how to process here, it's my first meeting with this section
19:15:54 <cait> hm let's see
19:15:58 <Joubu> did any of you follow?
19:16:13 <Joubu> we should not add them to the next meeting I guess
19:16:20 <Joubu> but let a #info to explain what's been done
19:16:24 <cait> bug 15522 still needs to have QA finished it looks like
19:16:25 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Signed Off , New interface for revamped circulation rules
19:16:25 <tuxayo> Why?
19:16:36 <cait> i think 2 and 3 are done
19:16:42 <tuxayo> yep
19:17:07 <cait> haven't checked it has been added to coding guidelines - but i remember we agreed on wording?
19:17:07 <Joubu> #action ashimema will get back to qa bug 15522
19:17:13 <davidnind> mine is still a work in progress
19:17:24 <Joubu> sorry, I am going line by line :)
19:17:32 <cait> ok
19:17:33 <cait> :)
19:17:36 <cait> checking on pasta
19:17:44 <tuxayo> So next is mine
19:17:51 <tuxayo> write a proposal for handing over stable branches
19:17:52 <Joubu> #info tuxayo wrote a proposal for handing over stable branches
19:17:58 <Joubu> #link https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/RMaint-handover-draft
19:18:00 <tuxayo> https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/RMaint-handover-draft
19:18:26 <Joubu> anything to add tuxayo, or it's just for info for the next rmaint handover?
19:18:35 <cait> reads good to me
19:18:37 <tuxayo> No new feedback on koha-devel.
19:18:50 <davidnind> looks fine to me
19:19:03 <tuxayo> I got one positive from aleisha
19:19:04 <cait> maybe instad of 'last bug considered' 'we could also say commit?
19:19:21 <Joubu> #info talljoy added the guideline as proposed to the official guidelines wiki page - https://wiki.koha-community.org/wiki/Coding_Guidelines#TERM3:_Inclusive_Language
19:19:37 <tuxayo> cait: They can have multiple commit. But maybe commit sound beter?
19:19:40 <tuxayo> *better
19:19:52 <Joubu> tuxayo: it reads ok for me as well, let's put some more light when we will need it in few months
19:19:55 <cait> bug is ok i think
19:20:08 <cait> we should see where to mve it - post release tasks page?
19:20:28 <tuxayo> That or the release maintenance wiki page
19:20:32 <Joubu> yes
19:20:38 <Joubu> or RMaint
19:20:57 <tuxayo> good question, I didn't though about those two other pages
19:21:47 <tuxayo> Any opinion on one of the 3 candidate pages?
19:22:20 <Joubu> nope
19:22:21 <Joubu> :D
19:22:21 <cait> release maintenance
19:22:31 <Joubu> ok, next one is about a guideline from ashimema, I did not hear about it, postponing it
19:22:34 <cait> pasta drained :)
19:22:39 <Joubu> #action ashimema to propose a guideline ragarding using direction object notation rather than indirect object notation (postponed)
19:22:47 <Joubu> tuxayo: next one is yours again
19:22:57 <Joubu> "tuxayo - prepare draft update to SQL11 to improve consistency for descriptions in kohastructure files: analysis of the state of DB fields and tables comments"
19:22:59 <tuxayo> Ok cait, let's lean to that. I'll try to find a nice place
19:23:36 <tuxayo> #action tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page
19:23:41 <tuxayo> (so I don't forget)
19:23:55 <tuxayo> The next item. prepare draft update to SQL11 to improve consistency for descriptions in kohastructure files:
19:24:16 <tuxayo> analysis of the state of DB fields and tables comments: https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/Coding_Guidelines-SQL11-changes
19:24:57 <cait> didn't we lean towards using comment in the future because it always works?
19:25:05 <cait> so a matter of changing coding guideline and the file?
19:25:33 <cait> and maybe qa tools
19:25:37 <tuxayo> Ater rereading the meeting logs, I had to explore stuff with ashimema
19:26:14 <tuxayo> > and the file
19:26:14 <tuxayo> That's more than 1000 field comments better be sure before doing that
19:26:39 <cait> what is the concern?
19:27:45 <cait> test?
19:27:45 <wahanui> test is failing on https://jenkins.koha-community.org/job/Koha_Master_D9/lastCompletedBuild/consoleFull (#1328)
19:28:41 <Joubu> I cannot help here, I did not follow the original problem
19:28:43 <tuxayo> Be sure that the comment ending up in DBIC is worth the conversion of the file. Not sure if that will ever be more a clear way that looking as schema spy.
19:28:46 <Joubu> should we postpone?
19:29:26 <tuxayo> cait: test?
19:29:26 <wahanui> test is failing on https://jenkins.koha-community.org/job/Koha_Master_D9/lastCompletedBuild/consoleFull (#1328)
19:29:31 <cait> ok
19:29:37 <tuxayo> wahanui: you tricked me!
19:29:37 <wahanui> tuxayo: sorry...
19:29:52 <Joubu> tuxayo: can you summarize the wiki page please?
19:30:00 <Joubu> It says "WIP see if there is something to change and what."
19:30:04 <Joubu> what's the conclusion then?
19:30:07 <Joubu> need more work?
19:30:10 <Joubu> need help?
19:30:34 <tuxayo> Yes, I'll do an #info line
19:31:20 <Joubu> ok
19:31:23 <Joubu> next is " ashimema to update minimum koha requirements on the website "
19:31:32 <Joubu> I don't find where are the requirements on the website
19:31:53 <Joubu> https://koha-community.org/download-koha/
19:32:02 <Joubu> there is no specified version there
19:32:05 <cait> i believe this page was meant
19:32:15 <Joubu> so it's considered "done"?
19:32:15 <cait> adding information there
19:32:26 <cait> no, there are no mininum requirements :)
19:32:34 <cait> oh
19:32:36 <cait> yes it is done
19:32:40 <cait> i missed the lines below
19:32:59 <Joubu> "Actively supported for packages: Debian 9/10 (Stretch/Buster), Ubuntu 18.04/20.04 (Bionic Beaver/Focal Fossa)."
19:32:59 <cait> lools alright?
19:33:15 <Joubu> #info ashimema updated the minimum koha requirements on the website
19:33:32 <Joubu> next is "cait to propose discussion about supported browsers at next meeting (IE especially) "
19:33:38 <cait> the IE issue was discussed at last General meeting
19:33:45 <tuxayo> #info The analysis of the state of DB fields and tables comments is done. Needs further work to see where we want to go and propose the changes.
19:33:52 <cait> we decided/agreed that we are not supporting IE for staff, people should be updating to use Edge at least
19:34:20 <Joubu> #info about supported browsers - we decided/agreed at the last general meeting that we are not supporting IE for staff, people should be updating to use Edge at least
19:34:20 <cait> and we discussed updating the note on the manual accordingly
19:34:23 <Joubu> great
19:34:35 <Joubu> " davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) "
19:34:37 <davidnind> sorry, mine is still a work in progress
19:34:40 <Joubu> this one is still in progress
19:34:42 <tuxayo> > i missed the lines below
19:34:42 <tuxayo> Missing some parts compared to the release notes for example.
19:34:45 <Joubu> ok
19:34:56 <cait> still shortened the list a bit :)
19:34:56 <Joubu> #davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)
19:35:06 <cait> Joubu: i think you need #action
19:35:09 <Joubu> I like that new #action section
19:35:13 <Joubu> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)
19:35:16 <Joubu> indeed!
19:35:25 <Joubu> #topic General development discussion (trends, ideas, ...)
19:35:25 <davidnind> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed, still in progress)
19:35:42 <davidnind> oops!
19:35:49 <Joubu> you will have to do it twice now!
19:35:52 <Joubu> ;)
19:36:01 <Joubu> something else to discuss/add?
19:36:04 <cait> davidnind always double-checks
19:36:12 <cait> can't think of anything right now
19:36:33 <Joubu> #topic Set time of next meeting
19:36:51 <davidnind> :-D
19:36:58 <Joubu> #info Next meeting: 12 August 2020, 14 UTC
19:37:25 <tuxayo> cait: how are the spaghetti? 🍝
19:37:29 <Joubu> #endmeeting