20:16:47 <tuxayo> #startmeeting Development IRC meeting 2 December 2020
20:16:47 <huginn> Meeting started Wed Dec  2 20:16:47 2020 UTC.  The chair is tuxayo. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:16:47 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:16:47 <huginn> The meeting name has been set to 'development_irc_meeting_2_december_2020'
20:17:02 <tuxayo> #topic Introductions
20:17:12 <tuxayo> #info tuxayo/Victor Grousset, France
20:17:47 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
20:17:59 <oleonard> It worked. You built it and I came.
20:17:59 <liliputech_asu> #info liliputech/Arthur Suzuki, BibLibre, France
20:18:09 <tuxayo> he he
20:18:18 <liliputech_asu> :)
20:18:42 <oleonard> Any NZers here? rangi alexbuckley ?
20:19:43 <tuxayo> #topic Announcements
20:19:59 <tuxayo> Does anyone have something?
20:21:06 <alexbuckley> #info Alex Buckley, Catalyst IT, Wellington NZ
20:21:22 <liliputech_asu> hi, during the last camp, christophe croullebois from biblibre has worked on a plugin to emulate an automaton
20:21:35 <liliputech_asu> https://github.com/biblibre/koha-plugin-sip-client-emulator
20:21:45 <tuxayo> #info during the last camp, christophe croullebois from biblibre has worked on a plugin to emulate an automaton
20:21:51 <tuxayo> #link https://github.com/biblibre/koha-plugin-sip-client-emulator
20:22:06 <tuxayo> This is great!
20:22:09 <oleonard> Neat!
20:22:52 <liliputech_asu> quite still a work in progress, but we managed to get a working SIP request builder frontend within koha, it uses sip-cli-emulator in the background
20:23:00 <liliputech_asu> there is another one
20:23:19 <tuxayo> amoyano around? (action in the agenda)
20:24:15 <liliputech_asu> claire hernandez has worked on a plugin to retrieve and display informations from wikidata about a work within koha
20:24:17 <liliputech_asu> https://github.com/biblibre/koha-plugin-linked-data
20:24:55 <tuxayo> #info claire hernandez has worked on a plugin to retrieve and display informations from wikidata about a work within koha
20:25:11 <tuxayo> #link https://github.com/biblibre/koha-plugin-linked-data
20:25:35 <tuxayo> more plugins yay :D
20:25:42 <tuxayo> #topic Update from the Release manager (21.05)
20:26:07 <tuxayo> #info 21.05 roadmap, see email on koha-devel - https://lists.koha-community.org/pipermail/koha-devel/2020-November/046157.html
20:26:15 <tuxayo> #info There is a collaborative pad, feel free to join the existing topics I've listed and to add your own stuffs in it.
20:27:11 <tuxayo> Basically, put there you christmas lists ^^
20:27:43 <liliputech_asu> oh, then I would love to raise interest on bz 17314
20:27:43 <tuxayo> #info git.koha-community.org has been migrated
20:27:57 <oleonard> bug 17314
20:27:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17314 enhancement, P5 - low, ---, tomascohen, Patch doesn't apply , Routes to create, list and delete a purchase suggestion
20:28:12 <tuxayo> ok, I note that liliputech_asu
20:28:16 <tuxayo> #info Devs will have to adjust their remote URL with: git remote set-url $remote
20:28:44 <liliputech_asu> (although i still have some work on that one to get it to apply on master)
20:28:48 <tuxayo> #info git remote set-url https://git.koha-community.org/Koha-community/Koha.git
20:29:07 <tuxayo> #info 20.11: Some bugs have been found already, and some important ones that should be fixed for .01 are listed there: https://frama.link/koha_bz_rel_21_05_candidate
20:29:21 <liliputech_asu> thx for the ready-made cmd :)
20:29:40 <tuxayo> #info Enforcement of the release notes needed before push to help the documentation team
20:29:52 <tuxayo> #topic Updates from the Release Maintainers
20:29:56 <tuxayo> rmaint?
20:29:56 <wahanui> i heard rmaint was definitely a great job to find all kinds of things to fix and clarify in translations, system requirements, CI among others.
20:30:05 <tuxayo> rmaints?
20:30:05 <wahanui> rmaints is fridolin, AndrewFH and tuxayo
20:30:55 <tuxayo> #info oldoldstable (19.11): handover done, ready to begin backporting :)
20:32:33 <tuxayo> #topic Updates from the QA team
20:32:53 <tuxayo> qa_team?
20:32:53 <wahanui> qa_team is probably cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
20:33:10 <tcohen> hi, sorry I cannot attend!
20:33:29 <tuxayo> no worries tcohen
20:33:39 <MarkHofstetter> #help how should  I set a calculated value for a controlfield without any user intervention within a framework?
20:34:29 <oleonard> MarkHofstetter we are in the middle of a meeting at the moment
20:34:39 <tuxayo> MarkHofstetter: The meeting will be over after a moment, I'll ping you so you could reask your question
20:34:39 <MarkHofstetter> oh sorry!
20:34:44 <cait> caroline++
20:34:54 <cait> almost missing the second meeting today!
20:35:01 <oleonard> Stick around if you can and ask again a little later MarkHofstetter
20:35:10 <cait> #info Katrin Fischer, BSZ, Germany
20:35:17 <tuxayo> cait: you came at the right moment ^^
20:35:30 <lukeG1> #info Lucas Gass, ByWater Solutions
20:36:23 <cait> i see
20:36:32 <cait> not so much to report from QA but hte things already said
20:36:34 <caroline> MarkHofstetter: start with this perhaps? https://koha-community.org/manual/20.11/en/html/administration.html#edit-a-marc-subfield
20:36:38 <cait> focus will be on the bugs found in the stable release for now
20:36:59 <cait> and to get everyone new settled in :)
20:37:01 <tuxayo> On my side, learning QA right now, quite hard to find bugs which I can QA but doing the analysis is a good way to learn
20:37:21 <cait> you can always comment that you already tested and leave it if you are unsure
20:37:25 <liliputech_asu> tuxayo++
20:37:27 <cait> that way the work is not lost
20:38:05 <cait> sign it too
20:38:28 <cait> I believe we might have to report more next meeting
20:38:37 <tuxayo> cait: thanks, I'll try that when I'll soon finish to check the queue of bugs needing QA
20:39:06 <tuxayo> ^^
20:39:28 <tuxayo> Anything else about QA?
20:39:36 <cait> not from me
20:39:44 <tuxayo> #topic Actions from last meeting
20:39:53 <tuxayo> amoyano around?
20:40:10 <tuxayo> davidnind not here
20:40:33 <tuxayo> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate)
20:40:48 <tuxayo> #action amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
20:40:57 <tuxayo> #topic  General development discussion (trends, ideas, ...)
20:41:37 <tuxayo> #info liliputech_asu « would love to raise interest on bz 17314»
20:41:49 <tuxayo> #info Routes to create, list and delete a purchase suggestion
20:42:12 <tuxayo> anything else to add liliputech_asu ?
20:42:15 <tuxayo> Any topic for someone else?
20:42:28 <cait> bug 17314
20:42:29 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17314 enhancement, P5 - low, ---, tomascohen, Patch doesn't apply , Routes to create, list and delete a purchase suggestion
20:42:48 <cait> looks like it currnetly needs a rebase - is there open discussion or an issue with it?
20:43:26 <liliputech_asu> cait: need a bit of work on my side, that one got lost in limbo for too long
20:43:46 <liliputech_asu> but have 3 other patch that needs a signoff
20:44:09 <ashimema> oop
20:44:11 <liliputech_asu> bug 20985
20:44:11 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20985 normal, P5 - low, ---, arthur.suzuki, Needs Signoff , CanBookBeReserved and CanItemBeReserved should check 'On shelf holds allowed' policy
20:44:11 <ashimema> hi
20:44:41 <liliputech_asu> bug 15261
20:44:41 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15261 enhancement, P5 - low, ---, arthur.suzuki, Needs Signoff , Verify if checkout or hold request periods overlap with existing holds
20:44:57 <liliputech_asu> and bug 23011
20:44:57 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=23011 enhancement, P4, ---, arthur.suzuki, Needs Signoff , AuthenticatePatron could alert if password is not safe
20:45:04 <liliputech_asu> hi ashimema :)
20:45:46 <tuxayo> #info other patches highlighted by liliputech_asu:
20:45:49 <tuxayo> #info 20985 (CanBookBeReserved and CanItemBeReserved should check 'On shelf holds allowed' policy)
20:45:53 <tuxayo> #info 15261 (Verify if checkout or hold request periods overlap with existing holds)
20:46:10 <tuxayo> #info 23011 (AuthenticatePatron could alert if password is not safe)
20:46:47 <tuxayo> #topic Set time of next meeting
20:47:40 <tuxayo> That would be the 16th, but I don't know the logic about the time
20:48:21 <cait> 2 weeks time is right
20:48:27 <cait> for time I usually struggle a bit too
20:48:34 <tuxayo> I would guess if we rotate that it would be 15UTC
20:48:37 <ashimema> today was 'the late one' so next time should be mid afternoon europe time
20:48:44 <ashimema> perfect
20:48:53 <ashimema> sorry I was lacking today.. too many things on the go :(
20:49:06 <tuxayo> #info Next meeting: 16 December 2020, 15 UTC
20:49:09 <ashimema> we have a polished KohaAdvent for tomorrow now though :)
20:49:20 <liliputech_asu> :)
20:49:23 <tuxayo> ashimema++
20:49:27 <tuxayo> #endmeeting