#koha: Development IRC meeting 4 November 2020

Meeting started by Joubu at 15:01:08 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 15:01:17)
    1. Jonathan Druart (Joubu, 15:01:26)
    2. https://wiki.koha-community.org/wiki/General_IRC_meeting_4_November_2020 (Joubu, 15:01:44)
    3. tuxayo/Victor Grousset, France (tuxayo, 15:02:17)
    4. Agustin Moyano, Theke Solutions (amoyano, 15:02:53)
    5. Owen Leonard, Athens County Public Libraries, Ohio, The Bad Place (oleonard, 15:03:20)
    6. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:03:46)
    7. Martin Renvoize, PTFS Europe (ashimema, 15:04:46)
    8. Thomas Dukleth, Agogme, New York City (thd, 15:04:47)

  2. Announcements (Joubu, 15:04:59)
    1. Election of 21.05 release team is "tonight"! 20 UTC (Joubu, 15:05:41)
    2. Katrin Fischer, BSZ, Konstanz (cait, 15:06:05)
    3. Lucas Gass, ByWater Solutions (lukeG, 15:06:42)

  3. Update from the Release Manager (20.11) (Joubu, 15:06:56)
  4. Updates from the Release Maintainers (Joubu, 15:18:14)
    1. 19.05: last security release was without issue (tuxayo, 15:19:04)
    2. If you have PQA bugs that have been FQA or needs a rebase, provide feedback ASAP to have them reach 20.11! (Joubu, 15:19:05)
    3. Koha under Debian 11 is broken, it must not be used until bug 26893 is fixed! (Joubu, 15:20:47)

  5. Updates from the QA team (Joubu, 15:21:25)
    1. about RMaint I did a first pass on the release maintenance wiki page to complete and fix the security process. Needs a second one and proofreading from aleisha and lukeG (tuxayo, 15:21:38)
    2. https://www.youtube.com/watch?v=0Q0KrFv_YnU (ashimema, 15:36:12)
    3. QA team - The project is having a long standing issue about the QA queue. We should have more people involved in the process. It will especially help if you are kind of expert in a given area, let us know! (Joubu, 15:36:44)

  6. Actions from last meeting (Joubu, 15:39:44)
  7. amoyano Will try to provide a Vue alternative to bug 15522 (Joubu, 15:39:52)
    1. amoyano wrote an alternative for the new circulation rules interface - code is available on bug 15522 (Joubu, 15:42:33)
    2. feedback is needed on the code and UX changes (tuxayo, 15:42:57)
    3. ACTION: amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc. (Joubu, 15:44:11)

  8. ashimema Setup a sandbox with lot of circ rules (ideally from production data) to test 15522. Then ask the list for feedback. (Joubu, 15:45:54)
    1. ACTION: davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this) (Joubu, 15:46:31)

  9. davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance) (initial information added - see Release maintenance page) (Joubu, 15:47:15)
    1. https://wiki.koha-community.org/wiki/Release_maintenance#Deciding_on_what_to_back_port (Joubu, 15:47:24)
    2. davidnind wrote a wiki page to list the general principle for backporting - https://wiki.koha-community.org/wiki/Release_maintenance#Deciding_on_what_to_back_port (Joubu, 15:49:27)

  10. ashimema to write a guideline to forbidding the use of type "number" (Joubu, 15:49:53)
    1. https://wiki.koha-community.org/wiki/Coding_Guidelines#ACC2:_Input_type_.22number.22_should_be_avoided (Joubu, 15:49:57)
    2. New coding guideline - Input type "number" is now forbidden, use inputmode=numeric instead. See https://wiki.koha-community.org/wiki/Coding_Guidelines#ACC2:_Input_type_.22number.22_should_be_avoided (Joubu, 15:52:05)
    3. ACTION: ashimema Open an omnibus bug to fix the existing occurrences of input type "number" (Joubu, 15:53:01)
    4. ACTION: ashimema to add an omnibus bug to retroactively fix inputs for ACC2 coding guideline (ashimema, 15:53:01)

  11. General development discussion (trends, ideas, ...) (Joubu, 15:53:15)
  12. Discuss Bug 20410, Remove OpacGroupResults system preference and feature -- oleonard (Joubu, 15:53:21)
    1. ACTION: oleonard ask the list if someone use OpacGroupResults somewhere... (Joubu, 15:56:26)

  13. Sign off and tests failing - question: Recently I've had several cases where the tests pass before and after the patches are applied. However, if system preferences are changed as part of the test plan and tests are run at the end then they fail. If the developer says this is fine (for whatever reason), should we accept that when signing off and then leave to QA to critique their work? Example (not (Joubu, 15:58:21)
  14. Review of coding guidelines (Joubu, 16:07:03)
  15. Proposal for uniform response code for duplicate errors on the API (vote) (Joubu, 16:07:16)
    1. https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/409 (Joubu, 16:10:22)

  16. Proposal for related object ids on the API (vote) (Joubu, 16:12:22)
  17. Set time of next meeting (Joubu, 16:17:50)
    1. Next meeting: 18 November 2020, 15 UTC (Joubu, 16:18:52)


Meeting ended at 16:19:25 UTC (full logs).

Action items

  1. amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
  2. davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this)
  3. ashimema Open an omnibus bug to fix the existing occurrences of input type "number"
  4. ashimema to add an omnibus bug to retroactively fix inputs for ACC2 coding guideline
  5. oleonard ask the list if someone use OpacGroupResults somewhere...


Action items, by person

  1. amoyano
    1. amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
  2. ashimema
    1. ashimema Open an omnibus bug to fix the existing occurrences of input type "number"
    2. ashimema to add an omnibus bug to retroactively fix inputs for ACC2 coding guideline
  3. oleonard
    1. oleonard ask the list if someone use OpacGroupResults somewhere...


People present (lines said)

  1. Joubu (147)
  2. ashimema (92)
  3. cait (56)
  4. tuxayo (31)
  5. amoyano (18)
  6. tcohen (14)
  7. kohaputti (10)
  8. huginn (9)
  9. oleonard (7)
  10. lukeG (6)
  11. wahanui (5)
  12. thd (3)
  13. henryb (1)
  14. matts (1)
  15. koha-jenkins (1)


Generated by MeetBot 0.1.4.