#koha: Development IRC meeting 6 May 2020

Meeting started by tcohen at 19:10:58 UTC (full logs).

Meeting summary

    1. https://wiki.koha-community.org/wiki/Development_IRC_meeting_6_May_2020 Agenda (cait, 19:11:12)
    2. Katrin Fischer, BSZ, Germany (cait, 19:11:31)
    3. Tomas Cohen Arazi, Javier and Manuel's father (tcohen, 19:11:33)
    4. Owen Leonard, Athens County Public Libraries, Ohio, USA (oleonard, 19:11:33)
    5. David Nind, Wlelington, New Zealand (davidnind, 19:12:05)
    6. tuxayo/Victor Grousset, France (tuxayo, 19:12:13)
    7. Thomas Dukleth, Agogme, New York City [still world virus capital] (thd, 19:12:30)

  1. Introductions (tcohen, 19:13:38)
  2. Announcements (tcohen, 19:14:11)
    1. We are in feature freeze, heading into String freeze end of week (cait, 19:14:48)

  3. Update from the Release manager (20.05) (tcohen, 19:16:39)
    1. Martin Renvoize, PTFS-Europe (ashimema[m], 19:16:53)
    2. We are loving at a pace readying ourselves for release.. QA team are great and bugs are getting squashed. We're now in feature freeze and string freeze is this coming Friday. (ashimema[m], 19:17:50)

  4. Updates from the Release Maintainers (tcohen, 19:19:59)
    1. Joy Nelson ByWater (talljoy, 19:21:37)
    2. some tests are failing on 19.11, no news from other rmaints (tcohen, 19:23:50)

  5. Updates from the QA team (tcohen, 19:26:24)
    1. QA Team please jump on any bugs popping up now - there is still some things we should include in release to make things go smoothly especially with the new feature sintroduced and highlighted (cait, 19:27:19)
    2. https://hebdo.framapad.org/p/9ga9-koha-tech-release-notes tech notes (ashimema[m], 19:32:20)

  6. General development discussion (trends, ideas, ...) (tcohen, 19:33:47)
    1. 1) What's the state of ES 7 support (tcohen, 19:34:08)
    2. 2) Default ES versions of koha-testing-docker and KohaDevBox (tcohen, 19:45:12)
    3. AGREED: We will make ES 6.x the default in our dev tools (koha-testing-docker and KohaDevBox) (tcohen, 19:51:12)
    4. tcohen will make sure our CI is still running tests against ES 5.x (tcohen, 19:51:36)
    5. We will make ES 6.x the default in our dev tools (koha-testing-docker and KohaDevBox) (tcohen, 19:51:52)
    6. 3) Should koha-testing-docker and KohaDevBox have ES enabled by default instead of Zebra? (tcohen, 19:53:55)
    7. tcohen will make ES6 the default in koha-testing-docker (tcohen, 20:10:41)

  7. Review of coding guidelines (tcohen, 20:12:19)
    1. There's a proposal to add aria-hidden="true" in the guidelines (tcohen, 20:12:47)
    2. https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25166 (tcohen, 20:13:04)
    3. https://developer.mozilla.org/en-US/docs/Web/Accessibility/ARIA/ARIA_Techniques/Using_the_aria-hidden_attribute (tuxayo, 20:13:57)
    4. https://github.com/kylemhall/koha-developers-handbook (tcohen, 20:27:36)

  8. Set time of next meeting (tcohen, 20:30:59)
    1. https://wiki.koha-community.org/wiki/Developers_Handbook (tcohen, 20:32:00)
    2. the 20.05 release is aimed at 22nd (tcohen, 20:32:36)
    3. Next meeting: 20 May 2020, 14 UTC (tcohen, 20:35:29)


Meeting ended at 20:35:42 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. tcohen (135)
  2. tuxayo (109)
  3. ashimema[m] (67)
  4. cait (64)
  5. kidclamp (20)
  6. oleonard (13)
  7. AnnaBoten (8)
  8. huginn (8)
  9. thd (8)
  10. davidnind (7)
  11. wahanui (4)
  12. talljoy (4)
  13. tuxayo-read-only (1)


Generated by MeetBot 0.1.4.