14:01:31 <Joubu> #startmeeting Development IRC meeting 7 October 2020
14:01:31 <huginn> Meeting started Wed Oct  7 14:01:31 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:31 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:31 <huginn> The meeting name has been set to 'development_irc_meeting_7_october_2020'
14:01:37 <Joubu> #topic Introductions
14:01:41 <Joubu> #info Jonathan Druart
14:01:43 <Joubu> qa_team?
14:01:43 <wahanui> i think qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
14:01:45 <Joubu> rmaints?
14:01:45 <wahanui> rmaints is lukeG, aleisha, and tuxayo, I SUMMON THEE!!⚡⚡
14:01:54 <ashimema[m]> #info Martin Renvoize, PTFS Europe
14:02:01 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
14:02:09 <jajm> #info Julian Maurice, BibLibre
14:02:12 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_7_October_2020
14:02:16 <amoyano> #info Agustin Moyano, Theke Solutions
14:03:27 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:04:03 <Joubu> #topic Announcements
14:04:17 <Joubu> #info Roles for 21.05 are opened https://wiki.koha-community.org/wiki/Roles_for_21.05
14:04:30 <Joubu> please add your name :)
14:04:38 <Joubu> I candidate to continue as serving for RM
14:05:15 <ashimema[m]> long live the RM
14:05:15 <oleonard> Joubu++
14:05:29 <Joubu> Anyone have something else to announce?
14:06:22 <Joubu> as usual, just ask me with quick "!" or "." or whatever if you want me to stop
14:06:28 <Joubu> otherwise I am moving on
14:06:32 <Joubu> #topic Update from the Release manager (20.11)
14:06:39 <ashimema[m]> :)
14:07:18 <Joubu> bug 20582 and bug 22417 have been pushed this week
14:07:18 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20582 enhancement, P5 - low, Future, julian.maurice, Pushed to master , Turn Koha into a Mojolicious application
14:07:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22417 new feature, P5 - low, ---, jonathan.druart, Pushed to master , Add a task queue
14:07:28 <Joubu> Keep going the work on those 2 and SO/QA on existing dependent patches or open/write follow-up bug reports.
14:07:51 <amoyano> great news!
14:07:59 <Joubu> #info If you face issues with ktd you certainly need to `docker-compose pull`
14:08:05 <Joubu> Those using kohadevbox will certainly to install new dependencies. Let us know if you face any problems related to them.
14:08:25 <Joubu> Other point, I would like to highlight bug 24488: That would be great to see one or two of us offering their help to aleisha.
14:08:25 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24488 enhancement, P5 - low, ---, aleisha, ASSIGNED , Holds to Pull sometimes shows the wrong 'first patron' details
14:09:02 <Joubu> #info The new git server will be live next month, after the October stable releases
14:09:08 * ashimema[m] has been tip toeing around that one..
14:09:18 <ashimema[m]> awesome on the gitserver front
14:09:42 <Joubu> I have started to add the release-notes-needed flag on some bug reports pushed to 20.11 that need them. Please add them when missing! At least for the ones I flagged.
14:09:50 <Joubu> And that's all for me, any questions?
14:10:38 <Joubu> ha yes, release dates will be published on the ML very soon
14:10:44 <Joubu> #topic Updates from the Release Maintainers
14:11:24 <ashimema[m]> are there any here?
14:11:36 <Joubu> #info October stable releases will be rolled out on 27th
14:11:39 * ashimema[m] is happy to see fridolin running for rmaint next cycle
14:11:51 <Joubu> postponed after KohaCon
14:12:18 <Joubu> #topic Updates from the QA team
14:12:53 <ashimema[m]> QA has been flowing well.. but there's always more that can be done
14:13:01 <Joubu> Queue is getting high a bit, 65 bugs
14:13:12 <ashimema[m]> usual suspects are shouldering allot of the burden
14:13:13 <Joubu> It would be great to see some of you focussed on Katrin's patches
14:13:29 <Joubu> as she did an awesome job last month to lower the numbers
14:13:45 <ashimema[m]> +1 (I'm locked out of most as I've done a chunk of SO on them)
14:14:17 <ashimema[m]> most are simple to QA too.. boost your numbers by taking some on chaps
14:15:23 <Joubu> #info @QA - QA ALL THE THINGS. There are easy ones to boost your name on top of the dashboard :)
14:16:10 <Joubu> #info Actions from last meeting
14:16:18 <Joubu> #topic Actions from last meeting
14:16:30 <Joubu> #topic ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
14:16:30 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Patch doesn't apply , New interface for revamped circulation rules
14:16:32 <ashimema[m]> It would be nice to see some more QA's from matts and alex_a
14:16:51 <matts> ashimema[m], I agree.
14:17:24 <Joubu> ashimema[m]: what is the status of this?
14:17:38 <ashimema[m]> OK.. 15522 generally I'm happy with.. I was hoping to see a vue alternative put forward for comparison to highlight the complexity/simplicity of the javascript
14:17:56 <Joubu> What are the feedbacks of the users?
14:18:12 <ashimema[m]> I believe the existing branch needs a minor rebase for the changes to our build scripts
14:18:13 <amoyano> I'll try to add my 2 cents on vue for that one
14:18:22 <ashimema[m]> UX wise everyone seemed happy
14:18:23 <tcohen> amoyano++
14:18:28 <ashimema[m]> amoyano that would be awesome
14:18:43 <tcohen> there's the need to revisit the gulpfile
14:18:49 <tcohen> I'll take a look there
14:18:52 <Joubu> amoyano: when do you think you will have time to dedicate to it?
14:18:59 <ashimema[m]> I've a feeling at this point it's not a 20.11 piece but one for very very early 21.05
14:19:11 <Joubu> it's definitely too late for 20.11
14:19:19 <ashimema[m]> I'd rather wait a month/cycle and see a nice proof of vue
14:19:31 <Joubu> maybe something to present during KohaCon?
14:19:36 <amoyano> I'll try to do something this week
14:19:41 <Joubu> I really would like to get some feedback from real users
14:19:41 <ashimema[m]> I'm not expert enough in either react or vue to have a strong feeling.. but I will admit the react code looks complex
14:19:45 <Joubu> (ie. not devs)
14:19:47 <ashimema[m]> amoyano that is awesome
14:20:11 <ashimema[m]> I got our support team to give it a run down and they liked it..
14:20:26 <ashimema[m]> especially once they'd had a chat with their contemporaries at ByWater..
14:20:26 <Joubu> #action amoyano Will try to provide a Vue alternative to bug 15522
14:20:33 <ashimema[m]> we also have a customer on standby to play with it
14:20:42 <Joubu> ashimema[m]: where are the notes you collected?
14:21:01 <ashimema[m]> in the end it was sumamrised as.. "We like it"
14:21:17 <amoyano> hehe
14:21:32 <Joubu> Could we imagine a sandbox with sample data with a lot of circ rules?
14:21:38 <Joubu> and ask the list for feedback?
14:22:05 <ashimema[m]> that's a nice idea
14:22:18 <Joubu> you are voluntering, right?
14:22:47 <ashimema[m]> how big is big..
14:22:48 <tcohen> ashimema[m]++
14:22:53 <Joubu> #action ashimema Setup a sandbox with lot of circ rules (ideally from production data) to test 15522. Then ask the list for feedback.
14:23:00 <Joubu> great :)
14:23:10 <ashimema[m]> the tests we ran with it were with a customers data.. a few hundred lines of circ rules
14:23:28 <Joubu> #topic davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed)
14:23:38 <ashimema[m]> I'll ask said customer if they're happy for me to share such a set (with anonymised users of course)
14:23:54 <Joubu> I think I pinged him at the last meeting but cannot remember his answer :-/
14:24:02 <ashimema[m]> me either
14:24:39 <Joubu> @later tell davidnind Can you update the actions assigned to you for the next dev meetings please?
14:24:39 <huginn> Joubu: The operation succeeded.
14:24:46 <Joubu> #action davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (postponed)
14:24:56 <Joubu> #action davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance)
14:25:03 <Joubu> #topic ashimema to write a guideline to forbidding the use of type "number"
14:25:55 <ashimema[m]> hmm
14:26:02 <ashimema[m]> I thought I did that
14:26:04 <ashimema[m]> just trying to find the draft
14:26:21 <amoyano> is it part of the qa script?
14:26:31 <Joubu> I think so
14:26:35 <Joubu> or there is a merge request
14:27:17 <Joubu> https://gitlab.com/koha-community/qa-test-tools/-/issues/38
14:27:27 <Joubu> there is a merge request associated to the issue
14:27:45 <ashimema[m]> OK.. seems I never added it
14:28:02 * fridolin waves
14:28:14 <Joubu> and it has been approved, I will merge it. I guess I was waiting for the guidelines to be approved
14:28:19 <ashimema[m]> I'll add it to the guidelines as "ACC2: Input type number should not be used"
14:28:30 <Joubu> #action ashimema to write a guideline to forbidding the use of type "number" (postponed)
14:28:39 <ashimema[m]> ajha.. I bet I drafted it on the bug report
14:28:41 <Joubu> #topic  tuxayo to collect notes (if any) from past&present RMaints about their backport policies.
14:29:25 <Joubu> #info tuxayo collected notes from past and present RMaints about their backport policies at https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/Release_maintenance_tips
14:29:44 <Joubu> #topic General development discussion (trends, ideas, ...)
14:30:04 <Joubu> ashimema[m]: ideally we should update the action entry directly on the meeting page
14:30:29 <Joubu> that will help to know if we should postpone or if the action has been done
14:30:56 <Joubu> especially if the author does not attend the meeting
14:31:02 <ashimema[m]> good idea
14:31:08 <Joubu> #topic What to do when updatedatabase fails ?
14:31:12 <ashimema[m]> thanks
14:31:50 <Joubu> jajm: you added that, right?
14:32:13 <ashimema[m]> It comes up semi-frequently
14:32:26 <ashimema[m]> most recent broader discussion is on bug 25078
14:32:26 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, koha-bugs, In Discussion , Gracefully stop updatedatabase/installer when a database change cannot be applied
14:32:32 <Joubu> yes
14:32:41 <Joubu> I was trying to find this one
14:32:44 <jajm> Joubu, yes, but I wasn't aware of bug 25078
14:32:52 <ashimema[m]> which was raised a a bug after discussions on bug 22887
14:32:52 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22887 enhancement, P5 - low, ---, jonathan.druart, Pushed to master , authorised_values is missing a unique constraint on category + authorised_value
14:33:01 <koha-jenkins> Yippee, build fixed!
14:33:01 <wahanui> Congratulations!
14:33:01 <koha-jenkins> Project Koha_19.11_U16 build #8: FIXED in 44 min: https://jenkins.koha-community.org/job/Koha_19.11_U16/8/
14:33:05 <ashimema[m]> and more recently came up in bug 18050
14:33:05 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=18050 minor, P5 - low, ---, katrin.fischer, Signed Off , Missing constraint on aqbudgets.budget_period_id in aqbudgets
14:33:33 <Joubu> basically, see my last comment on 25078
14:33:57 <ashimema[m]> In short.. there's a strong feeling amongst some that updatedatebase should somehow gracefully fail to ensure the database is consistent for all as apposed to just warning.
14:34:17 <Joubu> (note to myself: never write you are going to do something during the next dev cycle...)
14:34:52 <ashimema[m]> hehe
14:35:05 <ashimema[m]> well.. is it still a goal people are strongly feeling should be met
14:35:12 <jajm> Joubu, "As I said I would prefer to have the whole thing ran in one go." so you want to run every DB update even if the first failed ?
14:35:23 <Joubu> My point is: we can explode, people is supposed to have a backup.
14:35:30 <ashimema[m]> my feeling is as much as I'd like to see it done.. it also doesn't present me with enough of an issue to work on it personally..
14:35:40 <Joubu> jajm: yes
14:35:43 <Joubu> you get all the errors
14:35:50 <ashimema[m]> and.. I don't feel we should be failing existing bug reports for it
14:36:01 <Joubu> then you restore the backup, fix the problems and run the upgrade again
14:36:07 <jajm> errors that can happen only because the first failed
14:36:50 <Joubu> it's just a my developper point of view. Seems easier to fix
14:37:24 <Joubu> than redoing the whole script every error it faces
14:38:09 <Joubu> I am suggesting to continue the discussion on the bug report
14:38:33 <Joubu> I am open to anything we decide and I am willing to work on it if we find an concensus
14:39:55 <Joubu> ok?
14:39:58 <jajm> it seems dangerous to assume everyone has db backups and that the backups work :)
14:40:37 <jajm> ok to continue on the bug report
14:41:16 <Joubu> Another last minute discussion?
14:41:39 <Joubu> #topic Set time of next meeting
14:42:11 <Joubu> #info Next meeting: 28 October 2020, 20 UTC
14:42:17 <Joubu> in 3 weeks, after the KohaCon
14:42:28 <Joubu> #endmeeting