20:09:40 <davidnind> #startmeeting Development IRC meeting 9 September 2020
20:09:40 <huginn> Meeting started Wed Sep  9 20:09:40 2020 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:09:40 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:09:40 <huginn> The meeting name has been set to 'development_irc_meeting_9_september_2020'
20:10:01 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Development_IRC_meeting_9_September_2020
20:10:15 <davidnind> #topic Introductions
20:10:31 <aleisha_> #info Aleisha Amohia, Catalyst IT, Wellington NZ
20:10:32 <davidnind> #info David Nind, Wellington, New Zealand
20:10:59 <henryb> #info Henry Bolshaw, House of Lords Library, UK
20:11:05 <tuxayo> #info tuxayo/Victor Grousset, France
20:12:45 <tuxayo> Anyone else beside us 4 from these 2 opposites points of the globe?
20:13:02 <davidnind> Not too many around, so I think it will be a quicker meeting this time!
20:13:08 <tuxayo> ^^
20:13:20 <davidnind> #topic Review of action points
20:14:08 <davidnind> for those not here to speak to their action points, I will just add the actions again, so they automatically appear on the  next agenda
20:14:26 <davidnind> hi everyone!
20:14:35 <davidnind> #action ashimema is collecting notes about bug 15522 and is going to review and dig a bit more into the code (postponed)
20:14:35 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, jonathan.druart, Patch doesn't apply , New interface for revamped circulation rules
20:14:57 <davidnind> tuxyao, your item is next
20:15:10 <davidnind> thanks for adding an update to the agenda
20:15:21 <tuxayo> tuxayo integrate the RMaint-handover-draft into the "release maintenance" wiki page (postponed)
20:15:30 <tuxayo> It's done
20:15:33 <tuxayo> is the place in the page ok? Release_maintenance#Handover_between_two_cycles
20:15:40 <tuxayo> * https://wiki.koha-community.org/wiki/Release_maintenance#Handover_between_two_cycles
20:16:03 <tuxayo> I put it in the initial setup
20:16:20 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
20:16:30 <tuxayo> So new RMaint will read this as a last step
20:17:15 <davidnind> looks okay to me - can be built upon, maybe good to ask cait or ashimema when they around if they know of a better location
20:17:37 <tuxayo> ok, I'm noting that
20:17:50 <davidnind> #info tuxayo has added the RMaint-handover-draft into the "release maintenance" wiki page https://wiki.koha-community.org/wiki/Release_maintenance#Handover_between_two_cycles
20:18:40 <davidnind> thanks tuxayo - good to get something down while it is still fresh from your experience starting as a release maintainer
20:18:53 <tuxayo> ^^
20:20:17 <davidnind> my action point is still under action, will definitely get onto it by the next meeting!
20:20:49 <davidnind> #action davidnind Find and update relevant places to record Perl version  required, including release notes, manual and wiki (one source of the  truth) (postponed)
20:21:49 <davidnind> #info Joubu has opened a bug report for the QA script to catch input type number - see  https://gitlab.com/koha-community/qa-test-tools/-/issues/38 (there is a merge request attached)
20:22:24 <davidnind> ashimema is not here today, so his item can be postponed as well
20:22:54 <davidnind> #action ashimema to write a guideline to forbidding  the use of type "number"
20:23:38 <davidnind> oops, I see I jumped over all the other agenda items!
20:23:50 <davidnind> #topic Announcements
20:24:22 <davidnind> Has anyone got any announcements to make?
20:24:53 <oleonard> Joubu pushed Bug 20168 today! Yay!
20:24:53 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20168 enhancement, P5 - low, ---, oleonard, Pushed to master , Update of the OPAC bootstrap template to bootstrap v4
20:25:11 <tuxayo> :D
20:25:12 <oleonard> If anyone has issues rebasing patches on top of it I'd be happy to help
20:25:31 <davidnind> that's awesome!
20:25:36 <tuxayo> oleonard++
20:25:48 <davidnind> oleonard++
20:25:50 <henryb> oleonard++
20:26:33 <davidnind> #info Update of the OPAC bootstrap template to bootstrap v4 now pushed, see bug 20168
20:27:00 <tuxayo> 🥳
20:27:20 <davidnind> #info let oleonard know if you have issues rebasing patches, is happy to help
20:29:44 <davidnind> #info koha-US's annual conference is on this month, and is online beginning on 22 September - see http://koha-us.org/learn/conferences/onlinetogether2020/
20:31:04 <aleisha_> #info kohacon20's working together will still be going ahead in some shape or form, so keep tagging bugs as #academy for us to work on :)
20:31:04 <davidnind> the third day is bug-a-palooza! day, so looks like a bit of bug squashing will be happening!
20:31:23 <aleisha_> ( by 'working together' i mean the hackathon)
20:31:34 <davidnind> thanks aleisha_
20:31:57 <davidnind> will be good practice as well for Kohacon2020 in October
20:32:37 <aleisha_> yeah absolutely!
20:32:51 <davidnind> We have no release manager today, so will skip Joubu's update
20:33:06 <davidnind> #topic Updates from the Release Maintainers
20:33:32 <davidnind> We have release maintainers today, fire away with your updates!
20:34:10 <aleisha_> #info 19.11.x is going well. if anyone wants things backported, please don't direct message me - just add me to the CC list of the bug and leave a note on the bug report for me so i can look into it
20:34:46 <oleonard> aleisha_++
20:35:40 <davidnind> aleisha_++
20:36:05 <davidnind> thanks aleisha_!
20:36:27 <tuxayo> #info 19.05.x nothing unusual to report, will try to focus on more severe bugs. Too much backporting on oldoldstable isn't much worth it and is bad for translations when it's string changes.
20:36:50 <davidnind> tuxayo++
20:37:04 <davidnind> thanks tuxayo
20:37:11 <aleisha_> yeah that's good tuxayo. maybe we need to add more info to the wiki on what the different branches should be looking to backport because oldoldstable isn't very much
20:37:14 <aleisha_> just as a guide
20:37:16 <aleisha_> tuxayo++
20:38:02 <tuxayo> aleisha_: I documented my policy and stuff I was told:
20:38:02 <tuxayo> https://wiki.koha-community.org/wiki/User:Victor_Grousset_-_tuxayo/Release_maintenance_tips
20:38:54 <aleisha_> that looks good, i think that kind of stuff is useful as a guide for everyone :) i have my own notes somewhere too
20:40:33 <davidnind> agree, that looks really good, and should be added as a starter at least to the release maintainers role page - I'm happy to do that
20:41:54 <davidnind> #action davidnind to add information about what to backport to the release maintainers role page (as a starting point for further notes and guidance)
20:42:17 <davidnind> unless yo would like to tuxayo?
20:42:26 <tuxayo> At least having RMaints who have notes to put them in the wiki and link them from somewhere. If there are resources for discussions and coordination, common guidelines would be even better.
20:42:32 <aleisha_> thanks davidnind that would be awesome if you could do a starting point and maybe we add to it :)
20:43:11 <davidnind> something easy I can do to help out
20:43:31 <davidnind> #topic Updates from the QA team
20:43:40 <tuxayo> So some basic stuff and then link to individual notes with more detailed/different POVs?
20:44:15 <davidnind> that is as good a starting point as any
20:44:26 <davidnind> I'm not sure anyone from the QA Team is around....
20:44:33 <tuxayo> qa team?
20:44:33 <wahanui> qa team are the real gatekeepers, send cookies their way
20:44:46 <tuxayo> qateam?
20:45:19 <davidnind> hehe, chocolate as well :)
20:45:57 <tuxayo> #action tuxayo to collect notes (if any) from past&present RMaints about their backport policies.
20:46:48 <henryb> qa_team?
20:46:48 <wahanui> i think qa_team is cait Joubu marcelr kohaputti josef_moravec tcohen kidclamp khall ashimema alex_a jajm matts
20:47:09 <tuxayo> thanks henryb
20:47:09 <davidnind> #info Send the QA Team cookies and chocolate for the great job they do (and oleonard for all the UI things)!
20:47:25 <davidnind> thanks henryb!
20:47:26 <kidclamp> #info Nick Clemens
20:47:26 <wahanui> #info Nick Clemens is working on testing the circulations rules rewrite
20:47:41 <tuxayo> it worked!
20:47:41 <kidclamp> On my phone, not entirely about
20:48:06 <tuxayo> kidclamp got lured by the cookie
20:48:15 <davidnind> maybe kidclamp will need something stronger than virtual cookies or chocolate...
20:48:47 <tuxayo> Why is wahanui using #info ?
20:49:02 <tuxayo> wahanui forget #info Nick Clemens
20:49:02 <wahanui> tuxayo: I forgot #info nick clemens
20:49:03 <kidclamp> Our queue is small, but big works to test still, things progress
20:49:29 <davidnind> thanks kidclamp
20:49:57 <kidclamp> Sign off all the things ,:-)
20:50:24 <davidnind> there was a call at last week's general IRC meeting for help getting the sign off queue down (now around 260....)
20:50:48 <henryb> What is a good number for the sign off queue?
20:51:16 <davidnind> #info Please help with sign offs (now around 260), so the QA Team can have some things to do :-D
20:51:45 <thd> #info Thomas Dukleth, Agogme, New York City
20:51:47 <kidclamp> As low as possible ideally
20:52:14 <tuxayo> henryb: The fact that the QA queue is low means that the needs signoff one need to especially given time.
20:52:33 <aleisha_> if we move recalls along then it can get out of the sign off queue :) thanks to oleonard and others for testing bug 19532
20:52:34 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, Needs Signoff , Recalls for Koha
20:52:41 <davidnind> I think cait said it was unusually low, mainly because there are so many bugs waiting for sign-off... (and because the QA Team is doing such a great job!)
20:52:59 <tuxayo> If QA is overwhelmed I guess it's more about priorities of bugs/features than overall numbers
20:53:06 <oleonard> I'm trying to keep up with it aleisha_ ! Thanks for all the rebasing.
20:53:15 <aleisha_> i appreciate it oleonard !
20:54:00 <ashimema[m]> The dashboard colours the queues ;)
20:54:05 <ashimema[m]> Hello
20:54:05 <wahanui> que tal, ashimema[m]
20:54:12 * ashimema[m] pops in
20:54:22 <davidnind> #info Help with sign-off for Recalls in Koha would be appreciated (bug# 19532)
20:54:30 <davidnind> hi ashimema!
20:54:56 <davidnind> #topic General development discussion (trends, ideas, ...)
20:55:39 <davidnind> I added an item about Zebra support, from the discussion that was on the mailing list
20:56:36 <davidnind> will postpone to the next meeting I think, if still relevant
20:57:02 <davidnind> Any other general development discussions anyone wishes to raise?
20:57:58 <ashimema[m]> Long live zebra
20:58:40 <davidnind> Zebra for Queen or King
20:59:01 <davidnind> #topic Set time of next meeting
21:00:52 <davidnind> Would normally be 14:00 a fortnight from now, 23 September 2020, 14:00 UTC
21:01:48 <davidnind> Will be somewhere around the bug-a-palooza! day with the koha-US conference
21:02:18 <davidnind> will follow the same pattern, and if it needs to be changed it can be changed
21:02:55 <tuxayo> looks good
21:03:05 <oleonard> +1
21:03:22 <davidnind> #info Next meeting: 23 September 2020, 14:00 UTC
21:03:29 <davidnind> #endmeeting