#koha: Documentation IRC meeting 12 November 2020

Meeting started by caroline at 18:01:22 UTC (full logs).

Meeting summary

    1. agenda Documentation IRC meeting 12 November 2020 (caroline, 18:01:41)
    2. Martin Renvoize, PTFS Euope (ashimema, 18:01:43)
    3. agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_12_November_2020 (caroline, 18:01:50)

  1. Introductions (caroline, 18:02:02)
    1. Caroline Cyr La Rose, inLibro (caroline, 18:02:18)
    2. Lucy Vaux-Harvey, PTFS-Europe (lucyvh, 18:02:24)
    3. Martin Renvoize, PTFS Europe (ashimema, 18:02:40)
    4. , Thomas Dukleth, New York City [A little pre-occupied with sometime employer in hospital] (thd, 18:04:04)

  2. Review of action points (caroline, 18:04:24)
    1. https://wiki.koha-community.org/wiki/Editing_the_Koha_Manual#How_do_Bugzilla.2C_Taiga_and_Gitlab_work_together.3F (caroline, 18:05:53)
    2. ACTION: davidnind will check how we can use gitlab to simplify the workflow (caroline, 18:07:48)
    3. ACTION: caroline will check with ashimema on how to best insert the docs writing into the dev workflow (caroline, 18:10:58)
    4. ACTION: caroline will clean up the manual keywords in bugzilla (caroline, 18:28:49)
    5. ACTION: ashimema will ask cait or rangi to clean up the manual keyword (caroline, 18:29:39)
    6. AGREED: for the 21.05 release we will try using the "manual" keyword instead of Taiga to build up the task list (caroline, 18:30:19)
    7. new workflow will be to go through release notes and add the Manual keyword where a manual update is neede (caroline, 18:32:42)
    8. AGREED: the manual keyword will replace taiga for the 21.05 release as a test for this workflow (caroline, 18:39:51)
    9. AGREED: docs manager will go through release notes and add Manual keyword where it is needed (caroline, 18:40:21)
    10. ACTION: change the Documentation to-do search on bz main page to include Documentation component OR manual keyword (caroline, 18:41:21)
    11. anyone can add Manual keyword if they feel it is needed (caroline, 18:42:36)
    12. ACTION: caroline will document workflow for 21.05 (caroline, 18:43:15)

  3. Project updates (caroline, 18:44:51)
  4. What's been done so far (caroline, 18:49:59)
    1. ACTION: caroline (or anyone) to divide the syspref file as it is getting too big for updates through gitlab GUI (caroline, 18:53:14)

  5. Content development guidelines (caroline, 18:57:09)
    1. https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks#Images (caroline, 18:58:18)
    2. when adding images, remember to add alt text for increased accessibility (caroline, 18:59:29)

  6. Next steps (caroline, 18:59:57)
  7. Set time of next meeting (caroline, 19:00:45)
    1. Next meeting: 10 December 2020, 18 UTC (caroline, 19:04:51)


Meeting ended at 19:04:57 UTC (full logs).

Action items

  1. davidnind will check how we can use gitlab to simplify the workflow
  2. caroline will check with ashimema on how to best insert the docs writing into the dev workflow
  3. caroline will clean up the manual keywords in bugzilla
  4. ashimema will ask cait or rangi to clean up the manual keyword
  5. change the Documentation to-do search on bz main page to include Documentation component OR manual keyword
  6. caroline will document workflow for 21.05
  7. caroline (or anyone) to divide the syspref file as it is getting too big for updates through gitlab GUI


Action items, by person

  1. ashimema
    1. caroline will check with ashimema on how to best insert the docs writing into the dev workflow
    2. ashimema will ask cait or rangi to clean up the manual keyword
  2. cait
    1. ashimema will ask cait or rangi to clean up the manual keyword
  3. caroline
    1. caroline will check with ashimema on how to best insert the docs writing into the dev workflow
    2. caroline will clean up the manual keywords in bugzilla
    3. caroline will document workflow for 21.05
    4. caroline (or anyone) to divide the syspref file as it is getting too big for updates through gitlab GUI
  4. UNASSIGNED
    1. davidnind will check how we can use gitlab to simplify the workflow
    2. change the Documentation to-do search on bz main page to include Documentation component OR manual keyword


People present (lines said)

  1. caroline (121)
  2. ashimema (58)
  3. cait (19)
  4. lucyvh (15)
  5. koha-jenkins (10)
  6. thd (8)
  7. wahanui (5)
  8. huginn (3)
  9. tcohen (2)
  10. talljoy (1)


Generated by MeetBot 0.1.4.