19:04:15 <davidnind> #startmeeting Documentation IRC meeting 2 July 2020
19:04:15 <huginn> Meeting started Thu Jul  2 19:04:15 2020 UTC.  The chair is davidnind. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:15 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:04:15 <huginn> The meeting name has been set to 'documentation_irc_meeting_2_july_2020'
19:04:24 <davidnind> chair caroline
19:04:46 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_2_July_2020
19:04:55 <davidnind> #topic Introductions
19:05:10 <davidnind> #info David Nind, Wellington, New Zealand
19:05:14 <caroline> #info Caroline Cyr La Rose, inlibro, Canada
19:05:33 <thd> #info Thomas Dukleth, Agogme, New York City [mostly absent as I prepare to go to work]
19:06:59 <davidnind> #topic Updates
19:07:18 <davidnind> Looks like only a few of us today :)
19:07:47 <davidnind> I managed to get through my action points from the last meeting!
19:07:58 <davidnind> Any project updates?
19:08:32 <caroline> not from me
19:08:42 <davidnind> For me, I've been working slowly on a couple of them
19:09:22 <davidnind> Installation guide - have an outline from existing install guides, so starting to copy and paste content in now
19:11:24 <davidnind> For git guide, have been looking at other projects do - a post to the development list didn't have any ideas on how we could improve the git process (https://lists.koha-community.org/pipermail/koha-devel/2020-June/045802.html)
19:11:53 <davidnind> aprt from that, nothing more to add
19:13:47 <davidnind> For whats been done, lost of activity over the last month - Caroline, Kelly, Alexander
19:14:13 <davidnind> and lots more tasks added to Taiga :-D
19:14:15 <caroline> I've had some time to work on docs so I'm trying to catch up
19:14:28 <davidnind> caroline++
19:14:32 <davidnind> great
19:14:48 <caroline> I'm still trying to get used to not forgetting to cherry-pick to 20.05
19:15:30 <davidnind> easy to forget
19:16:23 <caroline> and still learning to manage git
19:16:29 <davidnind> I've been playing around with the structure, but nothing to share yet
19:17:09 <davidnind> I seem to master it, don't do anything for while, then I can't remember basic commands!
19:17:34 <davidnind> working on testing patches helps a little
19:18:25 <davidnind> I updated the theme for 20.11 as well, do you think we should do this for the older versions?
19:18:35 <davidnind> hi lucyvh!
19:19:14 <caroline> If it's possible to do them all easily, yes
19:19:43 <caroline> but if not, we'll just wait for 20.11
19:20:05 <davidnind> it is easy to do
19:20:47 <davidnind> #action davidnind to update manual theme for 20.05, 19.11 and 19.05
19:20:58 <tuxayo> davidnind++
19:21:17 <caroline> It looks really good https://koha-community.org/manual/20.11/en/html/
19:22:06 <davidnind> wasn't sure about changing the colour to green in the top left corner, but looks okay I think
19:22:19 <caroline> yes, it looks great!
19:22:35 <caroline> Maybe the 20.11 is not very visible though
19:22:50 <lucyvh> Hi there all
19:22:54 <davidnind> I'll see if I can fix that
19:22:56 <tuxayo> Looks more Koha-ish :)
19:23:07 <davidnind> hi lucyvh!
19:23:25 <lucyvh> I am here just sorting dinner at the same time!
19:23:29 <caroline> hi lucyvh!
19:23:31 <davidnind> only us today...
19:23:35 <tuxayo> hi o/
19:23:39 <davidnind> multitasking again!
19:24:02 <lucyvh> I haven't been able to do much recently I'm afraid
19:24:11 <davidnind> I can only do one thing at a time, if I'm lucky
19:24:24 <davidnind> no worries
19:24:35 <davidnind> #topic Content development guidelines
19:24:56 <lucyvh> The new theme looks great btw
19:25:39 <davidnind> thanks
19:25:41 <davidnind> contractions such as don't vs do not - do they create issues for translation?
19:26:28 <tuxayo> I would guess not.
19:26:59 <caroline> not in my case
19:27:05 <caroline> cait?
19:27:05 <wahanui> cait is really good at running into things
19:27:18 <davidnind> I was under the impression they do (from reading other project's style guides), but we use them a lot with the system preferences
19:27:36 <cait> I am awake!
19:27:42 <cait> oh meeting?
19:27:42 <wahanui> meeting is over :)
19:27:53 <tuxayo> wahanui: liar!
19:27:53 <wahanui> tuxayo: i'm not following you...
19:27:55 <caroline> afaik, they don't break the translating system, but I don't know if specific languages have problems with it
19:28:11 <caroline> in French it's not a problem
19:28:22 <cait> i am probably too slow readin back - was there a question?
19:28:35 <tuxayo> «contractions such as don't vs do not - do they create issues for translation?»
19:28:54 <cait> no
19:29:06 <davidnind> thanks cait!
19:29:20 <cait> there is only one problem i can think of, but we prevent it with a coding guideline
19:29:41 <cait> we have a coding guideline that double quotes sohuld be used around strings, so we can have the single quotes for french and the short forms inside
19:30:17 <cait> string "don't" works, but 'don't' wouldn't - but as I said, coding guidelines should help with that
19:30:37 <caroline> In french I know the « » cause problems, but " and ' are ok
19:31:08 <tuxayo> https://koha-fr.org/traduction-conseils-generaux/
19:31:12 <cait> yep, in general quotes should be fine
19:31:14 <tuxayo> " seems to be a problem
19:31:50 <cait> it's probably the javascript case
19:31:55 <cait> in html it doesn't matter
19:32:11 <cait> if you have double quote outside, double quotes inside can cause issues
19:32:12 <tuxayo> Yeah, avoiding " is for JS
19:32:22 <cait> yep
19:32:34 <cait> but i think that's nothing we need to worry about for the manual whatsoever
19:32:52 <davidnind> excellent, so we can leave as is for the manual as is
19:32:54 <caroline> I'd still like to eventually have a guideline
19:33:09 <caroline> Do we write "button" or 'button' for example
19:33:11 <cait> to use double or single for quoting?
19:33:12 <cait> ah
19:33:18 <cait> i like italic
19:33:19 <cait> :)
19:33:33 <caroline> lol! just making it more complicated
19:33:35 <cait> seriously, i thin a lot of quotes often make things harder to read, i prefer italic for things 'written in the gui' in my docs
19:33:56 <caroline> so that means using *?
19:34:24 <cait> probably a little late for the manual :)  I think so
19:34:29 <caroline> So far, I've mostly used single quotes, but I'm very used to using double in real life so I might mix them up
19:34:45 <cait> i tihnk i copied that style from some technical documentation books
19:34:48 <cait> similar here
19:34:49 <davidnind> I have a list of things to propose, for interface elements was going to suggest bold, such as Click OK <== OK would be bolded
19:34:51 <cait> Germany uses double
19:36:04 <caroline> ok we can do bold... maybe not retroactively, but like capitalization, correct them when you see them
19:36:10 <caroline> bold is **?
19:36:38 <davidnind> I think so
19:36:40 <cait> i thin if it stands out too much, we could still apply some css :)
19:36:46 <cait> as long as we format somewhat consistently
19:37:25 <cait> it should be fine
19:38:19 <davidnind> I'll come back by next meeting with some suggestions, was going to base on google developer guide for (Apache 2 licenced) so we can use (https://developers.google.com/style/)
19:39:03 <davidnind> #info Contractions such as don't do not cause problems for translation
19:39:15 <lucyvh> Good idea to base it on an existing standard
19:39:27 * cait agrees
19:39:29 <caroline> cool
19:39:46 <caroline> davidnind++
19:40:25 <davidnind> since  google things are web-based, and Koha  is, I thought it would make a bit more sense
19:40:31 <tuxayo> +1
19:41:00 <davidnind> the microsoft style guide covers a lot more, such as desktop applications, so not quite as relevant
19:41:43 <davidnind> #action davidnind to come back with documentation style guide suggestions for next next meeting for discussion (to send around for discussion before)
19:42:05 <davidnind> I seem to be giving myself more things to do!
19:43:06 <davidnind> git branch names - do we change master to main? (sounds like it is easy to do https://www.hanselman.com/blog/EasilyRenameYourGitDefaultBranchFromMasterToMain.aspx)
19:43:34 <caroline> what is the purpose?
19:44:07 <cait> inclusive language
19:44:18 <caroline> ah!
19:44:21 <caroline> makes sense
19:44:22 <cait> master slave as used in tech context is not good
19:44:22 <davidnind> beat me to it!
19:44:27 <cait> sorry!
19:44:36 <cait> i guess you also can explain it better
19:44:53 <davidnind> no, that seems fine
19:44:55 <caroline> then sure, we can change it
19:45:25 <lucyvh> Agreed, should be changed
19:46:09 <caroline> I don't feel comfortable doing it though, afraid I'll mees up everything
19:46:22 <cait> same
19:46:30 <cait> i think people will also have to do something with their local repos
19:46:45 <cait> or maybe not - i really don't know, but i have seen other projects have been doing it
19:46:46 <caroline> yeah, I was just thinking that
19:46:51 <davidnind> I'll experiment with anther repository to make sure it works, then do and let everyone know
19:46:58 <caroline> in .git/config or something
19:47:07 <cait> davidnind++
19:47:23 <davidnind> I can check with rangi just to make sure - will add as an issues in GitLab
19:47:30 <davidnind> just to make sure we get it right
19:48:06 <davidnind> #info agreed to change terminology to be more inclusive (master ==> main)
19:49:25 <davidnind> #action davidnind to open issue to change repository branch naming and advise documentation list in advance and once done
19:49:30 <tuxayo> > master slave as used in tech context is not good
19:49:39 <tuxayo> That really depends of the culture, the relationship with language changes. (though some are more problematic that others)
19:49:45 <tuxayo> main is great as it's still gives a good meaning to the branch so that's a good change as it should fit everyone.
19:50:10 <davidnind> thanks tuxayo!
19:50:42 <davidnind> any other content development guideline things?
19:50:57 * tuxayo did nothing
19:51:16 * thd should have left for work 10 min. ago.
19:52:12 <davidnind> #topic Next steps
19:52:23 <davidnind> over to you caroline...
19:53:09 <caroline> I checked the release notes for 20.11 last week I think and there wasn't much there yet, so continue on 20.05
19:53:31 <caroline> I'm working through taiga, trying to get as much in as possible while I have time
19:53:51 <davidnind> caroline++
19:54:15 * cait wishes there was ways to 'make' more time in a day
19:54:20 <caroline> https://tree.taiga.io/project/ldjamison-kohadocs-1805/epic/1117
19:54:52 <cait> my new coworker is currently proof reading the German translation and has found some cases where the sysprefs have been renamed
19:54:59 <cait> where do i report? taiga or bugzilla?
19:55:08 <tuxayo> ~ ❯❯❯ make time                                                            ✘ 1
19:55:09 <tuxayo> make: *** No rule to make target 'time'.  Stop.
19:55:10 <tuxayo> :(
19:55:20 <cait> can i just patch or should i always file?
19:56:07 <caroline> if you have time, just patch, if you can't patch right away and don't want to forget, file in bz
19:56:07 <tuxayo> cait: you mean the English manual has the old syspref name?
19:58:24 <davidnind> #topic Set time of next meeting
19:58:46 <cait> yes
19:58:55 <cait> ok thx caroline
20:00:06 <davidnind> as long as this time still suits everyone, 6 August 2020, 19:00 UTC?
20:00:26 <caroline> I'll probably be on vacation, but I don't mind missing one meeting
20:00:49 <davidnind> we can do a week later
20:01:12 <caroline> 13 would be good for me
20:01:28 <davidnind> we'll do that then
20:01:40 <davidnind> #info Next meeting: 13 August 2020, 19:00 UTC?
20:01:52 <davidnind> #endmeeting