20:01:39 <caroline> #startmeeting Documentation IRC meeting 5 March 2020
20:01:39 <huginn> Meeting started Thu Mar  5 20:01:39 2020 UTC.  The chair is caroline. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:39 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:39 <huginn> The meeting name has been set to 'documentation_irc_meeting_5_march_2020'
20:01:51 <caroline> #chair davidnind
20:01:51 <huginn> Current chairs: caroline davidnind
20:02:02 <davidnind> coolio!
20:02:09 <caroline> #topic Introductions
20:02:17 <caroline> (please use "#info" in front of your introduction to have it show up in the automatic minutes)
20:02:27 <caroline> #info Caroline Cyr La Rose, inLibro
20:02:31 <ashimema> #info Martin Renvoize, PTFS-Europe UK
20:02:39 <davidnind> #info David Nind, Wellington, New Zealand
20:02:43 <Marie-Luce> #info Marie-Luce Laflamme, inLibro
20:04:00 <davidnind> #info Apologies from Thomas Dukleth
20:04:30 <caroline> thx davidnind
20:05:13 <davidnind> #topic Review of action points
20:05:39 <kellym> #info Kelly McElligott ByWater
20:06:02 <davidnind> #info Agenda https://wiki.koha-community.org/wiki/Documentation_IRC_meeting_5_March_2020
20:06:29 <caroline> So last meeting (back in Jan) I said to concentrate on 19.11 tasks, but now we should dive in 20.05 otherwise we won't be able to keep up
20:06:43 <lucyvh> #info Lucy Vaux-Harvey PTFS Europe
20:07:24 <caroline> I slacked a little bit on adding the tasks in taiga, but I will try to pick up the pace and go through the release notes again
20:07:41 <caroline> everyone ok with that priority?
20:08:08 <lucyvh> Yes, thx for adding to Taiga for us
20:08:45 <caroline> #info priority now is 20.05 tasks
20:08:47 <davidnind> Sounds fine to me! There are a lot of changes going through at the moment!
20:08:57 <davidnind> ashimema++
20:09:05 <caroline> #action caroline to add release notes tasks to Taiga
20:09:30 <caroline> other action point : Change the manual terminology from "staff client" to "staff interface" (davidnind)
20:09:45 <davidnind> I will add an item to the next development meeting, asking developers to add a release note to the bug
20:09:46 <caroline> I think that was just to change it in the Content guide?
20:10:10 <davidnind> For me, I haven't yet finished changing "staff client" to "staff interface" yet, hopefully sometime by the end of next week..
20:10:20 <caroline> ok so you're doing it everywhere?
20:10:36 <davidnind> trying to!
20:10:38 <caroline> I though it was just to change the guide, hehe!
20:10:54 <davidnind> OK, will do that as well (my bad)
20:11:02 <caroline> well, that moots the next action point I guess which was  Add a task to change the terms in the manual (caroline_catlady)
20:11:28 <davidnind> Will also add to the next development meeting agenda, so developers are aware
20:12:20 <caroline> #info davidnind will finish changing all the mentions of "staff client" to "staff interface"
20:12:42 <caroline> #action davidnind will bring attention to the change at next dev meeting
20:13:10 <caroline> #action davidnind will ask developers to add a realease note note in their bugs at next dev meeting
20:13:33 <caroline> #topic Project updates
20:13:50 <caroline> #link https://wiki.koha-community.org/wiki/Koha_Documentation_Team#To_do_lists_and_projects
20:14:33 <davidnind> Apologies, I've been bad, so no update on any of my projects
20:14:56 <caroline> about the wiki update, thd said he will continue after the Libre Planet convention
20:15:05 <davidnind> excellent!
20:15:48 <davidnind> Actually, I have been working on the installation guide, having "fun" trying to separate out Debian and Ubuntu differences
20:15:55 <caroline> I admit I haven't worked on my assigned projects either... I did do other things, but not that, hehe!
20:16:27 <davidnind> Me too, having fun signing off bugs (it can get a bit addictive)
20:16:40 <caroline> davidnind++
20:17:11 <caroline> anyone else have updates they want to share?
20:17:37 <davidnind> Not that I need any more work, but was trying to think how we could create some sort of dashboard for docs (if Taiga doesn't have anything)
20:17:53 <lucyvh> Not done much, just a few Taiga tasks
20:18:01 <caroline> displaying what kind of info ?
20:19:00 <caroline> [off] ugh... cleared my cookies yesterday for a test and now I have to sign back in to every website...
20:19:24 <davidnind> Not sure yet, but number of doc bugs/taiga tasks pushed (not sure it is useful info), and have something show on the main dashboard
20:19:32 <davidnind> Still just an idea...
20:19:43 <davidnind> (which I have too many of)
20:20:06 <caroline> ideas are good :)
20:20:40 <caroline> #topic What's been done so far
20:21:05 <caroline> as previously mentioned, we got a lot of submissions from lucyvh++
20:21:35 <caroline> I had a bit of problems merging the last ones... will have to ask a git expert
20:22:35 <lucyvh> Sorry! Do let me know if I need to do anything differently
20:22:51 <caroline> I don't think it's you
20:23:15 <caroline> It's just that I needed to rebase and usually gitlab does it automatically, but not this time
20:23:46 <caroline> in other news, rangi set up permanent links to the latest manual woo!
20:23:52 <lucyvh> OKay
20:23:58 <davidnind> Great!
20:24:02 <caroline> this was a request from the education team
20:24:28 <caroline> so you have to replace the version number with "latest"
20:24:37 <caroline> example https://koha-community.org/manual/latest/en/html/
20:24:53 <caroline> this will go to the latest manual, in this case 19.11
20:25:42 <caroline> this is something that will have to be changed every realease so we will have to add it to our cycling workflow
20:25:43 <lucyvh> That's useful
20:26:22 <caroline> now, links in blog posts, training material, etc. will not go stale :D
20:26:35 <davidnind> #info Permanent links to the manual are now available. For example: https://koha-community.org/manual/latest/en/html/ goes to the manual page for the current version.
20:27:22 <caroline> #topic Content development guidelines
20:27:53 <davidnind> I didn't get a chance to add anything new for discussion - have several things to propose though..
20:28:04 <caroline> #info the manual has a content development guide for vocabulary, etc
20:28:09 <caroline> trying to find the link
20:28:27 <caroline> #link https://wiki.koha-community.org/wiki/Documentation_-_Content_Development_Guide
20:28:46 <caroline> hum, that's not the one I was looking for
20:29:12 <davidnind> https://wiki.koha-community.org/wiki/Word_usage_-_A-Z
20:29:49 <caroline> that's not the one I was looking for either... where is the one with the commit message section?
20:30:01 <caroline> or did you remove it?
20:30:56 <davidnind> Here it is https://wiki.koha-community.org/wiki/Git_guide_for_documentation#Commit_messages
20:31:12 <caroline> oh there it is!
20:31:18 <davidnind> I will make sure there is a link to it from the content development guide
20:31:22 <caroline> #link https://wiki.koha-community.org/wiki/Git_guide_for_documentation
20:31:34 <caroline> #link https://wiki.koha-community.org/wiki/Word_usage_-_A-Z
20:32:30 <caroline> #topic Next steps
20:32:32 <davidnind> One things is internal links and not breaking across the page, for example see https://gitlab.com/koha-community/koha-manual/-/commit/55cbb97d976e50f224e7c6b6902ae4ef7e31d651 for an example (tools.rst line 3362/3363)
20:32:47 <caroline> I forgot a point in project updates, so I'll do it here
20:33:11 <caroline> I wanted to know if y'all had an opinion on the current manual structure?
20:33:22 <caroline> I'd like to add more "how-tos" in the manual
20:34:11 <caroline> I reached out to technical writers and they said to simply add a FAQ section (which we already have)
20:34:50 <caroline> could we add common "how-tos"/workflows at the end of each chapter maybe?
20:35:49 <Marie-Luce> it would definitely help librarians
20:36:00 <kellym> +1
20:36:57 <davidnind> +1
20:37:02 <caroline> Ok, I'll add that to the projects and see what I can add until the next meeting
20:37:31 <davidnind> I was looking at updating the theme for the docs site (https://gitlab.com/koha-community/koha-manual/issues/14), so as part of that I thought adding something more like a landing page with links to how tos, manual, what;s new etc (dont have an example right now)
20:37:50 <caroline> ooh I like that idea!
20:38:21 <caroline> as far as landing pages, I like the learn from Koha-US https://koha-us.org/learn/
20:38:24 <davidnind> how tos could go in their own folder
20:38:34 <caroline> and also the bywater training page
20:39:03 <caroline> https://training.bywatersolutions.com/
20:39:05 <davidnind> That's a good example, I have plenty book marked, but can't find the right now!
20:39:38 <kellym> I also like how Koha US has their site set up Caroline!
20:40:21 <davidnind> inLibro's one is good as well! https://inlibro.com/en/products/koha-open-source-lms/knowledge-base/
20:40:54 <caroline> I'm biased for that one, so no opinion, lol!
20:40:59 <kellym> yes!  I love that one also!  So jealous
20:41:33 <davidnind> #info I will post a link to a 'demo' site with a new theme, for comment and discussion (will also add a requirements RFC to the wiki so we can pool ideas)
20:41:54 <caroline> and while were on the topic of themes, I much prefer the TOC on the translated manuals page
20:42:15 <caroline> on the left side of this for example https://translate.koha-community.org/manual/19.05/fr_CA/html/index.html
20:42:31 <caroline> you can clck on sections and they open up
20:43:01 <caroline> and it always stays on the left, you don't have to scroll back up if you need to see it again
20:43:26 <davidnind> that's good, because some pages are soooo looong!
20:43:46 <Marie-Luce> more user's friendly and easy to navigate
20:44:28 <caroline> #action davidnind will create a 'demo' manual with a new thme, landing page and an RFC to collect opinions
20:44:39 <caroline> (will hold you to that one lol)
20:45:18 <davidnind> I've got a couple locally that I'm playing around with, will make available sometime later next week
20:46:01 <caroline> cool!
20:46:44 <caroline> ok for more next steps, see the docs tasks on bugzilla and the taiga site for all new features to be documented
20:46:56 <caroline> #link https://bugs.koha-community.org/bugzilla3/buglist.cgi?bug_status=NEW&bug_status=REOPENED&bug_status=ASSIGNED&f1=keywords&f2=component&j_top=OR&known_name=Documentation%20To-do&list_id=317632&o1=allwords&o2=equals&query_based_on=Documentation%20To-do&query_format=advanced&v1=Manual&v2=Documentation
20:46:57 <davidnind> Also, I had a documentation workshop for Kohacon20 accepted - have added a blurb about it to the  agenda. If anyone has ideas about how this could be run let me know.
20:47:12 <caroline> #link https://tree.taiga.io/project/ldjamison-kohadocs-1805/timeline
20:47:51 <caroline> and again priority is on the 20.05 new features, then enhancements
20:48:17 <caroline> #info priority is documenting 20.05 new features and then enhancements
20:48:57 <caroline> #topic Set time of next meeting
20:49:45 <caroline> I know this is late for europeans, but since davidnind is co-manager, I like to have him attend :)
20:50:08 <davidnind> Thanks!
20:50:25 <davidnind> happy to alternate to an earlier time if that would help
20:51:10 <ashimema> Sorry I didn't keep up there tonight.
20:51:12 <caroline> lucyvh, ashimema, cait, opinions?
20:51:45 <caroline> just asking if it's inconvenient for you if we keep the meeting at the same time?
20:51:55 <ashimema> I trust you guys and only really lurk and respond when asked.  So don't worry too much timing wise for me
20:52:11 <ashimema> Happy with this timing
20:52:23 <caroline> lucyvh?
20:53:02 <lucyvh> This time is ok for me
20:53:07 <davidnind> we had a good turn out today
20:53:32 <caroline> wizzyrea poked all the bywater people hehe!
20:54:10 <caroline> is April 9 good?
20:54:14 <davidnind> wizzyrea++
20:54:51 <Marie-Luce> +1
20:54:53 <davidnind> +1
20:55:01 <kellym> +1
20:55:03 <lucyvh> =1
20:55:19 <lucyvh> You know what I mean!
20:55:40 <caroline> #info Next meeting: 9 April, 2020, 19 UTC
20:55:45 <caroline> #end meeting
20:55:49 <caroline> #endmeeting