14:01:11 <caroline_catlady> #startmeeting Documentation IRC meeting 9 January 2020
14:01:11 <huginn`> Meeting started Thu Jan  9 14:01:11 2020 UTC.  The chair is caroline_catlady. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:11 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:11 <huginn`> The meeting name has been set to 'documentation_irc_meeting_9_january_2020'
14:01:22 <ashimema[m]> ooh.. meeting :)
14:01:35 <caroline_catlady> #topic Introductions
14:01:43 <caroline_catlady> please use "#info" in front of your introduction to have it show up in the automatic minutes
14:01:45 <ashimema[m]> #info Martin Renvoize, PTFS Europe
14:01:51 <caroline_catlady> #info Caroline Cyr La Rose, inLibro
14:02:08 <Marie-Luce> #info Marie-Luce Laflamme, inLibro
14:02:16 <georgew> #George Williams, Northeast Kansas Library System
14:02:24 <cait> #info Katrin Fischer, BSZ, Germany
14:02:37 <caroline_catlady> davidnind says he set his alarm but might not have woken up... :(
14:02:50 <georgew> #info George Williams, Northeast Kansas Library System
14:03:44 <davidnind> #info David Nind, Wellington, New Zealand
14:03:54 <caroline_catlady> oh hi!
14:04:05 <davidnind> morning!
14:04:05 <wahanui> morning is always someone's afternoon
14:04:22 <caroline_catlady> #topic Review of action points
14:04:27 <caroline_catlady> #chair davidnind
14:04:27 <huginn`> Current chairs: caroline_catlady davidnind
14:04:41 <caroline_catlady> Ok so action point from last time
14:04:52 <caroline_catlady> review of documentation manager role
14:05:00 <caroline_catlady> #link https://wiki.koha-community.org/wiki/Documentation_management
14:05:13 <caroline_catlady> anybody have comments on what was done?
14:05:40 <davidnind> looks good so far
14:05:57 * caroline_catlady realizes she hasn't sent a reminder of the meeting on the list like it's written on that page ... -_-
14:06:16 <caroline_catlady> will do better next time!
14:06:32 <caroline_catlady> Also Review of transition workflow
14:06:43 <caroline_catlady> #link https://gitlab.com/koha-community/koha-manual/issues/13
14:07:00 <caroline_catlady> there has been some more dwork done on this
14:07:21 <caroline_catlady> I branched 19.11 so we are effectively working on the 20.05 manual!
14:07:47 <caroline_catlady> hoping to get 19.11 up to date asap before the new features and enhacements start rolling in for 20.05
14:08:19 <caroline_catlady> davidnind: you had a concern about the branching?
14:09:01 <davidnind> that's all good
14:09:13 <thd> #info Thomas Dukleth, Agogme, New York City - [mild cold]
14:09:28 <caroline_catlady> ok
14:09:43 * ashimema[m] should read the latest updates there.. will catch up
14:09:48 <caroline_catlady> Last action point Managing branches and back porting changes
14:10:03 <davidnind> got in the swing of back porting changes, so happy to do that if you would like
14:10:18 <caroline_catlady> Like I said, I branched 19.11, and I have been backporting commits as needed
14:10:25 <Joubu> #info Jonathan Druart
14:10:52 <caroline_catlady> rangi said what I did was ok, so I'll try to document what I did for future reference
14:11:16 <ashimema[m]> ++
14:11:50 <cait> caroline_catlady++
14:12:02 <caroline_catlady> #topic Project updates
14:12:14 <caroline_catlady> #link https://wiki.koha-community.org/wiki/Koha_Documentation_Team#To_do_lists_and_projects
14:12:43 <caroline_catlady> anybody have updates on projects they have been working on?
14:14:08 <thd> I am back in New York where I can work on Koha instead of cleaning ceiling's etc. for my mother in California.
14:14:44 <caroline_catlady> hehe!
14:15:19 <davidnind> nothing to add from me (did nothing over the xmas break :-()
14:15:33 * cait was lazy too
14:16:30 <caroline_catlady> alright so we'll see next time
14:16:45 <caroline_catlady> #topic What's been done so far
14:17:14 <caroline_catlady> davidnind: has been doing some maintenance work
14:17:19 <caroline_catlady> with bernardo
14:18:24 <ashimema[m]> :)
14:18:26 <caroline_catlady> lucyvh has been doing several changes from 18.11, thanks for catching us up!
14:18:48 <davidnind> lucyvh++
14:19:00 <caroline_catlady> ashimema[m] has the trophy for first commit to 19.11 :) add EDI LRP support to stock rotation
14:19:24 <cait> so happy to see all the updates!
14:19:31 <caroline_catlady> and AndyBoze has the trophy for first commit to 20.05 and it's his first contribution!
14:20:17 <caroline_catlady> We also have another first contributor : Alexander Borkowski (not sure what is the irc handle)
14:20:46 <caroline_catlady> ashimema[m]++ lucyvh++ AndyBoze++ everyone++ :D
14:20:57 <ashimema[m]> hehe.. i wrote that submission months ago when i wrote the code :)
14:21:05 * ashimema[m] would encourage devs to try to do the same.
14:21:22 <ashimema[m]> awesome to see new contributors too :)
14:21:26 <ashimema[m]> woop, woop
14:21:41 <cait> woop!
14:21:42 <caroline_catlady> yes! yay!
14:22:28 <caroline_catlady> awesome everyone!
14:22:33 <davidnind> caroline_catlady has been adding all the tasks to taiga, and a bit of a flurry of changes in the last week by Holly
14:22:50 <lucyvh> Apologies, lost track of time!
14:22:55 <caroline_catlady> right! I merged them and totally forgot to mention it :)
14:23:03 <lucyvh> Hi everyone
14:23:20 <caroline_catlady> hi lucyvh! we were just ++ing you for your great work :)
14:23:25 <davidnind> hi lucyvh!
14:24:02 <caroline_catlady> #topic Content development guidelines
14:24:16 <caroline_catlady> davidnind has been working on this
14:24:34 <caroline_catlady> New section on commit messages
14:24:38 <caroline_catlady> #link https://wiki.koha-community.org/wiki/Git_guide_for_documentation#Commit_messages
14:25:05 <caroline_catlady> (though I don't think we will not refuse commits if they don't have this formar)
14:25:27 <caroline_catlady> also more info on how to write links
14:25:30 <caroline_catlady> #link https://wiki.koha-community.org/wiki/ReStructuredText_-_Tips_and_Tricks#Links
14:26:13 <caroline_catlady> words to use instead of others
14:26:16 <caroline_catlady> #link https://wiki.koha-community.org/wiki/Word_usage_-_A-Z
14:26:37 <caroline_catlady> for example use staff clinet instead of intranet, etc...
14:26:42 <caroline_catlady> *client
14:26:44 <cait> wow, very cool
14:26:53 <ashimema[m]> awesome work
14:26:59 <cait> consistent use of words is helpful for translations as well
14:27:13 <cait> although one could argue that we don't have a client
14:27:34 <cait> in technical terms
14:27:34 <lucyvh> Its so useful to have all this written up somewhere - amazing work!
14:27:45 <caroline_catlady> I agree, but that's in the Koha terminology...
14:28:04 <cait> oh i see
14:28:07 <caroline_catlady> Personnaly, I would prefer staff interface
14:28:12 <cait> same :)
14:28:24 <cait> we use the literal translation fo that in German
14:28:37 <caroline_catlady> #link https://wiki.koha-community.org/wiki/Terminology
14:28:42 <davidnind> I've got a few more, but started with a couple  (staff client was from the current terminology list at https://wiki.koha-community.org/wiki/Terminology)
14:28:56 <cait> so maybe we shoudl rethink that there than if we want to change
14:29:27 <caroline_catlady> is it used a lot in the code of Koha?
14:29:34 <davidnind> do we want to change it? I prefer staff interface myself
14:29:51 <caroline_catlady> Ok, so we'll change it for the documentation
14:30:00 <lucyvh> +1 for staff interface
14:30:04 <davidnind> I think I've seen all of them used so far in the manual
14:30:06 <caroline_catlady> ashimema[m]: you can decide what you want to do in Koha's code itself
14:30:09 <ashimema[m]> code wise we say 'intranet'.. but that all hidden to end users in reality
14:30:17 <oleonard> My quick search only turns up one use of "staff client" in the templates
14:30:39 <cait> i think there is everything in the gui now
14:30:40 <ashimema[m]> terms wise I'm happy with 'staff interface' as the standard
14:30:41 <thd> Even if "X client" may be technically correct in terms of function.  People in the general population at least may relate better to "interface".
14:30:52 <cait> so not too late to change :)
14:31:03 <caroline_catlady> ok davidnind can you change the wiki page?
14:31:05 <ashimema[m]> I think it's most likely to come up allot in the manual but very rarely be a term we use in koha itself
14:31:23 <cait> i think probably in the prefs most
14:31:28 <davidnind> I will!
14:31:28 <oleonard> Switching from "intranet" to "staff client" was an improvement but also an arbitrary decision.
14:31:30 <cait> but t would be an easy clean-up job
14:31:41 <ashimema[m]> coolios
14:31:49 <cait> oleonard: are you ok too with staff interface?
14:31:53 <caroline_catlady> #action davidnind will change the manual terminology from staff client to staff interface
14:31:56 <cait> so maybe we should change both pages
14:32:06 <oleonard> I imagine that support companies might have standardized on "staff client" in their web sites and documentation?
14:32:16 <oleonard> Something to check on.
14:32:24 <oleonard> Otherwise I like staff interface.
14:32:32 <caroline_catlady> we use intranet or staff interface in our local docs
14:32:34 <cait> quickly checking bywater for some samples
14:33:00 <davidnind> as the terminology page is part of the development guide, should we raise at development meeting as well?
14:33:01 <caroline_catlady> #action caroline will add a task to change the terms in the manual
14:33:11 <georgew> I hear staff client, staff interface, and intranet from ByWater all the time.  It depends on who you're talking to.
14:34:02 <cait> hm couldn#t turn up an example yet
14:34:02 <oleonard> ByWater can patch those humans' operating systems in a snap right?
14:34:11 <lucyvh> We use all those variations times also at PTFS
14:34:17 <georgew> I'm sure they'd like to
14:34:37 <georgew> It varies in the documentation I've seen from them to
14:34:48 <cait> thx georgew
14:34:49 <georgew> And it changes overtime
14:35:17 <caroline_catlady> so there isn't a standard, but for the manual, we want it to be consistent
14:35:27 <caroline_catlady> I will be an easy task for a newbie to commit
14:36:03 <caroline_catlady> we're also thinking of adding a glossary to the manual to help ppl who are coming from other systems
14:36:16 <caroline_catlady> I started one on a local branch
14:36:41 <caroline_catlady> I will commit it soon, but I'm not sure how to make it show up in the table of contents
14:36:44 <caroline_catlady> is it automatic?
14:37:12 <davidnind> the glossary is autogenerated I think
14:37:20 <caroline_catlady> is it?
14:37:35 <cait> caroline_catlady: i think it's automatic yes
14:37:42 <cait> hm would it be top level new file?
14:37:55 <caroline_catlady> that's wahat I was thinking
14:38:00 <caroline_catlady> so it could go at the end
14:38:05 <cait> let me quickly check
14:38:37 <pastebot> "caroline_catlady" at 127.0.0.1 pasted "here's what an entry looks like in my file" (5 lines) at http://paste.koha-community.org/18771
14:39:52 <caroline_catlady> the "see" is "instead of term 1, use term 2
14:40:19 <caroline_catlady> so in my example, loan will refer to checkout
14:40:23 <cait> i thought it was source/index.rst
14:41:03 <davidnind> the terms show up in the index, there is a link to that at the top and bottom of each manual page
14:41:24 <cait> ah it is: https://gitlab.com/koha-community/koha-manual/raw/master/source/index.rst
14:41:37 <cait> gitlab does some rendering that makes some not show, but you can see it in raw
14:41:42 <cait> you just sort your new file in there
14:42:03 <caroline_catlady> ok thanks cait
14:42:21 <caroline_catlady> davidnind: I found the index list, but it's empty
14:42:48 <cait> i thin it just looks like it on gitlab - did you try 'raw'?
14:43:00 <cait> or edit, if you are logge din
14:43:03 <davidnind> that's because there areno entries yet
14:43:12 <caroline_catlady> https://koha-community.org/manual/19.11/en/html/genindex.html
14:43:55 <caroline_catlady> ok so when I add my file, it will populate this?
14:44:20 <davidnind> should do, I think it did when I tested
14:44:31 <caroline_catlady> ok cool!
14:45:01 <caroline_catlady> #topic Next steps
14:45:16 <caroline_catlady> I wanted to talk about priorities
14:45:55 <cait> oh, different file!
14:46:06 <caroline_catlady> I'd really like to catch up 19.11 so that when the devs start to add new stuff to 20.05 we can stay on top
14:46:19 <ashimema[m]> +1
14:46:25 <caroline_catlady> so priority #1 is anything in 19.11 on Taiga
14:46:59 <cait> should we note versions in commit messages?
14:47:30 <caroline_catlady> I started adding "new feature", "enhancement" and "screenshot" tags in taiga, and that is the prioriuty order too (new features, then enhancements, then screenshots)
14:47:30 <ashimema[m]> probably a good idea
14:47:47 <caroline_catlady> write the version number in the commit message or the commit comment
14:47:56 <davidnind> I think adding it to the merge request would be better, e.g. this was added in 19.05, etc
14:48:20 <caroline_catlady> as long as it's written somewhere
14:49:44 <caroline_catlady> There are some interesting agenda points still to cover, but I think we on't have enough time
14:50:06 <caroline_catlady> is it ok if we move these to the next meeting?
14:50:20 <davidnind> that's fine with me
14:50:29 <ashimema[m]> me too
14:50:36 <caroline_catlady> ok good!
14:50:37 <cait> yes
14:50:46 <caroline_catlady> #topic Set time of next meeting
14:51:19 <caroline_catlady> feb 6? 20UTC?
14:51:38 <davidnind> +1
14:52:00 <davidnind> hope it's not too late for everyone else...
14:52:38 <thd> +1
14:52:42 <ashimema[m]> 1
14:52:51 <lucyvh> +1
14:53:18 <caroline_catlady> #info Next meeting: 6 February 2020, 20 UTC
14:53:25 <caroline_catlady> #endmeeting