15:01:25 <Joubu> #startmeeting General IRC meeting 2 December 2020
15:01:25 <huginn> Meeting started Wed Dec  2 15:01:25 2020 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:25 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:25 <huginn> The meeting name has been set to 'general_irc_meeting_2_december_2020'
15:01:33 <Joubu> #topic Introductions
15:01:45 <ashimema> #info Martin Renvoize, PTFS Europe
15:01:46 <Joubu> #info Jonathan Druart
15:02:03 <fridolin> #info Fridolin Somers, Biblire, France
15:02:04 <tuxayo> #info tuxayo/Victor Grousset, France
15:02:05 <fridolin> ah AndrewFH i was not sure of your nick, hello
15:02:14 * AndrewFH waves
15:02:27 <fridolin> seen your picture on BW site ;)
15:02:27 <wahanui> I haven't seen 'your', fridolin
15:02:36 <Joubu> hey we have the whole RMaints team!
15:03:01 <AndrewFH> (currently waiting on a librarian to show up to talk about quarantine workflows - sorta semi-present)
15:03:22 <ashimema> impressive.. can't remember the last time we had the whole team
15:03:40 <Joubu> #topic Announcements
15:03:58 <Joubu> ashimema: the advent calendar maybe?
15:04:17 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:04:23 * fridolin starting RMaint 20.11 gently
15:04:26 <Joubu> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_2_December_2020
15:04:36 <ashimema> #info We have a community advent calendar this year: https://koha-community.gitlab.io/KohaAdvent/
15:04:40 <ashimema> #link https://koha-community.gitlab.io/KohaAdvent/
15:04:43 <caroline> #info Caroline Cyr La Rose, inLibro, Montréal, Québec (Canada)
15:05:02 <ashimema> #info Target audience is those who want to start creating plugins, using API's etc
15:05:29 <Joubu> shouldn't we announce it on the list?
15:05:39 <fridolin> +1
15:05:51 <ashimema> I have ;)
15:06:00 <ashimema> did you miss it?
15:06:08 <Joubu> ho, indeed :)
15:06:20 <fridolin> "Happy Advent" email
15:06:25 <Joubu> yup
15:06:26 <fridolin> from 01/12
15:06:33 * fridolin is going to seak what must be set obsolete, 19.05 is in pootle, jenkins ...
15:06:50 <Joubu> anything else?
15:06:50 <wahanui> i think anything else is necessarily going to be incremental.
15:06:51 <fridolin> not sur it is already listed
15:07:17 <fridolin> I'd like to point Bug 26991
15:07:17 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26991 enhancement, P5 - low, ---, fridolin.somers, Needs Signoff , Add action logs to search engine administration
15:07:18 <ashimema> can't think of anything
15:07:25 <fridolin> very usefull for Elastic
15:07:28 <ashimema> other than perhaps your starting to draft a roadmap for this release?
15:07:33 <ashimema> s/release/cycle
15:07:43 <Joubu> it's a general meeting fridolin, keep it for the dev meeting tonight
15:07:47 <Joubu> #topic Update from the Release Manager
15:07:52 <fridolin> ah oki sorry
15:07:58 <Joubu> 21.05 is out! And Packages are available already.
15:08:06 <Joubu> And it is, for sure, the best release ever!
15:08:08 <tuxayo> team++
15:08:11 <tuxayo> Joubu++
15:08:12 <fridolin> ++
15:08:15 <Joubu> Yes, before the next one...
15:08:19 <tuxayo> mtj++
15:08:24 <Joubu> mtj++
15:08:37 <Joubu> definitelly, he did a great job last cycle
15:08:46 <Joubu> the ones before as well ;)
15:08:51 <Joubu> I've sent an email to koha-devel to start building a roadmap for 21.05
15:09:02 <Joubu> This is an important thing to read!
15:09:18 <Joubu> #info Read the email "start building a roadmap for 21.05"
15:09:25 <Joubu> #link https://lists.koha-community.org/pipermail/koha-devel/2020-November/046157.html
15:09:33 <Joubu> There is a collaborative pad, feel free to join the existing topics I've listed and to add your own stuffs in it.
15:09:51 <Joubu> Any questions about that?
15:10:32 <Joubu> ok so, you certainly noticed the new git server. Gitea is now the web interface, even if gitweb is still there (to not break links).
15:10:46 <Joubu> Devs will have to adjust their remote URL with: git remote set-url $remote https://git.koha-community.org/Koha-community/Koha.git
15:10:52 <fridolin> yep its super
15:10:59 <Joubu> #info git server moved, adjust your remote URL!
15:11:12 <fridolin> we can now easy point to source code line using permalink
15:11:16 <ashimema> ooh, yes... git server
15:11:18 <Joubu> The homepage needs a bit of tweaking, let me know if you have any ideas.
15:11:53 <oleonard> Whoa, I had NOT noticed that yet!
15:12:12 <Joubu> then you didn't git pull for week!
15:12:18 <Joubu> #topic Updates from the Release Maintainers
15:12:18 <fridolin> ^^
15:12:20 <tuxayo> hehe
15:12:24 <fridolin> yo
15:12:27 <Joubu> Some bugs have been found already, and some important ones that should be fixed for .01 are listed there: https://frama.link/koha_bz_rel_21_05_candidate
15:12:28 <oleonard> I mean the new web interface Joubu :)
15:12:34 <fridolin> i'm still warming up
15:12:49 <fridolin> going to seak what must be set obsolete, 19.05 is in pootle, jenkins ...
15:13:11 * ashimema will be getting going on bugs next week.. this week has been a bit challenging
15:13:11 <Joubu> we keep the project on jenkins, but we disable them
15:13:14 <Joubu> project*s*
15:13:23 <fridolin> and what Bugzilla status must be done
15:13:40 <fridolin> seen that on jenkins
15:13:40 <wahanui> I haven't seen 'that', fridolin
15:13:58 <fridolin> we must alert poeple to start translating 20.11
15:14:05 <thd> #info: Thomas Dukleth, Agogme, New York City [addressing death of sometime employer]
15:14:06 <Joubu> We can keep the 19.05 version on bugzilla, it's helpful to know if some bugs are there
15:14:15 <tuxayo> +1
15:14:27 <fridolin> yep
15:14:34 <Joubu> fridolin: the translation team has been told to translate ~3w ago
15:14:45 <fridolin> oki sorry
15:15:02 <henryb> Sorry I'm late! joubu: is the roadmap just for backend stuff or new features too e.g. the recalls function (bug 19532)?
15:15:02 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19532 new feature, P1 - high, ---, aleisha, Signed Off , Recalls for Koha
15:15:03 <Joubu> fridolin: https://tree.taiga.io/project/koha-ils/us/19?kanban-status=1383
15:15:14 <Joubu> this is the list of actions we triggered after a relased is out
15:15:19 <Joubu> still not everything done
15:15:21 <fridolin> oki super
15:15:27 <henryb> Oh sorry, I missed the topic
15:15:51 <Joubu> henryb: it's basically the big things you are willing to spend time on them during the next 6 months
15:16:40 <fridolin> caroline: seen translation job on fr-CA, maybe we should talk how to use it in fr-FR ?
15:16:40 <wahanui> I haven't seen 'translation', fridolin
15:16:52 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:16:56 <oleonard> You haven't seen much wahanui
15:17:03 <fridolin> we may discuss this another time
15:17:21 <henryb> #info Henry Bolshaw, House of Lords Library, UK
15:17:26 <Joubu> henryb: did I answer your question?
15:17:48 <henryb> Yes you did. Thanks!
15:17:56 <Joubu> something else RMaints?
15:18:32 <Joubu> #topic KohaCon21
15:18:45 <Joubu> * Discuss if changes to process are requires because of COVID (Processes for KohaCons)
15:18:48 <Joubu> *  Start bidding process
15:19:26 <Joubu> any suggestions?
15:20:23 <oleonard> New Zealand may have been an outlier in that they were able to offer an in-person component... I wonder if that's true for other places that might want to host?
15:20:58 <oleonard> There could still be value in keeping the geographical rotation if that means that the local host can still hold in-person events.
15:21:21 <thd> Does anyone on a COVID free island want to host KohaCon again?
15:21:33 <Joubu> oleonard: You forgot that we will get a vaccine in 1 month and in about 3 months we are back to normal
15:21:40 <Joubu> (...)
15:22:01 <oleonard> :|
15:22:18 <tuxayo> hopefully, but that might be optimistic
15:22:24 <oleonard> That may be true for some countries, I hope!
15:22:36 <thd> Joubu: Will supply of vaccine be sufficient for back to normal in three months?
15:22:37 <oleonard> Certainly not here :(
15:22:43 <Joubu> should we then ask the ML if some people are willing to organise a virtual conf for KohaCon21?
15:23:15 <Joubu> or simply announce no KohaCon21?
15:23:40 <Joubu> or postpone to the next meeting (we postponed it 3x already)?
15:24:03 <caroline> I talked with my boss and both of us were kinda feeling down that yall couldn't come
15:24:03 <henryb> Can we ask for proposals and ask whether they want to do virtual and/or virtual + in person?
15:24:12 <tuxayo> +1
15:24:32 <caroline> If we didn't lose our chance to have in person later, I could try and see if we can do a virtual one
15:25:10 <thd> Presumably, people would want to do an in person conference, but circumstances may prevent that.
15:25:38 <ashimema> we can certainly try and drum up some interest on the mailing list.. see if anyone is contemplating hosting
15:25:48 <ashimema> at the moment I think people just haven't thought about it.
15:26:14 <Joubu> can I #action a volunteer?
15:26:44 <caroline> I can send an email to the ML
15:26:49 <oleonard> Should we require that KohaCon21 have an online component? I wish we could but I worry that it might prevent some from bidding.
15:26:53 <Joubu> thanks caroline
15:27:14 <Joubu> #action caroline send an email to the ML about KohaCon21
15:27:28 <caroline> I think online should be mandatory now
15:27:31 <Joubu> yes
15:27:36 <caroline> even if in person is possible
15:28:10 <caroline> even if it's possible to go in person, not everyone can afford to go
15:28:32 <caroline> and it's not like the technology is hard to use
15:28:48 <oleonard> Okay yeah I guess if they can't offer online they can just do their own regional conference.
15:28:48 <Joubu> and we (the community) can help
15:29:36 <Joubu> moving on then?
15:29:46 <Joubu> #topic Koha Cookbook Project
15:29:56 <Joubu> #link https://wiki.koha-community.org/wiki/Koha_cookbook_RFC
15:30:05 * fridolin likes cooking ;)
15:30:25 <cait1> oh
15:30:29 <cait1> sorry, i almist missed the meeting
15:30:37 <cait1> #info Katrin Fischer, BSZ Germany
15:30:40 <Joubu> no, it's the most important part
15:30:49 <Joubu> is it your topic?
15:30:53 <cait1> too many other unimportant meetings
15:31:00 <cait1> no it is not - maybe magnuse
15:31:13 <cait1> but I could contribute some cake recipes :)
15:31:19 <Joubu> the history of the meeting page tells you added it
15:31:28 <fridolin> datas may use Markdown format, it great for conversions
15:31:48 <caroline> I have a maple syrup dessert I can add too :D
15:31:52 <cait1> ok, then I don't remember! spooky. But I think the original idea was born during KohaCon and magnuse had followed up on it
15:31:55 <Joubu> ok, we need a "meeting manager" next cycle...
15:32:06 <cait1> i think what we can do:
15:32:10 * liliputech_asu missed the meeting, got just in time for food ^^
15:32:11 <cait1> do we think it's a great idea?
15:32:19 <liliputech_asu> cait1: it is!
15:32:21 <caroline> yass!
15:32:23 <cait1> I think so too :)
15:32:39 <cait1> maybe it could be something to tackle after the advent calendar?
15:32:59 <Joubu> perfect for December 25th
15:33:00 <cait1> and if we want to do it - which form should it take
15:33:09 <cait1> i was more thinking january heh
15:33:28 * liliputech_asu has prepared a "croziflette" for this evening, yummy! (dish for winter)
15:33:36 <Joubu> Do we add it to the 21.05 roadmap?
15:33:42 <Joubu> (maybe people will read it then)
15:33:49 <cait1> hm good question
15:33:54 <cait1> not sure if i'd tie it to release
15:34:00 <cait1> or maybe more as a side project?
15:34:18 <caroline> Should we name a "Cookbook manager"?
15:34:18 <Joubu> it's just a list of workgroup
15:34:24 <Joubu> people working on the same things at the same time
15:34:30 <cait1> are we mixing up things now?
15:34:31 <caroline> I'm willing to be on the team
15:34:31 <oleonard> Should we have pre-defined categories like cookbooks do? (appetizers, breakfast, soups, main dish, etc) and get a minimum number of submissions for each? Or should we have it be all desserts because that's all we want to eat.
15:34:43 <cait1> ok, maybe we could agree to have a cookbook meeting?
15:34:54 <cait1> i see lots of great ideas here :)
15:35:15 <caroline> Cookbook meeting in January?
15:35:16 <cait1> personally i just have a little too much on my plate (how fitting) to take a leading role rightnow for it
15:35:29 <cait1> and then discuss what we want to use
15:35:45 <cait1> we could do it with the manual tool for example -a lso gives us easy html and epub
15:35:57 <Joubu> so we can elect a leader, someone not around now, magnuse?
15:36:02 <cait1> heh
15:36:08 <cait1> i was more thinking caroline or owen
15:36:37 * oleonard hides
15:36:47 <caroline> I do have a lot on my plate too, but this is too fun to pass up
15:37:00 <Joubu> I'm adding it to the roadmap, just to gather a list of people who are willing to work/help on it, ok?
15:37:03 <caroline> It's like a stress release project
15:38:06 <cait1> yep ok
15:38:14 <cait1> for me (roadmap)
15:38:16 <Joubu> #action Joubu form a workgroup for the Koha Cookbook Project
15:38:19 <cait1> i will sign up for helping/contributing
15:38:20 <ashimema> om, nom
15:38:28 <cait1> but my measurements will be metric! be warned :)
15:38:39 <Joubu> everything will be metric, ofc
15:38:42 <Joubu> what else?
15:38:44 <caroline> we can have both :)
15:38:54 <caroline> cookbooks here always have both
15:39:00 <oleonard> METRIC??? (ノಠ益ಠ)ノ彡┻━━┻
15:39:06 <oleonard> ;)
15:39:10 <caroline> lol!
15:39:25 <oleonard> ┬─Metric─┬ノ(ಠ_ಠノ)
15:39:26 * cait1 whispers to Joubu careful...
15:39:46 <tuxayo> > we can have both
15:39:46 <tuxayo> IIRK, something crashes on Mars due to that
15:39:55 <tuxayo> *crashed
15:39:56 <Joubu> I think we can provide easily conversion ;)
15:39:59 <cait1> caroline: i think in january i might be able to share the load if you want (probably)
15:40:10 <cait1> and maybe we can get magnus back on it too
15:40:40 <thd> recipe sign off requires inclusion of at least metric ;)
15:40:57 <cait1> Cooking guildeline :)
15:41:05 <cait1> ok, fun topic, but maybe we should move on
15:41:06 <cait1> heh
15:41:14 <Joubu> I can provide a beer recipe, does it work?
15:41:15 <fridolin> also inclusing of a bootle of bier for the chef
15:41:16 <cait1> caroline: would you be ok with remembering about a meeting in january?
15:41:18 <caroline> Can we say like jan 14?
15:41:28 <cait1> ok for me
15:41:34 <caroline> Ok I'll set a date and send an email to the ML
15:41:43 <cait1> thank you :)
15:41:48 <Joubu> ok, moving on
15:41:52 <cait1> caroline++
15:41:57 <Joubu> #topic Actions from last meeting
15:42:09 <Joubu> #topic tuxayo: update release maintenance wiki page: when something is not been being backported the status should be switched to "RESOLVED - FIXED" instead of "pushed to $RELEASE"
15:42:12 <Joubu> it's done!
15:42:30 <tuxayo> next!
15:42:46 <Joubu> tuxayo: did you send an email to the RMaints?
15:42:56 <tuxayo> yes
15:43:09 <Joubu> sorry, I am forgetting things apparently
15:43:26 <Joubu> next action is done as well
15:43:31 <Joubu> #topic cait to add KohaCon21 as topic to next meeting's agenda
15:43:34 <Joubu> done then
15:44:05 <Joubu> anything else you would like to add before the end of the meeting?
15:44:28 <Joubu> #topic Set time of next meeting
15:44:37 <Joubu> in 5w
15:44:48 <Joubu> On Jan 6th
15:44:55 <Joubu> to prevent next colision with dev meetings
15:45:14 <Joubu> #info Next meeting: 6 January 2021, 20 UTC
15:45:19 <Joubu> no objections?
15:45:36 <Joubu> #endmeeting