20:00:10 <cait> #startmeeting General IRC meeting 4 November 2020
20:00:10 <huginn> Meeting started Wed Nov  4 20:00:10 2020 UTC.  The chair is cait. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:10 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:10 <huginn> The meeting name has been set to 'general_irc_meeting_4_november_2020'
20:00:16 <cait> #chair Joubu ashimema
20:00:16 <huginn> Current chairs: Joubu ashimema cait
20:00:28 <cait> been a while, hope I still know how to do this :)
20:00:31 <cait> #topic Introductions
20:00:41 * ashimema is juggling two meeings
20:00:42 <aleisha> #info Aleisha Amohia, Catalyst IT, Wellington NZ
20:00:42 <cait> Please introduce yourself using #info!
20:00:44 <caroline> #info Caroline Cyr La Rose, inlibro, Montreal
20:00:50 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
20:00:53 <cait> #info Katrin Fischer, BSZ, Germany
20:01:03 <tuxayo> #info tuxayo/Victor Grousset, France
20:01:03 <ashimema> #info Martin Renvoize, PTFS Europe
20:01:08 <josef_moravec> #info, Josef Moravec, Czech Republic
20:01:12 <Joubu> #info Jonathan Druart
20:01:36 <mkuhn> #info Michael Kuhn, Switzerland
20:01:40 <davidnind> #info David Nind, Wellington, New Zealand
20:02:06 <Joubu> #link https://wiki.koha-community.org/wiki/General_IRC_meeting_4_November_2020
20:02:07 <henryb> #info Henry Bolshaw, House of Lords Library, UK
20:02:09 <cait> will give it a a little more time
20:02:10 <marie-luce> #info Marie-Luce Laflamme, inLibro, Montreal
20:02:59 <cait> feel free to ping your friends - tonight is election meeting!
20:03:26 <cait> moving on!
20:03:33 <cait> #topic Update on releases
20:03:36 <cait> rmaints?
20:03:36 <wahanui> rmaints is lukeG, aleisha, and tuxayo, I SUMMON THEE!!⚡⚡
20:03:39 <cait> RM?
20:04:02 <Joubu> yup, will copy what I said during the dev meeting earlier today
20:04:14 <Joubu> lot of things have been PQA, I am processing them all and hopefully will be "done" (pushed or not) before end of the week
20:04:15 <tuxayo> #info 19:05 latest security release was without issue :)
20:04:19 <Joubu> no new enhancement will be pushed after this week
20:04:31 <Joubu> unless they have been PQA already
20:04:36 <cait> lukeG++ aleisha++ tuxayo++
20:04:49 <Joubu> Please add the release notes to your bugs. I will add the bz tags next week
20:05:00 <aleisha> #info 19.11 latest security release also smooth
20:05:18 <aleisha> #info thanks to Hayley Mapley for her support with that release given we were also organising Kohacon at the same time
20:05:40 * oleonard would like to see bugs which won't be backported marked as "resolved fixed," meant to mention it during the dev meeting
20:05:56 <aleisha> don't forget to #info things you want recorded in the minutes
20:06:08 <Joubu> yes oleonard, you are right. We should try and add this to our workflow next cycle
20:06:21 <tuxayo> +1
20:06:39 <cait> +1
20:07:03 <cait> ok, anything more?
20:07:05 <aleisha> so that's for rmaints that won't be backporting a bug to their maintenance branch?
20:07:37 <cait> that's how I understand it - the first one to decide not to backport closes the bug
20:07:48 <Joubu> yes, when something is been being backported the status should be switched to "closed" instead of "pushed to master"
20:07:57 <Joubu> or "pushed to *stable"
20:08:21 <cait> i think resolved fixed would be good - still shows up in search and then we close it later with the normal process
20:08:38 <aleisha> #info rmaints to mark a bug as 'resolved fixed' if it is not to be backported to their maintenance branch
20:09:08 <cait> ok, anything else?
20:09:08 <wahanui> somebody said anything else was necessarily going to be incremental.
20:09:26 <cait> i know there is no kohacon topic now
20:09:27 <tuxayo> ok
20:09:28 <tuxayo> #action tuxayo: update release maintenance wiki page: when something is not been being backported the status should be switched to "closed" instead of "pushed to $RELASE"
20:09:39 <Joubu> #info D11 is completely broken, see bug 26893, must not be used!
20:09:39 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26893 blocker, P5 - low, ---, koha-bugs, NEW , New version of JSON::Validator (D11) break our REST API routes
20:09:39 <cait> thx tuxayo
20:10:17 <cait> I notice I skipped the announcements
20:10:21 <cait> #topic Announcements
20:10:36 <Joubu> D11 is Debian 11 (bullseye)
20:11:04 <cait> #info A big thank you to Catalyst IT and everyone involved in KohaCon20! It was awesome :)
20:11:15 <caroline> catalyst++
20:11:18 <davidnind> +100
20:11:18 <oleonard> seconded!
20:11:23 <tuxayo> catalyst++
20:11:26 <ashimema> +1
20:11:26 <marie-luce> catalyst++
20:11:33 <ashimema> catalyst++
20:11:35 <aleisha> #info all the links for kohacon20 content are available on the kohacon website
20:11:42 <aleisha> #link https://2020.kohacon.org/
20:11:45 <tuxayo> :D
20:11:45 <Joubu> catalyst++ and the whole kohacon20 team!
20:11:58 <ashimema> will the site be around for a while..
20:12:08 <cait> it's a good question
20:12:17 <aleisha> i'm sure it will be till at least the end of the year! but will need Chris to confirm
20:12:20 <ashimema> is there a way to submit it to the waybackmacine archive
20:12:21 <cait> i noticed some of the old kohacon page are gone and programs and the like lost
20:12:29 <cait> maybe we hsoudl move the most important links to the website as well
20:12:34 * ashimema has never tried.. but I like the idea for the link in the history
20:12:36 <Joubu> we should keep kohacon20.org!
20:12:43 <Joubu> kohacon.org I mean
20:12:48 <cait> yep that too :)
20:12:54 <cait> is it possible?
20:12:58 <aleisha> #info the kohacon20 website will remain up forever says Chris Cormack
20:13:01 <tuxayo> > is there a way to submit it to the waybackmacine archive
20:13:01 <tuxayo> Yes, I do that a lot with various sites ^^"
20:13:06 <mkuhn> There's always the Internet Archive for lost sites...
20:13:08 <ashimema> kohacon.org is a great domain.. I had totally overlooked that
20:13:23 <aleisha> Chris owns kohacon.org
20:13:25 <cait> me too, but it is great indeed
20:13:31 <cait> rangi++
20:13:45 <aleisha> so he can point 2021.kohacon.org to wherever
20:13:48 <tuxayo> > There's always the Internet Archive for lost sites...
20:13:48 <tuxayo> it's important to check manually that all pages are archived.
20:13:52 <aleisha> or 2019 to last year etc
20:13:56 <aleisha> just needs to let him know :)
20:14:00 <cait> could you add that info to the kohacon organisation wiki page maybe?
20:14:03 <caroline> good to know!
20:14:03 <davidnind> or use a sub domain off koha-community.org and keep static copies of all sites
20:14:17 <aleisha> sure thing cait
20:14:26 <cait> so we don't forget... knowing us and all
20:14:28 <cait> ok
20:14:40 <cait> if there are no further announcments I will be moving on to the main event tonight
20:15:09 <cait> #topic Election of the 21.05 Release Team
20:15:22 <cait> #link https://wiki.koha-community.org/wiki/Roles_for_21.05 candidates
20:15:30 <josef_moravec> #info 202.kohacon.org is now on wayback machine: https://web.archive.org/web/20201104201359/https://2020.kohacon.org/
20:15:44 <ashimema> nice one
20:15:46 <cait> before we turn to voting I'd like to give some room for questions and last minute additions
20:15:54 <cait> some things to point out:
20:15:59 <tuxayo> josef_moravec++
20:16:23 <cait> 1)  Rmaints - we discussed earlier to check if current rmaints want to continue and are also encouraging new people :)
20:16:41 <cait> 2) There is a completely new and great role - Accessibility Advocate
20:16:54 <ashimema> henryb++
20:17:00 <ashimema> great proposal there :)
20:17:17 <caroline> henryb++
20:17:22 <cait> 3) Topic experts are also great starter roles if you feel comfortable in a certain area of Koha
20:17:45 <aleisha> i would be happy to a recalls topic expert if it could ever get through :( lol
20:18:13 <cait> 4) Chad, our newsletter editor, is stepping down, but we are lucky to have a new volunteer!
20:18:26 <mkuhn> Hi there
20:18:26 <wahanui> bonjour, mkuhn
20:18:31 <caroline> mkuhn++
20:18:36 <cait> mkuhn++
20:18:42 <cait> i will give you a moment to check
20:18:57 <cait> please let us know here if you decide on a last minute thing :)
20:18:59 <Joubu> I have not written a proposal, like I am used to do. But basically I will stick to the same rules as the current release.
20:19:14 <Joubu> Which does not mean anything useful, but I guess you start to know who I am and how I am working now :D
20:19:46 * oleonard will continue to perform the same ritual sacrifices
20:19:51 <ashimema> excellent.. I hadn't spotted Newletter Editor :).. mkuhn++
20:20:20 <cait> oleonard: draft beer?
20:20:26 <cait> open to questions now too
20:20:43 <cait> if there is no veto or wishes to do otherwise, we will vote on the full release team in one vote
20:20:48 <tuxayo> cait maybe another call for QA volunteers with emphasis about consistent time commitment? (even small)
20:21:06 <cait> tuxayo, couldn't have done it better :)
20:21:45 <cait> we need more shoulders to more evenly balance QA load - if you have a little time and can do QA somewhat regularly we'd be happy to have you
20:21:46 <tcohen> =9522,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,3
20:21:48 <tcohen> sorry
20:21:55 <ashimema> I think it's a little late for this coming team.. though I'm always open to extras.. but I do think during the next cycle we need to somehow really promote the roles and build more aspirations for a wider group of people to sign up
20:21:59 <cait> topic experts can also count towards qa with their sign-off, we established that a while ago :)
20:22:19 <caroline> tcohen you don't have cats per chance?
20:22:38 <cait> maybe a guinea pig?
20:22:47 <tcohen> mkuhn++
20:22:53 <Joubu> the QA group is quite big actually, we just need people to dedicate a bit more of their time ;)
20:23:00 <cait> going to read up on the voting command, brb with you all
20:23:08 <tcohen> caroline I have a demanding youngster
20:23:16 <cait> yes, i'd be super happy with 1-2 hours a week
20:23:16 <ashimema> The regulars on the team are all very friendly and supportive.. so don't be scared to put your names forward..
20:23:17 <caroline> hehe!
20:23:28 <tcohen> Joubu I think we need more team work
20:23:31 * cait thinks cait is scary
20:23:37 <tcohen> i.e.
20:23:44 <ashimema> I don't think any of us would mind new people having a go.. and they would be welcome to ask for support
20:23:55 <ashimema> or go their own way of course.
20:23:58 <tuxayo> Here are some citations from the previous meeting to encourage new QA
20:24:00 <tuxayo> > the QA queue is often full of easy starter bugs.. one's that don't take hours.. you can be on the QA team and be picky about what you choose to QA.. it's a good way to start
20:24:23 <tuxayo> > *cait recommends oleonard's for starters
20:24:39 <cait> I stand by that still :)
20:24:45 <tcohen> big devs need to incorporate other devs, probably QA team members into the discussion early. So there are no big-scary devs that no one can spend a week testing
20:24:52 <tuxayo> > ashimema if there's anyone out there at all interested in doing QA.. or anyone anyone here thinks might be good at QA then feel free to apply and I'd be happy to guide on the process/mentor people
20:25:02 <ashimema> tcohen++
20:25:11 <cait> tuxayo++ thank you
20:25:22 <ashimema> I do agree with that... getting QA onboard early really helps move the big stuff
20:25:26 <domm> quick question: Can I ran opac/intranet with just plack (eg starman), or does Koha need apache (or even mod_perl)?
20:25:33 <domm> s/ran/run/
20:25:40 <cait> domm: sorry, little bit of bad timing right now
20:25:44 <cait> we are holding elections
20:25:46 <tcohen> domm you can
20:25:48 <domm> oh, sorry
20:25:53 <cait> interested in becoming a bug wrangler? ;)
20:25:57 <ashimema> you can indeed domm
20:26:00 <tcohen> cait
20:26:03 <tcohen> cait++
20:26:06 <domm> thanks, and I'l shut up now
20:26:10 <tcohen> that's the spirit
20:26:16 <cait> #info We will vote on the whole release team in one go, results will be in tonight.
20:26:25 <cait> well.. my tonight.
20:26:26 <tuxayo> The world most important elections at the moment! :D
20:26:38 <cait> are there any more questions?
20:26:39 <ashimema> feel free to join in domm.. everyone is welcome at the meetings :)
20:26:42 <tcohen> I guess we can have the results before the US
20:26:45 <tuxayo> domm: no worries, just wait for the end of the meeting
20:26:48 <ashimema> and help cast the vote on the next team
20:27:03 <cait> yep, everyone can vote, join in! :)
20:27:19 <cait> ok, going to write up the voting command
20:27:33 <cait> can someone phrase me a question? i am so bad at it
20:27:40 <tuxayo> last moment to read the roles:
20:27:40 <tuxayo> https://wiki.koha-community.org/wiki/Roles_for_21.05
20:28:29 <cait> #startvote Do you elect all the candidates for the roles they signed up for in the Koha 21.05 release team as noted on the wiki? (no, yes, abstain)
20:28:29 <huginn> Begin voting on: Do you elect all the candidates for the roles they signed up for in the Koha 21.05 release team as noted on the wiki? Valid vote options are , no, yes, abstain, .
20:28:29 <huginn> Vote using '#vote OPTION'. Only your last vote counts.
20:28:35 <cait> #vote yes
20:28:41 <mkuhn> #vote yes
20:28:44 <ashimema> #vote yes
20:28:46 <caroline> #vote yes
20:28:47 <davidnind> #vote yes
20:28:50 <tcohen> #vote yes
20:28:50 <Joubu> #vote yes
20:28:50 <henryb> #vote yes
20:28:50 <oleonard> #vote yes
20:28:54 <ashimema> that's looking to be a great team :)
20:28:54 <marie-luce> #vote yes
20:28:57 <josef_moravec> #vote yes
20:28:58 <tuxayo> #vote yes
20:29:16 <aleisha> #vote yes
20:30:06 <cait> again going to give tihs at least one more minute
20:30:12 <mkuhn> Hmm... what kind of election is this with 100% yes votes? What happens if someone votes no?
20:30:23 <cait> mkuhn: it will be counted
20:30:48 <ashimema> also.. final #vote counts if you vote twice..
20:31:04 <ashimema> so you can't cheat and vote twice ;)
20:31:23 <mkuhn> But I haven't registered
20:31:30 <tcohen> no need to
20:31:34 <tuxayo> no need
20:31:36 <cait> it goes by the nick
20:32:03 <cait> is it too early for election jokes?
20:32:09 <A_brand_new_voter> Am I too late to vote?
20:32:11 <tuxayo-read-only> #vote cheat
20:32:11 <huginn> tuxayo-read-only: cheat is not a valid option. Valid options are , no, yes, abstain, .
20:32:23 <cait> ok,ending vote!
20:32:24 <tcohen> hehe
20:32:24 <Joubu> I think there is a rule saying that you need at least 1 patch in the codebase to vote
20:32:33 <cait> i don't think there is
20:32:40 <cait> any rules
20:32:50 <mkuhn> I had a patch on my trousers, when I was a boy
20:32:51 <tcohen> gmcharlt would know
20:32:56 <cait> #endvote
20:32:56 <huginn> Voted on "Do you elect all the candidates for the roles they signed up for in the Koha 21.05 release team as noted on the wiki?" Results are
20:32:56 <huginn> yes (13): Joubu, davidnind, cait, josef_moravec, oleonard, ashimema, tuxayo, henryb, marie-luce, tcohen, mkuhn, caroline, aleisha
20:33:04 <cait> great, we got a release team!
20:33:09 <cait> confetti!
20:33:09 <wahanui> o/`'`'`'`'`'`'`'`'`'`'`'`
20:33:15 <tcohen> confetti!
20:33:15 <wahanui> o/`'`'`'`'`'`'`'`'`'`'`'`
20:33:15 <ashimema> I wasn't aware of that rule.. as it stands I don't feel 'vote rigging' is a problem here.. if it ever became one I'm sure we have tools should we need them.
20:33:22 <cait> good bot
20:33:24 <gmcharlt> tcohen: that there was such a rule?
20:33:24 <tuxayo> cait: you beat me to be it :P
20:33:28 <gmcharlt> not that I recall
20:33:41 <tcohen> better :-D
20:33:49 <tcohen> I know you know all the things
20:34:03 <gmcharlt> I know that I do not. :)
20:34:06 <gmcharlt> but thank you
20:34:14 <cait> release_team_21_05++
20:34:15 * Joubu wonders why he dreams such things...
20:34:17 <cait> gmcharlt++
20:34:23 <ashimema> :)
20:34:38 <cait> Joubu: you want a vote per one of your patches? :)
20:34:59 <cait> maybe we should draft a rule for repetitive Release Manager terms or so
20:35:00 <Joubu> 1 for all would be enough
20:35:01 <cait> no more than ... 3
20:35:07 <mkuhn> That would be the Koha form of a meritocracy
20:35:10 <tcohen> gmcharlt++ # socrates quote
20:35:11 <cait> in a row
20:35:31 <Joubu> I approve that rule
20:35:38 <cait> but just to keep people from going ... well...
20:35:39 <mkuhn> Sure you do :)
20:35:40 <caroline> it's hard enough to get rms and rmaints
20:35:57 <cait> ok, checking agenda
20:36:01 <ashimema> It comes to my attention we're not great at announcing the new team.. anyone object to me sending a mail to the lists with an announcement of the new team, when they take over and a little advertising to see if anyone might like to shadow a tam member this coming cycle with a mind to possibly signing up for 21.11?
20:36:23 <mkuhn> The team will be announced in the next newsletter :)
20:36:25 <cait> +1
20:36:25 <davidnind> ashimema++
20:36:28 <henryb> +1
20:36:28 <tuxayo> ashimema++
20:36:30 <tcohen> +1
20:36:31 <aleisha> +1
20:36:34 <cait> i think all advertising is good
20:36:39 <tuxayo> yep
20:36:43 <cait> would you all be ok with adding the countries too?
20:36:50 <cait> i think it's a great picture for our international community
20:36:59 <aleisha> i agree
20:36:59 <Joubu> (I don't know how someone could survive of being 3 times RM in a row)
20:37:10 <tcohen> I liked catalyst style / aesthetic for Kohacon
20:37:12 <ashimema> +1
20:37:28 <tcohen> (for branding the announcement)
20:37:38 <mkuhn> (that's why you can only get 3 votes, maximally)
20:37:40 <tuxayo> > survive of being 3 times RM in a row
20:37:40 <tuxayo> The rule of no more than 3 is already in the human body :P
20:37:42 <cait> before we end tonight... I suggest adding something about bidding for kohacon21 to the next meeting agenda
20:37:54 <ashimema> +1 cait
20:38:03 <cait> we are late because of COVID, but i think we should start thinking about something?
20:38:09 <tuxayo> +1
20:38:12 <cait> hybrid again like this time might be ideal
20:38:26 <cait> #action cait to add KohaCon21 as topic to next meeting's agenda
20:38:37 <caroline> depends... in some places you can't have large atherings
20:38:48 <ashimema> remind me.. what continents are in the running for 2021?
20:38:50 <caroline> so it would be virtual only
20:38:56 <cait> it's true, so maybe all virtual shoudl be allowed to as proposals this time
20:39:02 <cait> :)
20:39:19 <tuxayo> ashimema: All maybe? Because of the anniversary rule?
20:39:20 <cait> not oceania and not europe i thnk
20:39:44 <tcohen> Cordoba!
20:39:46 <tcohen> hehe
20:39:47 <oleonard> So it's decided. Everyone head to tcohen's house
20:39:52 <tuxayo> :D
20:39:52 <cait> heh
20:39:54 <tcohen> Exactly
20:39:57 <ashimema> yeay..
20:39:58 <cait> the food was great
20:40:11 <ashimema> tcohens house for kohacon21.. done
20:40:14 <cait> ok, so now you can think about it and we can make a plan next time
20:40:31 <cait> oh i think i need to #info
20:40:53 <cait> #agreed The 21.05 Release team was elected (yes (13): Joubu, davidnind, cait, josef_moravec, oleonard, ashimema, tuxayo, henryb, marie-luce, tcohen, mkuhn, caroline, aleisha)
20:41:08 <cait> #topic Actions from last meeting
20:41:16 <cait> #info there are no actions from last meeting
20:41:26 <cait> so... what's the time for next general?
20:41:35 <cait> December 2 ok?
20:41:56 <ashimema> sounds good to me
20:41:59 <marie-luce> +1
20:42:03 <Joubu> 15 UTC was good today
20:42:15 <davidnind> +1
20:42:28 <Joubu> #info Next meeting: 2 December 2020, 14 UTC
20:42:29 <cait> so stick with it?
20:42:30 <tuxayo> Risk of collision with dev meeting?
20:42:31 <cait> oh
20:42:32 <cait> i just typed it
20:42:46 <cait> #endmeeting