14:32:25 <caroline_catlady> #startmeeting Cookbook meeting 12 march 2021
14:32:25 <huginn> Meeting started Fri Mar 12 14:32:25 2021 UTC.  The chair is caroline_catlady. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:25 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:32:25 <huginn> The meeting name has been set to 'cookbook_meeting_12_march_2021'
14:32:33 <caroline_catlady> i'm so hopeless at this...
14:32:53 <caroline_catlady> #topic Introductions
14:33:05 <cait> #info Katrin Fischer, BSZ, Germany
14:33:12 <caroline_catlady> #link agenda https://wiki.koha-community.org/wiki/Cookbook_meeting_12_march_2021
14:33:21 <ashimema> #info Martin Renvoize, PTFS Europe
14:33:22 <Joubu> #info Jonathan Druart
14:33:28 <caroline_catlady> #info Caroline Cyr La Rose, inLibro
14:33:43 <caroline_catlady> magnuse was around earlier
14:35:07 <caroline_catlady> #link last meeting https://meetings.koha-community.org/2021/cookbook_working_group.2021-01-15-14.33.log.html
14:35:25 <caroline_catlady> #topic  Review of action point
14:35:44 <caroline_catlady> caroline will create a template using restructuredtext for the contributions
14:35:52 <caroline_catlady> done, see https://gitlab.com/koha-community/koha-cookbook/-/blob/master/recipetemplate.rst
14:36:09 <caroline_catlady> #info recipe template is available on gitlab
14:36:23 <caroline_catlady> #link https://gitlab.com/koha-community/koha-cookbook/-/blob/master/recipetemplate.rst
14:36:34 <cait> caroline_catlady++
14:36:53 <caroline_catlady> I'm just going to run through the actions points, and then we can discuss in the next part
14:37:01 <caroline_catlady> Joubu or ashimema will set up the git repository and the sphinx part
14:37:10 <caroline_catlady> done, see https://gitlab.com/koha-community/koha-cookbook
14:37:27 <Joubu> we could have a "tags" section
14:37:27 <caroline_catlady> #info gitlab project is set up like the manual
14:37:44 <caroline_catlady> #link https://gitlab.com/koha-community/koha-cookbook
14:37:52 <caroline_catlady> Joubu will create the email address kohacookbook@protonmail.com
14:37:58 <caroline_catlady> done -- it is with an underscore koha_cookbook
14:38:16 <caroline_catlady> #info koha_cookbook@protonmail.com is ready
14:38:27 <cait> Maybe we should put it in the readme if it's not yet
14:38:52 <caroline_catlady> which part? the email adress?
14:39:00 <cait> yep sorry, maybe later
14:39:17 <caroline_catlady> no but it's a good idean, I hadn't thought about it
14:39:21 <caroline_catlady> #topic  Project update
14:39:32 <caroline_catlady> Git is set up
14:39:37 <caroline_catlady> Recipe template is ready for comments -- comments? suggestions?
14:39:57 <caroline_catlady> ok so a tags section at the bottom?
14:40:07 <caroline_catlady> https://gitlab.com/koha-community/koha-cookbook/-/blob/master/recipetemplate.rst
14:40:32 <Joubu> yes I think it would be nice to have a tags section
14:40:37 <cait> how will the tags work?
14:40:56 <cait> we were thinking about a printed book too
14:40:59 <caroline_catlady> I think we can create an index
14:41:09 <Joubu> if would be for the html version ofc
14:41:28 <cait> i like the idea of an index coming from it too
14:42:03 <ashimema> The template may well support it.. it is designed for print as well as html
14:43:32 <caroline_catlady> I'll look into how to create an index with rst
14:43:38 <cait> should/could we action that somehow or idea it?
14:44:07 <caroline_catlady> #action caroline will search how to create an index in ReStructuredText
14:44:29 <caroline_catlady> #action modify the template to add tags/index terms at the end
14:45:26 <cait> move on to the email question?
14:45:35 <caroline_catlady> yup
14:45:42 <cait> I was suggetiont to put a contact section in the Readme
14:46:01 <cait> telling people they can email if they have questions or want to submit a recipe but are not able to do a pull request
14:46:07 <caroline_catlady> I created a wiki page with all the info https://wiki.koha-community.org/wiki/Koha_cookbook
14:46:16 <cait> which brings up the question... who has access to the email account? :)
14:46:20 <caroline_catlady> maybe we could recopy most of this in the readme?
14:46:30 <caroline_catlady> me and Joubu
14:46:46 <caroline_catlady> I think we could all have access, would you want to?
14:47:03 <cait> or just link to the wiki page
14:47:06 <cait> no need to double up
14:47:08 <Joubu> [off] password is "koha"
14:47:29 <cait> btw great page!
14:47:45 <caroline_catlady> [off] did you change it? you gave me a super complicated one
14:47:50 <cait> hehe
14:47:58 <cait> better not to use off i think
14:47:58 <Joubu> [off] sorry, Friday afternoon.. silly jokes :D
14:48:02 <cait> not sure the meetingbot supports it
14:48:20 <caroline_catlady> ok phew lol!
14:48:34 <cait> just need to make sure someone checks it regularly and maybe distructes incoming work from there
14:48:37 <ashimema> lol
14:49:01 <caroline_catlady> anyway, I can share it with yall if you want
14:49:22 <caroline_catlady> I wanted to link it to my Thunderbird... would that prevent someone else from doing the same?
14:49:30 <caroline_catlady> I didn't want to break it
14:51:01 <cait> distributes...
14:51:15 <cait> i think if you use imap it's probably not an issue how many access it
14:51:20 <caroline_catlady> feel free to modify the wiki page too
14:51:32 <caroline_catlady> it's a first draft
14:51:55 <cait> it all looks great :)
14:52:15 <caroline_catlady> I also added a first recipe to test the process
14:52:16 <caroline_catlady> https://gitlab.com/koha-community/koha-cookbook/-/blob/master/source/poudingchomeur.rst
14:52:46 <caroline_catlady> This is what it looks like once it's rendered https://koha-community.gitlab.io/koha-cookbook/poudingchomeur.html
14:53:25 <caroline_catlady> (it's really hard to take a good picture of a delicious brown blob)
14:53:33 <cait> how prett
14:53:33 <cait> y
14:54:02 <cait> shoudl we add categories right away or sort them a bit once we have more later?
14:54:21 <caroline_catlady> I thought we'd sort them as they come in
14:54:31 <caroline_catlady> and maybe rework the categories if needed
14:54:34 <cait> ok
14:54:46 <cait> was just wondering because of the side navigation, but I see that it's in desserts on the front page
14:55:45 <caroline_catlady> We'll see when we get more how it looks
14:55:55 <caroline_catlady> maybe the side navigation only show the current category?
14:56:29 <ashimema> the right side 'Content' shows the headings from the page your on..
14:56:33 <caroline_catlady> it still has to be tweaked, but the structure is there
14:56:58 <ashimema> the left side would show an index.. except I think we didn't split it right somewhere.
14:57:29 <caroline_catlady> when I was trying to render it on my computer, it kept asking me for a contents.rst page
14:57:39 <caroline_catlady> but the contents page is called index.rst
14:57:47 <caroline_catlady> I was a bit confused
14:58:17 <cait> i think i can be solved - I really didn't mean to criticize, you got so far already
14:58:50 <caroline_catlady> no worries :)
14:59:11 <ashimema> :)
14:59:40 <caroline_catlady> There's also the title on the left side "Koha Cookbook documentation"
14:59:58 <caroline_catlady> I haven't searched how to remove the documentation part
15:00:58 <caroline_catlady> any other comments, suggestions?
15:01:34 <Joubu> It looks nice, we should add a couple more for testing
15:02:10 <ashimema> ok.. we need a toc.yml file for the left side stuff
15:02:35 <caroline_catlady> do you want to contribute your recipes first to test, or we ask the larger community for submissions?
15:03:18 <caroline_catlady> which brings us to the next topic
15:03:25 <caroline_catlady> #topic  Next steps
15:03:40 <cait> I think getting the word out now would not hurt
15:03:59 <caroline_catlady> so I thought the next step might be to send an email to the ML to request submissions
15:04:06 <cait> +1
15:04:13 <caroline_catlady> but if you want to test more, it's ok too
15:04:39 <ashimema> +1
15:04:45 <Joubu> I would ask before here, in order to get 6-10 recipes
15:04:47 <caroline_catlady> could we at least have one test contribution to test the steps on the wiki?
15:04:51 <Joubu> to provide examples
15:05:15 <caroline_catlady> https://wiki.koha-community.org/wiki/Koha_cookbook#Submitting_your_recipe
15:06:52 <caroline_catlady> maybe we can each ask our close colleagues?
15:07:07 <caroline_catlady> I ask at inlibro, ashimema asks at PTFS-E, etc.
15:07:12 <Joubu> yup
15:07:17 <caroline_catlady> that way we can collect a couple more
15:07:21 <ashimema> :)
15:08:22 <caroline_catlady> #action each one of us asks our colleagues for submissions to test the process and have more examples when we ask the community at large
15:08:32 <cait> I can do that
15:08:57 <caroline_catlady> Ok so that will be our mission until the next meeting
15:09:25 <cait> waht timeframe are we thinking of?
15:09:30 <magnuse> #info Magnus Enger, Norway
15:09:44 <magnuse> sorry, got stuck on the phone
15:10:11 <caroline_catlady> I took me two tries to get the measurements correct for my recipe
15:10:34 <caroline_catlady> that was two weeks (because I can't eat two cakes in one week, no matter how much I want to)
15:11:10 <caroline_catlady> and then a bit to fiddle with gitlab, etc.
15:11:25 <caroline_catlady> would two months again be too long?
15:11:51 <caroline_catlady> it would bring us in may
15:12:21 <Joubu> 1 month! :)
15:13:15 <caroline_catlady> ok so we plan to have the submissions by mid-appril
15:13:15 <cait> we'll try 1 month and extend if necessary or change plan?
15:13:51 <caroline_catlady> #info have preliminary submissions by mid-april
15:14:15 <magnuse> sounds good
15:14:22 <caroline_catlady> #info we postpone the request on the mailing list
15:14:33 <caroline_catlady> #topic Misc
15:14:57 <caroline_catlady> I added a "misc" topic in case someone wanted to talk about something that wasn't already in the agenda
15:16:28 <caroline_catlady> if not, I'll just move on to setting the time of next meeting
15:16:37 <magnuse> everything looks very promising so far - looking forward to seeing it with a few more examples
15:16:40 <cait> caroline_catlady++ ashimema++
15:16:48 <Joubu> I'm hungry now
15:16:54 <cait> I want that cake...
15:17:07 <caroline_catlady> feel free to test it :)
15:17:09 * magnuse too, am going to make pizza once we are done here
15:17:13 <cait> but made by caroline_catlady
15:17:24 <ashimema> me too
15:17:33 <cait> pizza or cake?
15:17:36 <Joubu> second submission is from you then, magnuse!
15:17:37 * ashimema goes to grab a slice of black bannana cake
15:18:10 <caroline_catlady> #topic Set time of next meeting
15:18:12 <magnuse> @quote add <caroline_catlady> it's really hard to take a good picture of a delicious brown blob
15:18:12 <huginn> magnuse: Error: You must be registered to use this command. If you are already registered, you must either identify (using the identify command) or add a hostmask matching your current hostmask (using the "hostmask add" command).
15:18:27 <cait> lol
15:18:33 <magnuse> @quote add <caroline_catlady> it's really hard to take a good picture of a delicious brown blob
15:18:33 <huginn> magnuse: The operation succeeded.  Quote #350 added.
15:18:45 <cait> magnuse is our quotes maintainer, that shoul be a release team role
15:18:46 * caroline_catlady faceplam
15:18:50 <magnuse> Joubu: if noone beats me to it!
15:18:54 <cait> as he seems to be the only one to remember his password for huginn :)
15:19:06 <magnuse> hehe
15:19:13 <cait> in a month on a friday?
15:19:21 <cait> that works well for me as i am not counting his as work time :)
15:19:50 <caroline_catlady> april 16?
15:19:51 <magnuse> april 9th?
15:20:19 <cait> shoudl both work for me
15:20:23 <magnuse> me too
15:20:25 <caroline_catlady> I thought 16 since we said we wanted the submissions by mid-april
15:20:32 <cait> yep
15:20:33 <cait> makes sense
15:20:37 <magnuse> yup
15:21:08 <caroline_catlady> #info Next meeting: 16 April 2021, 14:30 UTC
15:21:14 <caroline_catlady> #endmeeting