14:33:55 <caroline_crazycatlady> #startmeeting Cookbook Working Group
14:33:55 <huginn> Meeting started Fri Jan 15 14:33:55 2021 UTC.  The chair is caroline_crazycatlady. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:33:55 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:33:55 <huginn> The meeting name has been set to 'cookbook_working_group'
14:34:02 <caroline_crazycatlady> #topic Introductions
14:34:13 <caroline_crazycatlady> use #info for intorductions
14:34:23 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:34:34 <caroline_crazycatlady> #info Caroline Cyr La Rose, inLibro, Quebec, Canada
14:34:46 <magnuse> #info Magnus Enger, Libriotech, Norway
14:34:49 <cait> #info Katrin Fischer, Germany
14:35:03 <magnuse> (probably doing this on my own time, though)
14:35:09 <ashimema> #info Martin Renvoize, UK
14:35:30 <ashimema> me too..
14:35:34 <cait> same
14:35:43 <oleonard> Yes, won't someone please think of the shareholders!
14:36:29 <caroline_crazycatlady> lol!
14:36:48 <Joubu> #info Jonathan Druart
14:37:21 <caroline_crazycatlady> Ok, I didn't really prepare an agenda, but I thought of some things -- format, asking for contributions, measurements (:P)
14:37:23 <magnuse> international globetrotter ;-)
14:37:41 <magnuse> https://wiki.koha-community.org/wiki/Koha_cookbook_RFC
14:38:15 <magnuse> format can be both input and output, i guess
14:38:19 <caroline_crazycatlady> We can start with the format
14:38:33 <caroline_crazycatlady> on the RFC, it says PDF and or epub
14:38:43 <cait> i think an html version could be nice too
14:38:45 <caroline_crazycatlady> how do we add contributions?
14:39:28 <caroline_crazycatlady> I'll edit the wiki page as we discuss
14:39:49 <magnuse> i am thinkgin a git repo that can maybe accept pull requests, but at least the working group members should be able to add commits
14:39:50 <caroline_crazycatlady> epub might be a bit big
14:40:01 <magnuse> big?
14:40:12 <caroline_crazycatlady> to host
14:40:17 <cait> caroline_crazycatlady: it#s easy if we use the same tools we have for the manual
14:40:42 <magnuse> i had not thought of the tools for the manual, but that does sound like a good idea
14:41:03 <ashimema> epub is not bad.. it was the translations that made things big in the manual
14:41:04 * ashimema was wrong to blame epub
14:41:14 <caroline_crazycatlady> so we want to use Restructured text for formatting and sphinx for output?
14:41:26 <cait> it's an option that would make it quite easy to generate theother things...
14:41:28 <caroline_crazycatlady> ok, good to know
14:41:30 <cait> but there might be other options too
14:41:40 <caroline_crazycatlady> but we still have to find somewhere to host it
14:42:00 <Joubu> what do you need to host?
14:42:11 <cait> we could put it on gitlab maybe? or the gitea
14:42:15 <Joubu> only the output?
14:42:28 <magnuse> gitea = https://git.koha-community.org/ ?
14:42:32 <cait> yes
14:42:43 <caroline_crazycatlady> I think so, since the input will be on gitlab
14:42:48 <magnuse> don't we need to host the source too?
14:42:49 <caroline_crazycatlady> or gitea
14:42:55 <magnuse> ah
14:43:18 <Joubu> I'd consider it the same as other side-projects, use gitlab and its workflow
14:43:40 <magnuse> sounds good to me
14:43:41 <Joubu> I think we can rely on gitlab to host the output as well. If too big I can host the pdf/epub
14:43:51 <caroline_crazycatlady> ok
14:43:57 * oleonard wonders if we need a recipe copyright expert's advice
14:43:58 <cait> +1
14:44:05 <magnuse> yeah, we have plenty of space/bandwith too
14:44:23 <caroline_crazycatlady> #agreed use gitlab and its workflow
14:44:39 <caroline_crazycatlady> #agreed host the output on gitlab as well
14:45:06 <caroline_crazycatlady> there was also a print-on-demand option
14:45:10 <caroline_crazycatlady> in the wiki
14:45:17 <cait> i like the information/layout the wiki suggests, can we make this work with docbook in a structured way?
14:45:17 <caroline_crazycatlady> https://www.blurb.com/bookstore
14:45:24 <magnuse> yeah, i want a physical book :-)
14:45:28 <caroline_crazycatlady> same!
14:45:33 <cait> :)
14:45:56 <cait> sorry, we ar not using docbook... sphinx... thing
14:46:18 <cait> might be good to create a template one can follow
14:46:24 <magnuse> i yup
14:46:50 <magnuse> awesome if people familiar with the manual could suggest a temaplte
14:47:26 <magnuse> but should we say all submissions must use the template? or accept anything and convert to the template ourselves?
14:47:27 <cait> i am not sure we have many super familiar with the technical bits and ther might be things we don't really use yet?
14:47:41 <cait> i think we shoudl accept submissions outside of gitlab too
14:47:46 <oleonard> Agreed
14:47:53 <caroline_crazycatlady> yes bc not everyone is confortable with git
14:47:53 <cait> i'd be willing to help reformat, once we know how we do it
14:48:04 <cait> can you make that an agreed plz?
14:48:05 <Joubu> we could have a template wiki page
14:48:22 <magnuse> keep it simple s**** ;-)
14:48:23 <cait> even the wiki is a bit of a hurdle
14:48:31 <caroline_crazycatlady> #agreed we accept contributions outside of gitlab
14:48:41 <cait> maybe also have an email acceptance?
14:48:52 <magnuse> but how? set up an email somewhere?
14:49:02 <cait> hm list is bad because it eats the attachements
14:49:07 <caroline_crazycatlady> kohacookbook@gmail?
14:49:12 <cait> gmail???
14:49:16 <cait> sorry :)
14:49:18 <magnuse> i think gmail or similar makes sense
14:49:25 <cait> paranoid German
14:49:29 <caroline_crazycatlady> I don't really know other ones, sorry!
14:49:29 <magnuse> hehe
14:50:08 <cait> Joubu: you have a kc address... is that an option in general?
14:50:33 <Joubu> we can use it, yes
14:50:49 <Joubu> ha
14:51:01 <Joubu> sorry, you mean the bugs.k-c.org address?
14:51:05 <Joubu> it's not k-c.org
14:51:20 <Joubu> not sure it makes sense to have bugs.k-c.org
14:51:32 <cait> ah ok, yep no then
14:51:38 <caroline_crazycatlady> cookbook@k-c.org?
14:51:43 <Joubu> no
14:51:46 <caroline_crazycatlady> ok
14:51:46 <Joubu> not possible
14:51:52 <Joubu> (there is no mail server)
14:51:57 <magnuse> cait: what are you actually paranoid about? it's not for sensitive info? :-)
14:52:02 <Joubu> use koha_cookbook@protonmail.com
14:52:07 <Joubu> and we will create it
14:52:40 <cait> magnuse: it reads emails for advertising... i think that's creepy?
14:52:46 <cait> but offtopic here :)
14:53:03 <cait> no idea waht protonmail is, but Joubu is usually right
14:53:09 <caroline_crazycatlady> so cookbook@protonmail.com is good?
14:53:28 <Joubu> koha is missing :)
14:53:38 <caroline_crazycatlady> #agreed use kohacookbook@protonmail.com to send recipes to the editors
14:54:25 <cait> i like it all in one word
14:54:36 <magnuse> is that webmail where we can log in and work in the queue? or would it just pass email along to everyone in the committe?
14:56:28 <caroline_crazycatlady> #action caroline will create a template using restructuredtext for the contributions
14:56:58 <magnuse> it would be practical if we had one webmail to log into where we could see which submissions had already been handled
14:57:02 <caroline_crazycatlady> Joubu or ashimema : can you set up the git repository and the sphinx part?
14:57:17 <Joubu> yes, action us
14:57:56 <caroline_crazycatlady> #Joubu or ashimema will set up the git repository and the sphinx part
14:58:39 <caroline_crazycatlady> #Joubu will create the email address kohacookbook@protonmail.com
14:58:47 <caroline_crazycatlady> #action Joubu will create the email address kohacookbook@protonmail.com
14:59:08 <ashimema> :)
14:59:18 <Joubu> (I've create koha_cookbook already and sent you the credentials)
14:59:24 <Joubu> can recreate without _ if needed
14:59:31 <Joubu> create*d*
14:59:32 <caroline_crazycatlady> can you set it up so that we can access it via web and/or set it up so that it sends us all emails?
14:59:51 <caroline_crazycatlady> oops, sorry, I didn't see!
15:00:02 <caroline_crazycatlady> do we prefer koha_cookbook or kohacookbook?
15:00:07 <caroline_crazycatlady> I don't have a preference
15:00:21 <magnuse> me neither
15:00:31 <Joubu> I prefer with _
15:00:32 <Joubu> :D
15:00:32 <cait> not a strong one
15:00:42 <caroline_crazycatlady> ok so lets keep it that way
15:01:01 <caroline_crazycatlady> #info email is koha_cookbook@protonmail.com
15:01:01 <magnuse> (off topic: who can add 2021 on https://meetings.koha-community.org/ ?)
15:01:12 <caroline_crazycatlady> I'll do it
15:01:16 <caroline_crazycatlady> I was already in there
15:01:24 <Joubu> (magnuse: I've asked gmcharlt already)
15:01:26 <cait> gmcharlt
15:01:26 <wahanui> i think gmcharlt is usually lurking much earlier.. hense ashimema's pointing him out
15:01:42 <magnuse> (cool!)
15:02:04 <caroline_crazycatlady> ok if it's something complicated i'll l et them deal with it lol!
15:02:29 <cait> i think you probably need to change the html template, not complicated but requires access
15:02:59 <caroline_crazycatlady> 2020 stopped in June so I though it was a manual thing
15:03:26 <caroline_crazycatlady> ok back to cookbook
15:03:49 * oleonard wishes 2020 had stopped in June
15:03:55 <magnuse> lulz
15:04:05 <cait> more .. February
15:04:23 <cait> do we agree on the general information to collect as stated on the wiki?
15:04:27 <cait> the layout section?
15:04:32 <caroline_crazycatlady> does anyone have comments on the elements of the contribution (name of dish, short description, estc
15:04:45 <caroline_crazycatlady> https://wiki.koha-community.org/wiki/Koha_cookbook_RFC#Contributions
15:05:18 <magnuse> i was thinking, if we accept more than one receipe per person, it might make sense to collect the info about the people in one place
15:05:25 <caroline_crazycatlady> we had already discussed we wanted measurements in metric, so g for weight and ml for volume?
15:05:32 <magnuse> and link bwtween them
15:05:35 <oleonard> For completeness I would add "List of ingredients" to that list above "how to make the dish"
15:05:42 <cait> i thin it's there
15:05:53 <cait> The receipe  List of ingredients and quantities
15:06:00 <caroline_crazycatlady> yes under "The recipe"
15:06:27 <cait> ah it's in contributions
15:06:29 <cait> but missing in layout
15:06:32 <caroline_crazycatlady> Do we want more than one contribution per person or just one?
15:06:33 <oleonard> Right
15:06:54 <cait> hm i think it depends on how many we get
15:06:57 <cait> maybe?
15:06:59 <caroline_crazycatlady> Ok I added it to the "Layout part"
15:07:57 <magnuse> yeah, hard to tell if we will get lots of people contributing or not
15:08:17 <caroline_crazycatlady> circling back to oleonard's copyright comment we have to specify to people that this has to be an original recipe, or at least sufficiently modified from an existing one
15:08:25 <magnuse> yup
15:08:44 <cait> are recipes (simple ones) copyrighted?
15:08:53 <cait> a lot of cake recipes are very basic
15:08:53 <caroline_crazycatlady> if they are published, yes
15:09:05 <cait> waht about things like "pancake batter"
15:09:13 <oleonard> The US perspective: https://www.copyright.gov/help/faq/faq-protect.html#recipe
15:09:14 <cait> i mean a local recipe might be so general, it's hard to tell
15:09:26 <cait> something that is very common in a country
15:09:52 <cait> A mere listing of ingredients is not protected under copyright law. <
15:09:59 <cait> ok, so you have to make sure to write your own text?
15:10:02 <caroline_crazycatlady> If it's common, I wouldn't be worried about it
15:10:27 <cait> #link https://www.copyright.gov/help/faq/faq-protect.html#recipe
15:11:00 <cait> any suggestions on wording?
15:11:04 <caroline_crazycatlady> #agreed  specify to people that this has to be an original recipe, or at least sufficiently modified from an existing one
15:11:12 <cait> +1
15:11:33 * ashimema requests a beer recipe or two from Joubu ;)
15:12:08 <caroline_crazycatlady> Oh yeah, that makes me think, do we wait for contributions to see how we want to organized them?
15:12:23 <oleonard> I think that makes sense
15:12:25 <cait> ah categories
15:12:27 <magnuse> me too
15:12:29 <cait> i think that makes snse too
15:12:30 <caroline_crazycatlady> meaning in chapters, like desserts (first of course), main courses, drinks, etc
15:12:38 <cait> but we could state that all is good? cocktails to desserts? :)
15:12:41 <cait> and beer
15:12:47 <magnuse> sure
15:13:10 <caroline_crazycatlady> #agreed contributions of all sorts of recipes are welcome
15:13:40 <cait> do we really need to ahve beer? *hides*
15:14:02 <magnuse> a separate book for beer receipies? ;-)
15:14:10 <cait> maybe somethign for another volume
15:14:26 <magnuse> i wouldn't mind a few
15:14:27 <oleonard> cait no one will make you try the recipe
15:14:35 <magnuse> hehe
15:14:42 <marie-luce> favourite beer from different country
15:15:01 <cait> was just joking :)
15:15:03 <ashimema> hehe
15:15:15 <marie-luce> me too :)
15:15:24 <marie-luce> really exciting your project
15:16:01 <caroline_crazycatlady> The final point in the RFC is license
15:16:06 <magnuse> related to the question of copyrught is the license of the compilation we are making
15:16:18 <magnuse> jinx! ;-)
15:16:32 <cait> just got a cake delivery, back in a moment
15:16:51 <magnuse> :-O
15:16:59 <oleonard> :D
15:17:17 <oleonard> Hey you're not allowed to interrupt food meetings for food!!
15:17:18 <magnuse> i think it should be as open as possible, allow for remixing etc
15:17:23 <caroline_crazycatlady> CC0? CC BY?
15:17:28 <caroline_crazycatlady> https://creativecommons.org/about/cclicenses/
15:18:09 <caroline_crazycatlady> Non-commercial?
15:19:09 <caroline_crazycatlady> Since we are an open-source community, I would go with CC0
15:19:09 <oleonard> I would be fine with CC0
15:19:10 <magnuse> tricky
15:19:37 <magnuse> CC0 is public domain?
15:19:49 <caroline_crazycatlady> yes
15:20:01 <magnuse> i'm fine with that
15:20:30 <caroline_crazycatlady> anyone has an objection to CC0?
15:20:54 <caroline_crazycatlady> #agreed license will be CC0
15:21:01 <magnuse> cool!
15:21:05 <caroline_crazycatlady> #link https://creativecommons.org/publicdomain/zero/1.0/https://creativecommons.org/publicdomain/zero/1.0/
15:21:11 <caroline_crazycatlady> oops
15:21:14 <caroline_crazycatlady> #link https://creativecommons.org/publicdomain/zero/1.0/
15:21:40 <magnuse> CC0 x2 = CC0
15:21:53 <caroline_crazycatlady> (I shake a lot)
15:22:16 <caroline_crazycatlady> (It's a wonder I can actually knit)
15:22:54 <caroline_crazycatlady> Ok so, to summarize
15:23:10 <caroline_crazycatlady> We will send a request for contributions
15:23:30 <caroline_crazycatlady> specifying the format, elements needed, copyright and licese information
15:24:05 <caroline_crazycatlady> Gitlab will be set up
15:24:19 <caroline_crazycatlady> and I think that's all we have to do until next mmeting
15:24:26 <caroline_crazycatlady> am i forgetting something?
15:24:42 <magnuse> setting up the template?
15:24:46 <Joubu> even the picture of the contributosr?
15:25:12 <caroline_crazycatlady> good point
15:25:42 <magnuse> do we want pics of contributors?
15:25:59 <Joubu> yes it's the list
15:26:04 <caroline_crazycatlady> https://wiki.koha-community.org/wiki/Koha_cookbook_RFC#Contributions
15:26:08 <oleonard> I don't think we need it, personally
15:26:09 <Joubu> yes it's *in* the list
15:26:42 <caroline_crazycatlady> Me either
15:26:50 * caroline_crazycatlady doesn't like having her picture taken
15:27:43 <caroline_crazycatlady> anyone have strong feeling regarding pictures?
15:27:52 <magnuse> i put it in the list, but i'm fine with leaving it out
15:28:13 <caroline_crazycatlady> Can we put exceptions in a license?
15:28:40 <magnuse> best not to?
15:28:59 <caroline_crazycatlady> ok so we leave pictures of people out
15:29:14 <caroline_crazycatlady> but we want pictures of the dish
15:29:53 <caroline_crazycatlady> Next meeting?
15:29:53 <wahanui> i guess Next meeting is https://wiki.koha-community.org/wiki/Next_IRC_meetings
15:29:57 <magnuse> i want to see pics, yes. but they could be optional?
15:30:15 <magnuse> did we decide on more than one receipe per contributor?
15:30:34 <oleonard> We postponed the decision
15:30:40 <caroline_crazycatlady> No, we decided to wait and see what we receive
15:31:01 <magnuse> ok, so if we get a flood we can say "one per person"?
15:31:06 <magnuse> sounds good to me
15:31:43 <caroline_crazycatlady> Do we give it two months?
15:32:04 <caroline_crazycatlady> Or is that too long?
15:32:27 <magnuse> as the deadline for submissions?
15:32:37 <caroline_crazycatlady> I was thinking next meeting
15:32:46 <caroline_crazycatlady> but good point
15:32:47 <magnuse> ah, sorry, ok
15:33:17 <caroline_crazycatlady> I think we can have a deadline later that that
15:33:38 <caroline_crazycatlady> give time for people to find, test, wirte and take a picture of their recipe
15:33:52 <magnuse> sure
15:34:19 <caroline_crazycatlady> So Friday march 12 same time for next meeting?
15:35:02 <magnuse> works for me
15:35:07 <oleonard> +1
15:35:33 <caroline_crazycatlady> #info Next meeting: 12 March 2021, 14:30 UTC
15:35:38 <caroline_crazycatlady> #endmeeting