#koha: Development IRC meeting 10 February 2021

Meeting started by Joubu at 15:01:04 UTC (full logs).

Meeting summary

  1. Introductions (Joubu, 15:01:09)
    1. Jonathan Druart (Joubu, 15:01:17)
    2. Martin Renvoize, PTFS Europe, UK (ashimema, 15:01:20)
    3. Tomas Cohen Arazi, Theke Solutions (tcohen, 15:01:43)
    4. Thomas Dukleth, Agogme, New York City (thd, 15:02:06)
    5. https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_February_2021 (Joubu, 15:02:47)
    6. tuxayo/Victor Grousset, France (tuxayo, 15:02:54)

  2. Announcements (Joubu, 15:03:17)
    1. Kyle Hall, ByWater Solutions (khall_, 15:03:29)

  3. Update from the Release Manager (21.05) (Joubu, 15:04:11)
    1. be involved on 25078, 27526, 27467 and 27344 (please) (Joubu, 15:07:41)
    2. Katrin Fischer, BSZ, Germany (cait2, 15:07:43)
    3. https://annuel.framapad.org/p/koha_21.05_roadmap (tuxayo, 15:08:47)

  4. Updates from the Release Maintainers (Joubu, 15:18:01)
  5. Updates from the QA team (Joubu, 15:19:12)
    1. Please do QA! (Joubu, 15:20:12)
    2. Fridolin Somers, Biblibre, France (fridolin, 15:21:22)

  6. Status of roadmap projects (Joubu, 15:22:26)
    1. https://annuel.framapad.org/p/koha_21.05_roadmap (Joubu, 15:22:34)

  7. Improve the reliability of transfers (Joubu, 15:22:46)
    1. Joonas has QA'd the Phase One tree :) (ashimema, 15:23:16)
    2. Looking for someone to QA the final bug on that tree which adds a nice 'Transfers to send' report. (ashimema, 15:23:52)
    3. Phase one adds all the methods we need for transfers to the Koha:: namespace, with clear uses and workflows for each (ashimema, 15:24:14)
    4. cait to check the old transfer bugs to give the new work some serious testing once pushed (cait2, 15:24:30)
    5. Phase two will remove the last remaining cases where the C4 methods are used and drop those methods. (ashimema, 15:24:38)

  8. Performance investigation (Joubu, 15:25:03)
    1. First major identification lead to the backgrounding of the ES indexer bug.. work ongoing :) (ashimema, 15:25:50)

  9. Git repository shrinking (Joubu, 15:26:51)
  10. Release tools improvements (Joubu, 15:27:48)
  11. Backup splitter on a separate server (Joubu, 15:28:11)
    1. https://splitter2.koha-community.org (Joubu, 15:28:25)
    2. Splitter backup is now available at https://splitter2.koha-community.org (ashimema, 15:28:42)
    3. https://splitter2.koha-community.org (cait2, 15:28:56)

  12. Improve our "news" module (Joubu, 15:30:10)
    1. we discussed the different uses cases and probably a new naming scheme for the future, but moving forward with the move to the Koha namespace first (cait2, 15:30:59)

  13. Fix OPACHiddenItems [Bug 24403] (Joubu, 15:33:03)
  14. Handling of errors 500 (Joubu, 15:34:03)
  15. Developer handbook and documentation (Joubu, 15:35:32)
  16. Automated updates for translated manuals (Joubu, 15:44:09)
  17. Koha Cookbook Project  (Joubu, 15:50:04)
  18. Replace CGI scripts with Mojolicious controllers (Joubu, 15:50:58)
  19. Write Protecting fields in Koha from being overwritten through import (Joubu, 15:51:20)
  20. Actions from last meeting (Joubu, 15:53:43)
    1. ACTION: amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc. (Joubu, 15:54:00)

  21. Review of coding guidelines (Joubu, 15:54:45)
  22. Set time of next meeting (Joubu, 15:56:22)
    1. Next meeting: 24 February 2021, 20 UTC (Joubu, 15:56:40)


Meeting ended at 15:57:11 UTC (full logs).

Action items

  1. amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.


People present (lines said)

  1. Joubu (154)
  2. ashimema (99)
  3. cait2 (76)
  4. huginn (16)
  5. caroline (8)
  6. wahanui (7)
  7. tuxayo (5)
  8. tcohen (4)
  9. thd (3)
  10. fridolin (2)
  11. khall_ (1)
  12. kidclamp (1)


Generated by MeetBot 0.1.4.