14:59:49 <Joubu> #startmeeting Development IRC meeting 10 March 2021
14:59:49 <huginn> Meeting started Wed Mar 10 14:59:49 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:49 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:49 <huginn> The meeting name has been set to 'development_irc_meeting_10_march_2021'
14:59:53 <Joubu> qa_team?
14:59:53 <wahanui> qa_team is cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
14:59:54 <Joubu> rmaints?
14:59:54 <wahanui> rmaints is fridolin, AndrewFH and tuxayo
15:00:00 <Joubu> #topic Introductions
15:00:07 <Joubu> #info Jonathan Druart
15:00:12 <kidclamp> #info Nick Clemens, ByWater Solutions
15:00:24 <tuxayo> #info tuxayo/Victor Grousset, France
15:00:27 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_10_March_2021
15:00:30 <AndrewFH> #info Andrew Fuerste-Henry, ByWater Solutions
15:01:26 <thd> #info Thomas Dukleth, Agogme, New York City
15:02:29 <Joubu> cait1, tcohen, ashimema?
15:02:34 <fridolin> #info Fridolin, Biblibre, France
15:02:35 <Joubu> #topic Announcements
15:02:39 <Joubu> Anyone have something?
15:02:41 <ashimema> #info Martin Renvoize, PTFS Europe
15:02:59 <Joubu> I have, but will keep them for the 'update from RM' topic
15:03:03 <ashimema> Apologies, juggling two meetings right now
15:03:18 <Joubu> this one is more important, ashimema :D
15:03:36 <ashimema> #info PTFS Europe sandboxes now support installation of German, French, Spanish, Greek and Dutch translations.
15:03:43 <fridolin> ++
15:03:47 <tuxayo> yay!*
15:03:56 <ashimema> will poke bywater to grab the patches for theirs too
15:04:04 <ashimema> no other anouncements I can think of
15:04:14 <Joubu> #topic Update from the Release Manager (21.05)
15:04:26 <Joubu> I will be fast, send "!" if you want me to stop
15:04:54 <Joubu> #info There is now a --run-tests option to the QA script to run the tests modified by the patchset
15:05:03 <Joubu> Some changes on the CI:
15:05:09 <ashimema> Joubu++
15:05:16 <Joubu> #info we now have a new docker_7 node
15:05:39 <tuxayo> QA, CI: nice!
15:05:39 <cait1> #info Katrin Fischer, BSZ, Germany
15:05:53 <Joubu> #info There is a "light test suite" that is run by Jenkins for most of the job (apart from D10) - checkout https://tree.taiga.io/project/koha-ils/task/102 for more info
15:06:10 <Joubu> * Great cleanup on the YAML module, we are now only using YAML::XS everywhere (see bug 27673 and bug 22824).
15:06:10 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27673 enhancement, P5 - low, ---, jonathan.druart, Pushed to master , Replace YAML with YAML::XS
15:06:11 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22824 enhancement, P5 - low, ---, jonathan.druart, Pushed to master , Replace YAML::Syck with YAML::XS
15:06:13 <Joubu> It impacts how boolean sysprefs are read/written as we are getting rid of the (incorrect) ImplicitTyping behaviours.
15:06:22 <Joubu> * Bug 27829
15:06:22 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27829 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Remove specific LANG installer data
15:06:30 <Joubu> There are patches on bug 27621, bug 27623, bug 27624, and bug 27625. But others will need to be removed/adjusted.
15:06:30 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27621 minor, P5 - low, ---, jonathan.druart, Passed QA , Remove it-IT installer data
15:06:31 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27623 minor, P5 - low, ---, jonathan.druart, Signed Off , Remove pl-PL installer data
15:06:32 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27624 minor, P5 - low, ---, jonathan.druart, Signed Off , Remove ru-RU installer data
15:06:33 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27625 minor, P5 - low, ---, jonathan.druart, Needs Signoff , Remove uk-UA installer data
15:06:40 <Joubu> If you are using fr-FR, fr-CA or nb-NO, you should go ahead and help the move to the new system.
15:06:46 <Joubu> A goal would be to have them ALL removed for 21.11
15:06:53 <Joubu> You will certainly do it better than me as it needs mediculous work and good knowledge of the different files (which I don't have).
15:07:00 <tuxayo> !
15:07:04 <Joubu> I will propose to abandon and deprecate the remaining languages for the 21.11 dev cycle (ie. no more changes to specific language files, that may broke the installer).
15:07:14 <tuxayo> > A goal would be to have them ALL
15:07:14 <tuxayo> Are there for all languages?
15:07:18 <ashimema> nice one
15:07:21 <cait1> Joubu: we have known issues with different item config in the UNIMARC setups... so that will be harder. And UNIMARC is not on Pootle yet.
15:07:40 <Joubu> yes, that's part of the 'plan' (which does not exist yet)
15:07:50 <cait1> tuxayo: they can be in the future, but not now. the new system will make it mouch more less technical to add any language we want
15:07:50 <Joubu> we will have to work on the UNIMARC setup
15:07:59 <Joubu> maybe we should pick the one from fr-FR?
15:08:10 <cait1> i have been thinking about that
15:08:19 <tuxayo> So all language need to have those installer files removed?
15:08:21 <cait1> i think we need to keep an eye on the biblionumber link and the item mappings especially
15:08:30 <cait1> it's much less standardized for UNIMARC, but it would be a chance to consolidate
15:08:51 <cait1> tuxayo: yes, we are removing the language specific sql files as a goal
15:09:04 <tuxayo> ok thanks
15:09:14 <cait1> tuxayo: so if you want sample data in your language, you can tanslate them on pootle and they will be generated from yaml files and the po
15:09:26 <cait1> which also means that when adding a new notice you will only have to change the yml file in the future
15:09:30 <Joubu> we will need help from BibLibre for sure, and French users (at least)
15:09:32 <cait1> instead of changing all the installer file
15:09:32 <cait1> s
15:09:38 <Joubu> maybe also ping other UNIMARC users
15:09:44 <ashimema> we need a hackfest
15:09:52 <ashimema> best time to get biblibre onboard ;)
15:09:53 <cait1> toot rue
15:10:03 <Joubu> fridolin: ^
15:10:11 <Joubu> keep that in mind, I will catch you soon ;)
15:10:26 * fridolin i'm cool nothing realy different
15:10:43 <Joubu> fr-FR is a mess :D
15:10:50 <fridolin> ah ouch yep
15:11:01 <fridolin> i'll see with nlegrand
15:11:15 <ashimema> fridolin++
15:11:21 <Joubu> moving on?
15:11:34 <cait1> yes
15:11:35 <Joubu> * bug 25078 - I still wish to see more discussion on that one. Does everybody agree with the last comments between jajm and me?
15:11:35 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25078 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Update DB process - wrap each DBRev inside a transaction and better error handling
15:11:37 <fridolin> ahhh installer ok
15:12:20 <Joubu> then I have update for the roadmap, in a couple of minutes
15:12:29 <ashimema> I agree
15:12:33 <Joubu> #topic Updates from the Release Maintainers
15:12:45 <ashimema> keep this patch small and simple (just transactions and reporting back more nicely)
15:13:06 <ashimema> and move the idea's about splitting it up into files and handling versioning differently into the other bug
15:13:32 <tuxayo> RMaint: nothing in particular to say
15:13:38 <Joubu> ashimema: I will try to split them on that one, to avoid having to deal with the each dbrev twice
15:14:03 <ashimema> brill :)
15:14:23 <ashimema> I'd love ot see the AV translations stuff move forward too.. but not sure how to unstick it.
15:14:24 <Joubu> RMaints, use the move atomic update from bug 27903, it's awesome and easy to use )
15:14:24 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27903 enhancement, P5 - low, ---, jonathan.druart, ASSIGNED , Script to move atomic updates to updatedatabase.pl
15:14:27 <ashimema> sorry.. RMaint updates
15:14:30 <ashimema> RMaints?
15:14:30 <wahanui> RMaints is fridolin, AndrewFH and tuxayo
15:15:03 <AndrewFH> Nothing of import from me, thanks :)
15:15:13 <Joubu> #topic Updates from the QA team
15:15:43 <ashimema> #info More QA needed... always more QA needed :P
15:16:06 <ashimema> cait?
15:16:06 <wahanui> cait is really good at running into things
15:16:13 <Joubu> spread the load!
15:16:24 <ashimema> indeed
15:16:26 <tuxayo> > running into things
15:16:26 <tuxayo> Me too T_T
15:17:19 <Joubu> ok
15:17:34 <Joubu> #info Status of roadmap projects
15:17:44 <Joubu> #link https://annuel.framapad.org/p/koha_21.05_roadmap
15:17:52 <Joubu> same, '!' to stop me
15:17:53 <cait1> spread the load - and please QA :)
15:17:56 <cait1> and don't break stuff!
15:18:04 <cait1> sorry to be late
15:18:05 <Joubu> bug 15278
15:18:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15278 enhancement, P5 - low, ---, kyle, NEW , Port default slips and notices from bespoke syntax to Template Toolkit
15:18:16 <Joubu> Started too late and won't be part of 21.05.
15:18:22 <Joubu> postponed to 21.11
15:18:27 <cait1> will you mark it accordingly?
15:18:28 <Joubu> bug 24975
15:18:28 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24975 enhancement, P5 - low, ---, julian.maurice, In Discussion , Refactor database translations
15:18:35 <Joubu> No real focus on it, won't certainly be ready for 21.05
15:18:38 <Joubu> yes cait1
15:18:47 <Joubu> ashimema: ?
15:19:01 <Joubu> we discussed it (jajm, ashimema and me)
15:19:29 <Joubu> it took too long to start and I'm afraid we won't have time to finish (even start..) for 21.05
15:19:43 <Joubu> we are still disagreeing on how we should implemen tit
15:19:44 <cait1> sad, but i can see that
15:19:56 <cait1> can we give it a prio boost for 21.11?
15:20:02 <Joubu> can try
15:20:12 <ashimema> sorry.. had to talk in my other meeting
15:20:13 <ashimema> reading ujp
15:20:53 <Joubu> * Transfer improvement
15:21:05 <Joubu> bug 22569 has been pushed, the next on the list are bug 27281 and bug 27896
15:21:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22569 new feature, P5 - low, ---, martin.renvoize, Passed QA , Add a 'Transfers to send' report
15:21:06 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27281 enhancement, P5 - low, ---, martin.renvoize, Needs Signoff , Replace call to `C4::Circulation::DeleteTransfer` with `Koha::Item::Transfer->cancel({ comment => $comment })` in `C4::Circulation::LostItem`
15:21:07 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27896 enhancement, P5 - low, ---, martin.renvoize, Needs Signoff , Remove C4::Circulation::DeleteTransfer
15:21:07 <Joubu> it is moving fast
15:21:25 <ashimema> I am working slowly through bits of notices stuff.. but they're not directly related.. more things that i felt need fixing first.
15:21:27 <Joubu> ha 22569 is not pushed actually
15:22:03 <ashimema> yeah.. 33569 is PQA but not pushed yet ;)
15:22:10 <Joubu> will be soon
15:22:14 <cait1> I hope to spend more time with tarnsfers
15:22:26 <cait1> I tried to also work on the checkin checks for branch transfers... but got lost
15:22:33 <ashimema> the other two are the next two.. I don't want to end up with such a big tree of outstanding for phase 2
15:22:34 <cait1> commented and waiting for feedback
15:22:56 <ashimema> so I'll code and submit.. then wait for SO/QA rather than continuing with the next bugs.
15:23:18 <ashimema> where did you comment cait1.. was it aimed at me.. I tihnk I must have missed it
15:23:33 <cait1> ashimema: not on yours, arthur's
15:23:41 <ashimema> :)
15:23:59 <Joubu> * Performance investigation (compare 20.11 and 17.11)
15:24:03 <Joubu> The main work here is bug 27344, which needs more attention as it's an important bit. It would be nice to have another dev involved to get additional points of view.
15:24:03 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27344 enhancement, P5 - low, ---, jonathan.druart, In Discussion , Implement Elastic's update_index_background using Koha::BackgroundJob
15:24:20 <Joubu> * Git repository shrinking
15:24:24 <Joubu> I've started it, but I am stuck. I will send Martin an email soon to discuss it.
15:24:26 <ashimema> Agreed, would be good to get more eyes on performance
15:24:27 <Joubu> Git gurus are welcome to join the party!
15:24:44 <ashimema> I have been meaning to help work on some task queue patches to help that move.. jsut haven't found a moment.
15:24:59 <ashimema> happy to help where I can Joubu
15:25:06 <ashimema> more git guru's would be great
15:25:09 <Joubu> and *when*
15:25:15 <Joubu> * Release tools improvement
15:25:19 <Joubu> Still planned for a bit later in the cycle
15:25:23 <Joubu> * Improve our "news" module
15:25:23 <ashimema> +1
15:25:27 <tcohen> #info Tomas Cohen Arazi, Theke Solutions
15:25:29 <Joubu> Signoff is needed here, please? bug 22544
15:25:29 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=22544 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Move C4:NewsChannels to Koha namespace
15:25:33 <Joubu> This is only the first step and there are interesting changes to implement here, but we need this first step in!
15:26:09 <ashimema> I'll grab it for SO or QA.. anyone here want to volunteer for the one I don't do?
15:26:11 <Joubu> Josef disappeared so it's ashimema and cait1
15:26:25 <cait1> ok
15:26:41 <cait1> sounds doable,b ut not quite sure when, I will try
15:26:46 <ashimema> will look at it this week.. maybe even after this meeting
15:26:46 <cait1> not unhappy if someone beeats me to it
15:27:05 <Joubu> * Fix OPACHiddenItems - Bug 24403
15:27:05 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24403 normal, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] OpacHiddenItems should hide items everywhere in the OPAC
15:27:06 <Joubu> It has moved quickly then is a bit stuck right now. There is no trivial changes to implement, like adding the "hidden at the OPAC" info to the search engine index.
15:27:09 <Joubu> tcohen: something to add?
15:28:10 <Joubu> * Handling of errors 500 (it's actually "better handling of error pages")
15:28:12 <ashimema> I'd like to join a task force on that one.. but perhaps it's one to get back to for 21.11 ?
15:28:20 <ashimema> hidden that is..
15:28:22 <cait1> there are some spots independent of zebra/elastic that we could still fix i think, but there are API questions as well
15:28:40 <cait1> thinking of the top issues that are built from an sql query for an example
15:30:07 <cait1> also talking about hidden items actually :)
15:30:30 <Joubu> top issues look like a tricky one
15:31:00 <Joubu> we need a plan for this one in order to know where we are going and what's left (asking that for a couple of months)
15:31:19 <Joubu> ok so
15:31:20 <Joubu> * Handling of errors 500 (it's actually "better handling of error pages")
15:31:23 <Joubu> There are 3 bugs that are waiting for patches. David abandonned the ship and let me alone on this one.
15:31:29 <Joubu> I will try to find some time and submit patches. Will be good to have a tester and/or QA along with me (at least for motivation)
15:31:53 <Joubu> * Developer handbook and documentation
15:31:58 <Joubu> Abandonned for 21.05. There is no real desire (or at least to make some time) to work on it
15:32:19 <cait1> I think last discussine nded with the idea of maybe restarting the wiki
15:32:20 <Joubu> (that's not nice but that's true heh)
15:32:30 <cait1> i think the clena up woul be a lot easier if we had the categories and such better working again
15:32:45 <cait1> the old mediawiki is no fun and makes it probably harder for us than it needs to be
15:32:53 <ashimema> agreed
15:33:07 <cait1> we coudl mark pages oudated, needing work etc and bult up some process there
15:33:14 <ashimema> I don't really have the brain space for it right now.. fighting with the wiki just adds to that
15:33:15 <Joubu> yes but saying we should start a bigger work to start documenting things does not feel right
15:33:18 <cait1> that would help people navigate as well
15:33:37 <ashimema> I was however tempted to add a couple of micro documentation sites.. one for a more public api documentation
15:33:47 <ashimema> and one for more clear notes on developing plugins
15:34:01 <cait1> i was considering starting a a manuelly created list of pages
15:34:06 <ashimema> I think those are more manageable as self contained things
15:34:13 <cait1> but thought i might be a little insane... and we really hsoud use tags/categories probably
15:34:21 <ashimema> and would market Koha well from a 'Koha is still relevant and modern' perspective
15:34:32 <cait1> where would you put it?
15:34:45 <cait1> i think we actually have good stuff hidden in the wiki, but it's very often not found
15:34:49 <cait1> hidden in the pile
15:35:07 <cait1> so we could think about having a nicer entry page maybe for a start that lists the often needed things in a nice way...
15:35:14 <ashimema> I was thinking of using the gitlab pages stuff..
15:35:18 <cait1> not a total solution, but it might be helpful on the front page
15:35:21 <ashimema> and then asking for api.koha-community.org
15:35:25 <Joubu> so, plan for 21.11 would be 1. archive the wiki, 2. start from scratch with a better one, 3. Retrieve what is still valid/useful
15:35:33 <cait1> that coudl be
15:35:35 <cait1> yep
15:35:43 <ashimema> and possible dev.koha-community.org
15:35:51 <cait1> and maybe I will somehow find time to do some sorting and marking before
15:36:02 <cait1> makes sense
15:36:41 <ashimema> +1 for archive the existing wiki and stat fresh migrating only what we actually think is really useful
15:36:58 * ashimema even wonders if mediawiki is just too big and complex for our uses
15:37:12 <thd> If I could not have time for the greater goal I would work on updating the archive of the wiki.
15:37:14 <cait1> we used to have a dokuwiki, but both require a special syntax
15:37:22 <tuxayo> Do other wikis have categories?
15:37:26 <cait1> i think something with a more easy flow of things when entering would be more inviting
15:37:52 <thd> Things need tags for findability.
15:38:30 <thd> The biggest problem with Dokuwiki was that there was no means to find untagged pages.
15:38:52 <cait1> wysiwyg coudl lower the barrier some... abut also need good versioning
15:39:05 <Joubu> anyone willing to investigate the different alternatives we have (with a cons/pros list)?
15:39:33 <cait1> I don't kow the market really... we use something proprietory at work, so experience is limtied
15:39:35 <ashimema> modern mediawiki is much easier wysiwyg wise
15:40:08 <cait1> but we came from dokuwik and the easier handling for editing tables and the like made all the difference to get more people involved
15:40:22 <tuxayo> Need to install an additional service on the sever IIUC for the wysiwyg editor
15:40:31 <cait1> something for a separate meeting maybe
15:40:35 <Joubu> yes!
15:40:38 <Joubu> moving on
15:40:42 <cait1> yep sorry :)
15:40:46 <Joubu> #topic Automated updates for translated manuals
15:40:49 <Joubu> ashimema: ?
15:40:53 <Joubu> any updates on that?
15:41:13 <ashimema> Well.. we got the space on the server expanded so that builds started working again
15:41:29 <tuxayo> wizzyrea++
15:41:40 <ashimema> and the tool now triggers proper gitlab merge requests
15:41:42 <ashimema> and...
15:41:59 <ashimema> as of a couple of days ago I added a cronjob to trigger that tool to run once a month a few days after release
15:42:07 <cait1> oooooh nice
15:42:10 <cait1> ashimema++
15:42:18 <ashimema> so we should get translation merge requests a few days after koha release.. so at least it'll get updated monthly
15:42:37 <ashimema> as for automating it more.. I think perhaps lets wait and see how much things change each month for a little while
15:42:48 <tuxayo> ashimema++
15:43:00 <ashimema> we will however end up with the same mess the koha repo has.. translations mixed in add to the git girth.
15:43:03 <cait1> I am currently translating the 20.11 german manual, so there shoudl be something next itme
15:43:12 <ashimema> be nice to have translations in their own repo in the future
15:43:21 <Joubu> great, I let you adjust the roadmap for this topic
15:43:29 <ashimema> will do
15:43:43 <Joubu> ashimema: that's the plan with "git splitting"
15:43:53 <ashimema> indeed
15:43:57 <Joubu> * Koha Cookbook Project
15:44:04 <Joubu> Meeting planned next Friday (12th)! See the Koha agenda for the time.
15:44:08 <ashimema> be great to do the same for the manual repo once we have our heads wrapped around it :)
15:44:50 <Joubu> #topic Actions from last meeting
15:44:58 <Joubu> #info amoyano advertise Bug 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
15:44:58 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, koha-bugs, Patch doesn't apply , New interface for revamped circulation rules
15:45:16 <Joubu> tcohen: I stop postponing this one, I let you readd it if needed
15:45:31 <Joubu> #info General development discussion (trends, ideas, ...)
15:45:40 <Joubu> #topic General development discussion (trends, ideas, ...)
15:45:48 <Joubu> #topic Systemd, Containerisation, Packaging, Other... we need a long term goal and roadmap for these things. - Bug 25674
15:45:48 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25674 enhancement, P5 - low, ---, tomascohen, Pushed to master , Add RabbitMQ options to koha-create
15:46:16 <Joubu> ashimema: there are 3 topics coming from you
15:46:35 <Joubu> #info we need a long term goal and roadmap
15:46:36 <Joubu> (lol)
15:46:39 <ashimema> indeed there are
15:47:06 <Joubu> sorry, a bit sarcastic here, but we know that :)
15:47:14 <ashimema> hehe
15:47:17 <ashimema> indeed
15:47:43 <ashimema> basically.. on the rebbitmq stuff we seem to be working in various opposing directions and I got lost
15:48:00 <ashimema> do we need a systemd file or not.. how do we get things to startup as expected in the various installs
15:48:18 <ashimema> should rabbitmq be a require in the packages or an optional...
15:48:45 <ashimema> should the workers be part of core.. or in their own container, own package so you can install them on other machines and scale horizontally.
15:48:57 <ashimema> right now.. it's a mess and needs some clarity
15:49:01 <Joubu> we discussed some of that already
15:49:06 <ashimema> that's what this question was asking
15:49:18 <Joubu> rabbitmq is suggested, we created additional packages to fit the different needs
15:49:25 <ashimema> did we answer some of them and document it.
15:49:26 <Joubu> ok
15:49:34 <Joubu> how/where do we start the discussion?
15:50:32 <ashimema> :(
15:50:36 <cait1> i think we did discuss, it might be a case of lack of documenting
15:50:45 <cait1> i remember about koha-core etc
15:51:10 <Joubu> if we don't get more people involved more closely and regularly in the documentation and development process it will be hard to discuss such discussions anyway
15:51:15 <ashimema> perhaps the whole "lets make a koha-core" etc stuff should be one of the next cycles goals
15:51:33 <ashimema> and we should form a small working group to work out what we want, document it.. and then work towards it
15:51:33 <Joubu> it's done
15:51:47 <Joubu> we have the different packages, and it will be documented in the 21.05 release notes
15:51:55 <ashimema> ok
15:51:57 <Joubu> as "big tech changes in 21.05"
15:51:58 <cait1> can we also update the pacakge information in the wiki please?
15:52:23 <ashimema> ok.. so which package does the worker sit in?
15:52:32 <Joubu> koha-full
15:52:34 * fridolin like service koha-worker@
15:53:02 <fridolin> i'm on building sercives koha-plack@opac and @staff
15:53:16 <Joubu> which wiki page cait? "install on debian"?
15:53:27 <ashimema> I think maybe I just need someone to walk me through the plan at the next hackfest.. I'm sure it would sink into my brain better with a pint in hand
15:53:30 <cait1> there is one describing the different stable unstabel etc
15:53:33 <cait1> maybe link from that
15:53:38 <cait1> i will look
15:53:56 <cait1> also... we are building our own packages - does the proecess change in that case? i guess so
15:54:03 <Joubu> I don't find it
15:54:24 <cait1> https://wiki.koha-community.org/wiki/Building_Debian_Packages
15:54:31 <ashimema> sounds like it's more under control than I thought thought.. so yeah.. happy to concede and someone can explain how it's all meant to fit together to me at some point.. haha
15:54:40 <cait1> https://wiki.koha-community.org/wiki/Building_Debian_Packages_-_The_Easy_Way
15:55:18 <cait1> https://wiki.koha-community.org/wiki/How_was_my_Koha_installed (how to figure out which package?)
15:55:44 <Joubu> it's not listing the different packages the community provide
15:55:53 <cait1> https://wiki.koha-community.org/wiki/Building_Debian_Dependencies
15:56:06 <cait1> thee is tons on packages... that's one of our problems :) too scattered
15:56:13 <ashimema> this just highlights the need to tidy up the wiki again
15:56:18 <cait1> yep
15:56:19 <cait1> exactly
15:56:31 <cait1> i can group stuff, but i can#t really merge it myself... so I got stuck there
15:57:00 <Joubu> we need another page to list the different packages :D
15:58:07 <Joubu> #action mtj write something about the new packages for the 21.05 release notes
15:58:13 <cait1> lol
15:58:15 <Joubu> has to move on
15:58:19 <cait1> but if that works i am happy ;)
15:58:27 <Joubu> #topic Should we add a coding guideline to clarify our message types: 'alert' vs 'error' - Bug 27695
15:58:27 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27695 minor, P5 - low, ---, oleonard, Failed QA , Fix style of messages on Elasticsearch configuration page
15:58:52 <Joubu> yes we should
15:59:09 <Joubu> #action ashimema Write a coding guideline to clarify our message types: 'alert' vs 'error' (context of bug 27695)
15:59:10 <ashimema> So.. it was highligted to me recently that we have somewhat of a pattern for passing back 'messages' form methods.
15:59:16 <ashimema> but we don't have a guidelines for the 'types'
15:59:18 <Joubu> #topic We should reverse our 'title' elements - Bug 26703
15:59:18 <huginn> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=26703 enhancement, P5 - low, ---, wainuiwitikapark, Needs Signoff , We should reconsider best practice for our title elements
15:59:19 <ashimema> we should :)
15:59:21 <ashimema> brill
15:59:59 <Joubu> this is high priority (marking as such)
16:00:05 <Joubu> we need to help that bug
16:00:09 <ashimema> ok.. same again really... we need a guidelines so that we don't introduce new breakages once wainuiwitikpark has fixed all the current cases
16:00:15 <ashimema> yeah
16:00:30 <ashimema> I've been helping a little in terms of guiding them.. but trying not to take over too much
16:00:50 <Joubu> there was another on
16:00:52 <Joubu> cannot remember
16:00:53 <ashimema> brill.. looks ready for testing now :)
16:01:11 <Joubu> will see after the meeting
16:01:29 <ashimema> hehe
16:01:44 <Joubu> #action Joubu we need to push 26703 asap
16:01:52 <ashimema> OK.. I'll draft up guidelines for both of those to vote in next meeting :)
16:02:12 <Joubu> #action ashimema Write a guideline for 26703
16:02:18 <ashimema> I don't think either is contentious :)
16:02:25 <Joubu> #topic Review of coding guidelines
16:02:33 <Joubu> #topic On last meeting (24 feb) it was voted "using OPAC instead of Opac or opac", but it was forgotten to find someone to phrase it and add it to the guidelines.
16:03:06 <Joubu> #action ashimema write a guideline about using "OPAC instead of Opac or opac"
16:03:15 <tuxayo> Wait, it's already in terminology
16:03:32 <tuxayo> davidnind++
16:03:36 <tuxayo> Moving on!
16:03:39 <Joubu> indeed!
16:03:53 <Joubu> #info "OPAC instead of Opac or opac" is on the Terminology wiki page
16:04:10 <ashimema> :)
16:04:10 <Joubu> #topic Set time of next meeting
16:04:18 <Joubu> #info Next meeting: 24 March 2021 20 UTC
16:04:25 <Joubu> #info Next meeting: 24 March 2021, 20 UTC
16:04:54 <Joubu> we are going to hit DST soon
16:05:03 <Joubu> will adjust later if needed
16:05:08 <Joubu> #endmeeting