15:01:20 <Joubu> #startmeeting Development IRC meeting 13 January 2021
15:01:20 <huginn> Meeting started Wed Jan 13 15:01:20 2021 UTC. The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:20 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:20 <huginn> The meeting name has been set to 'development_irc_meeting_13_january_2021'
15:01:26 <Joubu> #topic Introductions
15:01:32 <Joubu> #info Jonathan Druart
15:01:42 <Joubu> qa_team?
15:01:42 <wahanui> qa_team is probably cait, dcook, amoyano, ashimema, marcelr, kohaputti, jajm, tcohen, josef_moravec, kidclamp, khall and tuxayo
15:01:43 <Joubu> rmaints?
15:01:43 <wahanui> somebody said rmaints was fridolin, AndrewFH and tuxayo
15:01:51 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
15:01:52 <kidclamp> #info Nick Clemens, ByWater Solutions
15:01:52 <magnuse> #info Magnus Enger, Libriotech, Norway
15:02:20 <thd> #info Thomas Dukleth, Agogme, New York City
15:02:58 <cait2> #info Katrin Fischer, BSZ, Germany
15:03:37 <jajm> #info Julian Maurice, BibLibre
15:03:44 <fridolin> #info Fridolin Somers, Biblire
15:03:49 <Joubu> #topic Announcements
15:03:52 <Joubu> Anyone have something?
15:04:15 <fridolin> Release of 20.11.01 is there
15:04:24 <fridolin> Joubu: do you know about packaging ?
15:04:34 <fridolin> i see perldeps is still 20.11.00
15:04:40 <ashimema> #info Martin Renvoize, PTFS-Europe, UK
15:04:47 <Joubu> I don't, mtj does not seem to be around much
15:04:52 <Joubu> maybe he is on holiday
15:05:01 <tuxayo> #info tuxayo/Victor Grousset, France
15:05:01 <fridolin> oki no pb
15:05:10 <cait2> there were some gitlab notices yesterday triggered by him i think?
15:05:16 <Joubu> fridolin: sent him an email!
15:05:22 <fridolin> yep oki
15:05:29 <Joubu> indeed cait2
15:05:42 <Joubu> #topic Update from the Release Manager (21.05)
15:05:56 <cait2> mjames on koha-testing-docker - so I think he is around in the background
15:06:02 <Joubu> I am starting to push new enhancements for 21.05. We are entering the month where we can push big things!
15:06:12 <Joubu> I really would like to push bug 25026 before end of January.
15:06:12 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=25026 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , RaiseError must be set for the UI
15:06:22 <Joubu> About the roadmap (https://annuel.framapad.org/p/koha_21.05_roadmap) I've sent some emails in the last 2 weeks to start working on some of the topics.
15:06:32 <Joubu> You can see the status of some of them (search for "Status:").
15:06:44 <Joubu> I am assuming everybody put there names and topics for now and I will move the topics without enough volunteers at the bottom ("LATER")
15:06:53 <Joubu> and will continue sending emails next week.
15:07:06 <Joubu> I'd like to highligh bug 20212 on which I worked in the last couple of days to improve it a bit.
15:07:06 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=20212 enhancement, P5 - low, ---, tomascohen, Needs Signoff , Slowness in receiving in acquisitions
15:07:12 <Joubu> with bug 27402 and
15:07:12 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27402 enhancement, P5 - low, ---, jonathan.druart, Needs Signoff , Add column filtering to the Datatables REST API wrapper
15:07:12 <liliputech_asu> #info Arthur Suzuki, BibLibre
15:07:25 <Joubu> bug 27403
15:07:25 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27403 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Enable fixedHeader for Datatables
15:07:46 <Joubu> It's ready for another SO+QA run. It's quite fun to test if you like REST API and DataTables.
15:07:55 <Joubu> any questions?
15:08:01 <khall> #info Kyle M Hall, ByWater Solutions
15:08:43 <cait2> i could share testing with anothr qa member if possible
15:09:07 <cait2> i not so confident about the code checking there, but can test the gui
15:09:21 <Joubu> Testing the UI would be very useful
15:09:58 <Joubu> #topic Updates from the Release Maintainers
15:10:03 <cait2> or maybe just do the sign-off with a note if i can
15:10:56 <Joubu> #info 20.11.01 is out, deb packages will be released soon!
15:11:04 <Joubu> (hopefully)
15:11:16 <fridolin> i mailled
15:11:37 <Joubu> anything else?
15:11:37 <wahanui> i heard anything else was necessarily going to be incremental.
15:11:43 <ashimema> :)
15:11:53 <fridolin> is 20.05 release tarball ok now ?
15:11:56 <ashimema> nice to see you back in the swing of things fridolin :)
15:12:05 <fridolin> yep ;)
15:12:33 <tuxayo2> > is 20.05 release tarball ok now ?
15:12:33 <tuxayo2> it's there so it seems ok https://download.koha-community.org/
15:12:46 <Joubu> was there a known problem about 20.05 tarball?
15:12:47 <fridolin> https://download.koha-community.org/ yep
15:13:02 <fridolin> juste Andrew had not SSH access
15:13:03 <Joubu> ok, all good if fixed now :)
15:13:37 <Joubu> will see later if needed
15:13:43 <fridolin> BTW is anyone using it ?
15:13:50 <fridolin> do we have stats ?
15:13:56 <cait2> is it 2011 or 20.05?
15:14:20 <tuxayo2> stats about version usage?
15:14:20 <tuxayo2> https://hea.koha-community.org/systempreferences
15:14:28 <cait2> we are testing 20.05 but a bit behind and building our own packages...
15:14:43 <tuxayo2> wow 423 reported instances on 20.1100000
15:15:08 <ashimema> we have a couple of early adopters testing 20.11
15:15:31 <kidclamp> we upgrade to 20.05 in february
15:15:37 <ashimema> they won't go live on it for a few more months.. but are testing the heck out of it with massive datasets copied from their live sites.
15:15:58 <ashimema> big public libraries so far.. might get a uni to thing about testing soon
15:16:00 <cait2> good to hear that!
15:16:48 <ashimema> 423 live on 20.11 in hea.. wow!
15:17:13 <ashimema> can we see history in hea somehow?
15:17:25 <ashimema> I'm interested to see how many of those are new installs vs how many are upgrades
15:17:45 <ashimema> i.e. is there a sudden decrease in 20.05 usage when 20.11 came out
15:17:49 <cait2> 11.600 libaries too - i guess we can up our assumed number quite a bit
15:18:49 <tuxayo2> Koha is taking over the world :D
15:19:10 <tuxayo2> > can we see history in hea somehow?
15:19:10 <tuxayo2> Nope, the only way is to make snapshots at https://web.archive.org/web/2020*/https://hea.koha-community.org/systempreferences
15:19:28 * tuxayo2 does one now
15:20:43 <ashimema> `Ex Libris Titley - http://home.ostara.titley.com`.. interesting one to be in our stats
15:21:13 <Joubu> moving on?
15:21:19 <Joubu> #topic Updates from the QA team
15:21:51 <cait2> #info QA queue is around 50ish, not super bad, but could be better!
15:22:10 <cait2> #info Very glad to see more interaction in QA team and quite a bit of QA activity spread out a bit more
15:22:13 <ashimema> I had a slow start this year.. but have been working through bugs this week
15:22:17 <cait2> please keep this up!
15:22:26 <ashimema> working myself up to looking at the bigger things again
15:22:53 <kidclamp> ^same
15:22:55 <cait2> yes, I need you devs to get rid of the scary ones for me ;)
15:23:14 <cait2> but seriously, some I am not confident to touch, so always happy to see you guys go there
15:23:19 <kidclamp> I apologize to anyone who has been subjected to me rewriting things when I tery to QA, I will reign it in
15:23:30 <Joubu> bug 27251
15:23:30 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27251 enhancement, P5 - low, ---, jonathan.druart, Signed Off , Rewrite the QOTD editor using the Koha REST API
15:23:34 <Joubu> pick that one
15:23:36 <magnuse> qateam++
15:23:39 <ashimema> I'd love to see some others grabbing more of the easy ones.. and thus pushing me back into the harder ones..
15:23:43 <tuxayo2> Had a hard time since last week to spend time on Koha & QA, hopefully thing will get better
15:23:46 <tuxayo2> :)
15:23:49 <ashimema> at the minute.. it's been a bit easy to pick low handing fruit ;)
15:24:27 <Joubu> and bug 24488
15:24:27 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24488 normal, P5 - low, ---, jonathan.druart, Signed Off , Holds to Pull sometimes shows the wrong 'first patron' details
15:25:03 <ashimema> ah, that ol' chesnut.. 24488 has been on my list to look at for ages.. but every time I have I'd struggled to wrap my brain around it.
15:26:19 <Joubu> # Actions from last meeting
15:26:37 <Joubu> #topic Actions from last meeting
15:26:43 <Joubu> #topic davidnind Find and update relevant places to record Perl version required, including release notes, manual and wiki (one source of the truth) (still working on this - feel free to reallocate)
15:26:54 <Joubu> #info tuxayo: wikipage draft for System requirements and recommendations. Used by the RMaints for the latest minor release.
15:27:00 <Joubu> #link https://wiki.koha-community.org/wiki/System_requirements_and_recommendations
15:27:20 <Joubu> next step would be to review it and find a good place to put them
15:27:32 <Joubu> then we should point to that place from everywhere else
15:27:44 <tuxayo> +1
15:27:47 <ashimema> +1
15:27:48 <Joubu> tuxayo: willing to continue on it?
15:28:11 <ashimema> they looked solid to me.. seems I forgot to say that :)
15:28:17 <ashimema> well done on collecting all the info tuxayo
15:29:17 <cait2> phone call
15:29:56 <Joubu> Is someone else willing to work on that?
15:31:25 <Joubu> ok, will continue by email for now, and update the action for the next meeting if needed
15:31:39 <Joubu> #topic amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
15:31:48 <Joubu> I sent a later to amoyano, will send an email
15:31:50 <Joubu> postponing
15:31:55 <Joubu> #action amoyano advertise 15522 and ask the list for feedback [after 20.11 is released], setup a sandbox, etc.
15:32:18 <Joubu> #topic General development discussion (trends, ideas, ...)
15:32:28 <Joubu> hum.. last minute topics
15:32:38 <Joubu> #topic ILS-DI bug 27423
15:32:38 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27423 normal, P5 - low, ---, koha-bugs, NEW , ILS-DI should be deprecated and functions moved to REST API
15:32:53 <Joubu> kidclamp: ?
15:33:07 <kidclamp> Just to be clear, I am not suggesting we disable or remove it anytime soon
15:33:38 <kidclamp> It seems this specification is not managed anymore, so I think we should deprecate and consider replacing it
15:33:40 <tuxayo> System requirements and recommendations: I'm trying to focus consitently on some other tasks so I'm not sure I'll push much on that.
15:33:41 <tuxayo> And not sure what more to do to review and I don't know about where is best to put them.
15:33:48 <tuxayo> Sorry, was long to write that ><
15:34:12 <kidclamp> cait made a good point about it being different from rest api, but I think we could find a way to provide the info more in line with rest
15:34:19 <ashimema> bug 15522
15:34:19 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=15522 enhancement, P5 - low, ---, koha-bugs, Patch doesn't apply , New interface for revamped circulation rules
15:34:19 <wahanui> hmmm... bug 15522 is the right place
15:35:05 <kidclamp> there are access concerns with current ILS-DI - it provides a lot of unprivileged access that must be managed via server config
15:35:41 <ashimema> we could certainly start to advertise an intention to eventually deprecate it.
15:35:46 <Joubu> kidclamp: if we have the REST API routes for the same info, I'd be ok to deprecate them (IMO!)
15:36:05 <ashimema> I have a feeling it's widely used at the moment
15:36:09 <kidclamp> agreed
15:36:30 <Joubu> the other softwares can do the job if they know we are going to drop ILSDI
15:36:31 <kidclamp> but we have some bugs/enh in the queue and no real clear guidance on how exactly it should work
15:36:39 <ashimema> but yes.. I'd be keen to reduce our api surface a bit and instead encourage people onto one well maintained one...
15:37:08 <kidclamp> bug 17229 made me think, and the idea that REST and ILS-DI shoudl match behaviour, raises questions of how they should perform
15:37:08 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=17229 normal, P5 - low, ---, julian.maurice, Passed QA , ILS-DI HoldTitle and HoldItem should check if patron is expired
15:38:45 <kidclamp> please comment more on the bug - i will talk to tomas when he is back about how the REST api can serve similar function, but just seeking discussion at this point
15:39:15 <ashimema> kidclamp++
15:39:29 <Joubu> #topic CI: ok to remove mysql 8 from 20.05 and only test in master? [tuxayo]
15:39:35 <ashimema> ++
15:40:10 <Joubu> yes for me (already answered by email)
15:40:13 <Joubu> I will take on it
15:40:20 <tuxayo> It was proposed during a discussion about the system requirements and recommendations.
15:40:30 <tuxayo> No objections?
15:41:05 <tuxayo> If there isn't, what to do, just delete the job in the CI or there are more steps?
15:41:40 <ashimema> as it's already not appearing in the Dashboard.. yeah.. I think that it'
15:41:43 <ashimema> jsut delete it from the CI
15:41:47 <Joubu> yes
15:42:19 <Joubu> done
15:42:27 <ashimema> :)
15:42:28 <kidclamp> Joubu++
15:42:28 <ashimema> nice one
15:42:31 <Joubu> anything else?
15:42:31 <wahanui> i think anything else is necessarily going to be incremental.
15:42:42 <tuxayo> Joubu++
15:42:56 <Joubu> #topic Set time of next meeting
15:43:10 <ashimema> do we test 19.x against D10?
15:43:24 <Joubu> Koha_19.11_D10
15:43:29 <ashimema> seems weird we test it against U18 if we don't
15:43:35 <ashimema> ah..
15:43:39 <ashimema> ok.. there's a bug in the dashboard then
15:43:40 <ashimema> haha
15:43:43 <ashimema> I'll fix that
15:43:55 <Joubu> #info Next meeting: 27 January 2021, 14 UTC
15:43:59 <Joubu> no
15:44:03 <Joubu> #info Next meeting: 27 January 2021, 20 UTC
15:44:18 <ashimema> works for me
15:44:36 <Joubu> #endmeeting