14:01:51 <Joubu> #startmeeting Development IRC meeting 13 October 2021
14:01:51 <huginn`> Meeting started Wed Oct 13 14:01:51 2021 UTC.  The chair is Joubu. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:51 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:51 <huginn`> The meeting name has been set to 'development_irc_meeting_13_october_2021'
14:02:13 <Joubu> #link https://wiki.koha-community.org/wiki/Development_IRC_meeting_13_October_2021
14:02:23 <Joubu> #topic Introductions
14:02:27 <petrova> #info Peter (Petro) Vashchuk, National Library of Finland, HELSINKI
14:02:30 <Joubu> #info Jonathan Druart
14:02:31 <nugged> #info Andrew Nugged, National Library of Finland, HELSINKI
14:02:36 <tuxayo> #info Victor Grousset, Tuxayo Solutions, France
14:02:48 <oleonard> #info Owen Leonard, Athens County Public Libraries, Ohio, USA
14:03:07 <thd> #info Thomas Dukleth, Agogme, New York City
14:03:16 <ashimema> #info Martin Renvoize, PTFS Europe, UK
14:03:40 <Joubu> #topic Announcements
14:03:42 <Joubu> something?
14:03:42 <wahanui> hmmm... something is broken
14:03:51 <Joubu> everything is broken, wahanui
14:03:51 <wahanui> ...but everything is there...
14:03:57 <Joubu> as well
14:04:26 <ashimema> #info We're starting to think about the advent calendar.. volunteers for writing posts, editing etc welcome
14:05:11 <Joubu> #topic Update from the Release Manager (21.11)
14:05:15 <ashimema> I was going to propose a more mixed approach this year.. some Dev posts, some more general ones to try and attract more of an audience
14:05:30 <Joubu> sorry
14:05:44 <tcohen> #info Tomas Cohen Arazi, Theke Solutions, Argentina
14:05:56 <Joubu> could you start a pad with different ideas?
14:06:10 <Joubu> To show what you have in mind, and collect ideas from others?
14:06:14 <kidclamp> #info Nick Clemens, ByWater Solutions
14:06:44 <Joubu> maybe a mail to the list could be nice as well "if you want a tuto explaining how to do..."
14:06:53 <ashimema> Nice idea
14:07:21 <ashimema> Yeah.. will discus further out of meeting.. we onl usut thought about it (thanks for the reminder tcohen)
14:07:43 <Joubu> #action ashimema initiate the advent calendar - create a pad to collect ideas + send email to the list
14:08:12 <Joubu> anything else?
14:08:13 <wahanui> i guess anything else is necessarily going to be incremental.
14:08:40 <Joubu> We are less than 2 weeks from the 21.11 feature freeze. I will send the release dates soon.
14:09:23 <Joubu> I've flagged bugs and enhs as 21.11 candidate
14:09:26 <Joubu> there are quite a lot - https://link.infini.fr/koha_bz_rel_21_11_candidate
14:09:40 <Joubu> and some don't have patches. It would be good to see the team working on that list
14:09:58 <Joubu> especially for the bugfixes, I will need help.
14:10:07 <Joubu> SO+QA should focus on that list as well
14:10:18 <Joubu> well, nothing new
14:10:26 <Joubu> any questions?
14:10:47 <nugged> Joubu: I see 11175 in that list, great, will 20447 pass also some doors... or too complicated?
14:11:10 <Joubu> they are both candidates
14:11:17 <Joubu> the list is up-to-date
14:11:18 <Joubu> :)
14:11:53 <oleonard> I'm working on Bug 29212 now, should have a patch ready for testing today
14:11:53 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=29212 enhancement, P5 - low, ---, oleonard, NEW , Use Flatpickr on OPAC pages
14:12:13 <Joubu> nugged: the problem with 20447 is that there are lot of other related bugs
14:12:27 <Joubu> and I asked for a discussion, you need to help each others
14:12:41 <Joubu> Next week is the General IRC meeting, should we vote for the 22.05 team?
14:13:16 <nugged> (I just did rebase of 20447 seconds ago because of 29135)
14:13:17 <Joubu> oleonard: is it the last one before the jqueryui removal?
14:13:26 <oleonard> I believe so
14:13:44 <Joubu> would be good to have for 21.11 :)
14:14:07 <ashimema> I'll happily test the flatpickr stuff
14:14:20 <ashimema> been beavering away at it on the staff side so it shouldn't be too hard to follow
14:14:31 <ashimema> yes.. lets vote at the next general meeting
14:14:42 <ashimema> (also voting on the reduction of number of meetings then too I think)
14:14:42 <oleonard> +1
14:15:05 <Joubu> #action fridolin write your RM proposal
14:15:10 <Joubu> @later tell fridolin write your RM proposal
14:15:10 <huginn`> Joubu: The operation succeeded.
14:15:19 <Joubu> Or I will submit mine
14:15:37 <Joubu> #topic Updates from the Release Maintainers
14:15:55 <tuxayo> nothing to report
14:16:13 <Joubu> #topic Updates from the QA team
14:16:52 <nugged> I can say that we installed Sunday's master (Joubu knews the feedback and all things goes tightly) on one production (pilot friendly victim :) ), and we found few quick fixes and in the most it survived and "almost good" so we coming to more or less stable build with feature freeze :). I CAN focus librarians to test SPECIFIC things if you mates hint me what them explicitly ask to test
14:17:51 <Joubu> anything about the new date picker widget?
14:17:57 <Joubu> Did they notice the changes?
14:18:20 <ashimema> do they have any accessibility focused people nugged?
14:18:31 <ashimema> always good to get people who use screen readers and things in real life to feed back
14:20:09 <nugged> sadly, ... librarians only. But this good point to ask from all 15 customer libraries to get such feedback. I'll ask. And our mostly uses API for people, so staff only swmming in intranet.
14:20:10 <thd> Think of the low vision people with extra super large font magnification
14:20:46 <Joubu> #topic Status of roadmap projects
14:20:56 <thd> ... also.  No screen reader use needed for testing magnification.
14:21:03 * ashimema has been terrible at poking people :(
14:21:20 <Joubu> Did I tell you I *really* wanted bug 28445 for 21.11?
14:21:20 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28445 enhancement, P5 - low, ---, jonathan.druart+koha, Failed QA , Use the task queue for the batch delete and update items tool
14:21:35 <tcohen> yes
14:21:44 <tcohen> do you need help with the QA raised issues?
14:21:44 <Joubu> sure?
14:21:45 <Joubu> :D
14:22:02 <Joubu> I fixed them already
14:22:06 <tcohen> ok
14:22:15 <Joubu> it was not QA, testing problems
14:22:28 <tcohen> will look at it with kidclamp ASAP
14:22:47 <tcohen> if he can heh
14:23:01 <kidclamp> I just failed QA again Joubu
14:23:01 <Joubu> Other topics to talk about?
14:23:35 <tcohen> Joubu: would you consider some new API routes that are being submitted?
14:23:38 <Joubu> ha, thanks kidclamp! I didn't see yet. Will get back to it soon
14:23:57 <Joubu> new API routes?
14:24:08 <tcohen> the work on the /public space has been locking other devs
14:25:07 <tcohen> I'm talking about bug 28948
14:25:07 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=28948 enhancement, P5 - low, ---, martin.renvoize, Passed QA , Add a /public counterpart for the libraries REST endpoints
14:25:29 <Joubu> PQA yesterday..
14:25:34 <ashimema> That dev is a great piece of foundation code
14:25:39 <nugged> > anything about the new date picker widget?
14:25:39 <nugged> I did. But librarians more concerned about other things. I will try kindly hint them to enjoy louder :)
14:25:40 <Joubu> let me a bit of time please
14:25:53 <tcohen> (y)
14:26:10 <tcohen> <3
14:26:27 <Joubu> I don't like pushing things that is not used. And the devs "locked" are not for 21.11
14:26:31 <Joubu> so it's not urgent to me
14:26:53 <Joubu> I have ton of things I'd like to deal with before
14:26:59 <Joubu> like all the 21.11 I've flagged
14:27:20 <Joubu> tcohen: we abandon bug 24403 for 21.11?
14:27:20 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=24403 normal, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] OpacHiddenItems should hide items everywhere in the OPAC
14:27:56 <Joubu> ha! I have a **** good news
14:28:00 <Joubu> bug 27829 is almost done
14:28:00 <huginn`> 04Bug https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=27829 enhancement, P5 - low, ---, koha-bugs, NEW , [OMNIBUS] Remove specific LANG installer data
14:28:05 <Joubu> only fr-FR left!
14:28:33 <tcohen> Joubu: the ones missing (24403) are shelves and those related to searching
14:30:05 <Joubu> and?
14:30:20 <Joubu> there is a bunch in the "depends on" list
14:30:24 <Joubu> anyway, moving on.
14:30:59 <tcohen> not many, yes, move on
14:31:10 <Joubu> #topic General development discussion (trends, ideas, ...)
14:31:16 <Joubu> something?
14:31:16 <wahanui> something is broken
14:31:35 <tuxayo> #off https://medium.com/message/everything-is-broken-81e5f33a24e1
14:31:55 <oleonard> FYI, when the Flatpickr conversion is done I will start working on jQueryUI tabs.
14:32:32 <oleonard> The jQueryUI project announced there will not be another feature release
14:34:36 <Joubu> oleonard: do you have the list of the jQueryUI features we are using?
14:34:47 <Joubu> datetime picker we are going to remove, then the tabs
14:34:49 <Joubu> what else?
14:35:15 <oleonard> Then the rest :)
14:35:44 <oleonard> Autocomplete, accordion... progressbar maybe?
14:36:24 <tuxayo> last jQueryUI release was a week ago, the previous one 5 years ago ^^"
14:36:38 <Joubu> it will help to have an omnibus report with the different dependencies
14:36:45 <oleonard> There's no rush i don't think, but especially with the components that can be replaced by Bootstrap we shouldn't wait.
14:36:46 <Joubu> we could even help you
14:37:14 <oleonard> We'll have to move to a whole new solution for autocomplete
14:37:35 <oleonard> You always help me Joubu! :)
14:38:02 <Joubu> at least trying
14:38:19 <Joubu> Do you think it's a good idea to have the bug tree?
14:38:31 <oleonard> Yes definitely.
14:38:45 <oleonard> I will work on it
14:38:50 <Joubu> thans
14:38:51 <Joubu> thanks
14:38:55 <Joubu> somethings else?
14:39:12 <Joubu> #topic Set time of next meeting
14:39:16 <thd> No one would have noticed because I had not posted an explanation to look with a link to a git archive which I am now testing for possible installation errors or omissions, but the binary and other wiki files which would only confuse seeing changes in version control  available from the old link have a slight directory nesting error which I am now fixing so that automated installation does not break.
14:41:05 <thd> Previous unreadable sentence was about wiki migration testing.
14:41:07 <koha-jenkins> Yippee, build fixed!
14:41:08 <wahanui> Congratulations!
14:41:08 <koha-jenkins> Project Koha_19.11_D8 build #426: FIXED in 33 min: https://jenkins.koha-community.org/job/Koha_19.11_D8/426/
14:41:53 <Joubu> #info Next meeting: 27 October 2021, 14 UTC
14:41:58 <tcohen> thanks thd
14:42:21 <Joubu> last one before the hour shift
14:42:26 <Joubu> #endmeeting